Программирование в ИнГео

Содержание

Программы
Программные модули
Наборы программных модулей
Доступ к объектам Ингео из программных модулей
Обработка событий
Интеграция с интерфейсом пользователя Ингео
Использование ActiveX-объектов

Программы

Основным элементом программирования в среде ГИС ИнГео является программа - текст на каком-либо языке программирования, содержащий набор инструкций. В ГИС ИнГео используется технология Microsoft Active Scripting, позволяющая использовать язык программирования по усмотрению пользователя. Наиболее распространенными языками программирования, поддерживаемыми данной технологией, являются VBScript и JavaScript, исполняющие подсистемы которых входят в комплект программы Internet Explorer, которая практически стала частью операционной системы Microsoft Windows.

Инструкции, содержащиеся в теле программы принято объединять в специальные именованные группы, называемые процедурами или функциями.

В начало

Программные модули

При реализации сложных задач часто возникает необходимость разбить одну большую программу на несколько более мелких с целю локализации отдельных подзадач в самостоятельных программах. Для этого в ГИС ИнГео предусмотрена возможность формировать программные модули - наборы программ, предназначенных для решения одной задачи.

Для удобства организации программ в пределах модуля можно создавать папки - группы программ и вложенных папок. Используя папки и вложенные папки, программы можно хранить не линейным списком, а в виде гармонично организованной иерархии.

Помимо программ, модуль может содержать различные ресурсы - различные вспомогательные элементы которые, могут использоваться программами во время их выполнения для облегчения программирования некоторых задач. В качестве примера ресурса можно привести ресурс описания меню. Более подробно об этом будет сказано в последующих разделах.

Программный модуль может находится в одном из двух состояний: загружен или активен. При активизации программного модуля выполняются следующие действия:

  1. Загружаются исполняющие подсистемы языков программирования, используемых в программах модуля.
  2. Тексты программ преобразуются (компилируются) в промежуточный псевдокод, более приемлемый для быстрого исполнения, нежели исходный текст.
  3. Скомпилированные программы присоединяются к источникам событий ГИС Ингео (обработка событий более подробно будет рассмотрена далее).

После компиляции каждая программа становится объектом. При этом все определенные в программе процедуры и функции становятся методами объекта, а глобальные переменные - свойствами.

В начало

Наборы программных модулей

Верхней ступенью организации программной среды Ингео являются иерархически организованные наборы программных модулей.

Каждый набор связан с одним из объектов Ингео и загружается при активизации объекта. Наборы модулей могут быть связаны со следующими объектами Ингео:

  • ГИС Ингео - набор программных модулей храниться в файле "INGEO.INM" в той папке, где содержится "INGEO.EXE" и загружается при запуске ГИС Ингео.
  • База данных - набор программных модулей храниться в базе данных и загружается при открытии базы данных.
  • Проект - набор программных модулей храниться в базе данных при проекте и загружается при открытии проекта.
  • Макет печати - набор программных модулей храниться в файле макета печати и загружается при открытии файла.

В начало

Доступ к объектам Ингео из программных модулей

При создании программ естественным образом возникает потребность получать доступ к различным объектам и элементам ГИС Ингео, таким как списки слоев, карт, территорий, пространственные объекты. Такой доступ предоставляется со стороны Ингео в виде иерархически организованной объектной модели посредством глобальной переменной с именем Application. Переменная Application является корневым объектом всей иерархии объектов, доступной из программ. Полная иерархия объектов представлена на диаграмме объектов Ингео.

В начало

Обработка событий

На протяжении всей работы пользователя с ГИС Ингео, в системе происходят различные события (например: был удален объект, изменился набор выделенных объектов, и т.д.). Возникает естественная потребность каким-то образом обрабатывать такие события в программах, добавляя дополнительное поведение для штатных операций ГИС.

В ГИС Ингео предусмотрена возможность программной обработки некоторых событий, периодически возникающих в системе (набор событий предопределен).

Для этого в программах необходимо определять процедуры со специальными зарезервированными именами (такие процедуры принято называть обработчиками событий). При запуске программного модуля система автоматически распознает имена процедур-обработчиков событий и присоединяет эти процедуры к источникам событий. Затем, при возникновении события в системе, автоматически выполняется процедура обработки события.

В начало

Интеграция с интерфейсом пользователя Ингео

ГИС Ингео позволяет программам, созданным пользователем, встраиваться в интерфейс пользователя системы - добавлять "свои" пункты в главное меню программы и кнопки на панелях инструментов.

Подсистема интерфейса пользователя главного окна ГИС Ингео содержит три основных элемента:

  1. Список команд - содержит перечень команд, где каждая команда имеет собственное уникальное имя, процедуру обработки и различную информацию, связанную с командой: заголовок, подсказку и набор состояний.
  2. Главное меню - содержит иерархически организованный перечень всех пунктов главного меню программы. Каждый пункт связан с одной из команд из общего списка команд.
  3. Панели инструментов - перечень панелей инструментов и содержащихся в них кнопок. Каждая кнопка связана с одной из команд из общего списка команд.

Как следует из выше сказанного, пункты меню и кнопки панелей инструментов не связаны напрямую с процедурами обработки. Вместо этого они связываются с командами, которые, в свою очередь, связываются с процедурами обработки. Кроме того, ряд свойств пунктов меню и кнопок панелей инструментов жестко связаны с соответствующими свойствами команд. При изменении таких свойств у команд, автоматически изменяются свойства связанных с командой элементов интерфейса пользователя. Например, при изменении свойства Enabled (доступна) у команды, автоматически изменятся состояния всех пунктов меню и кнопок панелей инструментов, связанных с данной командой.

Для облегчения создания пользовательских элементов интерфейса пользователя, программный модуль может содержать специальные элементы - ресурсы с описанием списка команд и меню. Внутренняя среда программирования Ингео позволяет интерактивно создавать и изменять такие ресурсы. Затем программа с помощью всего одной команды может создать и добавить в общий список команд и в общее меню программы, новые элементы, созданные на основе информации из ресурса описания команд и меню. При этом автоматически устанавливаются связи с процедурами обработки команд, реализация которых описана в программах модуля.

Типичный сценарий встраивания пользовательских команд выглядит следующим образом:

  1. Пользователь создает программный модуль, программу, ресурс со списком команд и ресурс с определением меню.
  2. Пользователь создает процедуру обработки события запуска модуля.
  3. В этой процедуре выполняется добавление команд из указанного ресурса списка команд. Система автоматически установит связи команд с процедурами обработки.
  4. Затем в этой же процедуре выполняется добавление пунктов меню из указанного ресурса меню.
  5. При выполнении пользователем добавленного пункта меню, автоматически вызовется процедура обработки команды, связанной с пунктом меню.

В начало

Использование ActiveX-объектов

При создании сложных программных модулей часто встает вопрос создания сложных экранных форм для взаимодействия программы с пользователем. Но возможности встроенных языков ограничены, и не позволяют организовать взаимодействие с пользователем более сложное нежели простой вывод текстового сообщения или ввод одной строки.

Кроме того, часто возможностей встроенных языков программирования недостаточны для эффективной реализации некоторых сложных алгоритмов.

Как быть в таких ситуациях?

Встроенные языки программирования позволяют создавать экземпляры внешних объектов, реализованных с учетом стандарта ActiveX. Разрабатывать ActiveX-объекты позволяют практически все современные средства разработки, такие как Delphi, C++ Builder, Visual Basic, Visual C++ и т.д.

Типичный сценарий разработки программных модулей с "участием" ActiveX-объектов выглядит следующим образом.

  1. Разрабатывается внешний ActiveX-объект: интерфейс пользователя и интерфейс объекта, который будет доступен из программных модулей Ингео.
  2. Из программы создается экземпляр внешнего ActiveX-объекта. После создания, объекту передаются ссылки на объекты Ингео, необходимые для работы внешнего объекта. Ссылка на объект запоминается в переменной программы.
  3. Из процедур обработки событий или команд происходит вызов нужных методов внешнего объекта, которые и выполняют те виды работ, которые невозможно реализовать средствами встроенных языков программирования Ингео.

В начало


Диаграмма объектов ИнГео


Идентификация объектов

Каждый объект системы ИнГЕО, (карта, слой, стиль, пространственный объект и пр.) имеет АБСОЛЮТНО уникальный идентификатор.

Полный формат такого идентификатора следующий: "{группа}номер", например "{EE02D47E-2B3A-468c-9127-DB2F0CFF0E7C}1256".

Что такое "группа" и что такое "номер"?

Все множество идентификаторов разбивается на подмножества, называемые группами идентификаторов (пространства идентификаторов). Каждая группа имеет абсолютно уникальный код (GUID). Код группы генерируется при помощи специальной функции операционной системы, гарантирующей абсолютную уникальность этого кода.

"номер" - это некоторое уникальное целое число в пределах группы.

Сам же идентификатор является совокупностью кода группы и уникального номера в пределах этой группы.

Поскольку в БД идентификаторы присутствуют повсеместно, их хранение в полной форме было бы весьма накладным. Поэтому для хранения идентификаторов в БД применяются следующие "хитрости":

В БД содержится таблица "коротких" псевдонимов для всех групп, используемых во всех идентификаторах, содержащихся в БД. Структура таблицы: "целое число", "GUID". Например: "1", "{E55B79A7-4A7A-49e3-B8EC-F4DDDD08E29F}" "2", "{0C99601E-512E-41b1-AFC8-5EC3E30EA1FC}" ... Каждый идентификатор записывается в сокращенной форме: "псевдоним группы" "номер". Физически это представляется двенадцатисимвольной строкой формата "GGGGNNNNNNNN", где: GGGG - шестнадцатеричное представление псевдонима группы, NNNNNNNN - шестнадцатеричное представление номера идентификатора в пределах группы. При миграции идентификаторов из одной БД в другую глобальный идентификатор не меняется, а вот сокращенная форма представления может измениться в части GGGG, так как псевдоним группы в разных БД может отличаться. Например, группа "{0C99601E-512E-41b1-AFC8-5EC3E30EA1FC}" в одной БД может иметь псевдоним "2", а в другой - "5". Это значит, что в одной БД сокращенная форма идентификатора будет иметь вид "0002NNNNNNNN", а в другой - "0005NNNNNNNN", хотя это один и тот же идентификатор.

При создании нового объекта Ингео создает новый идентификатор увеличивая "номер", либо создавая новую группу (если текущая уже заполнена).

Замечание:
<абсолютно - уникальный идентификатор> - уникальность идентификатора определяется уникальностью генерируемого системой GUID, если на машине установлена сетевая карта (не битая) с корректным MAC адресом, то GUID должен быть уникален

При импорте короткая "форма идентификатора" может изменится, но сам идентификатор (в его полной форме) остается постоянным. Поэтому при написанни модулей для ГИС ИнГео, если Вы сохраняете настройки во внешнем источнике и содержащие идентификаторы объектов ГИС, желательно сохранять их в полной форме.

Полный идентификатор, так же можно изменить, но обычно это делают в случае ошибок в БД, при помощи внешних утилит.

Глобальные идентификаторы пространственных объектов также изменяются при копировании объектов из одного слоя в другой.

См.также

IIngeoDb, GlobalIDToLocalID, LocalIDToGlobalID, IDSpaces


Отображение карт

Рисование в окне карты

Рисование в окне карты производится в следующем порядке:
  • MapEditorsSink.RepaintDragging
  • Заливка фона
  • MapWindowSink.WillPaint
  • DbPaintSink.WillPaint
  • DbPaintSink.ProjectWillPaint
  • Рисование карт:
    • DbPaintSink.MapWillPaint
    • Рисование слоев:
      • DbPaintSinkLayer.WillPaint
      • Рисование объектов
      • Рисование стилей с флагом "После всех объектов слоя"
      • DbPaintSink.LayerPaintComplete
    • Рисование стилей с флагом "После всех объектов карты"
    • DbPaintSink.MapPaintComplete
  • Рисование стилей с флагом "После всех объектов"
  • DbPaintSink.ProjectPaintComplete
  • DbPaintSink.PaintComplete
  • Рисование границы и центра территории
  • Рисование выделенных объектов
  • MapEditorsSink.Paint
  • Рисование "старых" модулей расширения
  • Рисование режимных редакторов (создание, редактирование объекта)
  • MapWindowSink.PaintComplete
  • MapEditorsSink.RepaintDragging

    Рисование элемента типа "Карта"

    Рисование в макете печати элемента типа "Карта" производится в следующем порядке:
    • Заливка фона элемента
    • DbPaintSink.WillPaint
    • DbPaintSink.ProjectWillPaint
    • Рисование карт:
      • DbPaintSink.MapWillPaint
      • Рисование слоев:
        • DbPaintSinkLayer.WillPaint
        • Рисование объектов
        • Рисование стилей с флагом "После всех объектов слоя"
        • DbPaintSink.LayerPaintComplete
      • Рисование стилей с флагом "После всех объектов карты"
      • DbPaintSink.MapPaintComplete
    • Рисование стилей с флагом "После всех объектов"
    • DbPaintSink.ProjectPaintComplete
    • DbPaintSink.PaintComplete
    • Рисование окантовки элемента.

    Рисование методом MakeImageFile

    Рисование методом "MakeImageFile" производится в следующем порядке:
    • Заливка фона
    • DbPaintSink.WillPaint
    • DbPaintSink.ProjectWillPaint
    • Рисование карт:
      • DbPaintSink.MapWillPaint
      • Рисование слоев:
        • DbPaintSinkLayer.WillPaint
        • Рисование объектов
        • Рисование стилей с флагом "После всех объектов слоя"
        • DbPaintSink.LayerPaintComplete
      • Рисование стилей с флагом "После всех объектов карты"
      • DbPaintSink.MapPaintComplete
    • Рисование стилей с флагом "После всех объектов"
    • DbPaintSink.ProjectPaintComplete
    • DbPaintSink.PaintComplete

    Рисование методом PaintXml

    Порядок рисования методом PaintXml задается пользователем и определяется последовательностью XML команд.

    См.также

    События в ГИС ИнГео


Правила задания масштабов

Значения масштабов в API ИнГео задаются числом от 0 до 1.
Например, если вам необходимо задать масштаб 1:500, используйте формулу 1/500 или значение 0.002.

Правила задания диапазона видимости

При задании диапазона видимости (VisibleMin, VisibleMax) следует учитывать, что VisibleMin соответствует самому крупному масштабу видимости, а VisibleMax самому мелкому. Например, для слоя задан следующий диапазон видимости:

    Layer.VisibleMin = 1/500
    Layer.VisibleMax = 1/10000
объекты слоя будут видны на диапазоне масштабов от [1:500 до 1:10000], включая обе границы диапазона. ГИС ИнГео начиная с версии 4.3 позволяет исключать граничные значения из диапазона видимости, для этого достаточно задать граничное значение с отрицательным знаком. Если задать следующий диапазон видимости в слое
    Layer.VisibleMin = -1/500
    Layer.VisibleMax = 1/10000
объекты слоя будут видны на масштабах (1:500 до 1:10000], исключая масштаб 1:500.

Нулевое граничное значение означает отсутствие каких-либо ограничений по заданной границе. Так, в следующем примере:

    Layer.VisibleMin = 0
    Layer.VisibleMax = 1/10000
объекты слоя будут видны на масштабах 1:10000 и крупнее, а в этом случае:
    Layer.VisibleMin = -1/500
    Layer.VisibleMax = 0
объекты слоя будут видны на масштабах мельче 1:500.


События в ГИС ИнГео

Список объектов обработчиков событий

Свойства

Обработчик событий | Описание
IIngeoApplicationSink | Объект-обработчик событий от Application.
IIngeoDbPaintSink | Объект-обработчик событий, связанных с рисованием содержимого активной базы данных.
IIngeoDbSysObjectsSink | Объект обработчик событий связанных с созданием, изменением и удалением системных объектов.
IIngeoDbMapObjectsSink | Объект обработчик событий связанных с созданием, изменением и удалением пространственных объектов.
IIngeoMapWindowSink | Объект-обработчик событий, связанных с рисованием содержимого окна карты.
IIngeoMapEditorsSink | Объект-обработчик событий, связанных c обработкой различных событий в окне карты.

См.также

Порядок рисования карт


Список страниц

Страница
IInUIAction
IInUIActionCaption
IInUIActionChecked
IInUIActionEnabled
IInUIActionShortcut
IInUIActionHandler
IInUIActionCategory
IInUIActionVisible
IInUIActionHint
IInUIActionName
IInUIActionHandlerMethod
IInUIActionHandlerOptions
IInUIActionExecute
IInUIActions
IInUIActionsCount
IInUIActionsItem
IInUIActions_NewEnum
IInUIActionsAdd
IInUIActionsRemove
IInUIMenu
IInUIMenuItems
IInUIMenuItem
IInUIMenuItemCaption
IInUIMenuItemName
IInUIMenuItemRadioItem
IInUIMenuItemGroupIndex
IInUIMenuItemAction
IInUIMenuItemItems
IInUIMenuItemVisible
IInUIMenuItems
IInUIMenuItemsCount
IInUIMenuItemsItem
IInUIMenuItems_NewEnum
IInUIMenuItemsInsert
IInUIMenuItemsRemove
IInWindow
IInWindowLeft
IInWindowTop
IInWindowWidth
IInWindowHeight
IInWindowWindowState
IInWindowName
IInWindowVisible
IInWindowCaption
IInWindowClose
IInPictureFigures
IInPictureFiguresCount
IInPictureFigures_NewEnum
IInPictureFiguresItem
IInPictureFiguresAdd
IInPictureFiguresIndexOf
IInPictureFiguresIsExists
IInPictureFiguresFind
IInPictureFiguresDelete
IInPictureFigure
IInPictureFigureName
IInPictureFigureLeft
IInPictureFigureBottom
IInPictureFigureWidth
IInPictureFigureHeight
IInPictureFigureFigureType
IInPictureFigureVisible
IInPen
IInPenStyle
IInPenWidthInMM
IInPenForZoomScale
IInPenColor
IInPenMode
IInBrush
IInBrushStyle
IInBrushBackColor
IInBrushHatchColor
IInBrushTransparency
IInFont
IInFontName
IInFontStyle
IInFontColor
IInFontSize
IInFontForZoomScale
IInFontPitch
IInFontCharSet
TInPictureFigureType
TInPenStyle
TInBrushStyle
TInFontStyle
TInFontPitch
TInTextAlignment
TInTextOrientation
TInPictureHorAlign
TInPictureVerAlign
TInPictureStretch
IInPictureRectFigure
IInPictureRectFigurePen
IInPictureRectFigureBrush
IInPictureEllipseFigure
IInPictureEllipseFigurePen
IInPictureEllipseFigureBrush
IInPictureLineFigure
IInPictureLineFigurePen
IInPictureLineFigureX1
IInPictureLineFigureY1
IInPictureLineFigureX2
IInPictureLineFigureY2
IInPicturePolygonFigure
IInPicturePolygonFigurePen
IInPicturePolygonFigureBrush
IInPicturePolygonFigureClosed
IInPicturePolygonFigurePoints
IInPictureTextFigure
IInPictureTextFigurePen
IInPictureTextFigureBrush
IInPictureTextFigureFont
IInPictureTextFigureAlignment
IInPictureTextFigureOrientation
IInPictureTextFigureIndent
IInPictureTextFigureText
IInPicturePictureFigure
IInPicturePictureFigurePen
IInPicturePictureFigureBrush
IInPicturePictureFigureHorAlign
IInPicturePictureFigureVerAlign
IInPicturePictureFigureStretch
IInPicturePictureFigureTransparentBack
IInPicturePictureFigurePicture
IInScriptScope
IInScriptScopeLoadActions
IInScriptScopeLoadMenu
IInPictureGridFigure
IInPictureGridFigureText
IInPictureGridFigureCellFormat
IInPictureGridFigureRowFormat
IInPictureGridFigureColFormat
IInPictureGridFigureGridFormat
IInPictureGridFigureColCount
IInPictureGridFigureRowCount
IInPictureGridFigureLeftCol
IInPictureGridFigureTopRow
IInPictureGridFigureGetFormat
IInPictureGridFigureDropFormat
IInPictureGridFigureContainsFormat
IInGridFormat
IInGridFormatPen
IInGridFormatBrush
IInGridFormatTextFormat
IInGridFormatSize
IInGridFormatFont
IInGridFormatDropKinds
IInGridFormatContainsKinds
IInGridFormatUpdate
TInGridFormatKind
TInGridTextFormat
IInScript
IInScriptDisp
IInScriptContextCard
IInContextCard
TInPenMode
IInLayoutWindow
IInLayoutWindowFigures
IInLayoutWindowDesignMode
IInLayoutWindowModified
IInLayoutWindowActions
IInLayoutWindowMenu
IInLayoutWindowPrintParams
IInLayoutWindowSelection
IInLayoutWindowNewLayout
IInLayoutWindowOpenLayout
IInLayoutWindowSaveLayout
IInLayoutWindowSaveLayoutAs
IInLayoutWindowPrintPage
TInWindowState
IInWindows
IInWindowsCount
IInWindowsItem
IInWindows_NewEnum
IInPictureMapFigure
IInPictureMapFigurePen
IInPictureMapFigureBrush
IInPictureMapFigureMapVisible
IInPictureMapFigureCenterX
IInPictureMapFigureCenterY
IInPictureMapFigureZoomScale
IInPictureMapFigureXAngle
IInPictureMapFigureYMirror
IInModuleSink
IInModuleSinkStartComplete
IInModuleSinkWillStop
IInHTMLWindow
IInHTMLWindowExternal
IInHTMLWindowBrowser
IInHTMLWindowToolbarVisible
IInHTMLWindowShowModal
IInPrintParams
IInPrintParamsScaleX
IInPrintParamsScaleY
IInPrintParamsMarginX1
IInPrintParamsMarginY1
IInPrintParamsMarginX2
IInPrintParamsMarginY2
IInPrintParamsPrintMargins
IInPrintParamsPageOrientation
IInPrintParamsPageFormat
IInPrintParamsPageFormatIndex
IInPrintParamsPageSizeX
IInPrintParamsPageSizeY
IInPrintParamsRasterizeBitCount
IInPrintParamsRasterizeBufSize
IInPrintParamsRasterize
IInPrintParamsPageCountX
IInPrintParamsPageCountY
IInPrintParamsPrinterPaperSizeX
IInPrintParamsPrinterPaperSizeY
TInPageOrientation
TInPageFormat
TInPageFormatIndex
IInPrinter
IInPrinterName
IInPrinterPortName
IInPrinterDriverName
IInPrinterComment
IInPrinterSelected
IInPrinters
IInPrintersCount
IInPrintersItem
IInPrinters_NewEnum
IInPrintersDefaultPrinterName
IInPrintersRefresh
TInUIHandlerOptions
IInLayoutSelection
IInLayoutSelectionCount
IInLayoutSelectionItem
IInLayoutSelectionIsSelected
IInLayoutSelectionBeginUpdate
IInLayoutSelectionEndUpdate
IInLayoutSelectionSelectAll
IInLayoutSelectionDeselectAll
IInLayoutSelectionSelect
IInLayoutSelectionDeselect
IIngeoApplication
IIngeoApplicationMainWindow
IIngeoApplicationSelection
IIngeoApplicationActiveDb
IIngeoApplicationActiveProjectView
IIngeoApplicationUserProfile
IIngeoApplicationWindows
IIngeoApplicationPrinters
IIngeoApplicationExePath
IIngeoApplicationVersion
IIngeoApplicationCreateObject
IIngeoApplicationOpenWindow
IIngeoApplicationOpenHTMLWindow
IIngeoApplicationOpenOverlappedHTMLWindow
IIngeoApplicationProcessMessages
IIngeoApplicationXmlRequest
IIngeoApplicationOpenDb
IIngeoApplicationCloseActiveDb
IIngeoApplicationOpenProject
IIngeoApplicationCloseActiveProject
IIngeoMainWindow
IIngeoMainWindowHandle
IIngeoMainWindowMapWindow
IIngeoMainWindowMenu
IIngeoMainWindowActions
IIngeoMainWindowSetStatusText
IIngeoMainWindowCreateTaskPanel
IIngeoSelection
IIngeoSelectionCount
IIngeoSelectionIDs
IIngeoSelectionShapeIndexes
IIngeoSelectionBeginUpdate
IIngeoSelectionEndUpdate
IIngeoSelectionSelect
IIngeoSelectionDeselect
IIngeoSelectionIsSelected
IIngeoSelectionDeselectAll
IIngeoSelectionSelectAlone
IIngeoDb
IIngeoDbAreas
IIngeoDbSemDbTables
IIngeoDbRefBooks
IIngeoDbMapObjects
IIngeoDbUsers
IIngeoDbRoles
IIngeoDbAC
IIngeoDbIDSpaces
IIngeoDbLogonUserID
IIngeoDbID
IIngeoDbCaption
IIngeoDbServerLicense
IIngeoDbServerVersion
IIngeoDbAreaExists
IIngeoDbAreaFromID
IIngeoDbProjectExists
IIngeoDbProjectFromID
IIngeoDbMapExists
IIngeoDbMapFromID
IIngeoDbLayerExists
IIngeoDbLayerFromID
IIngeoDbStyleExists
IIngeoDbStyleFromID
IIngeoDbSemTableExists
IIngeoDbSemTableFromID
IIngeoDbRefBookExists
IIngeoDbRefBookFromID
IIngeoDbGenerateID
IIngeoDbGlobalIDToLocalID
IIngeoDbLocalIDToGlobalID
IIngeoDbIsGlobalID
IIngeoDbPaintXml
IIngeoDbRegisterIDSpace
IIngeoDbGetProjectView
IIngeoDbDropCache
IIngeoAreas
IIngeoAreasCount
IIngeoAreasItem
IIngeoAreas_NewEnum
IIngeoAreasAdd
IIngeoAreasAddWithID
IIngeoArea
IIngeoAreaID
IIngeoAreaName
IIngeoAreaX1
IIngeoAreaY1
IIngeoAreaX2
IIngeoAreaY2
IIngeoAreaModified
IIngeoAreaProjects
IIngeoAreaMaps
IIngeoAreaAC
IIngeoAreaUpdate
IIngeoAreaDropChanges
IIngeoAreaDelete
IIngeoProject
IIngeoProjectID
IIngeoProjectName
IIngeoProjectContents
IIngeoProjectModified
IIngeoProjectArea
IIngeoProjectAC
IIngeoProjectUpdate
IIngeoProjectDelete
IIngeoProjectDropChanges
IIngeoProjects
IIngeoProjectsCount
IIngeoProjectsItem
IIngeoProjects_NewEnum
IIngeoProjectsAdd
IIngeoProjectsAddWithID
IIngeoProjectContents
IIngeoProjectContentsCount
IIngeoProjectContentsItem
IIngeoProjectContents_NewEnum
IIngeoProjectContentsAdd
IIngeoProjectContentsRemove
IIngeoProjectContentsContains
IIngeoMap
IIngeoMapID
IIngeoMapName
IIngeoMapVisibleMin
IIngeoMapVisibleMax
IIngeoMapMapType
IIngeoMapArea
IIngeoMapModified
IIngeoMapAC
IIngeoMapUpdate
IIngeoMapDelete
IIngeoMapDropChanges
IIngeoRasterMap
IIngeoRasterMapOffsetX
IIngeoRasterMapOffsetY
IIngeoRasterMapCellSizeX
IIngeoRasterMapCellSizeY
IIngeoRasterMapCellDivX
IIngeoRasterMapCellDivY
IIngeoRasterMapCellNumStartX
IIngeoRasterMapCellNumStartY
IIngeoRasterMapCellNumStepX
IIngeoRasterMapCellNumStepY
IIngeoRasterMapColor
IIngeoVectorMap
IIngeoVectorMapLayers
IIngeoMaps
IIngeoMapsCount
IIngeoMapsItem
IIngeoMaps_NewEnum
IIngeoMapsAddRasterMap
IIngeoMapsAddVectorMap
IIngeoMapsAddRasterMapWithID
IIngeoMapsAddVectorMapWithID
TIngeoMapType
IIngeoLayer
IIngeoLayerID
IIngeoLayerName
IIngeoLayerVisibleMin
IIngeoLayerVisibleMax
IIngeoLayerModified
IIngeoLayerMap
IIngeoLayerStyles
IIngeoLayerSemTables
IIngeoLayerAC
IIngeoLayerUpdate
IIngeoLayerDelete
IIngeoLayerDropChanges
IIngeoLayers
IIngeoLayersCount
IIngeoLayersItem
IIngeoLayers_NewEnum
IIngeoLayersAdd
IIngeoLayersAddWithID
IIngeoStyle
IIngeoStyleID
IIngeoStyleName
IIngeoStyleFlags
IIngeoStyleCreationStart
IIngeoStyleCreationClosing
IIngeoStyleCreationStartOrtho
IIngeoStyleCreationClosingOrtho
IIngeoStyleMinPoints
IIngeoStyleMaxPoints
IIngeoStyleLayer
IIngeoStyleModified
IIngeoStylePainters
IIngeoStyleAC
IIngeoStyleUpdate
IIngeoStyleDelete
IIngeoStyleDropChanges
IIngeoStylePaintContour
TIngeoStyleFlags
TIngeoStyleCreation
TIngeoStyleClosing
IIngeoStyles
IIngeoStylesCount
IIngeoStylesItem
IIngeoStyles_NewEnum
IIngeoStylesAdd
IIngeoStylesAddWithID
IIngeoProjectView
IIngeoProjectViewProject
IIngeoProjectViewMapViews
IIngeoProjectViewSelectedMapView
IIngeoProjectViewSelectedLayerView
IIngeoProjectViewActiveMapView
IIngeoProjectViewActiveLayerView
IIngeoProjectViewSelectedStyleView
IIngeoProjectViewFindLayerView
IIngeoProjectViewFindMapView
IIngeoProjectViewMakeImageFile
IIngeoProjectViewFindStyleView
IIngeoMapView
IIngeoMapViewMap
IIngeoMapViewVisible
IIngeoMapViewLayerViews
IIngeoMapViewExpanded
IIngeoMapViewIndex
IIngeoMapViewFindLayerView
IIngeoMapViews
IIngeoMapViewsCount
IIngeoMapViewsItem
IIngeoMapViews_NewEnum
IIngeoLayerView
IIngeoLayerViewLayer
IIngeoLayerViewVisible
IIngeoLayerViewIndex
IIngeoLayerViewMapView
IIngeoLayerViewExpanded
IIngeoLayerViewStyleViews
IIngeoLayerViewFindStyleView
IIngeoLayerViews
IIngeoLayerViewsCount
IIngeoLayerViewsItem
IIngeoLayerViews_NewEnum
IIngeoSemDbTable
IIngeoSemDbTableFields
IIngeoSemDbTableIndexes
IIngeoSemDbTableTableName
IIngeoSemDbTableModified
IIngeoSemDbTableDropChanges
IIngeoSemDbTableUpdate
IIngeoSemDbTableSelectData
IIngeoSemDbTableDeleteData
IIngeoSemDbTableInsertData
IIngeoSemDbTableDelete
IIngeoSemDbTableUpdateData
IIngeoSemDbDataSet
IIngeoSemDbDataSetFields
IIngeoSemDbDataSetBOF
IIngeoSemDbDataSetEOF
IIngeoSemDbDataSetMoveFirst
IIngeoSemDbDataSetMoveLast
IIngeoSemDbDataSetMoveNext
IIngeoSemDbDataSetMovePrev
IIngeoSemDbDataSetClose
IIngeoSemDbField
IIngeoSemDbFieldName
IIngeoSemDbFieldDataType
IIngeoSemDbFieldDataSize
IIngeoSemDbFieldFlags
IIngeoSemDbFieldPrecision
IIngeoSemDbFieldDelete
IIngeoSemDbFields
IIngeoSemDbFieldsCount
IIngeoSemDbFieldsItem
IIngeoSemDbFields_NewEnum
IIngeoSemDbFieldsAdd
IIngeoSemDbIndex
IIngeoSemDbIndexName
IIngeoSemDbIndexFields
IIngeoSemDbIndexFlags
IIngeoSemDbIndexDelete
IIngeoSemDbIndexes
IIngeoSemDbIndexesCount
IIngeoSemDbIndexesItem
IIngeoSemDbIndexes_NewEnum
IIngeoSemDbIndexesAdd
IIngeoSemDbTables
IIngeoSemDbTablesCount
IIngeoSemDbTablesItem
IIngeoSemDbTables_NewEnum
IIngeoSemDbTablesAdd
IIngeoSemDbTablesExists
IIngeoSemDbTablesExecSQL
TIngeoFieldDataType
TIngeoFieldFlags
TIngeoIndexFlags
IIngeoSemDbValue
IIngeoSemDbValueName
IIngeoSemDbValueDisplayValue
IIngeoSemDbValueValue
IIngeoSemDbValues
IIngeoSemDbValuesCount
IIngeoSemDbValuesItem
IIngeoSemDbValues_NewEnum
IIngeoSemTable
IIngeoSemTableID
IIngeoSemTableName
IIngeoSemTableSemDbTableName
IIngeoSemTableLinkType
IIngeoSemTableFieldInfos
IIngeoSemTableSemDbTable
IIngeoSemTableModified
IIngeoSemTableAC
IIngeoSemTableUpdate
IIngeoSemTableDelete
IIngeoSemTableDropChanges
IIngeoSemTableDropCache
IIngeoRefBook
IIngeoRefBookID
IIngeoRefBookName
IIngeoRefBookSemDbTableName
IIngeoRefBookSemDbTable
IIngeoRefBookModified
IIngeoRefBookAC
IIngeoRefBookUpdate
IIngeoRefBookDelete
IIngeoRefBookDropChanges
IIngeoSemFieldInfo
IIngeoSemFieldInfoFieldName
IIngeoSemFieldInfoCaption
IIngeoSemFieldInfoRefBookID
IIngeoSemFieldInfoRefBookKeyField
IIngeoSemFieldInfoRefBookDisplayFields
IIngeoSemFieldInfoDelete
IIngeoSemFieldInfos
IIngeoSemFieldInfosCount
IIngeoSemFieldInfosItem
IIngeoSemFieldInfos_NewEnum
IIngeoSemFieldInfosAdd
TIngeoSemTableLinkType
IIngeoSemTables
IIngeoSemTablesCount
IIngeoSemTablesItem
IIngeoSemTables_NewEnum
IIngeoSemTablesAdd
IIngeoSemTablesAddWithID
IIngeoRefBooks
IIngeoRefBooksCount
IIngeoRefBooksItem
IIngeoRefBooks_NewEnum
IIngeoRefBooksAdd
IIngeoRefBooksAddWithID
IIngeoPainter
IIngeoPainterComment
IIngeoPainterVisibleMin
IIngeoPainterVisibleMax
IIngeoPainterPainterType
IIngeoPainterIndex
IIngeoPainterDelete
IIngeoPainterPaintContour
TIngeoPainterType
IIngeoStdPainter
IIngeoStdPainterPen
IIngeoStdPainterBrush
IIngeoTextPainter
IIngeoTextPainterFont
IIngeoTextPainterFlags
IIngeoTextPainterBackColor
IIngeoTextPainterText
IIngeoSymbolPainter
IIngeoSymbolPainterPaintMethod
IIngeoSymbolPainterPictureZoomScale
IIngeoSymbolPainterPicture
IIngeoPainters
IIngeoPaintersCount
IIngeoPaintersItem
IIngeoPainters_NewEnum
IIngeoPaintersAdd
IIngeoPicture
IIngeoPictureX1
IIngeoPictureX2
IIngeoPictureY1
IIngeoPictureY2
IIngeoPictureFigures
TIngeoPicturePaintMethod
TIngeoTextPainterFlags
IIngeoMapObjects
IIngeoMapObjectsTransactionName
IIngeoMapObjectsStoreUndo
IIngeoMapObjectsGetObject
IIngeoMapObjectsAddObject
IIngeoMapObjectsDeleteObject
IIngeoMapObjectsLayerIDFromObjectID
IIngeoMapObjectsIsObjectExists
IIngeoMapObjectsUpdateChanges
IIngeoMapObjectsDropChanges
IIngeoMapObjectsQueryByRect
IIngeoMapObjectsQueryByStyle
IIngeoMapObjectsQueryByContour
IIngeoMapObjectsQueryByObject
IIngeoMapObjectsQueryBySurfacePos
IIngeoMapObjectsAddObjectWithID
IIngeoMapObjectsQueryByLayers
IIngeoMapObject
IIngeoMapObjectID
IIngeoMapObjectX1
IIngeoMapObjectY1
IIngeoMapObjectX2
IIngeoMapObjectY2
IIngeoMapObjectShapes
IIngeoMapObjectSemData
IIngeoMapObjectTopoLinks
IIngeoMapObjectLayerID
IIngeoMapObjectModified
IIngeoMapObjectMapObjects
IIngeoMapObjectSquare
IIngeoMapObjectPerimeter
IIngeoMapObjectDropChanges
IIngeoMapObjectPaint
IIngeoMapObjectFormatText
IIngeoSemData
IIngeoSemDataGetDisplayText
IIngeoSemDataGetValue
IIngeoSemDataSetValue
IIngeoSemDataAddRec
IIngeoSemDataDeleteRec
IIngeoSemDataGetRecCount
IIngeoSemDataAddRecWithID
IIngeoContour
IIngeoContourCount
IIngeoContourItem
IIngeoContour_NewEnum
IIngeoContourSquare
IIngeoContourPerimeter
IIngeoContourInsert
IIngeoContourClear
IIngeoContourTestRelation
IIngeoContourCombine
IIngeoContourAddPartsFrom
IIngeoContourGetBounds
IIngeoContourDistanceFromPoint
IIngeoContoursGetBounds
IIngeoContourBuildBufferZone
IIngeoContourPart
IIngeoContourPartVertexCount
IIngeoContourPartClosed
IIngeoContourPartIsHole
IIngeoContourPartSquare
IIngeoContourPartPerimeter
IIngeoContourPartGetVertex
IIngeoContourPartSetVertex
IIngeoContourPartInsertVertex
IIngeoContourPartDeleteVertex
IIngeoContourPartClear
IIngeoContourPartDelete
IIngeoContourPartsGetVertex
IIngeoContourPartDistanceFromPoint
IIngeoShapes
IIngeoShapesCount
IIngeoShapesItem
IIngeoShapes_NewEnum
IIngeoShapesMapObject
IIngeoShapesInsert
IIngeoShapesClear
IIngeoShape
IIngeoShapeContour
IIngeoShapeStyleID
IIngeoShapeIndex
IIngeoShapeStyle
IIngeoShapeDefineGeometry
IIngeoShapeDelete
IIngeoShapePaint
IIngeoTopoLinks
IIngeoTopoLinksCount
IIngeoTopoLinksItem
IIngeoTopoLinks_NewEnum
IIngeoTopoLinksDelete
IIngeoTopoLinksAdd
IIngeoTopoLinksDeleteID
IIngeoTopoLinksClear
TIngeoContourRelation
TIngeoContourCombineOperation
IIngeoUserProfile
IIngeoUserProfileGet
IIngeoUserProfilePut
IIngeoUserProfileExists
IIngeoUserProfileDelete
TIngeoUserProfileScope
IIngeoUser
IIngeoUserID
IIngeoUserName
IIngeoUserFullName
IIngeoUserDescription
IIngeoUserPassword
IIngeoUserModified
IIngeoUserRoleIDs
IIngeoUserUpdate
IIngeoUserDropChanges
IIngeoUserDelete
IIngeoRole
IIngeoRoleID
IIngeoRoleName
IIngeoRoleDescription
IIngeoRoleModified
IIngeoRoleUserIDs
IIngeoRoleUpdate
IIngeoRoleDropChanges
IIngeoRoleDelete
IIngeoUsers
IIngeoUsersCount
IIngeoUsersItem
IIngeoUsers_NewEnum
IIngeoUsersAdd
IIngeoUsersUserFromID
IIngeoUsersAddWithID
IIngeoRoles
IIngeoRolesCount
IIngeoRolesItem
IIngeoRoles_NewEnum
IIngeoRolesAdd
IIngeoRolesRoleFromID
IIngeoRolesAddWithID
TIngeoObjectClass
IIngeoAC
IIngeoACHasRights
IIngeoACGetACL
IIngeoACUpdateACL
TIngeoOp
IIngeoMapWindow
IIngeoMapWindowSurface
IIngeoMapWindowNavigator
IIngeoMapWindowCursor
IIngeoMapWindowStopHandler
IIngeoMapWindowStartObjectCreation
IIngeoMapWindowStartShapeCreation
IIngeoMapWindowInvalidate
IIngeoMapWindowInvalidateRect
IIngeoProjection
IIngeoProjectionZoomScale
IIngeoProjectionYMirror
IIngeoProjectionProjectPoint
IIngeoProjectionUnprojectPoint
IIngeoProjectionProjectContour
IIngeoProjectionUnprojectContour
IIngeoProjectionProjectBounds
IIngeoProjectionUnprojectBounds
IIngeoProjectionsProjectPoint
IIngeoProjectionsUnprojectPoint
IIngeoProjectionsProjectBounds
IIngeoProjectionsUnprojectBounds
IIngeoMatrixProjection
IIngeoMatrixProjectionClear
IIngeoMatrixProjectionAddScaling
IIngeoMatrixProjectionAddTranslation
IIngeoMatrixProjectionAddRotation
IIngeoMatrixProjectionAddReflection
IIngeoMatrixProjectionAddShear
IIngeoPaintSurface
IIngeoPaintSurfacePaperX1
IIngeoPaintSurfacePaperY1
IIngeoPaintSurfacePaperX2
IIngeoPaintSurfacePaperY2
IIngeoPaintSurfaceProjection
IIngeoPaintSurfacePen
IIngeoPaintSurfaceBrush
IIngeoPaintSurfaceFont
IIngeoPaintSurfaceDeviceLeft
IIngeoPaintSurfaceDeviceTop
IIngeoPaintSurfaceDeviceRight
IIngeoPaintSurfaceDeviceBottom
IIngeoPaintSurfaceDeviceType
IIngeoPaintSurfaceDC
IIngeoPaintSurfaceNavigator
IIngeoPaintSurfacePaintContour
IIngeoPaintSurfacePointDeviceToPaper
IIngeoPaintSurfacePointPaperToDevice
IIngeoPaintSurfaceRectDeviceToPaper
IIngeoPaintSurfaceRectPaperToDevice
IIngeoPaintSurfacePointDeviceToWorld
IIngeoPaintSurfacePointWorldToDevice
IIngeoPaintSurfacesPointDeviceToPaper
IIngeoPaintSurfacesPointPaperToDevice
IIngeoPaintSurfacesRectDeviceToPaper
IIngeoPaintSurfacesRectPaperToDevice
IIngeoPaintSurfacesPointDeviceToWorld
IIngeoPaintSurfacesPointWorldToDevice
IIngeoPaintSurfaceSizeDeviceToPaper
IIngeoPaintSurfaceSizePaperToDevice
IIngeoPaintSurfaceSizeDeviceToWorld
IIngeoPaintSurfaceSizeWorldToDevice
IIngeoPaintSurfaceGetContourTouchInfo
IIngeoPaintSurfacesGetContourTouchInfo
IIngeoNavigator
IIngeoNavigatorZoomToFitPaperRect
IIngeoNavigatorZoomToFitWorldRect
IIngeoNavigatorNavigate
IIngeoNavigatorFitWorldBounds
TIngeoNavigatorFitMode
IIngeoMatrixProjectionNavigator
IIngeoMatrixProjectionNavigatorCenterX
IIngeoMatrixProjectionNavigatorCenterY
IIngeoMatrixProjectionNavigatorZoomScale
IIngeoMatrixProjectionNavigatorXAngle
IIngeoMatrixProjectionNavigatorYMirror
TIngeoDeviceType
IIngeoApplicationSink
IIngeoApplicationSinkOpenDbComplete
IIngeoApplicationSinkDbWillClose
IIngeoApplicationSinkOpenProjectComplete
IIngeoApplicationSinkProjectWillClose
IIngeoApplicationSinkLayerActivateComplete
IIngeoApplicationSinkSelectionChangeComplete
IIngeoApplicationSinkStateChangeComplete
TIngeoSysObjectType
IIngeoDbPaintSink
IIngeoDbPaintSinkWillPaint
IIngeoDbPaintSinkPaintComplete
IIngeoDbPaintSinkProjectWillPaint
IIngeoDbPaintSinkProjectPaintComplete
IIngeoDbPaintSinkMapWillPaint
IIngeoDbPaintSinkMapPaintComplete
IIngeoDbPaintSinkLayerWillPaint
IIngeoDbPaintSinkLayerPaintComplete
IIngeoDbSysObjectsSink
IIngeoDbSysObjectsSinkWillCreate
IIngeoDbSysObjectsSinkCreateComplete
IIngeoDbSysObjectsSinkWillUpdate
IIngeoDbSysObjectsSinkUpdateComplete
IIngeoDbSysObjectsSinkWillDelete
IIngeoDbSysObjectsSinkDeleteComplete
IIngeoDbMapObjectsSink
IIngeoDbMapObjectsSinkCreateComplete
IIngeoDbMapObjectsSinkWillUpdate
IIngeoDbMapObjectsSinkUpdateComplete
IIngeoDbMapObjectsSinkWillDelete
IIngeoDbMapObjectsSinkDeleteComplete
IIngeoMapWindowSink
IIngeoMapWindowSinkWillPaint
IIngeoMapWindowSinkPaintComplete
IIngeoMapWindowSinkViewChangeComplete
IIngeoMapEditorsSink
IIngeoMapEditorsSinkPaint
IIngeoMapEditorsSinkMouseMove
IIngeoMapEditorsSinkMouseDown
IIngeoMapEditorsSinkMouseUp
IIngeoMapEditorsSinkKeyDown
IIngeoMapEditorsSinkKeyUp
IIngeoMapEditorsSinkAddGlues
IIngeoMapEditorsSinkRepaintDragging
TIngeoShiftState
TIngeoMouseButton
TIngeoMapObjectPart
IIngeoMapObjectsQuery
IIngeoMapObjectsQueryEOF
IIngeoMapObjectsQueryLayerID
IIngeoMapObjectsQueryObjectID
IIngeoMapObjectsQueryShapeIndex
IIngeoMapObjectsQueryReset
IIngeoMapObjectsQueryFetch
IIngeoMapObjectsQuerysFetch
IIngeoMapObjectsQueryMoveNext
TIngeoQueryByStyleFlags
IIngeoGlues
IIngeoGluesAddVertexGlue
IIngeoGluesAddEdgeGlue
TIngeoTouchInfo
IInImage
IInImageWidth
IInImageHeight
IInImageTransparentColor
IInImageTransparent
IInImageSurface
IInImageData
IInImageResolutionX
IInImageResolutionY
IInImageLoadFromFile
IInImageSaveToFile
TInImageDataType
IIngeoModule
IIngeoModuleCategory
IIngeoModuleName
IIngeoModuleCaption
IIngeoModuleStartModule
IIngeoModuleStopModule
IIngeoPlugin
IIngeoPluginModuleCount
IIngeoPluginModules
TIngeoXmlRequestFlags
IIngeoXmlResponse
IIngeoXmlResponseEOF
IIngeoXmlResponseRead
IIngeoContourEditor
IIngeoContourEditorBeginEditObject
IIngeoContourEditorBeginCreateObject
IIngeoContourEditorBeginCreateShapeForObject
TShapeCreationFlags
TIngeoCursor
TCoordinateSpace
IIngeoTaskPanel
IIngeoTaskPanelName
IIngeoTaskPanelCaption
IIngeoTaskPanelActive
IIngeoTaskPanelWindowHandle
IIngeoTaskPanelVisible
IIngeoTaskPanelActivate
IIngeoStyleView
IIngeoStyleViewVisible
IIngeoStyleViewStyle
IIngeoStyleViewLayerView
IIngeoStyleViews
IIngeoStyleViewsCount
IIngeoStyleViewsItem
IIngeoStyleViews_NewEnum
IIngeoLicense
IIngeoLicenseNumber
IIngeoLicenseCustomer
IIngeoLicenseDemoMode
IIngeoLicenseConnectionLimit
IIngeoLicenseDateLimit


Объект IInBrush

Закраска.

Свойства

Свойство | Описание
BackColor | Цвет фона.
HatchColor | Цвет штрихов.
Style | Стиль закраски.
Transparency | Прозрачность.

См.также

IInPen, IInFont, TInBrushStyle


Свойство BackColor (Объект IInBrush)

Цвет фона.

Синтаксис

Язык Описание
VBScript, JavaScript
BackColor
Visual Basic
Property BackColor As Long
Delphi
property BackColor: Longint
C, C++
HRESULT get_BackColor(long* Value);
HRESULT set_BackColor(long Value);


Свойство HatchColor (Объект IInBrush)

Цвет штрихов.

Синтаксис

Язык Описание
VBScript, JavaScript
HatchColor
Visual Basic
Property HatchColor As Long
Delphi
property HatchColor: Longint
C, C++
HRESULT get_HatchColor(long* Value);
HRESULT set_HatchColor(long Value);


Свойство Style (Объект IInBrush)

Стиль закраски.

Синтаксис

Язык Описание
VBScript, JavaScript
Style
Visual Basic
Property Style As TInBrushStyle
Delphi
property Style: TInBrushStyle
C, C++
HRESULT get_Style(TInBrushStyle* Value);
HRESULT set_Style(TInBrushStyle Value);

См.также

TInBrushStyle


Свойство Transparency (Объект IInBrush)

Определяет степень прозрачности фона.

Синтаксис

Язык Описание
VBScript, JavaScript
Transparency
Visual Basic
Property Transparency As Byte
Delphi
property Transparency: Byte
C, C++
HRESULT get_Transparency(unsigned char* Value);
HRESULT set_Transparency(unsigned char Value);

Примечания

Может принимать значения от 0 до 10
  • 0 - сплошной фон
  • 1 - прозрачный
  • 6 - полупрозрачный
  • 10 - 10% прозрачности.


Объект IInContextCard

Карточка контекста.
Используется для корректного удаления различных объектов, созданных со стороны программ.


Объект IInFont

Шрифт

Свойства

Свойство | Описание
CharSet | Кодировка.
Color | Цвет шрифта.
ForZoomScale | Для масштаба.
Name | Название шрифта.
Pitch | Шаг шрифта.
Size | Размер шрифта (в пунктах).
Style | Начертание шрифта.

См.также

IInPen, IInBrush, TInFontStyle, TInFontStyle


Свойство CharSet (Объект IInFont)

Набор символов.

Синтаксис

Язык Описание
VBScript, JavaScript
CharSet
Visual Basic
Property CharSet As Byte
Delphi
property CharSet: Byte
C, C++
HRESULT get_CharSet(unsigned char* Value);
HRESULT set_CharSet(unsigned char Value);

Примечания

Например: MS DOS, Восточная Европа, Русский.


Свойство Color (Объект IInFont)

Цвет шрифта.

Синтаксис

Язык Описание
VBScript, JavaScript
Color
Visual Basic
Property Color As Long
Delphi
property Color: Longint
C, C++
HRESULT get_Color(long* Value);
HRESULT set_Color(long Value);


Свойство ForZoomScale (Объект IInFont)

Значение масштаба, для которого определяется размер шрифта.

Синтаксис

Язык Описание
VBScript, JavaScript
ForZoomScale
Visual Basic
Property ForZoomScale As Double
Delphi
property ForZoomScale: Double
C, C++
HRESULT get_ForZoomScale(double* Value);
HRESULT set_ForZoomScale(double Value);


Свойство Name (Объект IInFont)

Название шрифта.

Синтаксис

Язык Описание
VBScript, JavaScript
Name
Visual Basic
Property Name As String
Delphi
property Name: WideString
C, C++
HRESULT get_Name(BSTR* Value);
HRESULT set_Name(BSTR Value);


Свойство Pitch (Объект IInFont)

Шаг шрифта.

Синтаксис

Язык Описание
VBScript, JavaScript
Pitch
Visual Basic
Property Pitch As TInFontPitch
Delphi
property Pitch: TInFontPitch
C, C++
HRESULT get_Pitch(TInFontPitch* Value);
HRESULT set_Pitch(TInFontPitch Value);

См.также

TInFontPitch


Свойство Size (Объект IInFont)

Размер шрифта (в пунктах).

Синтаксис

Язык Описание
VBScript, JavaScript
Size
Visual Basic
Property Size As Long
Delphi
property Size: Longint
C, C++
HRESULT get_Size(long* Value);
HRESULT set_Size(long Value);


Свойство Style (Объект IInFont)

Начертание шрифта.

Синтаксис

Язык Описание
VBScript, JavaScript
Style
Visual Basic
Property Style As TInFontStyle
Delphi
property Style: TInFontStyle
C, C++
HRESULT get_Style(TInFontStyle* Value);
HRESULT set_Style(TInFontStyle Value);

См.также

TInFontStyle


Объект IIngeoAC

Права доступа к системному объекту БД или к самой БД.

Методы

Метод | Описание
GetACL | Получение списка прав доступа к объекту или классу вложеных объектов.
HasRights | Проверка на наличие у текущего пользователя прав на выполнение указанной операции над объектом.
UpdateACL | Изменение списка прав доступа к объекту или классу вложеных объектов.

См.также

Список прав


Метод GetACL (Объект IIngeoAC)

Получение списка прав доступа к объекту или классу вложеных объектов.

Синтаксис

Язык | Описание
VBScript, JavaScript | FunctionGetACL(aSubClass)
Visual Basic | Function GetACL(ByVal aSubClass As String) As Variant
Delphi | function GetACL(const aSubClass: WideString): OleVariant;
C, C++ | HRESULT GetACL(BSTR aSubClass, VARIANT* Value);

Параметры

aSubClass
Подкласс объекта.
Может принимать одно из следующих значений:
Значение | Описание
NOID | Данный объект
AREA | Права вложеных территорий
PROJECT | Права вложеных проектов'
RASTMAP | Права вложеных растровых карт
VECTMAP | Права вложеных векторных карт
LAYER | Права вложеных слоев
STYLE | Права вложеных стилей
SEMTABLE | Права вложеных семантических таблиц
REFBOOK | Права вложеных справочников

Возвращаемое значение

Возвращается таблица прав доступа в виде массива, каждый элемент которого является массивом из четырех элементов:
- вид пользователя (0 - пользователь, 1 - группа пользователей);
- идентификатор пользоватиеля или группы;
- комбинация разрешаемых операций;
- комбинация запрещаемых операций.


Метод HasRights (Объект IIngeoAC)

Проверка на наличие у текущего пользователя прав на выполнение указанной операции над объектом.

Синтаксис

Язык | Описание
VBScript, JavaScript | FunctionHasRights(anOp)
Visual Basic | Function HasRights(ByVal anOp As TIngeoOp) As Boolean
Delphi | function HasRights(anOp: TIngeoOp): WordBool;
C, C++ | HRESULT HasRights(TIngeoOp anOp, VARIANT_BOOL* Value);

Параметры

anOp
Код операции.

См.также

TIngeoOp


Метод UpdateACL (Объект IIngeoAC)

Изменение списка прав доступа к объекту или классу вложеных объектов.

Синтаксис

Язык | Описание
VBScript, JavaScript | SubUpdateACL(aSubClass, anACL)
Visual Basic | Sub UpdateACL(ByVal aSubClass As String, ByVal anACL As Variant)
Delphi | procedure UpdateACL(const aSubClass: WideString; anACL: OleVariant);
C, C++ | HRESULT UpdateACL(BSTR aSubClass, VARIANT anACL);

Параметры

aSubClass
Подкласс объекта.
Может принимать одно из следующих значений:
Значение | Описание
NOID | Данный объект
AREA | Права вложеных территорий
PROJECT | Права вложеных проектов'
RASTMAP | Права вложеных растровых карт
VECTMAP | Права вложеных векторных карт
LAYER | Права вложеных слоев
STYLE | Права вложеных стилей
SEMTABLE | Права вложеных семантических таблиц
REFBOOK | Права вложеных справочников
anACL
Таблица прав доступа в виде массива, каждый элемент которого является массивом из четырех элементов:
- вид пользователя (0 - пользователь, 1 - группа пользователей);
- идентификатор пользоватиеля или группы;
- комбинация разрешаемых операций;
- комбинация запрещаемых операций.


Объект IIngeoApplication

Главный объект, предоставляемый со стороны ИнГЕО. Доступ к любым объектам ИнГЕО начинается с этого объекта.

Свойства

Свойство | Описание
ActiveDb | Активная в данный момент база данных.
ActiveProjectView | Открытый в данный момент проект.
ExePath | Полный путь к программе, предоставившей объект Application. Обычно это путь к InGEO.EXE, InGEOAppServer.EXE, InGEOMapX.OCX.
MainWindow | Главное окно ГИС ИнГЕО.
Printers | Список принтеров, установленных в системе.
Selection | Список выделенных объектов в окне карты.
UserProfile | Объект для доступа к профилю пользователя.
Version | Версия ИнГео.
Windows | Список вспомогательных окон, открытых в данных момент.

Методы

Метод | Описание
CloseActiveDb | Закрывает активную в данный момент базу данных.
CloseActiveProject | Закрывает активный на данный момент проект.
CreateObject | Создание вспомогательного объекта.
OpenDb | Открывает базу данных.
OpenHTMLWindow | Открывает новое окно HTML.
OpenOverlappedHTMLWindow | Аналогично OpenHTMLWindow с тем отличием, что созданное окно будет окном верхнего уровня.
OpenProject | Открывает проект с указанным идентификатором.
OpenWindow | Открытие вспомогательного окна.
ProcessMessages | Обработка очереди сообщений ГИС ИнГЕО.
XmlRequest | Выполнить XML-запрос.

Примечания

Данный объект доступен из встроенных программных модулей под именем Application


Свойство ActiveDb (Объект IIngeoApplication)

Активная в данный момент база данных.

Синтаксис

Язык Описание
VBScript, JavaScript
ActiveDb
Visual Basic
Property ActiveDb As IIngeoDb
Delphi
property ActiveDb: IIngeoDb
C, C++
HRESULT get_ActiveDb(IIngeoDb** Value);

Примечания

Если в данный момент времени база данных не открыта, то значение свойства Nothing.

См.также

IIngeoDb


Свойство ActiveProjectView (Объект IIngeoApplication)

Открытый в данный момент проект.

Синтаксис

Язык Описание
VBScript, JavaScript
ActiveProjectView
Visual Basic
Property ActiveProjectView As IIngeoProjectView
Delphi
property ActiveProjectView: IIngeoProjectView
C, C++
HRESULT get_ActiveProjectView(IIngeoProjectView** Value);

Примечания

Если в данный момент времени проект не открыт, то значение свойства Nothing.

См.также

IIngeoProjectView


Метод CloseActiveDb (Объект IIngeoApplication)

Закрывает активную в данный момент базу данных.

Синтаксис

Язык | Описание
VBScript, JavaScript | SubCloseActiveDb()
Visual Basic | Sub CloseActiveDb()
Delphi | procedure CloseActiveDb;
C, C++ | HRESULT CloseActiveDb();


Метод CloseActiveProject (Объект IIngeoApplication)

Закрывает активный на данный момент проект.

Синтаксис

Язык | Описание
VBScript, JavaScript | SubCloseActiveProject()
Visual Basic | Sub CloseActiveProject()
Delphi | procedure CloseActiveProject;
C, C++ | HRESULT CloseActiveProject();


Метод CreateObject (Объект IIngeoApplication)

Создание вспомогательного объекта.

Синтаксис

Язык | Описание
VBScript, JavaScript | FunctionCreateObject(aClass, aParam)
Visual Basic | Function CreateObject(ByVal aClass As TIngeoObjectClass, ByVal aParam As Variant) As Object
Delphi | function CreateObject(aClass: TIngeoObjectClass; aParam: OleVariant): IDispatch;
C, C++ | HRESULT CreateObject(TIngeoObjectClass aClass, VARIANT aParam, IDispatch* Value);

Параметры

aClass

Класс создаваемого объекта.

aParam
Вспомогательный параметр, значение которого зависит от значения параметра aClass.

См.также

TIngeoObjectClass


Свойство ExePath (Объект IIngeoApplication)

Полный путь к программе, предоставившей объект Application. Обычно это путь к InGEO.EXE, InGEOAppServer.EXE, InGEOMapX.OCX.

Синтаксис

Язык Описание
VBScript, JavaScript
ExePath
Visual Basic
Property ExePath As String
Delphi
property ExePath: WideString
C, C++
HRESULT get_ExePath(BSTR* Value);


Свойство MainWindow (Объект IIngeoApplication)

Главное окно ГИС ИнГЕО.

Синтаксис

Язык Описание
VBScript, JavaScript
MainWindow
Visual Basic
Property MainWindow As IIngeoMainWindow
Delphi
property MainWindow: IIngeoMainWindow
C, C++
HRESULT get_MainWindow(IIngeoMainWindow** Value);


Метод OpenDb (Объект IIngeoApplication)

Открывает базу данных.

Синтаксис

Язык | Описание
VBScript, JavaScript | SubOpenDb(Server, DbID, UserName, Password)
Visual Basic | Sub OpenDb(ByVal Server As String, ByVal DbID As String, ByVal UserName As String, ByVal Password As String)
Delphi | procedure OpenDb(const Server: WideString; const DbID: WideString; const UserName: WideString; const Password: WideString);
C, C++ | HRESULT OpenDb(BSTR Server, BSTR DbID, BSTR UserName, BSTR Password);

Параметры

Server
Имя или IP адрес компьютера, на котором распологается сервер данных.
DbID
Идентификатор базы данных.
UserName
Имя пользователя.
Password
Пароль.


Метод OpenHTMLWindow (Объект IIngeoApplication)

Открывает новое окно HTML.

Синтаксис

Язык | Описание
VBScript, JavaScript | FunctionOpenHTMLWindow(aContextCard)
Visual Basic | Function OpenHTMLWindow(ByVal aContextCard As IInContextCard) As IInHTMLWindow
Delphi | function OpenHTMLWindow(aContextCard: IInContextCard): IInHTMLWindow;
C, C++ | HRESULT OpenHTMLWindow(IInContextCard* aContextCard, IInHTMLWindow** Value);

Параметры

aContextCard
Карточка контекста, к которой приписывается открытое окно. При уничтожении карточки контекста окно автоматически закрывается.

Примечания

Созданное окно не видимо. Для того, чтобы сделать окно видимым, необходимо присвоить значение True свойству Visible объекта окна.


Метод OpenOverlappedHTMLWindow (Объект IIngeoApplication)

Аналогично OpenHTMLWindow с тем отличием, что созданное окно будет окном верхнего уровня.

Синтаксис

Язык | Описание
VBScript, JavaScript | FunctionOpenOverlappedHTMLWindow(aContextCard)
Visual Basic | Function OpenOverlappedHTMLWindow(ByVal aContextCard As IInContextCard) As IInHTMLWindow
Delphi | function OpenOverlappedHTMLWindow(aContextCard: IInContextCard): IInHTMLWindow;
C, C++ | HRESULT OpenOverlappedHTMLWindow(IInContextCard* aContextCard, IInHTMLWindow** Value);

Параметры

aContextCard


Метод OpenProject (Объект IIngeoApplication)

Открывает проект с указанным идентификатором.

Синтаксис

Язык | Описание
VBScript, JavaScript | SubOpenProject(ProjectID)
Visual Basic | Sub OpenProject(ByVal ProjectID As String)
Delphi | procedure OpenProject(const ProjectID: WideString);
C, C++ | HRESULT OpenProject(BSTR ProjectID);

Параметры

ProjectID
Идентификатор проекта


Метод OpenWindow (Объект IIngeoApplication)

Открытие вспомогательного окна.

Синтаксис

Язык | Описание
VBScript, JavaScript | FunctionOpenWindow(aName, aParams)
Visual Basic | Function OpenWindow(ByVal aName As String, ByVal aParams As Variant) As IInWindow
Delphi | function OpenWindow(const aName: WideString; aParams: OleVariant): IInWindow;
C, C++ | HRESULT OpenWindow(BSTR aName, VARIANT aParams, IInWindow** Value);

Параметры

aName

Название вспомогательного окна.

Может принимать следующие значения:

Значение Описание
LayoutWindow Открывается окно макета печати. Если задан параметр aParams, то он должен содержать полное название файла макета печати, который будет открыт в окне макета печати. Замечание: при вызове данного метода всегда создается новое окно макета печати.
Возращает объект типа IInLayoutWindow.
ExplorerWindow Открывается окно проводника базы данных. Если задан параметр aParams, то он должен содержать идентификатор системного объекта, который будет выделен после открытия окна проводника. Замечание: так как окно проводника может быть только в единственном экземпляре, то в случае, если окно проводника уже открыто, произойдет выделение указанного объекта и активизация окна проводника.
Возвращает объект типа IInWindow.
MapObjectWindow Открывается окно свойств выделенного объекта. Параметр aParams не используется. Замечание: так как окно свойств объекта может быть только в единственном экземпляре, то в случае, если оно уже открыто, произойдет активизация окна.
Возвращает объект типа IInWindow.
aParams
Дополнительные параметры для открытия окна. Назначение данного параметра зависит от названия окна.

Возвращаемое значение

Возвращает объект открытого окна.

См.также

IInLayoutWindow IInWindow


Свойство Printers (Объект IIngeoApplication)

Список принтеров, установленных в системе.

Синтаксис

Язык Описание
VBScript, JavaScript
Printers
Visual Basic
Property Printers As IInPrinters
Delphi
property Printers: IInPrinters
C, C++
HRESULT get_Printers(IInPrinters** Value);


Метод ProcessMessages (Объект IIngeoApplication)

Данный метод предназначен для того, что бы ГИС ИнГЕО могла обработать все накопившиеся сообщения Windows. При выполнении длительных операций рекомендуется вызывать данный метод.

Синтаксис

Язык | Описание
VBScript, JavaScript | SubProcessMessages()
Visual Basic | Sub ProcessMessages()
Delphi | procedure ProcessMessages;
C, C++ | HRESULT ProcessMessages();


Свойство Selection (Объект IIngeoApplication)

Список выделенных объектов в окне карты.

Синтаксис

Язык Описание
VBScript, JavaScript
Selection
Visual Basic
Property Selection As IIngeoSelection
Delphi
property Selection: IIngeoSelection
C, C++
HRESULT get_Selection(IIngeoSelection** Value);

См.также

IIngeoSelection


Объект IIngeoApplicationSink

Объект-обработчик событий от Application.

Методы

Метод | Описание
DbWillClose | Вызывается перед закрытием базы данных.
LayerActivateComplete | Вызывается после изменения активного слоя или карты.
OpenDbComplete | Вызывается после открытия базы данных.
OpenProjectComplete | Вызывается после открытия проект.
ProjectWillClose | Вызывается перед закрытием проекта.
SelectionChangeComplete | Вызывается после изменения набора выделенных объектов в окне карты.
StateChangeComplete | Изменилось состояние окна редактора карты.

Примечания

Данный объект реализуется на стороне внешнего модуля.

Все события с префиксом Will вызываются только в том процессе ИнГео, в котором выполняется модуль расширения.


Метод DbWillClose (Объект IIngeoApplicationSink)

Вызывается перед закрытием базы данных.

Синтаксис

Язык | Описание
VBScript, JavaScript | SubDbWillClose()
Visual Basic | Sub DbWillClose()
Delphi | procedure DbWillClose;
C, C++ | HRESULT DbWillClose();


Метод LayerActivateComplete (Объект IIngeoApplicationSink)

Вызывается после изменения активного слоя или карты.

Синтаксис

Язык | Описание
VBScript, JavaScript | SubLayerActivateComplete()
Visual Basic | Sub LayerActivateComplete()
Delphi | procedure LayerActivateComplete;
C, C++ | HRESULT LayerActivateComplete();


Метод OpenDbComplete (Объект IIngeoApplicationSink)

Вызывается после открытия базы данных.

Синтаксис

Язык | Описание
VBScript, JavaScript | SubOpenDbComplete()
Visual Basic | Sub OpenDbComplete()
Delphi | procedure OpenDbComplete;
C, C++ | HRESULT OpenDbComplete();


Метод OpenProjectComplete (Объект IIngeoApplicationSink)

Вызывается после открытия проект.

Синтаксис

Язык | Описание
VBScript, JavaScript | SubOpenProjectComplete()
Visual Basic | Sub OpenProjectComplete()
Delphi | procedure OpenProjectComplete;
C, C++ | HRESULT OpenProjectComplete();


Метод ProjectWillClose (Объект IIngeoApplicationSink)

Вызывается перед закрытием проекта.

Синтаксис

Язык | Описание
VBScript, JavaScript | SubProjectWillClose()
Visual Basic | Sub ProjectWillClose()
Delphi | procedure ProjectWillClose;
C, C++ | HRESULT ProjectWillClose();


Метод SelectionChangeComplete (Объект IIngeoApplicationSink)

Вызывается после изменения набора выделенных объектов в окне карты.

Синтаксис

Язык | Описание
VBScript, JavaScript | SubSelectionChangeComplete()
Visual Basic | Sub SelectionChangeComplete()
Delphi | procedure SelectionChangeComplete;
C, C++ | HRESULT SelectionChangeComplete();

Примечания

Если за один раз было выделенно несколько объектов, до данный метод вызовется всего один раз - после завершения выделения объектов.


Метод StateChangeComplete (Объект IIngeoApplicationSink)

Изменилось состояние окна редактора карты.

Синтаксис

Язык | Описание
VBScript, JavaScript | SubStateChangeComplete()
Visual Basic | Sub StateChangeComplete()
Delphi | procedure StateChangeComplete;
C, C++ | HRESULT StateChangeComplete();


Свойство UserProfile (Объект IIngeoApplication)

Объект для доступа к профилю пользователя.

Синтаксис

Язык Описание
VBScript, JavaScript
UserProfile
Visual Basic
Property UserProfile As IIngeoUserProfile
Delphi
property UserProfile: IIngeoUserProfile
C, C++
HRESULT get_UserProfile(IIngeoUserProfile** Value);


Свойство Version (Объект IIngeoApplication)

Версия ИнГео.

Синтаксис

Язык Описание
VBScript, JavaScript
Version
Visual Basic
Property Version As String
Delphi
property Version: WideString
C, C++
HRESULT get_Version(BSTR* Value);


Свойство Windows (Объект IIngeoApplication)

Список вспомогательных окон, открытых в данных момент.

Синтаксис

Язык Описание
VBScript, JavaScript
Windows
Visual Basic
Property Windows As IInWindows
Delphi
property Windows: IInWindows
C, C++
HRESULT get_Windows(IInWindows** Value);


Метод XmlRequest (Объект IIngeoApplication)

Выполнить XML-запрос.

Синтаксис

Язык | Описание
VBScript, JavaScript | FunctionXmlRequest(aRequest, anOptions)
Visual Basic | Function XmlRequest(ByVal aRequest As Variant, ByVal anOptions As Long) As Variant
Delphi | function XmlRequest(aRequest: OleVariant; anOptions: Longint): OleVariant;
C, C++ | HRESULT XmlRequest(VARIANT aRequest, long anOptions, VARIANT* Value);

Параметры

aRequest
Строка, содержащая XML-запрос.
anOptions
Должен быть равен inxrReturnString.

Возвращаемое значение

Текст ответа в формате XML.

См.также

XmlRequests


Объект IIngeoArea

Объект IIngeoArea представляет собой территорию.

Свойства

Свойство | Описание
AC | Права доступа.
ID | Внутренний идентификатор территории.
Maps | Карта.
Modified | Признак измения значений свойств территрии.
Name | Название территории.
Projects | Проект.
X1 | Минимальная координата границы территории по оси X.
X2 | Максимальная координата границы территории по оси X.
Y1 | Минимальная координата границы территории по оси Y.
Y2 | Максимальная координата границы территории по оси Y.

Методы

Метод | Описание
Delete | Удаление территории.
DropChanges | Отмена внесенных изменений.
Update | Сохранение внесенных изменений свойств территории в базу данных.


Свойство AC (Объект IIngeoArea)

Права доступа.

Синтаксис

Язык Описание
VBScript, JavaScript
AC
Visual Basic
Property AC As IIngeoAC
Delphi
property AC: IIngeoAC
C, C++
HRESULT get_AC(IIngeoAC** Value);

См.также

Список прав


Метод Delete (Объект IIngeoArea)

Удаление территории.

Синтаксис

Язык | Описание
VBScript, JavaScript | SubDelete()
Visual Basic | Sub Delete()
Delphi | procedure Delete;
C, C++ | HRESULT Delete();


Метод DropChanges (Объект IIngeoArea)

Отмена внесенных изменений.

Синтаксис

Язык | Описание
VBScript, JavaScript | SubDropChanges()
Visual Basic | Sub DropChanges()
Delphi | procedure DropChanges;
C, C++ | HRESULT DropChanges();


Свойство ID (Объект IIngeoArea)

Внутренний идентификатор территории.

Синтаксис

Язык Описание
VBScript, JavaScript
ID
Visual Basic
Property ID As String
Delphi
property ID: WideString
C, C++
HRESULT get_ID(BSTR* Value);


Свойство Maps (Объект IIngeoArea)

Карта.

Синтаксис

Язык Описание
VBScript, JavaScript
Maps
Visual Basic
Property Maps As IIngeoMaps
Delphi
property Maps: IIngeoMaps
C, C++
HRESULT get_Maps(IIngeoMaps** Value);


Свойство Modified (Объект IIngeoArea)

Признак измения значений свойств территрии.

Синтаксис

Язык Описание
VBScript, JavaScript
Modified
Visual Basic
Property Modified As Boolean
Delphi
property Modified: WordBool
C, C++
HRESULT get_Modified(VARIANT_BOOL* Value);

Примечания

Изменения свойств территории будут внесены в базу данных только после вызова метода Update IIngeoArea.


Свойство Name (Объект IIngeoArea)

Название территории.

Синтаксис

Язык Описание
VBScript, JavaScript
Name
Visual Basic
Property Name As String
Delphi
property Name: WideString
C, C++
HRESULT get_Name(BSTR* Value);
HRESULT set_Name(BSTR Value);


Свойство Projects (Объект IIngeoArea)

Проект.

Синтаксис

Язык Описание
VBScript, JavaScript
Projects
Visual Basic
Property Projects As IIngeoProjects
Delphi
property Projects: IIngeoProjects
C, C++
HRESULT get_Projects(IIngeoProjects** Value);


Объект IIngeoAreas

Объект Areas представляет собой список территорий.

Свойства

Свойство | Описание
Count | Колличество территорий.
Item | Получение территории по Index.
_NewEnum | Служебный метод: возвращает перечислитель коллекции списка.

Методы

Метод | Описание
Add | Добавление территории.
AddWithID | Добавление территории с указанным идентификатором.

См.также

IIngeoArea


Свойство _NewEnum (Объект IIngeoAreas)

Служебный метод: возвращает перечислитель коллекции списка.

Синтаксис

Язык Описание
VBScript, JavaScript
_NewEnum
Visual Basic
Property _NewEnum As Object
Delphi
property _NewEnum: IUnknown
C, C++
HRESULT get__NewEnum(IUnknown* Value);

Пример

For Each aMap In aMaps
...
Next


Метод Add (Объект IIngeoAreas)

Добавление территории.

Синтаксис

Язык | Описание
VBScript, JavaScript | FunctionAdd()
Visual Basic | Function Add() As IIngeoArea
Delphi | function Add: IIngeoArea;
C, C++ | HRESULT Add(IIngeoArea** Value);

Примечания

Новая территория будет добавлена в базу данных только после вызова метода Update IIngeoArea.

Пример

i = aDb.Area.Add


Метод AddWithID (Объект IIngeoAreas)

Добавление территории с указанным идентификатором.

Синтаксис

Язык | Описание
VBScript, JavaScript | FunctionAddWithID(anID)
Visual Basic | Function AddWithID(ByVal anID As String) As IIngeoArea
Delphi | function AddWithID(const anID: WideString): IIngeoArea;
C, C++ | HRESULT AddWithID(BSTR anID, IIngeoArea** Value);

Параметры

anID
Идентификатор добавляемой территории.

Примечания

Новая территория будет добавлена в базу данных только после вызова метода Update IIngeoArea.


Свойство Count (Объект IIngeoAreas)

Колличество территорий.

Синтаксис

Язык Описание
VBScript, JavaScript
Count
Visual Basic
Property Count As Long
Delphi
property Count: Longint
C, C++
HRESULT get_Count(long* Value);


Свойство Item (Объект IIngeoAreas)

Получение территории по Index.

Синтаксис

Язык Описание
VBScript, JavaScript
Item(anIndex)
Visual Basic
Property Item(ByVal anIndex As Long) As IIngeoArea
Delphi
property Item[anIndex: Longint]: IIngeoArea
C, C++
HRESULT get_Item(long anIndex, IIngeoArea** Value);

Параметры

anIndex
Index территории (диапазон от 0 до Count-1)

Возвращаемое значение

Возвращает объект территории.

См.также

IIngeoArea


Метод Update (Объект IIngeoArea)

Сохранение внесенных изменений свойств территории в базу данных.

Синтаксис

Язык | Описание
VBScript, JavaScript | SubUpdate()
Visual Basic | Sub Update()
Delphi | procedure Update;
C, C++ | HRESULT Update();


Свойство X1 (Объект IIngeoArea)

Минимальная координата границы территории по оси X.

Синтаксис

Язык Описание
VBScript, JavaScript
X1
Visual Basic
Property X1 As Double
Delphi
property X1: Double
C, C++
HRESULT get_X1(double* Value);
HRESULT set_X1(double Value);


Свойство X2 (Объект IIngeoArea)

Максимальная координата границы территории по оси X.

Синтаксис

Язык Описание
VBScript, JavaScript
X2
Visual Basic
Property X2 As Double
Delphi
property X2: Double
C, C++
HRESULT get_X2(double* Value);
HRESULT set_X2(double Value);


Свойство Y1 (Объект IIngeoArea)

Минимальная координата границы территории по оси Y.

Синтаксис

Язык Описание
VBScript, JavaScript
Y1
Visual Basic
Property Y1 As Double
Delphi
property Y1: Double
C, C++
HRESULT get_Y1(double* Value);
HRESULT set_Y1(double Value);


Свойство Y2 (Объект IIngeoArea)

Максимальная координата границы территории по оси Y.

Синтаксис

Язык Описание
VBScript, JavaScript
Y2
Visual Basic
Property Y2 As Double
Delphi
property Y2: Double
C, C++
HRESULT get_Y2(double* Value);
HRESULT set_Y2(double Value);


Объект IIngeoContour

Контур. Определяет координаты и форму пространственного объекта.

Свойства

Свойство | Описание
Count | Количество частей контура.
Item | Возвращает часть контура.
Perimeter | Периметр контура.
Square | Площадь контура.
_NewEnum | Возвращает перечислитель по элементам (частям контура) коллекции.

Методы

Метод | Описание
AddPartsFrom | Добавляет части контура из другого контура.
BuildBufferZone | Строит буферную зону для контура.
Clear | Удаляет все части контура.
Combine | Производит пространственную операцию с другим контуром.
DistanceFromPoint | Вычисляет растояние до заданной точки.
GetBounds | Вычисляет границы контура.
Insert | Добавляет часть контура.
sGetBounds | Вычисляет границы контура. Скриптовая версия метода GetBounds.
TestRelation | Определяет пространственное расположение данного контура по отношению к другому контуру.

См.также

IIngeoShape, IIngeoContourPart, Application.CreateObject


Свойство _NewEnum (Объект IIngeoContour)

Возвращает перечислитель по элементам (частям контура) коллекции.

Синтаксис

Язык Описание
VBScript, JavaScript
_NewEnum
Visual Basic
Property _NewEnum As Object
Delphi
property _NewEnum: IUnknown
C, C++
HRESULT get__NewEnum(IUnknown* Value);

См.также

IIngeoContour, IIngeoContourPart


Метод AddPartsFrom (Объект IIngeoContour)

Добавляет части контура из другого контура.

Синтаксис

Язык | Описание
VBScript, JavaScript | SubAddPartsFrom(aSource)
Visual Basic | Sub AddPartsFrom(ByVal aSource As IIngeoContour)
Delphi | procedure AddPartsFrom(aSource: IIngeoContour);
C, C++ | HRESULT AddPartsFrom(IIngeoContour* aSource);

Параметры

aSource
Контур у которого берутся части контура.

См.также

IIngeoContour


Метод BuildBufferZone (Объект IIngeoContour)

Строит буферную зону для контура.

Синтаксис

Язык | Описание
VBScript, JavaScript | FunctionBuildBufferZone(aRadius)
Visual Basic | Function BuildBufferZone(ByVal aRadius As Double) As IIngeoContour
Delphi | function BuildBufferZone(aRadius: Double): IIngeoContour;
C, C++ | HRESULT BuildBufferZone(double aRadius, IIngeoContour** Value);

Параметры

aRadius
Радиус буферной зоны.


Метод Clear (Объект IIngeoContour)

Удаляет все части контура.

Синтаксис

Язык | Описание
VBScript, JavaScript | SubClear()
Visual Basic | Sub Clear()
Delphi | procedure Clear;
C, C++ | HRESULT Clear();

См.также

IIngeoContour


Метод Combine (Объект IIngeoContour)

Производит пространственную операцию с другим контуром. Результат помещается в этом же контуре.

Синтаксис

Язык | Описание
VBScript, JavaScript | SubCombine(anOperation, aContour)
Visual Basic | Sub Combine(ByVal anOperation As TIngeoContourCombineOperation, ByVal aContour As IIngeoContour)
Delphi | procedure Combine(anOperation: TIngeoContourCombineOperation; aContour: IIngeoContour);
C, C++ | HRESULT Combine(TIngeoContourCombineOperation anOperation, IIngeoContour* aContour);

Параметры

anOperation
Тип пространственной операции.
aContour
Контур, который участвует в операции.

См.также

IIngeoContour, TIngeoContourCombineOperation


Свойство Count (Объект IIngeoContour)

Количество частей контура.

Синтаксис

Язык Описание
VBScript, JavaScript
Count
Visual Basic
Property Count As Long
Delphi
property Count: Longint
C, C++
HRESULT get_Count(long* Value);

См.также

IIngeoContour


Метод DistanceFromPoint (Объект IIngeoContour)

Вычисляет растояние до заданной точки.

Синтаксис

Язык | Описание
VBScript, JavaScript | FunctionDistanceFromPoint(aX, aY)
Visual Basic | Function DistanceFromPoint(ByVal aX As Double, ByVal aY As Double) As Double
Delphi | function DistanceFromPoint(aX: Double; aY: Double): Double;
C, C++ | HRESULT DistanceFromPoint(double aX, double aY, double* Value);

Параметры

aX
X координата точки.
aY
Y координата точки.

Возвращаемое значение

Расстояние от точки до данной части контура.

Пример

Dim MapObjects, theObject1, theContour1
Dim x1, y1, length

if Application.Selection.Count = 1 then
  Set MapObjects = Application.ActiveDB.MapObjects
  Set theObject1 = MapObjects.GetObject(Application.Selection.IDs(0))
  Set theContour1 = theObject1.Shapes.Item(0).Contour

  x1 = 0
  y1 = 0
  length = theContour1.DistanceFromPoint(x1, y1)
  MsgBox "Контур от точки (" & x1 &", " & y1 &") находится на расстоянии: " & length
else
    MsgBox "Выделите один объект."
end if


Объект IIngeoContourEditor

Не реализовано.

Методы

Метод Описание
BeginCreateObject
BeginCreateShapeForObject
BeginEditObject


Метод BeginCreateObject (Объект IIngeoContourEditor)

Синтаксис

Язык | Описание
VBScript, JavaScript | SubBeginCreateObject(aStyleID)
Visual Basic | Sub BeginCreateObject(ByVal aStyleID As String)
Delphi | procedure BeginCreateObject(const aStyleID: WideString);
C, C++ | HRESULT BeginCreateObject(BSTR aStyleID);

Параметры

aStyleID


Метод BeginCreateShapeForObject (Объект IIngeoContourEditor)

Синтаксис

Язык | Описание
VBScript, JavaScript | SubBeginCreateShapeForObject(anObjectID, aStyleID)
Visual Basic | Sub BeginCreateShapeForObject(ByVal anObjectID As String, ByVal aStyleID As String)
Delphi | procedure BeginCreateShapeForObject(const anObjectID: WideString; const aStyleID: WideString);
C, C++ | HRESULT BeginCreateShapeForObject(BSTR anObjectID, BSTR aStyleID);

Параметры

anObjectID
aStyleID


Метод BeginEditObject (Объект IIngeoContourEditor)

Синтаксис

Язык | Описание
VBScript, JavaScript | SubBeginEditObject(anObjectID)
Visual Basic | Sub BeginEditObject(ByVal anObjectID As String)
Delphi | procedure BeginEditObject(const anObjectID: WideString);
C, C++ | HRESULT BeginEditObject(BSTR anObjectID);

Параметры

anObjectID


Метод GetBounds (Объект IIngeoContour)

Вычисляет границы контура.

Синтаксис

Язык | Описание
VBScript, JavaScript | FunctionGetBounds(aX1, aY1, aX2, aY2)
Visual Basic | Function GetBounds(ByVal aX1 As Double, ByVal aY1 As Double, ByVal aX2 As Double, ByVal aY2 As Double) As Boolean
Delphi | function GetBounds(aX1: Double; aY1: Double; aX2: Double; aY2: Double): WordBool;
C, C++ | HRESULT GetBounds(double* aX1, double* aY1, double* aX2, double* aY2, VARIANT_BOOL* Value);

Параметры

aX1
Левая граница контура.
aY1
Верхняя граница контура.
aX2
Правая граница контура.
aY2
Нижняя граница контура.

Возвращаемое значение

Если удалось вычислить границы, то возвращает True , иначе False. Границы контура невозможно вычислить лишь в том случае, если контур не содержит ни одной вершины.

См.также

IIngeoContour


Метод Insert (Объект IIngeoContour)

Добавляет часть контура.

Синтаксис

Язык | Описание
VBScript, JavaScript | FunctionInsert(anIndex)
Visual Basic | Function Insert(ByVal anIndex As Long) As IIngeoContourPart
Delphi | function Insert(anIndex: Longint): IIngeoContourPart;
C, C++ | HRESULT Insert(long anIndex, IIngeoContourPart** Value);

Параметры

anIndex
Позиция, в которую вставляется часть контура. Если значение этого параметра равно "-1 ", то часть добавляется в конец контура.

Возвращаемое значение

Объект части контура.

См.также

IIngeoContour, IIngeoContourPart


Свойство Item (Объект IIngeoContour)

Возвращает часть контура. Часть контура задается по порядковому номеру.

Синтаксис

Язык Описание
VBScript, JavaScript
Item(anIndex)
Visual Basic
Property Item(ByVal anIndex As Long) As IIngeoContourPart
Delphi
property Item[anIndex: Longint]: IIngeoContourPart
C, C++
HRESULT get_Item(long anIndex, IIngeoContourPart** Value);

Параметры

anIndex
Индекс части контура.

Возвращаемое значение

Возвращает часть контура IIngeoContourPart.

См.также

IIngeoContour, IIngeoContourPart


Объект IIngeoContourPart

Часть контура.

Свойства

Свойство | Описание
Closed | Замкнута часть контура или нет.
IsHole | Признак того, что часть контура является "дыркой".
Perimeter | Периметр части контура.
Square | Площадь части контура.
VertexCount | Количество вершин (команд) части контура.

Методы

Метод | Описание
Clear | Удаляет все вершины (команды) из части контура.
Delete | Удаляет часть контура из контура, которому она принадлежит.
DeleteVertex | Удаляет вершину (команду) из части контура.
DistanceFromPoint | Вычисляет растояние до заданной точки.
GetVertex | Возвращает параметры вершины.
InsertVertex | Добавляет вершину (команду) в часть контура.
SetVertex | Устанавливает параметры вершины (команды) контура.
sGetVertex | Возвращает параметры вершины. Скриптовая версия метода GetVertex.

См.также

IIngeoContour


Метод Clear (Объект IIngeoContourPart)

Удаляет все вершины (команды) из части контура.

Синтаксис

Язык | Описание
VBScript, JavaScript | SubClear()
Visual Basic | Sub Clear()
Delphi | procedure Clear;
C, C++ | HRESULT Clear();

См.также

IIngeoContourPart


Свойство Closed (Объект IIngeoContourPart)

Замкнута часть контура или нет.

Синтаксис

Язык Описание
VBScript, JavaScript
Closed
Visual Basic
Property Closed As Boolean
Delphi
property Closed: WordBool
C, C++
HRESULT get_Closed(VARIANT_BOOL* Value);
HRESULT set_Closed(VARIANT_BOOL Value);

См.также

IIngeoContourPart


Метод Delete (Объект IIngeoContourPart)

Удаляет часть контура из контура, которому она принадлежит.

Синтаксис

Язык | Описание
VBScript, JavaScript | SubDelete()
Visual Basic | Sub Delete()
Delphi | procedure Delete;
C, C++ | HRESULT Delete();

См.также

IIngeoContourPart


Метод DeleteVertex (Объект IIngeoContourPart)

Удаляет вершину (команду) из части контура.

Синтаксис

Язык | Описание
VBScript, JavaScript | SubDeleteVertex(anIndex)
Visual Basic | Sub DeleteVertex(ByVal anIndex As Long)
Delphi | procedure DeleteVertex(anIndex: Longint);
C, C++ | HRESULT DeleteVertex(long anIndex);

Параметры

anIndex
Индекс вершины.

См.также

IIngeoContourPart


Метод DistanceFromPoint (Объект IIngeoContourPart)

Вычисляет растояние до заданной точки.

Синтаксис

Язык | Описание
VBScript, JavaScript | FunctionDistanceFromPoint(aX, aY)
Visual Basic | Function DistanceFromPoint(ByVal aX As Double, ByVal aY As Double) As Double
Delphi | function DistanceFromPoint(aX: Double; aY: Double): Double;
C, C++ | HRESULT DistanceFromPoint(double aX, double aY, double* Value);

Параметры

aX
X Координата точки.
aY
Y Координата точки.

Возвращаемое значение

Расстояние от точки до данной части контура.


Метод GetVertex (Объект IIngeoContourPart)

Возвращает параметры вершины.

Синтаксис

Язык | Описание
VBScript, JavaScript | SubGetVertex(anIndex, aX, aY, aConvexity)
Visual Basic | Sub GetVertex(ByVal anIndex As Long, ByVal aX As Double, ByVal aY As Double, ByVal aConvexity As Double)
Delphi | procedure GetVertex(anIndex: Longint; aX: Double; aY: Double; aConvexity: Double);
C, C++ | HRESULT GetVertex(long anIndex, double* aX, double* aY, double* aConvexity);

Параметры

anIndex
Индекс вершины.
aX
X координата вершины.
aY
Y координата вершины.
aConvexity

Кривизна ребра, проведенного из предыдущей вершины в текущую. Если часть контура замнута, то кривизна первой вершины применяется для замыкающего ребра.

Математический смысл кривизны ребра следующий:

Дано:
две точки P1 и P2;
дуга E, проходящая через точки P1 и P2;
вектор V1, проведенный из точки P1 в точку P2;
вектор V2, проведенный из точки P1 и касательный к дуге E.;
угол A между вектором V1 и V2.

Тогда кривизна дуги равна tg (A / 2).

Если кривизна дуги равна нулю, то ребро является прямой линией.

См.также

IIngeoContourPart


Метод InsertVertex (Объект IIngeoContourPart)

Добавляет вершину (команду) в часть контура.

Синтаксис

Язык | Описание
VBScript, JavaScript | SubInsertVertex(anIndex, aX, aY, aConvexity)
Visual Basic | Sub InsertVertex(ByVal anIndex As Long, ByVal aX As Double, ByVal aY As Double, ByVal aConvexity As Double)
Delphi | procedure InsertVertex(anIndex: Longint; aX: Double; aY: Double; aConvexity: Double);
C, C++ | HRESULT InsertVertex(long anIndex, double aX, double aY, double aConvexity);

Параметры

anIndex
Индекс вершины, перед которой будет вставлена новая вершина. Если значение данного параметра равно "-1", то вершина добавляется в конец части контура.
aX
X координата вершины.
aY
Y координата вершины.
aConvexity

Кривизна ребра, проведенного из предыдущей вершины в добавляемую. Если часть контура замнута, то кривизна первой вершины применяется для замыкающего ребра.

Математический смысл кривизны ребра следующий:

Дано:
две точки P1 и P2;
дуга E, проходящая через точки P1 и P2;
вектор V1, проведенный из точки P1 в точку P2;
вектор V2, проведенный из точки P1 и касательный к дуге E.;
угол A между вектором V1 и V2.

Тогда кривизна дуги равна tg (A / 2).

Если кривизна дуги равна нулю, то ребро является прямой линией.

См.также

IIngeoContourPart


Свойство IsHole (Объект IIngeoContourPart)

Признак того, что часть контура является "дыркой".

Синтаксис

Язык Описание
VBScript, JavaScript
IsHole
Visual Basic
Property IsHole As Boolean
Delphi
property IsHole: WordBool
C, C++
HRESULT get_IsHole(VARIANT_BOOL* Value);

См.также

IIngeoContourPart


Свойство Perimeter (Объект IIngeoContourPart)

Периметр части контура.

Синтаксис

Язык Описание
VBScript, JavaScript
Perimeter
Visual Basic
Property Perimeter As Double
Delphi
property Perimeter: Double
C, C++
HRESULT get_Perimeter(double* Value);


Метод SetVertex (Объект IIngeoContourPart)

Устанавливает параметры вершины (команды) контура.

Синтаксис

Язык | Описание
VBScript, JavaScript | SubSetVertex(anIndex, aX, aY, aConvexity)
Visual Basic | Sub SetVertex(ByVal anIndex As Long, ByVal aX As Double, ByVal aY As Double, ByVal aConvexity As Double)
Delphi | procedure SetVertex(anIndex: Longint; aX: Double; aY: Double; aConvexity: Double);
C, C++ | HRESULT SetVertex(long anIndex, double aX, double aY, double aConvexity);

Параметры

anIndex
Индекс вершины.
aX
X координата вершины.
aY
Y координата вершины.
aConvexity

Кривизна ребра, проведенного из предыдущей вершины в текущую. Если часть контура замнута, то кривизна первой вершины применяется для замыкающего ребра.

Математический смысл кривизны ребра следующий:

Дано:
две точки P1 и P2;
дуга E, проходящая через точки P1 и P2;
вектор V1, проведенный из точки P1 в точку P2;
вектор V2, проведенный из точки P1 и касательный к дуге E.;
угол A между вектором V1 и V2.

Тогда кривизна дуги равна tg (A / 2).

Если кривизна дуги равна нулю, то ребро является прямой линией.

См.также

IIngeoContourPart


Метод sGetVertex (Объект IIngeoContourPart)

Возвращает параметры вершины. Скриптовая версия метода GetVertex.

Синтаксис

Язык | Описание
VBScript, JavaScript | SubsGetVertex(anIndex, aX, aY, AC)
Visual Basic | Sub sGetVertex(ByVal anIndex As Long, ByVal aX As Variant, ByVal aY As Variant, ByVal AC As Variant)
Delphi | procedure sGetVertex(anIndex: Longint; aX: OleVariant; aY: OleVariant; AC: OleVariant);
C, C++ | HRESULT sGetVertex(long anIndex, VARIANT* aX, VARIANT* aY, VARIANT* AC);

Параметры

anIndex
Индекс вершины.
aX
X координата вершины.
aY
Y координата вершины.
AC

Кривизна ребра, проведенного из предыдущей вершины в текущую. Если часть контура замнута, то кривизна первой вершины применяется для замыкающего ребра.

Математический смысл кривизны ребра следующий:

Дано:
две точки P1 и P2;
дуга E, проходящая через точки P1 и P2;
вектор V1, проведенный из точки P1 в точку P2;
вектор V2, проведенный из точки P1 и касательный к дуге E.;
угол A между вектором V1 и V2.

Тогда кривизна дуги равна tg (A / 2).

Если кривизна дуги равна нулю, то ребро является прямой линией.

См.также

IIngeoContourPart


Свойство Square (Объект IIngeoContourPart)

Площадь части контура.

Синтаксис

Язык Описание
VBScript, JavaScript
Square
Visual Basic
Property Square As Double
Delphi
property Square: Double
C, C++
HRESULT get_Square(double* Value);


Свойство VertexCount (Объект IIngeoContourPart)

Количество вершин (команд) части контура.

Синтаксис

Язык Описание
VBScript, JavaScript
VertexCount
Visual Basic
Property VertexCount As Long
Delphi
property VertexCount: Longint
C, C++
HRESULT get_VertexCount(long* Value);

См.также

IIngeoContourPart


Свойство Perimeter (Объект IIngeoContour)

Периметр контура.

Синтаксис

Язык Описание
VBScript, JavaScript
Perimeter
Visual Basic
Property Perimeter As Double
Delphi
property Perimeter: Double
C, C++
HRESULT get_Perimeter(double* Value);


Метод sGetBounds (Объект IIngeoContour)

Вычисляет границы контура. Скриптовая версия метода GetBounds.

Синтаксис

Язык | Описание
VBScript, JavaScript | FunctionsGetBounds(aX1, aY1, aX2, aY2)
Visual Basic | Function sGetBounds(ByVal aX1 As Variant, ByVal aY1 As Variant, ByVal aX2 As Variant, ByVal aY2 As Variant) As Boolean
Delphi | function sGetBounds(aX1: OleVariant; aY1: OleVariant; aX2: OleVariant; aY2: OleVariant): WordBool;
C, C++ | HRESULT sGetBounds(VARIANT* aX1, VARIANT* aY1, VARIANT* aX2, VARIANT* aY2, VARIANT_BOOL* Value);

Параметры

aX1
Левая граница контура.
aY1
Верхняя граница контура.
aX2
Правая граница контура.
aY2
Нижняя граница контура.

Возвращаемое значение

Если удалось вычислить границы, то возвращает True , иначе False. Границы контура невозможно вычислить лишь в том случае, если контур не содержит ни одной вершины.

См.также

IIngeoContour


Свойство Square (Объект IIngeoContour)

Площадь контура.

Синтаксис

Язык Описание
VBScript, JavaScript
Square
Visual Basic
Property Square As Double
Delphi
property Square: Double
C, C++
HRESULT get_Square(double* Value);


Метод TestRelation (Объект IIngeoContour)

Определяет пространственное расположение данного контура по отношению к другому контуру.

Синтаксис

Язык | Описание
VBScript, JavaScript | FunctionTestRelation(aContour)
Visual Basic | Function TestRelation(ByVal aContour As IIngeoContour) As TIngeoContourRelation
Delphi | function TestRelation(aContour: IIngeoContour): TIngeoContourRelation;
C, C++ | HRESULT TestRelation(IIngeoContour* aContour, TIngeoContourRelation* Value);

Параметры

aContour
Контур, с которым производится сравненение.

Возвращаемое значение

Результат сравнения пространственного расположения контуров. Возвращаемое значение содержит комбинацию следующих констант:

Значение | Описание
incrIntersected | Контура пересекаются
incrContained | Данный контур лежит внутри другого контура
incrContains | Другой контур лежит внутри данного контура
incrTouched | Контура имеют точки соприкосновения

Значения incrContained и incrContains не могут присутствовать одновременно.

См.также

IIngeoContour, TIngeoContourRelation


Объект IIngeoDb

Объект Db предоставляет доступ к информации в базе данных ИнГЕО.

Свойства

Свойство | Описание
AC | Объект управления правами доступа к БД.
Areas | Список территорий, определенных в базе данных.
Caption | Название базы данных.
ID | Идентификатор базы данных.
IDSpaces | Таблица пространств идентификаторов.
LogonUserID | Идентификатор пользователя, учетная запись которого используется для доступа к базе данных.
MapObjects | Доступ к пространственным объектам.
RefBooks | Список справочников, расположенных в базе данных.
Roles | Список ролей пользователей.
SemDbTables | Список реляционных таблиц базы данных.
ServerLicense
ServerVersion
Users | Список пользователей.

Методы

Метод | Описание
AreaExists | Проверка существования территории.
AreaFromID | Получение территории по идентификатору.
DropCache
GenerateID | Генерация нового идентификатора.
GetProjectView | Создает объект IngeoProjectView для указанного проекта.
GlobalIDToLocalID | Преобразование глобального идентификатора во внутренний.
IsGlobalID | Прверка соответствия внутреннего идентификатора глобальному.
LayerExists | Проверка существования слоя.
LayerFromID | Получение слоя по идентификатору.
LocalIDToGlobalID | Преобразование внутреннего идентификатора в глобальный.
MapExists | Проверка существования карты.
MapFromID | Получение карты по идентификатору.
PaintXml | Рисование карты на указанную поверхность рисования.
ProjectExists | Проверка существования проекта.
ProjectFromID | Получение проекта по идентификатору.
RefBookExists | Проверка существования справочника.
RefBookFromID | Получение справочника по идентификатору.
RegisterIDSpace | Зарегистрировать пространство идентификаторов.
SemTableExists | Проверка существования семантической таблицы.
SemTableFromID | Получение семантической таблицы таблицы по идентификатору.
StyleExists | Проверка существования стиля.
StyleFromID | Получение стиля по идентификатору.

Примечания

Приложение ГИС ИнГЕО может работает только с одной базой данных, поэтому в любой момент времени существует только один экземпляр объекта Db. Получить доступ к текущей открытой базе данных можно при помощи свойства ActiveDb объекта Application.

См.также

IIngeoApplication


Свойство AC (Объект IIngeoDb)

Объект управления правами доступа к БД.

Синтаксис

Язык Описание
VBScript, JavaScript
AC
Visual Basic
Property AC As IIngeoAC
Delphi
property AC: IIngeoAC
C, C++
HRESULT get_AC(IIngeoAC** Value);

См.также

IIngeoAC, Список прав


Метод AreaExists (Объект IIngeoDb)

Данный метод проверяет - существует или нет территория с указанным идентификатором.

Синтаксис

Язык | Описание
VBScript, JavaScript | FunctionAreaExists(anAreaID)
Visual Basic | Function AreaExists(ByVal anAreaID As String) As Boolean
Delphi | function AreaExists(const anAreaID: WideString): WordBool;
C, C++ | HRESULT AreaExists(BSTR anAreaID, VARIANT_BOOL* Value);

Параметры

anAreaID
Идентификатор территории.

Возвращаемое значение

Возвращает True, территория существует и False в противном случае.


Метод AreaFromID (Объект IIngeoDb)

Данный метод позволяет получить объект территории по указанному идентификатору.

Синтаксис

Язык | Описание
VBScript, JavaScript | FunctionAreaFromID(anAreaID)
Visual Basic | Function AreaFromID(ByVal anAreaID As String) As IIngeoArea
Delphi | function AreaFromID(const anAreaID: WideString): IIngeoArea;
C, C++ | HRESULT AreaFromID(BSTR anAreaID, IIngeoArea** Value);

Параметры

anAreaID
Идентификатор территории.

Возвращаемое значение

Возвращает оъект территории IngeoArea.

Примечания

Если территория с указанным идентификатором не найдена, то данный метод генерирует исключительную ситуацию.

См.также

IIngeoArea


Свойство Areas (Объект IIngeoDb)

Список территорий, определенных в базе данных.

Синтаксис

Язык Описание
VBScript, JavaScript
Areas
Visual Basic
Property Areas As IIngeoAreas
Delphi
property Areas: IIngeoAreas
C, C++
HRESULT get_Areas(IIngeoAreas** Value);


Свойство Caption (Объект IIngeoDb)

Название базы данных.

Синтаксис

Язык Описание
VBScript, JavaScript
Caption
Visual Basic
Property Caption As String
Delphi
property Caption: WideString
C, C++
HRESULT get_Caption(BSTR* Value);


Метод DropCache (Объект IIngeoDb)

Синтаксис

Язык | Описание
VBScript, JavaScript | SubDropCache()
Visual Basic | Sub DropCache()
Delphi | procedure DropCache;
C, C++ | HRESULT DropCache();


Метод GenerateID (Объект IIngeoDb)

Генерация нового идентификатора.

Синтаксис

Язык | Описание
VBScript, JavaScript | FunctionGenerateID()
Visual Basic | Function GenerateID() As String
Delphi | const function GenerateID: WideString;
C, C++ | HRESULT GenerateID(BSTR* Value);

Примечания

Данный идентификатор представляет собой 12-ти символьную строку. Уникален в пределах базы данных.

См.также

Идентификация объектов


Метод GetProjectView (Объект IIngeoDb)

Создает объект IngeoProjectView для указанного проекта.

Синтаксис

Язык | Описание
VBScript, JavaScript | FunctionGetProjectView(aProjectID)
Visual Basic | Function GetProjectView(ByVal aProjectID As String) As IIngeoProjectView
Delphi | function GetProjectView(const aProjectID: WideString): IIngeoProjectView;
C, C++ | HRESULT GetProjectView(BSTR aProjectID, IIngeoProjectView** Value);

Параметры

aProjectID
Идентификатор проекта.


Метод GlobalIDToLocalID (Объект IIngeoDb)

Преобразование глобального идентификатора во внутренний.

Синтаксис

Язык | Описание
VBScript, JavaScript | FunctionGlobalIDToLocalID(aSpace, aNumber)
Visual Basic | Function GlobalIDToLocalID(ByVal aSpace As String, ByVal aNumber As Long) As String
Delphi | const function GlobalIDToLocalID(const aSpace: WideString; aNumber: Longint): WideString;
C, C++ | HRESULT GlobalIDToLocalID(BSTR aSpace, long aNumber, BSTR* Value);

Параметры

aSpace
Глобальный идентификатор пространства.
aNumber
Номер в пределах пространства идентификаторов.

См.также

Идентификация объектов


Свойство ID (Объект IIngeoDb)

Идентификатор базы данных.

Синтаксис

Язык Описание
VBScript, JavaScript
ID
Visual Basic
Property ID As String
Delphi
property ID: WideString
C, C++
HRESULT get_ID(BSTR* Value);


Свойство IDSpaces (Объект IIngeoDb)

Таблица пространств идентификаторов.

Синтаксис

Язык Описание
VBScript, JavaScript
IDSpaces
Visual Basic
Property IDSpaces As Variant
Delphi
property IDSpaces: OleVariant
C, C++
HRESULT get_IDSpaces(VARIANT* Value);

Возвращаемое значение

Таблица возвращается в виде массива строк. Каждая строка является массивом столбцов.
Первый столбец содержит глобальный идентификатор пространства.
Второй столбец содержит локальный код пространства.

См.также

Идентификация объектов


Метод IsGlobalID (Объект IIngeoDb)

Прверка соответствия внутреннего идентификатора глобальному.

Синтаксис

Язык | Описание
VBScript, JavaScript | FunctionIsGlobalID(aLocalID, aSpace, aNumber)
Visual Basic | Function IsGlobalID(ByVal aLocalID As String, ByVal aSpace As String, ByVal aNumber As Long) As Boolean
Delphi | function IsGlobalID(const aLocalID: WideString; const aSpace: WideString; aNumber: Longint): WordBool;
C, C++ | HRESULT IsGlobalID(BSTR aLocalID, BSTR aSpace, long aNumber, VARIANT_BOOL* Value);

Параметры

aLocalID
Внутренний идентификатор.
aSpace
Идентификатор пространства.
aNumber
Номер в пределах пространства идентификаторов.

См.также

Идентификация объектов


Метод LayerExists (Объект IIngeoDb)

Данный метод проверяет - существует или нет слой с указанным идентификатором.

Синтаксис

Язык | Описание
VBScript, JavaScript | FunctionLayerExists(aLayerID)
Visual Basic | Function LayerExists(ByVal aLayerID As String) As Boolean
Delphi | function LayerExists(const aLayerID: WideString): WordBool;
C, C++ | HRESULT LayerExists(BSTR aLayerID, VARIANT_BOOL* Value);

Параметры

aLayerID
Идентификатор слоя.

Возвращаемое значение

Возвращает True, если слой существует или False в противном случае.


Метод LayerFromID (Объект IIngeoDb)

Данный метод позволяет получить объект слоя по указанному идентификатору.

Синтаксис

Язык | Описание
VBScript, JavaScript | FunctionLayerFromID(aLayerID)
Visual Basic | Function LayerFromID(ByVal aLayerID As String) As IIngeoLayer
Delphi | function LayerFromID(const aLayerID: WideString): IIngeoLayer;
C, C++ | HRESULT LayerFromID(BSTR aLayerID, IIngeoLayer** Value);

Параметры

aLayerID
Идентификатор слоя.

Возвращаемое значение

Возвращает объект слоя IngeoLayer.

Примечания

Если слой с указанным идентификатором не существует, то данный метод генерирует исключение.


Метод LocalIDToGlobalID (Объект IIngeoDb)

Преобразование внутреннего идентификатора в глобальный.

Синтаксис

Язык | Описание
VBScript, JavaScript | SubLocalIDToGlobalID(aLocalID, aSpace, aNumber)
Visual Basic | Sub LocalIDToGlobalID(ByVal aLocalID As String, ByVal aSpace As Variant, ByVal aNumber As Variant)
Delphi | procedure LocalIDToGlobalID(const aLocalID: WideString; aSpace: OleVariant; aNumber: OleVariant);
C, C++ | HRESULT LocalIDToGlobalID(BSTR aLocalID, VARIANT* aSpace, VARIANT* aNumber);

Параметры

aLocalID
Внутренний идентификатор.
aSpace
Идентификатор пространства.
aNumber
Номер в пределах пространства идентификаторов.

См.также

Идентификация объектов


Свойство LogonUserID (Объект IIngeoDb)

Идентификатор пользователя, учетная запись которого используется для доступа к базе данных.

Синтаксис

Язык Описание
VBScript, JavaScript
LogonUserID
Visual Basic
Property LogonUserID As String
Delphi
property LogonUserID: WideString
C, C++
HRESULT get_LogonUserID(BSTR* Value);


Метод MapExists (Объект IIngeoDb)

Данный метод проверяет - существует или нет карта с указанным идентификатором.

Синтаксис

Язык | Описание
VBScript, JavaScript | FunctionMapExists(aMapID)
Visual Basic | Function MapExists(ByVal aMapID As String) As Boolean
Delphi | function MapExists(const aMapID: WideString): WordBool;
C, C++ | HRESULT MapExists(BSTR aMapID, VARIANT_BOOL* Value);

Параметры

aMapID
Идентификатор карты.

Возвращаемое значение

Возвращает True, если карта существует или False в противном случае.


Метод MapFromID (Объект IIngeoDb)

Данный метод позволяет получить объект карты по указанному идентификатору.

Синтаксис

Язык | Описание
VBScript, JavaScript | FunctionMapFromID(aMapID)
Visual Basic | Function MapFromID(ByVal aMapID As String) As IIngeoMap
Delphi | function MapFromID(const aMapID: WideString): IIngeoMap;
C, C++ | HRESULT MapFromID(BSTR aMapID, IIngeoMap** Value);

Параметры

aMapID
Идентификатор карты.

Возвращаемое значение

Возвращает объект карты IngeoMap.

Примечания

Если карта с указанным идентификатором не найдена, то данный метод генерирует исключительную ситуацию.


Свойство MapObjects (Объект IIngeoDb)

Доступ к пространственным объектам.

Синтаксис

Язык Описание
VBScript, JavaScript
MapObjects
Visual Basic
Property MapObjects As IIngeoMapObjects
Delphi
property MapObjects: IIngeoMapObjects
C, C++
HRESULT get_MapObjects(IIngeoMapObjects** Value);


Объект IIngeoDbMapObjectsSink

Объект обработчик событий связанных с созданием, изменением и удалением пространственных объектов.

Методы

Метод | Описание
CreateComplete | Вызывается после создания пространственного объекта.
DeleteComplete | Вызывается после удалением пространственного объекта.
UpdateComplete | Вызывается после изменения пространственного объекта.
WillDelete | Вызывается перед удалением пространственного объекта.
WillUpdate | Вызывается перед изменением пространственного объекта.

Примечания

Все события с префиксом Will вызываются только в том процессе ИнГео, в котором выполняется модуль расширения.


Метод CreateComplete (Объект IIngeoDbMapObjectsSink)

Вызывается после создания пространственного объекта.

Синтаксис

Язык | Описание
VBScript, JavaScript | SubCreateComplete(aMapObjectID, aMy)
Visual Basic | Sub CreateComplete(ByVal aMapObjectID As String, ByVal aMy As Boolean)
Delphi | procedure CreateComplete(const aMapObjectID: WideString; aMy: WordBool);
C, C++ | HRESULT CreateComplete(BSTR aMapObjectID, VARIANT_BOOL aMy);

Параметры

aMapObjectID
Идентификатор созданного пространственного объекта.
aMy
Признак того, что данное событие возникло в результате выполнения операции в том процессе ИнГео, в котором выполняется модуль расширения.

Пример

sub DBMapObjects_CreateComplete(aMapObjectID)
  MsgBox "Был создан объект " & aMapObjectID
end sub


Метод DeleteComplete (Объект IIngeoDbMapObjectsSink)

Вызывается после удалением пространственного объекта.

Синтаксис

Язык | Описание
VBScript, JavaScript | SubDeleteComplete(aMapObjectID, aMy)
Visual Basic | Sub DeleteComplete(ByVal aMapObjectID As String, ByVal aMy As Boolean)
Delphi | procedure DeleteComplete(const aMapObjectID: WideString; aMy: WordBool);
C, C++ | HRESULT DeleteComplete(BSTR aMapObjectID, VARIANT_BOOL aMy);

Параметры

aMapObjectID
Идентификатор удаленного пространственного объекта.
aMy
Признак того, что данное событие возникло в результате выполнения операции в том процессе ИнГео, в котором выполняется модуль расширения.

Пример

sub DBMapObjects_DeleteComplete(aMapObjectID)
  MsgBox "Был удален объект " & aMapObject
end sub


Метод UpdateComplete (Объект IIngeoDbMapObjectsSink)

Вызывается после изменения пространственного объекта.

Синтаксис

Язык | Описание
VBScript, JavaScript | SubUpdateComplete(aMapObjectID, aMy)
Visual Basic | Sub UpdateComplete(ByVal aMapObjectID As String, ByVal aMy As Boolean)
Delphi | procedure UpdateComplete(const aMapObjectID: WideString; aMy: WordBool);
C, C++ | HRESULT UpdateComplete(BSTR aMapObjectID, VARIANT_BOOL aMy);

Параметры

aMapObjectID
Идентификатор измененного пространственного объекта.
aMy
Признак того, что данное событие возникло в результате выполнения операции в том процессе ИнГео, в котором выполняется модуль расширения.

Пример

sub DBMapObjects_UpdateComplete(aMapObjectID)
  msgbox "Объект " & aMapObjectID & " изменен"
end sub


Метод WillDelete (Объект IIngeoDbMapObjectsSink)

Вызывается перед удалением пространственного объекта.

Синтаксис

Язык | Описание
VBScript, JavaScript | SubWillDelete(aMapObjectID)
Visual Basic | Sub WillDelete(ByVal aMapObjectID As String)
Delphi | procedure WillDelete(const aMapObjectID: WideString);
C, C++ | HRESULT WillDelete(BSTR aMapObjectID);

Параметры

aMapObjectID
Идентификатор удаляемого пространственного объекта.

Пример

sub DBMapObjects_WillDelete(aMapObjectID)
  MsgBox "Будет удален объект " & aMapObject
end sub


Метод WillUpdate (Объект IIngeoDbMapObjectsSink)

Вызывается перед изменением пространственного объекта.

Синтаксис

Язык | Описание
VBScript, JavaScript | SubWillUpdate(aMapObjectID)
Visual Basic | Sub WillUpdate(ByVal aMapObjectID As String)
Delphi | procedure WillUpdate(const aMapObjectID: WideString);
C, C++ | HRESULT WillUpdate(BSTR aMapObjectID);

Параметры

aMapObjectID
Идентификатор изменяемого пространственного объекта.

Пример

sub DBMapObjects_WillUpdate(aMapObjectID)
  msgbox "Объект " & aMapObjectID & " будет изменен"
end sub


Объект IIngeoDbPaintSink

Объект-обработчик событий, связанных с рисованием содержимого активной базы данных.

Методы

Метод | Описание
LayerPaintComplete | Вызывается после рисования слоя.
LayerWillPaint | Вызывается перед рисованием слоя.
MapPaintComplete | Вызывается после рисования карты.
MapWillPaint | Вызывается перед рисованием карты.
PaintComplete | Вызывается после рисования содержимого базы данных.
ProjectPaintComplete | Вызывается после рисованиея проекта.
ProjectWillPaint | Вызывается перед рисованием проекта.
WillPaint | Вызывается перед рисованием содержимого базы данных.

См.также

Порядок рисования карт


Метод LayerPaintComplete (Объект IIngeoDbPaintSink)

Вызывается после рисования слоя.

Синтаксис

Язык | Описание
VBScript, JavaScript | SubLayerPaintComplete(aSurface, aLayerID, aVisible)
Visual Basic | Sub LayerPaintComplete(ByVal aSurface As IIngeoPaintSurface, ByVal aLayerID As String, ByVal aVisible As Boolean)
Delphi | procedure LayerPaintComplete(aSurface: IIngeoPaintSurface; const aLayerID: WideString; aVisible: WordBool);
C, C++ | HRESULT LayerPaintComplete(IIngeoPaintSurface* aSurface, BSTR aLayerID, VARIANT_BOOL aVisible);

Параметры

aSurface
Поверхность рисования.
aLayerID
Идентификатор слоя.
aVisible

Признак того - видим слой или нет. Видимость слоя может быть ограничена по следующим причинам:

  1. Масштаб отображения не попадает в диапазон видимости слоя.
  2. Отображение карты принудительно выключено пользователем.


Метод LayerWillPaint (Объект IIngeoDbPaintSink)

Вызывается перед рисованием слоя.

Синтаксис

Язык | Описание
VBScript, JavaScript | SubLayerWillPaint(aSurface, aLayerID, aVisible)
Visual Basic | Sub LayerWillPaint(ByVal aSurface As IIngeoPaintSurface, ByVal aLayerID As String, ByVal aVisible As Boolean)
Delphi | procedure LayerWillPaint(aSurface: IIngeoPaintSurface; const aLayerID: WideString; aVisible: WordBool);
C, C++ | HRESULT LayerWillPaint(IIngeoPaintSurface* aSurface, BSTR aLayerID, VARIANT_BOOL aVisible);

Параметры

aSurface
Поверхность рисования.
aLayerID
Идентификатор слоя.
aVisible

Признак того - видим слой или нет. Видимость слоя может быть ограничена по следующим причинам:

  1. Масштаб отображения не попадает в диапазон видимости слоя.
  2. Отображение карты принудительно выключено пользователем.


Метод MapPaintComplete (Объект IIngeoDbPaintSink)

Вызывается после рисования карты.

Синтаксис

Язык | Описание
VBScript, JavaScript | SubMapPaintComplete(aSurface, aMapID, aVisible)
Visual Basic | Sub MapPaintComplete(ByVal aSurface As IIngeoPaintSurface, ByVal aMapID As String, ByVal aVisible As Boolean)
Delphi | procedure MapPaintComplete(aSurface: IIngeoPaintSurface; const aMapID: WideString; aVisible: WordBool);
C, C++ | HRESULT MapPaintComplete(IIngeoPaintSurface* aSurface, BSTR aMapID, VARIANT_BOOL aVisible);

Параметры

aSurface
Поверхность рисования.
aMapID
Идентификатор карты.
aVisible

Признак того - видима карта или нет. Видимость карты может быть ограничена по следующим причинам:

  1. Масштаб отображения не попадает в диапазон видимости карты.
  2. Отображение карты принудительно выключено пользователем.


Метод MapWillPaint (Объект IIngeoDbPaintSink)

Вызывается перед рисованием карты.

Синтаксис

Язык | Описание
VBScript, JavaScript | SubMapWillPaint(aSurface, aMapID, aVisible)
Visual Basic | Sub MapWillPaint(ByVal aSurface As IIngeoPaintSurface, ByVal aMapID As String, ByVal aVisible As Boolean)
Delphi | procedure MapWillPaint(aSurface: IIngeoPaintSurface; const aMapID: WideString; aVisible: WordBool);
C, C++ | HRESULT MapWillPaint(IIngeoPaintSurface* aSurface, BSTR aMapID, VARIANT_BOOL aVisible);

Параметры

aSurface
Поверхность рисования.
aMapID
Идентификатор карты.
aVisible

Признак того - видима карта или нет. Видимость карты может быть ограничена по следующим причинам:

  1. Масштаб отображения не попадает в диапазон видимости карты.
  2. Отображение карты принудительно выключено пользователем.


Метод PaintComplete (Объект IIngeoDbPaintSink)

Вызывается после рисования содержимого базы данных.

Синтаксис

Язык | Описание
VBScript, JavaScript | SubPaintComplete(aSurface)
Visual Basic | Sub PaintComplete(ByVal aSurface As IIngeoPaintSurface)
Delphi | procedure PaintComplete(aSurface: IIngeoPaintSurface);
C, C++ | HRESULT PaintComplete(IIngeoPaintSurface* aSurface);

Параметры

aSurface
Поверхность рисования.


Метод ProjectPaintComplete (Объект IIngeoDbPaintSink)

Вызывается после рисованиея проекта.

Синтаксис

Язык | Описание
VBScript, JavaScript | SubProjectPaintComplete(aSurface, aProjectID)
Visual Basic | Sub ProjectPaintComplete(ByVal aSurface As IIngeoPaintSurface, ByVal aProjectID As String)
Delphi | procedure ProjectPaintComplete(aSurface: IIngeoPaintSurface; const aProjectID: WideString);
C, C++ | HRESULT ProjectPaintComplete(IIngeoPaintSurface* aSurface, BSTR aProjectID);

Параметры

aSurface
Поверхность рисования.
aProjectID
Идентификатор проекта.


Метод ProjectWillPaint (Объект IIngeoDbPaintSink)

Вызывается перед рисованием проекта.

Синтаксис

Язык | Описание
VBScript, JavaScript | SubProjectWillPaint(aSurface, aProjectID)
Visual Basic | Sub ProjectWillPaint(ByVal aSurface As IIngeoPaintSurface, ByVal aProjectID As String)
Delphi | procedure ProjectWillPaint(aSurface: IIngeoPaintSurface; const aProjectID: WideString);
C, C++ | HRESULT ProjectWillPaint(IIngeoPaintSurface* aSurface, BSTR aProjectID);

Параметры

aSurface
Поверхность рисования.
aProjectID
Идентификатор проекта.


Метод WillPaint (Объект IIngeoDbPaintSink)

Вызывается перед рисованием содержимого базы данных.

Синтаксис

Язык | Описание
VBScript, JavaScript | SubWillPaint(aSurface)
Visual Basic | Sub WillPaint(ByVal aSurface As IIngeoPaintSurface)
Delphi | procedure WillPaint(aSurface: IIngeoPaintSurface);
C, C++ | HRESULT WillPaint(IIngeoPaintSurface* aSurface);

Параметры

aSurface
Поверхность рисования.


Метод PaintXml (Объект IIngeoDb)

Данный метод позволяет рисовать содержимое карты на заданную поверхность рисования.

Последовательность рисования задается в виде набора команд рисования, представленного в формате XML.

Синтаксис

Язык | Описание
VBScript, JavaScript | SubPaintXml(aSurface, aXml)
Visual Basic | Sub PaintXml(ByVal aSurface As IIngeoPaintSurface, ByVal aXml As String)
Delphi | procedure PaintXml(aSurface: IIngeoPaintSurface; const aXml: WideString);
C, C++ | HRESULT PaintXml(IIngeoPaintSurface* aSurface, BSTR aXml);

Параметры

aSurface
Поверхность рисования.
aXml

Описание последовательности команд рисования в формате XML.
Структура XML должна быть следущей:

<paint>

<project oid=oid /> Нарисовать проект.
Атрибут oid - идентификатор проекта.

<map oid=oid /> Нарисовать карту.
Атрибут oid - идентификатор карты.

<layer oid=oid /> Нарисовать слой.
Атрибут oid - идентификатор слоя

<flush-after-map/> Рисование стилями с флагом "После всех объектов карты".

<flush-after-all/> Рисование стилей с флагом "После всех объектов карты".

<object oid=oid /> Нарисовать пространственный объект.
Атрибут oid - идентификатор пространственного объекта.

<contour x=x y=y for-zoom-scale=for-zoom-scale> Нарисовать произвольный контур. Контур может быть абсолютным или относительным. Координаты абсолютного контура представлены в метрах картографируемой местности. Координаты относительного контура представлены в системе координат бумажного листа относительно некоторой базовой точки.
Атрибуты x, y - базовая точка для относительных контуров. Если базовая точка не задана, то контур - абсолютный. В противном случае координаты контура заданы в бумажных метрах относительно базовой точки.
Атрибут for-zoom-scale - масштаб, для которого задан относительный контур. Вещественное число (0 - контур внемасштабный). Значение по умолчанию 0.

<pen style=style width=width for-zoom-scale=for-zoom-scale color=color /> Описание окантовки. Допускается присутствие только одного элемента данного типа.
Атрибут style - стиль окантовки Допустимые значения none | solid | dash | dot | dash-dot | dash-dot-dot | inside-frame. Значение по умолчанию solid.
Атрибут width - ширина окантовки в мм. Вещественное число (0=максимально тонкий). Значение по умолчанию 0.
Атрибут for-zoom-scale - масштаб, для которого задана ширина окантовки (0 - внемасштабная толщина). Вещественное число. Значение по умолчанию для абсолютных контуров = 0. Для относительных используется атрибут контура for-zoom-scale.
Атрибут color - цвет окантовки. Задается в виде: #RRGGBB. Значение по умолчанию Черный (#000000)

<brush style=style color=color hatch-color=hatch-color transparency=transparency /> Описание закраски. Допускается присутствие только одного элемента данного типа.
Атрибут style - стиль закраски. Допустимые значения none | solid | horizontal | vertical | f-diagonal | b-diagonal | cross | diag-cross. Значение по умолчанию solid.
Атрибут color - цвет фона. Задается в виде: #RRGGBB. Значение по умолчанию Белый (#FFFFFF).
Атрибут hatch-color - цвет штрихов (для закрасок horizontal, vertical, f-diagonal, b-diagonal, cross, diag-cross). Задается в виде: #RRGGBB Значение по умолчанию Черный (#000000).
Атрибут transparency - степень прозрачности фона. Допустимые значения 1-10 | opaque | half-transparent | transparent. Значение по умолчанию opaque.

<point x=x y=y /> - часть контура - точка.
Атрибуты x, y - координаты точки. Вещественные числа в метрах.s

<polygon closed=closed> - часть контура - многоугольник.
Атрибут closed - признак замкнутости многоугольника. Допустимые значения yes | no. Значение по умолчанию yes.

<point x=x y=y convexity=convexity /> - вершина многоугольника.
Атрибуты x, y - координаты вершины. Вещественые числа в метрах.
Атрибут convexity - выпуклось ребра, построенного от предыдущей вершины к данной. Если значение данного атрибута = 0, то ребро является прямой линией. Если многоугольник замкнут, то выпуклость последнего ребра задается у первой вершины. Вещественное число. Значение по умолчанию 0.

</polygon>

</contour>

</paint>


Метод ProjectExists (Объект IIngeoDb)

Данный метод проверяет - существует или нет проект с указанным идентификатором в базе данных.

Синтаксис

Язык | Описание
VBScript, JavaScript | FunctionProjectExists(aProjectID)
Visual Basic | Function ProjectExists(ByVal aProjectID As String) As Boolean
Delphi | function ProjectExists(const aProjectID: WideString): WordBool;
C, C++ | HRESULT ProjectExists(BSTR aProjectID, VARIANT_BOOL* Value);

Параметры

aProjectID
Идентификатор проекта.

Возвращаемое значение

Возвращает True, если проект существует и False в противном случае.


Метод ProjectFromID (Объект IIngeoDb)

Данный метод позволяет получить объект проекта по указанному идентификатору.

Синтаксис

Язык | Описание
VBScript, JavaScript | FunctionProjectFromID(aProjectID)
Visual Basic | Function ProjectFromID(ByVal aProjectID As String) As IIngeoProject
Delphi | function ProjectFromID(const aProjectID: WideString): IIngeoProject;
C, C++ | HRESULT ProjectFromID(BSTR aProjectID, IIngeoProject** Value);

Параметры

aProjectID
Идентификатор проекта.

Возвращаемое значение

Возвращает объект проекта IngeoProject.

Примечания

Если проект с указанным идентификатором не существует, то данный метод генерирует исключение.


Метод RefBookExists (Объект IIngeoDb)

Данный метод проверяет - существует или нет справочник с указанным идентификатором.

Синтаксис

Язык | Описание
VBScript, JavaScript | FunctionRefBookExists(aRefBookID)
Visual Basic | Function RefBookExists(ByVal aRefBookID As String) As Boolean
Delphi | function RefBookExists(const aRefBookID: WideString): WordBool;
C, C++ | HRESULT RefBookExists(BSTR aRefBookID, VARIANT_BOOL* Value);

Параметры

aRefBookID
Идентификатор справочника.

Возвращаемое значение

Возвращает True, если справочник существует или False в противном случае.


Метод RefBookFromID (Объект IIngeoDb)

Данный метод позволяет получить справочник по указанному идентификатору.

Синтаксис

Язык | Описание
VBScript, JavaScript | FunctionRefBookFromID(aRefBookID)
Visual Basic | Function RefBookFromID(ByVal aRefBookID As String) As IIngeoRefBook
Delphi | function RefBookFromID(const aRefBookID: WideString): IIngeoRefBook;
C, C++ | HRESULT RefBookFromID(BSTR aRefBookID, IIngeoRefBook** Value);

Параметры

aRefBookID
Идентификатор справочника.

Возвращаемое значение

Возвращает объект справочника IngeoRefBook.

Примечания

Если справочник с указанным идентификатором не существует, то данный метод генерирует исключение.


Свойство RefBooks (Объект IIngeoDb)

Список справочников, расположенных в базе данных.

Синтаксис

Язык Описание
VBScript, JavaScript
RefBooks
Visual Basic
Property RefBooks As IIngeoRefBooks
Delphi
property RefBooks: IIngeoRefBooks
C, C++
HRESULT get_RefBooks(IIngeoRefBooks** Value);


Метод RegisterIDSpace (Объект IIngeoDb)

Зарегистрировать пространство идентификаторов.

Синтаксис

Язык | Описание
VBScript, JavaScript | FunctionRegisterIDSpace(aSpace)
Visual Basic | Function RegisterIDSpace(ByVal aSpace As String) As Long
Delphi | function RegisterIDSpace(const aSpace: WideString): Longint;
C, C++ | HRESULT RegisterIDSpace(BSTR aSpace, long* Value);

Параметры

aSpace
Глобальный идентификатор пространства.

Возвращаемое значение

Возвращает внутренний код пространства.

Примечания

Данный метод при необходимости добавляет указанное пространство идентификаторов в таблицу пространств базы данных.

Если указанное пространство уже зарегистрировано в базе данных, то возвращается текущий локальный код.

Если указанное пространство не зарегистрировано в базе данных, то оно будет добавлено в таблицу пространств, и для него будет сформирован новый локальный код.

См.также

Идентификация объектов


Свойство Roles (Объект IIngeoDb)

Список ролей пользователей.

Синтаксис

Язык Описание
VBScript, JavaScript
Roles
Visual Basic
Property Roles As IIngeoRoles
Delphi
property Roles: IIngeoRoles
C, C++
HRESULT get_Roles(IIngeoRoles** Value);


Свойство SemDbTables (Объект IIngeoDb)

Список реляционных таблиц базы данных.

Синтаксис

Язык Описание
VBScript, JavaScript
SemDbTables
Visual Basic
Property SemDbTables As IIngeoSemDbTables
Delphi
property SemDbTables: IIngeoSemDbTables
C, C++
HRESULT get_SemDbTables(IIngeoSemDbTables** Value);


Метод SemTableExists (Объект IIngeoDb)

Данный метод проверяет - существует или нет семантическая таблица с указанным идентификатором.

Синтаксис

Язык | Описание
VBScript, JavaScript | FunctionSemTableExists(aSemTableID)
Visual Basic | Function SemTableExists(ByVal aSemTableID As String) As Boolean
Delphi | function SemTableExists(const aSemTableID: WideString): WordBool;
C, C++ | HRESULT SemTableExists(BSTR aSemTableID, VARIANT_BOOL* Value);

Параметры

aSemTableID
Идентификатор таблицы.

Возвращаемое значение

Возвращает True, если таблица существует или False в противном случае.


Метод SemTableFromID (Объект IIngeoDb)

Данный метод позволяет получить семантическую таблицу по указанному идентификатору.

Синтаксис

Язык | Описание
VBScript, JavaScript | FunctionSemTableFromID(aSemTableID)
Visual Basic | Function SemTableFromID(ByVal aSemTableID As String) As IIngeoSemTable
Delphi | function SemTableFromID(const aSemTableID: WideString): IIngeoSemTable;
C, C++ | HRESULT SemTableFromID(BSTR aSemTableID, IIngeoSemTable** Value);

Параметры

aSemTableID
Идентификатор семантической таблицы.

Возвращаемое значение

Возвращает объект семантической таблицы IngeoTable.

Примечания

Если семантическая таблица с указанным идентификатором не существует, то данный метод генерирует исключение.


Свойство ServerLicense (Объект IIngeoDb)

Синтаксис

Язык Описание
VBScript, JavaScript
ServerLicense
Visual Basic
Property ServerLicense As IIngeoLicense
Delphi
property ServerLicense: IIngeoLicense
C, C++
HRESULT get_ServerLicense(IIngeoLicense** Value);


Свойство ServerVersion (Объект IIngeoDb)

Синтаксис

Язык Описание
VBScript, JavaScript
ServerVersion
Visual Basic
Property ServerVersion As String
Delphi
property ServerVersion: WideString
C, C++
HRESULT get_ServerVersion(BSTR* Value);


Метод StyleExists (Объект IIngeoDb)

Данный метод проверяет - существует или нет стиль с указанным идентификатором..

Синтаксис

Язык | Описание
VBScript, JavaScript | FunctionStyleExists(aStyleID)
Visual Basic | Function StyleExists(ByVal aStyleID As String) As Boolean
Delphi | function StyleExists(const aStyleID: WideString): WordBool;
C, C++ | HRESULT StyleExists(BSTR aStyleID, VARIANT_BOOL* Value);

Параметры

aStyleID
Идентификатор стиля.

Возвращаемое значение

Возвращает True, если слой существует или False в противном случае.


Метод StyleFromID (Объект IIngeoDb)

Данный метод позволяет получить объект стиля по указанному идентификатору.

Синтаксис

Язык | Описание
VBScript, JavaScript | FunctionStyleFromID(aStyleID)
Visual Basic | Function StyleFromID(ByVal aStyleID As String) As IIngeoStyle
Delphi | function StyleFromID(const aStyleID: WideString): IIngeoStyle;
C, C++ | HRESULT StyleFromID(BSTR aStyleID, IIngeoStyle** Value);

Параметры

aStyleID
Идентификатор стиля.

Возвращаемое значение

Возвращает объект стиля IngeoStyle.

Примечания

Если стиль с указанным идентификатором не существует, то данный метод генерирует исключение.


Объект IIngeoDbSysObjectsSink

Объект обработчик событий связанных с созданием, изменением и удалением системных объектов.

Методы

Метод | Описание
CreateComplete | Вызывается после изменения свойств системного объекта.
DeleteComplete | Вызывается после удаления системного объекта.
UpdateComplete | Вызывается после изменения свойств системного объекта.
WillCreate | Вызывается перед созданием системного объекта.
WillDelete | Вызывается перед удалением системного объекта.
WillUpdate | Вызывается перед изменением свойств системного объекта.

Примечания

Все события с префиксом Will вызываются только в том процессе ИнГео, в котором выполняется модуль расширения.


Метод CreateComplete (Объект IIngeoDbSysObjectsSink)

Вызывается после изменения свойств системного объекта.

Синтаксис

Язык | Описание
VBScript, JavaScript | SubCreateComplete(aSysObjectType, aSysObject, aMy)
Visual Basic | Sub CreateComplete(ByVal aSysObjectType As TIngeoSysObjectType, ByVal aSysObject As Object, ByVal aMy As Boolean)
Delphi | procedure CreateComplete(aSysObjectType: TIngeoSysObjectType; aSysObject: IDispatch; aMy: WordBool);
C, C++ | HRESULT CreateComplete(TIngeoSysObjectType aSysObjectType, IDispatch aSysObject, VARIANT_BOOL aMy);

Параметры

aSysObjectType
Тип системного объекта.
aSysObject
Системный объект.
aMy
Признак того, что данное событие возникло в результате выполнения операции в том процессе ИнГео, в котором выполняется модуль расширения.

Пример

sub DBSysObjects_CreateComplete(aSysObjectType, aSysObject)
s = "Cоздан"
if aSysObjectType = 0 then
s = s & "а территория"
end if
if aSysObjectType = 1 then
s = s & " справочник"
end if
if aSysObjectType = 2 then
s = s & "а растровая карта"
end if
if aSysObjectType = 3 then
s = s & "а векторная карта"
end if
if aSysObjectType = 4 then
s = s & " слой"
end if
if aSysObjectType = 5 then
s = s & " стиль"
end if
if aSysObjectType = 6 then
s = s & "а семантическая таблица"
end if

s = s & " с именем " & aSysObject.Name
end sub


Метод DeleteComplete (Объект IIngeoDbSysObjectsSink)

Вызывается после удаления системного объекта.

Синтаксис

Язык | Описание
VBScript, JavaScript | SubDeleteComplete(aSysObjectType, aSysObjectID, aMy)
Visual Basic | Sub DeleteComplete(ByVal aSysObjectType As TIngeoSysObjectType, ByVal aSysObjectID As String, ByVal aMy As Boolean)
Delphi | procedure DeleteComplete(aSysObjectType: TIngeoSysObjectType; const aSysObjectID: WideString; aMy: WordBool);
C, C++ | HRESULT DeleteComplete(TIngeoSysObjectType aSysObjectType, BSTR aSysObjectID, VARIANT_BOOL aMy);

Параметры

aSysObjectType
Тип системного объекта.
aSysObjectID
Идентификатор удаленного системного объекта.
aMy
Признак того, что данное событие возникло в результате выполнения операции в том процессе ИнГео, в котором выполняется модуль расширения.

Пример

sub DBSysObjects_DeleteComplete(aSysObjectType, aSysObject)
s = "Удален"
if aSysObjectType = 0 then
s = s & "а территория"
end if
if aSysObjectType = 1 then
s = s & " справочник"
end if
if aSysObjectType = 2 then
s = s & "а растровая карта"
end if
if aSysObjectType = 3 then
s = s & "а векторная карта"
end if
if aSysObjectType = 4 then
s = s & " слой"
end if
if aSysObjectType = 5 then
s = s & " стиль"
end if
if aSysObjectType = 6 then
s = s & "а семантическая таблица"
end if

s = s & " с именем " & aSysObject.Name
end sub


Метод UpdateComplete (Объект IIngeoDbSysObjectsSink)

Вызывается после изменения свойств системного объекта.

Синтаксис

Язык | Описание
VBScript, JavaScript | SubUpdateComplete(aSysObjectType, aSysObject, aMy)
Visual Basic | Sub UpdateComplete(ByVal aSysObjectType As TIngeoSysObjectType, ByVal aSysObject As Object, ByVal aMy As Boolean)
Delphi | procedure UpdateComplete(aSysObjectType: TIngeoSysObjectType; aSysObject: IDispatch; aMy: WordBool);
C, C++ | HRESULT UpdateComplete(TIngeoSysObjectType aSysObjectType, IDispatch aSysObject, VARIANT_BOOL aMy);

Параметры

aSysObjectType
Тип системного объекта.
aSysObject
Системный объект.
aMy
Признак того, что данное событие возникло в результате выполнения операции в том процессе ИнГео, в котором выполняется модуль расширения.

Пример

sub DBSysObjects_WillUpdate(aSysObjectType, aSysObject)
if aSysObjectType = 0 then
MsgBox "Территория с именем " & aSysObject.Name
end if
aSysObject.Name = "Новое имя территории"
end sub
sub DBSysObjects_UpdateComplete(aSysObjectType, aSysObject)
if aSysObjectType = 0 then
MsgBox "Территория с новым именем " & aSysObject.Name
end if
end sub


Метод WillCreate (Объект IIngeoDbSysObjectsSink)

Вызывается перед созданием системного объекта.

Синтаксис

Язык | Описание
VBScript, JavaScript | SubWillCreate(aSysObjectType, aSysObject)
Visual Basic | Sub WillCreate(ByVal aSysObjectType As TIngeoSysObjectType, ByVal aSysObject As Object)
Delphi | procedure WillCreate(aSysObjectType: TIngeoSysObjectType; aSysObject: IDispatch);
C, C++ | HRESULT WillCreate(TIngeoSysObjectType aSysObjectType, IDispatch aSysObject);

Параметры

aSysObjectType
Тип системного объекта.
aSysObject
Системный объект.

Пример

sub DBSysObjects_WillCreate(aSysObjectType, aSysObject)
s = "Будет создан"
if aSysObjectType = 0 then
s = s & "а территория"
end if
if aSysObjectType = 1 then
s = s & " справочник"
end if
if aSysObjectType = 2 then
s = s & "а растровая карта"
end if
if aSysObjectType = 3 then
s = s & "а векторная карта"
end if
if aSysObjectType = 4 then
s = s & " слой"
end if
if aSysObjectType = 5 then
s = s & " стиль"
end if
if aSysObjectType = 6 then
s = s & "а семантическая таблица"
end if

s = s & " с именем " & aSysObject.Name
end sub

См.также

TIngeoSysObjectType


Метод WillDelete (Объект IIngeoDbSysObjectsSink)

Вызывается перед удалением системного объекта.

Синтаксис

Язык | Описание
VBScript, JavaScript | SubWillDelete(aSysObjectType, aSysObject)
Visual Basic | Sub WillDelete(ByVal aSysObjectType As TIngeoSysObjectType, ByVal aSysObject As Object)
Delphi | procedure WillDelete(aSysObjectType: TIngeoSysObjectType; aSysObject: IDispatch);
C, C++ | HRESULT WillDelete(TIngeoSysObjectType aSysObjectType, IDispatch aSysObject);

Параметры

aSysObjectType
Тип системного объекта.
aSysObject
Системный объект.

Пример

sub DBSysObjects_WillDelete(aSysObjectType, aSysObject)
s = "Будет удален"
if aSysObjectType = 0 then
s = s & "а территория"
end if
if aSysObjectType = 1 then
s = s & " справочник"
end if
if aSysObjectType = 2 then
s = s & "а растровая карта"
end if
if aSysObjectType = 3 then
s = s & "а векторная карта"
end if
if aSysObjectType = 4 then
s = s & " слой"
end if
if aSysObjectType = 5 then
s = s & " стиль"
end if
if aSysObjectType = 6 then
s = s & "а семантическая таблица"
end if

s = s & " с именем " & aSysObject.Name
end sub


Метод WillUpdate (Объект IIngeoDbSysObjectsSink)

Вызывается перед изменением свойств системного объекта.

Синтаксис

Язык | Описание
VBScript, JavaScript | SubWillUpdate(aSysObjectType, aSysObject)
Visual Basic | Sub WillUpdate(ByVal aSysObjectType As TIngeoSysObjectType, ByVal aSysObject As Object)
Delphi | procedure WillUpdate(aSysObjectType: TIngeoSysObjectType; aSysObject: IDispatch);
C, C++ | HRESULT WillUpdate(TIngeoSysObjectType aSysObjectType, IDispatch aSysObject);

Параметры

aSysObjectType
Тип системного объекта.
aSysObject
Системный объект.

Пример

sub DBSysObjects_WillUpdate(aSysObjectType, aSysObject)
if aSysObjectType = 0 then
MsgBox "Территория с именем " & aSysObject.Name
end if
end sub


Свойство Users (Объект IIngeoDb)

Список пользователей.

Синтаксис

Язык Описание
VBScript, JavaScript
Users
Visual Basic
Property Users As IIngeoUsers
Delphi
property Users: IIngeoUsers
C, C++
HRESULT get_Users(IIngeoUsers** Value);


Объект IIngeoGlues

Объект для добавления элементов подравнивания.

Методы

Метод | Описание
AddEdgeGlue | Добавляет элемент подравнивания, типа ребро.
AddVertexGlue | Добавляет элемент подравнивания, типа точка.

См.также

IIngeoMapEditorsSink


Метод AddEdgeGlue (Объект IIngeoGlues)

Добавляет элемент подравнивания, типа ребро.

Синтаксис

Язык | Описание
VBScript, JavaScript | SubAddEdgeGlue(aX, aY, anEdgeX1, anEdgeY1, anEdgeX2, anEdgeY2, anEdgeC, aDescription)
Visual Basic | Sub AddEdgeGlue(ByVal aX As Double, ByVal aY As Double, ByVal anEdgeX1 As Double, ByVal anEdgeY1 As Double, ByVal anEdgeX2 As Double, ByVal anEdgeY2 As Double, ByVal anEdgeC As Double, ByVal aDescription As String)
Delphi | procedure AddEdgeGlue(aX: Double; aY: Double; anEdgeX1: Double; anEdgeY1: Double; anEdgeX2: Double; anEdgeY2: Double; anEdgeC: Double; const aDescription: WideString);
C, C++ | HRESULT AddEdgeGlue(double aX, double aY, double anEdgeX1, double anEdgeY1, double anEdgeX2, double anEdgeY2, double anEdgeC, BSTR aDescription);

Параметры

aX
X координата точки подравнивания.
aY
X координата точки подравнивания.
anEdgeX1
X координата точки первой вершины ребра.
anEdgeY1
Y координата точки первой вершины ребра.
anEdgeX2
X координата точки второй вершины ребра.
anEdgeY2
Y координата точки второй вершины ребра.
anEdgeC
Кривизна ребра.
aDescription
Текст описания элемента подравнивания.

Примечания

Все координаты задаются в мировой системе координат.

См.также

IIngeoMapEditorsSink, IIngeoGlues


Метод AddVertexGlue (Объект IIngeoGlues)

Добавляет элемент подравнивания, типа точка.

Синтаксис

Язык | Описание
VBScript, JavaScript | SubAddVertexGlue(aX, aY, aDescription)
Visual Basic | Sub AddVertexGlue(ByVal aX As Double, ByVal aY As Double, ByVal aDescription As String)
Delphi | procedure AddVertexGlue(aX: Double; aY: Double; const aDescription: WideString);
C, C++ | HRESULT AddVertexGlue(double aX, double aY, BSTR aDescription);

Параметры

aX
X координата точки (в мировой системе координат).
aY
Y координата точки (в мировой системе координат).
aDescription
Текст описания элемента подравнивания.

См.также

IIngeoMapEditorsSink, IIngeoGlues


Объект IIngeoIDList

Список идентификаторов.

Свойства

Свойство | Описание
Count | Количество идентификаторов.
Item | Возвращает идентификатор.
_NewEnum | Возвращает перечислитель по элементам (идентификаторам) коллекции.

Методы

Метод | Описание
Add | Добавляет идентификатор в список.
Delete | Удаляет идентификатор из списка.
Clear | Удаляет все идентификаторы из списка.


Свойство _NewEnum (Объект IIngeoIDList)

Возвращает перечислитель по элементам (идентификаторам) коллекции.

Синтаксис

Язык Описание
VBScript, JavaScript
_NewEnum
Visual Basic
Property _NewEnum As Object
Delphi
property _NewEnum: IUnknown
C, C++
HRESULT get__NewEnum(IUnknown* Value);

См.также

IIngeoIDList


Метод Add (Объект IIngeoIDList)

Добавляет идентификатор в список.

Синтаксис

Язык | Описание
VBScript, JavaScript | Sub(anID)
Visual Basic | Sub Add(ByVal anID As String)
Delphi | procedure Add(const anID: WideString);
C, C++ | HRESULT Add(BSTR anID);

Параметры

anID
Добавляемый идентификатор.

См.также

IIngeoIDList


Метод Clear (Объект IIngeoIDList)

Удаляет все идентификаторы из списка.

Синтаксис

Язык | Описание
VBScript, JavaScript | Sub()
Visual Basic | Sub Clear()
Delphi | procedure Clear;
C, C++ | HRESULT Clear();

См.также

IIngeoIDList


Свойство Count (Объект IIngeoIDList)

Количество идентификаторов.

Синтаксис

Язык Описание
VBScript, JavaScript
Count
Visual Basic
Property Count As Long
Delphi
property Count: Longint
C, C++
HRESULT get_Count(long* Value);

См.также

IIngeoIDList


Метод Delete (Объект IIngeoIDList)

Удаляет идентификатор из списка.

Синтаксис

Язык | Описание
VBScript, JavaScript | Sub(anID)
Visual Basic | Sub Delete(ByVal anID As String)
Delphi | procedure Delete(const anID: WideString);
C, C++ | HRESULT Delete(BSTR anID);

Параметры

anID
Удаляемый идентификатор.

См.также

IIngeoIDList


Свойство Item (Объект IIngeoIDList)

Возвращает идентификатор. Идентификатор задается по порядковому номеру.

Синтаксис

Язык Описание
VBScript, JavaScript
Item(anIndex)
Visual Basic
Property Item(ByVal anIndex As Long) As String
Delphi
property Item[anIndex: Longint]: WideString
C, C++
HRESULT get_Item(long anIndex, BSTR* Value);

Параметры

anIndex
Порядковый номер.

См.также

IIngeoIDList


Объект IIngeoLayer

Объект Layer представляет собой слой.

Свойства

Свойство | Описание
AC | Права доступа к слою.
ID | Внутренний идентификатор слоя.
Map | Карта, к которой принадлежит слой.
Modified | Признак измения значений свойств слоя.
Name | Название слоя.
SemTables | Семантические таблицы, принадлежащие слою.
Styles | Список стилей, принадлежащих слою.
VisibleMax | Максимальный диапазон видимости.
VisibleMin | Минимальный диапазон видимости.

Методы

Метод | Описание
Delete | Удаление слоя.
DropChanges | Отмена внесенных изменений.
Update | Сохранение внесенных изменений свойств слоя в базу данных.

См.также

IIngeoVectorMap


Свойство AC (Объект IIngeoLayer)

Права доступа к слою.

Синтаксис

Язык Описание
VBScript, JavaScript
AC
Visual Basic
Property AC As IIngeoAC
Delphi
property AC: IIngeoAC
C, C++
HRESULT get_AC(IIngeoAC** Value);

См.также

Список прав


Метод Delete (Объект IIngeoLayer)

Удаление слоя.

Синтаксис

Язык | Описание
VBScript, JavaScript | SubDelete()
Visual Basic | Sub Delete()
Delphi | procedure Delete;
C, C++ | HRESULT Delete();


Метод DropChanges (Объект IIngeoLayer)

Отмена внесенных изменений.

Синтаксис

Язык | Описание
VBScript, JavaScript | SubDropChanges()
Visual Basic | Sub DropChanges()
Delphi | procedure DropChanges;
C, C++ | HRESULT DropChanges();


Свойство ID (Объект IIngeoLayer)

Внутренний идентификатор слоя.

Синтаксис

Язык Описание
VBScript, JavaScript
ID
Visual Basic
Property ID As String
Delphi
property ID: WideString
C, C++
HRESULT get_ID(BSTR* Value);


Свойство Map (Объект IIngeoLayer)

Карта, к которой принадлежит слой.

Синтаксис

Язык Описание
VBScript, JavaScript
Map
Visual Basic
Property Map As IIngeoVectorMap
Delphi
property Map: IIngeoVectorMap
C, C++
HRESULT get_Map(IIngeoVectorMap** Value);


Свойство Modified (Объект IIngeoLayer)

Признак измения значений свойств слоя.

Синтаксис

Язык Описание
VBScript, JavaScript
Modified
Visual Basic
Property Modified As Boolean
Delphi
property Modified: WordBool
C, C++
HRESULT get_Modified(VARIANT_BOOL* Value);

Примечания

Изменения свойств слоя будут внесены в базу данных только после вызова метода Update IIngeoLayer.


Свойство Name (Объект IIngeoLayer)

Название слоя.

Синтаксис

Язык Описание
VBScript, JavaScript
Name
Visual Basic
Property Name As String
Delphi
property Name: WideString
C, C++
HRESULT get_Name(BSTR* Value);
HRESULT set_Name(BSTR Value);


Объект IIngeoLayers

Объект IIngeoLayers представляет собой список слоев.

Свойства

Свойство | Описание
Count | Количество слоев.
Item | Получение слоя по индексу.
_NewEnum | Служебный метод: возвращает перечислитель коллекции списка.

Методы

Метод | Описание
Add | Добавление слоя.
AddWithID | Добавление слоя с указанным идентификатором.

См.также

IIngeoLayer, IIngeoVectorMap


Свойство _NewEnum (Объект IIngeoLayers)

Служебный метод: возвращает перечислитель коллекции списка.

Синтаксис

Язык Описание
VBScript, JavaScript
_NewEnum
Visual Basic
Property _NewEnum As Object
Delphi
property _NewEnum: IUnknown
C, C++
HRESULT get__NewEnum(IUnknown* Value);


Метод Add (Объект IIngeoLayers)

Добавление слоя.

Синтаксис

Язык | Описание
VBScript, JavaScript | FunctionAdd()
Visual Basic | Function Add() As IIngeoLayer
Delphi | function Add: IIngeoLayer;
C, C++ | HRESULT Add(IIngeoLayer** Value);

Примечания

Новый слой будет добавлен в базу данных только после вызова метода Update IIngeoLayer.


Метод AddWithID (Объект IIngeoLayers)

Добавление слоя с указанным идентификатором.

Синтаксис

Язык | Описание
VBScript, JavaScript | FunctionAddWithID(anID)
Visual Basic | Function AddWithID(ByVal anID As String) As IIngeoLayer
Delphi | function AddWithID(const anID: WideString): IIngeoLayer;
C, C++ | HRESULT AddWithID(BSTR anID, IIngeoLayer** Value);

Параметры

anID
Идентификатор добавляемого слоя.

Примечания

Новый слой будет добавлен в базу данных только после вызова метода Update IIngeoLayer.


Свойство Count (Объект IIngeoLayers)

Количество слоев.

Синтаксис

Язык Описание
VBScript, JavaScript
Count
Visual Basic
Property Count As Long
Delphi
property Count: Longint
C, C++
HRESULT get_Count(long* Value);


Свойство SemTables (Объект IIngeoLayer)

Семантические таблицы, принадлежащие слою.

Синтаксис

Язык Описание
VBScript, JavaScript
SemTables
Visual Basic
Property SemTables As IIngeoSemTables
Delphi
property SemTables: IIngeoSemTables
C, C++
HRESULT get_SemTables(IIngeoSemTables** Value);

Пример

Создание новой семантической таблицы, типа "Один-к-Одному"
option explicit

const LayerID = "006500000859"

dim Layer, SemTable, SemDbTable

set Layer = ActiveDb.LayerFromID(LayerID)
set SemTable = Layer.SemTables.Add

SemTable.Name = "Новая семантическая таблица"
SemTable.SemDbTableName = "MySemTableName"
SemTable.SemDbTable.Fields.Add "StrData", inftString, 130, 0, 0 ' Добавляем новое поле
SemTable.Update


Свойство Item (Объект IIngeoLayers)

Получение слоя по индексу.

Синтаксис

Язык Описание
VBScript, JavaScript
Item(anIndex)
Visual Basic
Property Item(ByVal anIndex As Long) As IIngeoLayer
Delphi
property Item[anIndex: Longint]: IIngeoLayer
C, C++
HRESULT get_Item(long anIndex, IIngeoLayer** Value);

Параметры

anIndex
Индекс слоя (диапазон от 0 до Count - 1).

Возвращаемое значение

Возвращает объект слоя.

См.также

IIngeoLayer


Свойство Styles (Объект IIngeoLayer)

Список стилей, принадлежащих слою.

Синтаксис

Язык Описание
VBScript, JavaScript
Styles
Visual Basic
Property Styles As IIngeoStyles
Delphi
property Styles: IIngeoStyles
C, C++
HRESULT get_Styles(IIngeoStyles** Value);


Метод Update (Объект IIngeoLayer)

Сохранение внесенных изменений свойств слоя в базу данных.

Синтаксис

Язык | Описание
VBScript, JavaScript | SubUpdate()
Visual Basic | Sub Update()
Delphi | procedure Update;
C, C++ | HRESULT Update();


Объект IIngeoLayerView

Объект управления текущим слоем.

Свойства

Свойство | Описание
Expanded
Index | Получение представления слоя по индексу.
Layer | Представленный слой.
MapView | Представленная карта.
StyleViews | Список представлений стилей, принадлежащих текущему слою.
Visible | Управление видимостью представления слоя.

Методы

Метод | Описание
FindStyleView | Поиск объекта представления стиля.

См.также

IIngeoProjectView, IIngeoMapView


Свойство Expanded (Объект IIngeoLayerView)

Синтаксис

Язык Описание
VBScript, JavaScript
Expanded
Visual Basic
Property Expanded As Boolean
Delphi
property Expanded: WordBool
C, C++
HRESULT get_Expanded(VARIANT_BOOL* Value);
HRESULT set_Expanded(VARIANT_BOOL Value);


Метод FindStyleView (Объект IIngeoLayerView)

Поиск объекта представления стиля.

Синтаксис

Язык | Описание
VBScript, JavaScript | FunctionFindStyleView(StyleID)
Visual Basic | Function FindStyleView(ByVal StyleID As String) As IIngeoStyleView
Delphi | function FindStyleView(const StyleID: WideString): IIngeoStyleView;
C, C++ | HRESULT FindStyleView(BSTR StyleID, IIngeoStyleView** Value);

Параметры

StyleID
Идентификатор стиля.


Свойство Index (Объект IIngeoLayerView)

Получение представления слоя по индексу.

Синтаксис

Язык Описание
VBScript, JavaScript
Index
Visual Basic
Property Index As Long
Delphi
property Index: Longint
C, C++
HRESULT get_Index(long* Value);
HRESULT set_Index(long Value);

Возвращаемое значение

Возвращает объект представленного слоя.


Свойство Layer (Объект IIngeoLayerView)

Представленный слой.

Синтаксис

Язык Описание
VBScript, JavaScript
Layer
Visual Basic
Property Layer As IIngeoLayer
Delphi
property Layer: IIngeoLayer
C, C++
HRESULT get_Layer(IIngeoLayer** Value);


Свойство MapView (Объект IIngeoLayerView)

Представленная карта.

Синтаксис

Язык Описание
VBScript, JavaScript
MapView
Visual Basic
Property MapView As IIngeoMapView
Delphi
property MapView: IIngeoMapView
C, C++
HRESULT get_MapView(IIngeoMapView** Value);


Объект IIngeoLayerViews

Список представленных слоев.

Свойства

Свойство | Описание
Count | Количество представленных слоев.
Item | Получение представленного слоя по индексу.
_NewEnum | Служебный метод: возвращает перечислитель коллекции списка.


Свойство _NewEnum (Объект IIngeoLayerViews)

Служебный метод: возвращает перечислитель коллекции списка.

Синтаксис

Язык Описание
VBScript, JavaScript
_NewEnum
Visual Basic
Property _NewEnum As Object
Delphi
property _NewEnum: IUnknown
C, C++
HRESULT get__NewEnum(IUnknown* Value);


Свойство Count (Объект IIngeoLayerViews)

Количество представленных слоев.

Синтаксис

Язык Описание
VBScript, JavaScript
Count
Visual Basic
Property Count As Long
Delphi
property Count: Longint
C, C++
HRESULT get_Count(long* Value);


Свойство Item (Объект IIngeoLayerViews)

Получение представленного слоя по индексу.

Синтаксис

Язык Описание
VBScript, JavaScript
Item(anIndex)
Visual Basic
Property Item(ByVal anIndex As Long) As IIngeoLayerView
Delphi
property Item[anIndex: Longint]: IIngeoLayerView
C, C++
HRESULT get_Item(long anIndex, IIngeoLayerView** Value);

Параметры

anIndex
Индекс объекта в списке.


Свойство StyleViews (Объект IIngeoLayerView)

Список представлений стилей, принадлежащих текущему слою.

Синтаксис

Язык Описание
VBScript, JavaScript
StyleViews
Visual Basic
Property StyleViews As IIngeoStyleViews
Delphi
property StyleViews: IIngeoStyleViews
C, C++
HRESULT get_StyleViews(IIngeoStyleViews** Value);


Свойство Visible (Объект IIngeoLayerView)

Управление видимостью представления слоя.

Синтаксис

Язык Описание
VBScript, JavaScript
Visible
Visual Basic
Property Visible As Boolean
Delphi
property Visible: WordBool
C, C++
HRESULT get_Visible(VARIANT_BOOL* Value);
HRESULT set_Visible(VARIANT_BOOL Value);


Свойство VisibleMax (Объект IIngeoLayer)

Максимальный диапазон видимости.

Синтаксис

Язык Описание
VBScript, JavaScript
VisibleMax
Visual Basic
Property VisibleMax As Double
Delphi
property VisibleMax: Double
C, C++
HRESULT get_VisibleMax(double* Value);
HRESULT set_VisibleMax(double Value);

См.также

Правила задания масштабов


Свойство VisibleMin (Объект IIngeoLayer)

Минимальный диапазон видимости.

Синтаксис

Язык Описание
VBScript, JavaScript
VisibleMin
Visual Basic
Property VisibleMin As Double
Delphi
property VisibleMin: Double
C, C++
HRESULT get_VisibleMin(double* Value);
HRESULT set_VisibleMin(double Value);

См.также

Правила задания масштабов


Объект IIngeoLicense

Свойства

Свойство Описание
ConnectionLimit
Customer
DateLimit
DemoMode
Number


Свойство ConnectionLimit (Объект IIngeoLicense)

Синтаксис

Язык Описание
VBScript, JavaScript
ConnectionLimit
Visual Basic
Property ConnectionLimit As Long
Delphi
property ConnectionLimit: Longint
C, C++
HRESULT get_ConnectionLimit(long* Value);


Свойство Customer (Объект IIngeoLicense)

Синтаксис

Язык Описание
VBScript, JavaScript
Customer
Visual Basic
Property Customer As String
Delphi
property Customer: WideString
C, C++
HRESULT get_Customer(BSTR* Value);


Свойство DateLimit (Объект IIngeoLicense)

Синтаксис

Язык Описание
VBScript, JavaScript
DateLimit
Visual Basic
Property DateLimit As Date
Delphi
property DateLimit: TDateTime
C, C++
HRESULT get_DateLimit(DATE* Value);


Свойство DemoMode (Объект IIngeoLicense)

Синтаксис

Язык Описание
VBScript, JavaScript
DemoMode
Visual Basic
Property DemoMode As Boolean
Delphi
property DemoMode: WordBool
C, C++
HRESULT get_DemoMode(VARIANT_BOOL* Value);


Свойство Number (Объект IIngeoLicense)

Синтаксис

Язык Описание
VBScript, JavaScript
Number
Visual Basic
Property Number As String
Delphi
property Number: WideString
C, C++
HRESULT get_Number(BSTR* Value);


Объект IIngeoMainWindow

Данный объект обеспечивает доступ к главному окну программы.

Свойства

Свойство | Описание
Actions | Главный список команд программы.
Handle | Идентификатор главного окна программы, использующийся в функциях Windows API .
MapWindow | Окно карты.
Menu | Главное меню программы.

Методы

Метод | Описание
CreateTaskPanel | Создает новую панель задач.
SetStatusText | Выводит в строке состояния указанный текст.

Примечания

Получить экземпляр данного объекта можно с помощью свойства MainWindow объекта Application.


Свойство Actions (Объект IIngeoMainWindow)

Главный список команд программы.

Синтаксис

Язык Описание
VBScript, JavaScript
Actions
Visual Basic
Property Actions As IInUIActions
Delphi
property Actions: IInUIActions
C, C++
HRESULT get_Actions(IInUIActions** Value);

См.также

IInUIActions


Метод CreateTaskPanel (Объект IIngeoMainWindow)

Создает новую панель задач.

Синтаксис

Язык | Описание
VBScript, JavaScript | FunctionCreateTaskPanel(Name, Caption)
Visual Basic | Function CreateTaskPanel(ByVal Name As String, ByVal Caption As String) As IIngeoTaskPanel
Delphi | function CreateTaskPanel(const Name: WideString; const Caption: WideString): IIngeoTaskPanel;
C, C++ | HRESULT CreateTaskPanel(BSTR Name, BSTR Caption, IIngeoTaskPanel** Value);

Параметры

Name
Имя панели задач.
Caption
Заголовок панели задач.

См.также

IIngeoTaskPanel


Свойство Handle (Объект IIngeoMainWindow)

Идентификатор главного окна программы, использующийся в функциях Windows API .

Синтаксис

Язык Описание
VBScript, JavaScript
Handle
Visual Basic
Property Handle As Long
Delphi
property Handle: Longint
C, C++
HRESULT get_Handle(long* Value);


Свойство MapWindow (Объект IIngeoMainWindow)

Окно карты.

Синтаксис

Язык Описание
VBScript, JavaScript
MapWindow
Visual Basic
Property MapWindow As IIngeoMapWindow
Delphi
property MapWindow: IIngeoMapWindow
C, C++
HRESULT get_MapWindow(IIngeoMapWindow** Value);

См.также

IIngeoMapWindow


Свойство Menu (Объект IIngeoMainWindow)

Главное меню программы.

Синтаксис

Язык Описание
VBScript, JavaScript
Menu
Visual Basic
Property Menu As IInUIMenu
Delphi
property Menu: IInUIMenu
C, C++
HRESULT get_Menu(IInUIMenu** Value);

См.также

IInUIMenu


Метод SetStatusText (Объект IIngeoMainWindow)

Выводит в строке состояния указанный текст.

Синтаксис

Язык | Описание
VBScript, JavaScript | SubSetStatusText(Text)
Visual Basic | Sub SetStatusText(ByVal Text As String)
Delphi | procedure SetStatusText(const Text: WideString);
C, C++ | HRESULT SetStatusText(BSTR Text);

Параметры

Text


Объект IIngeoMap

Объект Map представляет собой карту.

Свойства

Свойство | Описание
AC | Права доступа.
Area | Территория, к которй принадлежит карта.
ID | Внутренний идентификатор карты.
MapType | Тип карты (растровая или векторная).
Modified | Признак измения значений свойств карты.
Name | Название карты.
VisibleMax | Максимальный диапазон видимости.
VisibleMin | Минимальный диапазон видимости.

Методы

Метод | Описание
Delete | Удаление карты.
DropChanges | Отмена внесенных изменений.
Update | Сохранение внесенных изменений свойств карты в базу данных.


Свойство AC (Объект IIngeoMap)

Права доступа.

Синтаксис

Язык Описание
VBScript, JavaScript
AC
Visual Basic
Property AC As IIngeoAC
Delphi
property AC: IIngeoAC
C, C++
HRESULT get_AC(IIngeoAC** Value);

См.также

Список прав


Свойство Area (Объект IIngeoMap)

Территория, к которй принадлежит карта.

Синтаксис

Язык Описание
VBScript, JavaScript
Area
Visual Basic
Property Area As IIngeoArea
Delphi
property Area: IIngeoArea
C, C++
HRESULT get_Area(IIngeoArea** Value);


Метод Delete (Объект IIngeoMap)

Удаление карты.

Синтаксис

Язык | Описание
VBScript, JavaScript | SubDelete()
Visual Basic | Sub Delete()
Delphi | procedure Delete;
C, C++ | HRESULT Delete();


Метод DropChanges (Объект IIngeoMap)

Отмена внесенных изменений.

Синтаксис

Язык | Описание
VBScript, JavaScript | SubDropChanges()
Visual Basic | Sub DropChanges()
Delphi | procedure DropChanges;
C, C++ | HRESULT DropChanges();


Объект IIngeoMapEditorsSink

Объект-обработчик событий, связанных c обработкой различных событий в окне карты.

Методы

Метод | Описание
AddGlues | Вызывается для получения от обработчика дополнительных элементов подравнивания.
KeyDown | Вызывается при нажатии на клавишу клавиатуры.
KeyUp | Вызывается при отпускании клавиши клавиатуры.
MouseDown | Вызывается при нажатии на кнопку мыши.
MouseMove | Вызывается при перемещении указателя мыши.
MouseUp | Вызывается при отпускании кнопки мыши.
Paint | Вызывается для отображения редактором вспомогательных элементов.
RepaintDragging | Вызывается для перерисовки редактором инверсных элементов.

См.также

Порядок рисования карт


Метод AddGlues (Объект IIngeoMapEditorsSink)

Вызывается для получения от обработчика дополнительных элементов подравнивания.

Синтаксис

Язык | Описание
VBScript, JavaScript | SubAddGlues(aX, aY, aRadius, aGlues)
Visual Basic | Sub AddGlues(ByVal aX As Double, ByVal aY As Double, ByVal aRadius As Double, ByVal aGlues As IIngeoGlues)
Delphi | procedure AddGlues(aX: Double; aY: Double; aRadius: Double; aGlues: IIngeoGlues);
C, C++ | HRESULT AddGlues(double aX, double aY, double aRadius, IIngeoGlues* aGlues);

Параметры

aX
X координата точки указателя мыши (в мировой системе координат).
aY
Y координата точки указателя мыши (в мировой системе координат).
aRadius
Радиус окружности, в пределах которой производится поиск элементов подравнивания.
aGlues
Объект для добавления элементов подравнивания.

Пример

sub PaintPoint(x, y)
  Dim theSurface, theContour, theContourPart
  Dim theParam
  Set theSurface = Application.MainWindow.MapWindow.Surface
  theSurface.Pen.Color = 0
  Set theContour = Application.CreateObject(0, theParam)
  Set theContourPart = theContour.Insert(0)
  theContourPart.InsertVertex 0, x, y, 0
  theContourPart.InsertVertex 1, x+1, y+1, 0
  theSurface.PaintContour theContour, true
end sub

' Добавление точек подравнивания
sub MapEditors_AddGlues(aX, aY, aRadius, aGlues)
  Dim i, j
  Dim theSurface
  Set theSurface = Application.MainWindow.MapWindow.Surface
  for i=0 to 1000
    for j=0 to 1000
      aGlues.AddVertexGlue i, j, ""
      PaintPoint i, j
      j = j+100
    next
    i = i+100
  next
end sub

См.также

IIngeoMapEditorsSink, IIngeoGlues


Метод KeyDown (Объект IIngeoMapEditorsSink)

Вызывается при нажатии на клавишу клавиатуры.

Синтаксис

Язык | Описание
VBScript, JavaScript | SubKeyDown(aKey, aShift)
Visual Basic | Sub KeyDown(ByVal aKey As Long, ByVal aShift As TIngeoShiftState)
Delphi | procedure KeyDown(aKey: Longint; aShift: TIngeoShiftState);
C, C++ | HRESULT KeyDown(long aKey, TIngeoShiftState aShift);

Параметры

aKey
Код клавиши.
aShift
Флаги состояния клавиш <Alt>, <Shift>, <Ctrl> клавиатуры и кнопок мыши.

Пример

sub MapEditors_KeyDown(aKey, aShift)
  if aShift = (inssShift and inssAlt and inssCtrl) then
     MsgBox "Код нажатой клавиши - " & aKey
  end if
end sub

См.также

IIngeoMapEditorsSink


Метод KeyUp (Объект IIngeoMapEditorsSink)

Вызывается при отпускании клавиши клавиатуры.

Синтаксис

Язык | Описание
VBScript, JavaScript | SubKeyUp(aKey, aShift)
Visual Basic | Sub KeyUp(ByVal aKey As Long, ByVal aShift As TIngeoShiftState)
Delphi | procedure KeyUp(aKey: Longint; aShift: TIngeoShiftState);
C, C++ | HRESULT KeyUp(long aKey, TIngeoShiftState aShift);

Параметры

aKey
Код клавиши.
aShift
Флаги состояния клавиш <Alt>, <Shift>, <Ctrl> клавиатуры и кнопок мыши.

Пример

sub MapEditors_KeyUp(aKey, aShift)
  if aShift = (inssShift and inssAlt and inssCtrl) then
    MsgBox "Код нажатой клавиши - " & aKey
  end if
end sub

См.также

IIngeoMapEditorsSink


Метод MouseDown (Объект IIngeoMapEditorsSink)

Вызывается при нажатии на кнопку мыши.

Синтаксис

Язык | Описание
VBScript, JavaScript | SubMouseDown(aButton, aShift, aX, aY)
Visual Basic | Sub MouseDown(ByVal aButton As TIngeoMouseButton, ByVal aShift As TIngeoShiftState, ByVal aX As Long, ByVal aY As Long)
Delphi | procedure MouseDown(aButton: TIngeoMouseButton; aShift: TIngeoShiftState; aX: Longint; aY: Longint);
C, C++ | HRESULT MouseDown(TIngeoMouseButton aButton, TIngeoShiftState aShift, long aX, long aY);

Параметры

aButton
Кнопка мыши.
aShift
Флаги состояния клавиш <Alt>, <Shift>, <Ctrl> клавиатуры и кнопок мыши.
aX
X координата указателя мыши (в координатной системе устройства).
aY
Y координата указателя мыши (в координатной системе устройства).

Пример

sub MapEditors_MouseDown(aButton, aShift, aX, aY)
  if aButton = inmbLeft then
    if aShift = (inssShift and inssAlt) then
       MsgBox "Точка (" & aX & ", " & aY & ")."
    end if
  end if
end sub


Метод MouseMove (Объект IIngeoMapEditorsSink)

Вызывается при перемещении указателя мыши.

Синтаксис

Язык | Описание
VBScript, JavaScript | SubMouseMove(aShift, aX, aY)
Visual Basic | Sub MouseMove(ByVal aShift As TIngeoShiftState, ByVal aX As Long, ByVal aY As Long)
Delphi | procedure MouseMove(aShift: TIngeoShiftState; aX: Longint; aY: Longint);
C, C++ | HRESULT MouseMove(TIngeoShiftState aShift, long aX, long aY);

Параметры

aShift
Флаги состояния клавиш <Alt>, <Shift>, <Ctrl> клавиатуры и кнопок мыши.
aX
X координата указателя мыши (в координатной системе устройства).
aY
Y координата указателя мыши (в координатной системе устройства).

См.также

IIngeoMapEditorsSink


Метод MouseUp (Объект IIngeoMapEditorsSink)

Вызывается при отпускании кнопки мыши.

Синтаксис

Язык | Описание
VBScript, JavaScript | SubMouseUp(aButton, aShift, aX, aY)
Visual Basic | Sub MouseUp(ByVal aButton As TIngeoMouseButton, ByVal aShift As TIngeoShiftState, ByVal aX As Long, ByVal aY As Long)
Delphi | procedure MouseUp(aButton: TIngeoMouseButton; aShift: TIngeoShiftState; aX: Longint; aY: Longint);
C, C++ | HRESULT MouseUp(TIngeoMouseButton aButton, TIngeoShiftState aShift, long aX, long aY);

Параметры

aButton
Кнопка мыши.
aShift
Флаги состояния клавиш <Alt>, <Shift>, <Ctrl> клавиатуры и кнопок мыши.
aX
X координата указателя мыши (в координатной системе устройства).
aY
Y координата указателя мыши (в координатной системе устройства).

Пример

sub MapEditors_MouseUp(aButton, aShift, aX, aY)
  if aButton = inmbLeft  then
    if aShift = (inssShift and inssAlt)  then
      if Application.Selection.Count = 1 then
         MsgBox "Идентификатор выделенного объекта " & Application.Selection.IDs(0)
      end if
    end if
  end if
end sub

См.также

IIngeoMapEditorsSink


Метод Paint (Объект IIngeoMapEditorsSink)

Вызывается для отображения редактором вспомогательных элементов.

Синтаксис

Язык | Описание
VBScript, JavaScript | SubPaint(aSurface)
Visual Basic | Sub Paint(ByVal aSurface As IIngeoPaintSurface)
Delphi | procedure Paint(aSurface: IIngeoPaintSurface);
C, C++ | HRESULT Paint(IIngeoPaintSurface* aSurface);

Параметры

aSurface
Поверхность рисования.

См.также

IIngeoMapEditorsSink


Метод RepaintDragging (Объект IIngeoMapEditorsSink)

Вызывается для перерисовки редактором инверсных элементов.

Синтаксис

Язык | Описание
VBScript, JavaScript | SubRepaintDragging(Surface)
Visual Basic | Sub RepaintDragging(ByVal Surface As IIngeoPaintSurface)
Delphi | procedure RepaintDragging(Surface: IIngeoPaintSurface);
C, C++ | HRESULT RepaintDragging(IIngeoPaintSurface* Surface);

Параметры

Surface
Поверхность рисования.

См.также

IIngeoMapEditorsSink


Свойство ID (Объект IIngeoMap)

Внутренний идентификатор карты.

Синтаксис

Язык Описание
VBScript, JavaScript
ID
Visual Basic
Property ID As String
Delphi
property ID: WideString
C, C++
HRESULT get_ID(BSTR* Value);


Свойство MapType (Объект IIngeoMap)

Тип карты (растровая или векторная).

Синтаксис

Язык Описание
VBScript, JavaScript
MapType
Visual Basic
Property MapType As TIngeoMapType
Delphi
property MapType: TIngeoMapType
C, C++
HRESULT get_MapType(TIngeoMapType* Value);


Свойство Modified (Объект IIngeoMap)

Признак измения значений свойств карты.

Синтаксис

Язык Описание
VBScript, JavaScript
Modified
Visual Basic
Property Modified As Boolean
Delphi
property Modified: WordBool
C, C++
HRESULT get_Modified(VARIANT_BOOL* Value);

Примечания

Изменения свойств карты будут внесены в базу данных только после вызова метода Update IIngeoMap.


Свойство Name (Объект IIngeoMap)

Название карты.

Синтаксис

Язык Описание
VBScript, JavaScript
Name
Visual Basic
Property Name As String
Delphi
property Name: WideString
C, C++
HRESULT get_Name(BSTR* Value);
HRESULT set_Name(BSTR Value);


Объект IIngeoMapObject

Пространственный объект.

Свойства

Свойство | Описание
ID | Идентификатор пространственного объекта.
LayerID | Идентификатор слоя, в котором находится пространственный объект.
MapObjects | Возвращает транзакцию, которой принадлежит объект.
Modified | Определяет вносились ли изменения в пространственный объект.
Perimeter | Периметр объекта.
SemData | Через этот объект осуществляется работа с семантическими данными пространственного объекта.
Shapes | Коллекция фигур пространственного объекта.
Square | Площадь объекта.
TopoLinks | Коллекция топологических связей пространственного объекта.
X1 | Левая граница объекта.
X2 | Правая граница объекта.
Y1 | Верхняя граница объекта.
Y2 | Нижняя граница объекта.

Методы

Метод | Описание
DropChanges | Отменяет все сделанные изменения в пространственном объекте.
FormatText | Форматирует строку.
Paint | Рисует объект на заданной поверхности рисования.

См.также

IIngeoMapObjects, IIngeoDb


Метод DropChanges (Объект IIngeoMapObject)

Отменяет все сделанные изменения в пространственном объекте.

Синтаксис

Язык | Описание
VBScript, JavaScript | SubDropChanges()
Visual Basic | Sub DropChanges()
Delphi | procedure DropChanges;
C, C++ | HRESULT DropChanges();

См.также

IIngeoMapObject


Метод FormatText (Объект IIngeoMapObject)

Форматирует строку.
На вход методу подается строка в формате текста текстового метода отображения, на выходе возвращается уже отформатированная строка.

Синтаксис

Язык | Описание
VBScript, JavaScript | FunctionFormatText(Format)
Visual Basic | Function FormatText(ByVal Format As String) As String
Delphi | const function FormatText(const Format: WideString): WideString;
C, C++ | HRESULT FormatText(BSTR Format, BSTR* Value);

Параметры

Format
Форматируемая строка.


Свойство ID (Объект IIngeoMapObject)

Идентификатор пространственного объекта.

Синтаксис

Язык Описание
VBScript, JavaScript
ID
Visual Basic
Property ID As String
Delphi
property ID: WideString
C, C++
HRESULT get_ID(BSTR* Value);

См.также

IIngeoMapObject


Свойство LayerID (Объект IIngeoMapObject)

Идентификатор слоя, в котором находится пространственный объект.

Синтаксис

Язык Описание
VBScript, JavaScript
LayerID
Visual Basic
Property LayerID As String
Delphi
property LayerID: WideString
C, C++
HRESULT get_LayerID(BSTR* Value);

См.также

IIngeoMapObject


Свойство MapObjects (Объект IIngeoMapObject)

Возвращает транзакцию, которой принадлежит объект.

Синтаксис

Язык Описание
VBScript, JavaScript
MapObjects
Visual Basic
Property MapObjects As IIngeoMapObjects
Delphi
property MapObjects: IIngeoMapObjects
C, C++
HRESULT get_MapObjects(IIngeoMapObjects** Value);

См.также

IIngeoMapObject, IIngeoMapObjects


Свойство Modified (Объект IIngeoMapObject)

Определяет вносились ли изменения в пространственный объект. То есть изменялись ли пространственные формы объекта, его семантические данные, топологическое связи.

Возвращает True если объект был изменен, иначе - False.

Синтаксис

Язык Описание
VBScript, JavaScript
Modified
Visual Basic
Property Modified As Boolean
Delphi
property Modified: WordBool
C, C++
HRESULT get_Modified(VARIANT_BOOL* Value);

См.также

IIngeoMapObject


Метод Paint (Объект IIngeoMapObject)

Рисует объект на заданной поверхности рисования.

Синтаксис

Язык | Описание
VBScript, JavaScript | SubPaint(aSurface)
Visual Basic | Sub Paint(ByVal aSurface As IIngeoPaintSurface)
Delphi | procedure Paint(aSurface: IIngeoPaintSurface);
C, C++ | HRESULT Paint(IIngeoPaintSurface* aSurface);

Параметры

aSurface
Поверхность рисования.


Свойство Perimeter (Объект IIngeoMapObject)

Периметр объекта.

Синтаксис

Язык Описание
VBScript, JavaScript
Perimeter
Visual Basic
Property Perimeter As Double
Delphi
property Perimeter: Double
C, C++
HRESULT get_Perimeter(double* Value);

Примечания

При подсчете периметра учитываются только контура форм, определяющих геометрию объекта.


Объект IIngeoMapObjects

Через этот объект осуществляется работа с пространственными объектами ГИС.

Каждое получение ссылки на этот объект начинает новую транзакцию. При последнем освобождении ссылки на этот объект транзакция завершается. Таким образом чтобы какая-либо последовательность действий над объектами происходила внутри одной транзакции, надо ссылку на этот объект сохранить в переменной. Потом через эту ссылку произвести последовательность действий. После чего освободить ссылку.

Свойства

Свойство | Описание
StoreUndo | Определяет надо ли сохранять информацию о сделанных изменениях, чтобы потом можно было изменения отменить.
TransactionName | Имя транзакции.

Методы

Метод | Описание
AddObject | Создает пространственный объект.
AddObjectWithID | Создает пространственный объект с указанным идентификатором.
DeleteObject | Удаляет пространственный объект.
DropChanges | Отменяет сделанные изменения.
GetObject | Возвращает пространственный объект.
IsObjectExists | Определяет есть ли пространственный объект с данным идентификатором.
LayerIDFromObjectID | Возвращает идентификатор слоя в котором находится пространственный объект с данным идентификатором.
QueryByContour | Поиск пространственных объектов имеющих указанное пространственное отношение к заданному контуру.
QueryByLayers | Получить список всех объектов слоя(-ев).
QueryByObject | Поиск пространственных объектов имеющих указанное пространственное отношение к заданному объекту.
QueryByRect | Поиск пространственных объектов, находящихся в границах заданного прямоугольника.
QueryByStyle | Поиск пространственных объектов, содержащих формы с указанными стилями.
QueryBySurfacePos | Поиск объектов по координате точке на поверхности рисования.
UpdateChanges | Применяет сделанные изменения.

См.также

IIngeoDb, IIngeoMapObject


Метод AddObject (Объект IIngeoMapObjects)

Создает пространственный объект. После этого необходимо заполнить формы и, возможно, семантические данные объекта.

Синтаксис

Язык | Описание
VBScript, JavaScript | FunctionAddObject(aLayerID)
Visual Basic | Function AddObject(ByVal aLayerID As String) As IIngeoMapObject
Delphi | function AddObject(const aLayerID: WideString): IIngeoMapObject;
C, C++ | HRESULT AddObject(BSTR aLayerID, IIngeoMapObject** Value);

Параметры

aLayerID
Идентификатор слоя, в котором создается пространственный объект.

Возвращаемое значение

Созданный пространственный объект.

См.также

IIngeoMapObjects, IIngeoMapObject


Метод AddObjectWithID (Объект IIngeoMapObjects)

Создает пространственный объект с указанным идентификатором. После этого необходимо заполнить формы и, возможно, семантические данные объекта.

Синтаксис

Язык | Описание
VBScript, JavaScript | FunctionAddObjectWithID(aLayerID, anID)
Visual Basic | Function AddObjectWithID(ByVal aLayerID As String, ByVal anID As String) As IIngeoMapObject
Delphi | function AddObjectWithID(const aLayerID: WideString; const anID: WideString): IIngeoMapObject;
C, C++ | HRESULT AddObjectWithID(BSTR aLayerID, BSTR anID, IIngeoMapObject** Value);

Параметры

aLayerID
Идентификатор слоя, в котором создается пространственный объект.
anID
Идентификатор создаваемого объекта.

Возвращаемое значение

Созданный пространственный объект.

См.также

IIngeoMapObjects, IIngeoMapObject


Метод DeleteObject (Объект IIngeoMapObjects)

Удаляет пространственный объект.

Синтаксис

Язык | Описание
VBScript, JavaScript | SubDeleteObject(anObjectID)
Visual Basic | Sub DeleteObject(ByVal anObjectID As String)
Delphi | procedure DeleteObject(const anObjectID: WideString);
C, C++ | HRESULT DeleteObject(BSTR anObjectID);

Параметры

anObjectID
Идентификатор удаляемого пространственного объекта.

См.также

IIngeoMapObjects


Метод DropChanges (Объект IIngeoMapObjects)

Отменяет сделанные изменения. Предыдущая транзакция завершается и начинается новая транзакция.

Синтаксис

Язык | Описание
VBScript, JavaScript | SubDropChanges()
Visual Basic | Sub DropChanges()
Delphi | procedure DropChanges;
C, C++ | HRESULT DropChanges();

См.также

IIngeoMapObjects


Свойство SemData (Объект IIngeoMapObject)

Через этот объект осуществляется работа с семантическими данными пространственного объекта.

Синтаксис

Язык Описание
VBScript, JavaScript
SemData
Visual Basic
Property SemData As IIngeoSemData
Delphi
property SemData: IIngeoSemData
C, C++
HRESULT get_SemData(IIngeoSemData** Value);

См.также

IIngeoMapObject, IIngeoSemData


Метод GetObject (Объект IIngeoMapObjects)

Возвращает пространственный объект.

Синтаксис

Язык | Описание
VBScript, JavaScript | FunctionGetObject(anObjectID)
Visual Basic | Function GetObject(ByVal anObjectID As String) As IIngeoMapObject
Delphi | function GetObject(const anObjectID: WideString): IIngeoMapObject;
C, C++ | HRESULT GetObject(BSTR anObjectID, IIngeoMapObject** Value);

Параметры

anObjectID
Идентификатор пространственного объекта.

Возвращаемое значение

Пространственный объект.

См.также

IIngeoMapObjects, IIngeoMapObject


Свойство Shapes (Объект IIngeoMapObject)

Коллекция фигур пространственного объекта.

Синтаксис

Язык Описание
VBScript, JavaScript
Shapes
Visual Basic
Property Shapes As IIngeoShapes
Delphi
property Shapes: IIngeoShapes
C, C++
HRESULT get_Shapes(IIngeoShapes** Value);

См.также

IIngeoMapObject, IIngeoShapes


Метод IsObjectExists (Объект IIngeoMapObjects)

Определяет есть ли пространственный объект с данным идентификатором.

Синтаксис

Язык | Описание
VBScript, JavaScript | FunctionIsObjectExists(anObjectID)
Visual Basic | Function IsObjectExists(ByVal anObjectID As String) As Boolean
Delphi | function IsObjectExists(const anObjectID: WideString): WordBool;
C, C++ | HRESULT IsObjectExists(BSTR anObjectID, VARIANT_BOOL* Value);

Параметры

anObjectID
Идентификатор пространственного объекта.

Возвращаемое значение

Возвращает True если объект существует, иначе - False.

См.также

IIngeoMapObjects


Метод LayerIDFromObjectID (Объект IIngeoMapObjects)

Возвращает идентификатор слоя в котором находится пространственный объект с данным идентификатором.

Синтаксис

Язык | Описание
VBScript, JavaScript | FunctionLayerIDFromObjectID(anObjectID)
Visual Basic | Function LayerIDFromObjectID(ByVal anObjectID As String) As String
Delphi | const function LayerIDFromObjectID(const anObjectID: WideString): WideString;
C, C++ | HRESULT LayerIDFromObjectID(BSTR anObjectID, BSTR* Value);

Параметры

anObjectID
Идентификатор пространственного объекта.

Возвращаемое значение

Идентификатор слоя.

См.также

IIngeoMapObjects


Свойство Square (Объект IIngeoMapObject)

Площадь объекта.

Синтаксис

Язык Описание
VBScript, JavaScript
Square
Visual Basic
Property Square As Double
Delphi
property Square: Double
C, C++
HRESULT get_Square(double* Value);

Примечания

При подсчете площади учитываются только контура форм, определяющих геометрию объекта.


Объект IIngeoMapObjectsQuery

Данный объект возвращается различными функциями отбора пространственных объектов. Для получения списка идентификаторов используются понятия текущей записи и перемещения по списку:

  • Для получения информации об очередном объекте используйте свойства LayerID, ObjectID, ShapeIndex.
  • Для проверки достижения конца списка используйте свойство EOF.
  • Дле перемещения указателя текущей записи на следующую используйте метод MoveNext.

Свойства

Свойство | Описание
EOF | Признак того что достигнут конец списка объектов.
LayerID | Идентификатор слоя текущего объекта.
ObjectID | Идентификатор текущего объекта.
ShapeIndex | Порядковый номер контура текущего объекта.

Методы

Метод | Описание
Fetch | Получить текущий элемент списка и переместиться на следующую запись.
MoveNext | Переместить указатель текущей записи на следующую.
Reset | Переустановить указатель текущей записи на начало списка.
sFetch | Скриптовая версия метода Fetch.

См.также

IIngeoMapObjects


Метод QueryByContour (Объект IIngeoMapObjects)

Поиск пространственных объектов имеющих указанное пространственное отношение к заданному контуру.

Синтаксис

Язык | Описание
VBScript, JavaScript | FunctionQueryByContour(aLayerIDs, aContour, aRelationMask, aRelation)
Visual Basic | Function QueryByContour(ByVal aLayerIDs As Variant, ByVal aContour As IIngeoContour, ByVal aRelationMask As TIngeoContourRelation, ByVal aRelation As TIngeoContourRelation) As IIngeoMapObjectsQuery
Delphi | function QueryByContour(aLayerIDs: OleVariant; aContour: IIngeoContour; aRelationMask: TIngeoContourRelation; aRelation: TIngeoContourRelation): IIngeoMapObjectsQuery;
C, C++ | HRESULT QueryByContour(VARIANT aLayerIDs, IIngeoContour* aContour, TIngeoContourRelation aRelationMask, TIngeoContourRelation aRelation, IIngeoMapObjectsQuery** Value);

Параметры

aLayerIDs
Список идентификаторов слоев, в которых следует производить поиск. Данный параметр может содержать строку или массив строк.
aContour
Контур, по отношению к которому производится поиск.
aRelationMask
Маска пространственных отношений, на которые необходимо производить проверку.
aRelation
Значения пространственных отношений, удовлетворяющих поиску. Пространственные отношения, не указанные в параметре aRelationMask игнорируются.

Возвращаемое значение

Объект для перебора результатов поиска.

Примечания

При анализе каждого пространственного объекта производится вычисление пространственного отношения заданного контура с контурами форм объекта, определяющими геометрию.

Затем к вычисленному отношению применяется маска aRelationMask и результат сравнивается с aRelation. Если значения совпали, то объект считается удовлетворяющим поиску.

Пример

Пример 1

aRelationMask | incrIntersected + incrTouched
aRelation | incrIntersected

Будут найдены все объекты имеющие пересечения, но не имеющие точек соприкосновения с заданным контуром.

Пример 2

aRelationMask | incrContains + incrTouched
aRelation | incrTouched

Будут найдены все объекты имеющие точки соприкосновения, но не лежащие внутри заданного контура.

Пример 3

aRelationMask | incrContained
aRelation | incrContained

Будут найдены все объекты, содержащие внутри себя указанный контур.


Метод QueryByLayers (Объект IIngeoMapObjects)

Получить список всех объектов слоя(-ев).

Синтаксис

Язык | Описание
VBScript, JavaScript | FunctionQueryByLayers(aLayerIDs)
Visual Basic | Function QueryByLayers(ByVal aLayerIDs As Variant) As IIngeoMapObjectsQuery
Delphi | function QueryByLayers(aLayerIDs: OleVariant): IIngeoMapObjectsQuery;
C, C++ | HRESULT QueryByLayers(VARIANT aLayerIDs, IIngeoMapObjectsQuery** Value);

Параметры

aLayerIDs
Идентификатор слоя или массив идентификаторов слоев.

Возвращаемое значение

Объект для перебора результатов поиска.


Метод QueryByObject (Объект IIngeoMapObjects)

Поиск пространственных объектов имеющих указанное пространственное отношение к заданному объекту.

Синтаксис

Язык | Описание
VBScript, JavaScript | FunctionQueryByObject(aLayerIDs, anObjectID, aRelationMask, aRelation)
Visual Basic | Function QueryByObject(ByVal aLayerIDs As Variant, ByVal anObjectID As String, ByVal aRelationMask As TIngeoContourRelation, ByVal aRelation As TIngeoContourRelation) As IIngeoMapObjectsQuery
Delphi | function QueryByObject(aLayerIDs: OleVariant; const anObjectID: WideString; aRelationMask: TIngeoContourRelation; aRelation: TIngeoContourRelation): IIngeoMapObjectsQuery;
C, C++ | HRESULT QueryByObject(VARIANT aLayerIDs, BSTR anObjectID, TIngeoContourRelation aRelationMask, TIngeoContourRelation aRelation, IIngeoMapObjectsQuery** Value);

Параметры

aLayerIDs
Список идентификаторов слоев, в которых следует производить поиск. Данный параметр может содержать строку или массив строк.
anObjectID
Идентификатор объекта, по отношению к которому производится поиск.
aRelationMask
Маска пространственных отношений, на которые необходимо производить проверку.
aRelation
Значения пространственных отношений, удовлетворяющих поиску. Пространственные отношения, не указанные в параметре aRelationMask игнорируются.

Возвращаемое значение

Объект для перебора результатов поиска.

Примечания

При анализе каждого пространственного объекта производится вычисление пространственного отношения всех форм заданного объекта с контурами форм тестируемого объекта. Проверяются только формы, определяющие геометрию объекта.

К вычисленному отношению применяется маска aRelationMask и результат сравнивается с aRelation. Если значения совпали, то объект считается удовлетворяющим поиску.

Пример

Пример 1

aRelationMask | incrIntersected + incrTouched
aRelation | incrIntersected

Будут найдены все объекты имеющие пересечения, но не имеющие точек соприкосновения с заданным объектом.

Пример 2

aRelationMask | incrContains + incrTouched
aRelation | incrTouched

Будут найдены все объекты имеющие точки соприкосновения, но не лежащие внутри заданного объекта.

Пример 3

aRelationMask | incrContained
aRelation | incrContained

Будут найдены все объекты, содержащие внутри себя указанный объект.


Метод QueryByRect (Объект IIngeoMapObjects)

Поиск пространственных объектов, находящихся в границах заданного прямоугольника.

У объектов берутся границы и по ним производится сравнение.

Синтаксис

Язык | Описание
VBScript, JavaScript | FunctionQueryByRect(aLayerIDs, aX1, aY1, aX2, aY2, anEnclosed)
Visual Basic | Function QueryByRect(ByVal aLayerIDs As Variant, ByVal aX1 As Double, ByVal aY1 As Double, ByVal aX2 As Double, ByVal aY2 As Double, ByVal anEnclosed As Boolean) As IIngeoMapObjectsQuery
Delphi | function QueryByRect(aLayerIDs: OleVariant; aX1: Double; aY1: Double; aX2: Double; aY2: Double; anEnclosed: WordBool): IIngeoMapObjectsQuery;
C, C++ | HRESULT QueryByRect(VARIANT aLayerIDs, double aX1, double aY1, double aX2, double aY2, VARIANT_BOOL anEnclosed, IIngeoMapObjectsQuery** Value);

Параметры

aLayerIDs
Идентификатор или массив идентификаторов слоя(-ев), в котором(-ых) осуществляется поиск объектов.
aX1
Левая граница прямоугольника поиска.
aY1
Верхняя граница прямоугольника поиска.
aX2
Правая граница прямоугольника поиска.
aY2
Нижняя граница прямоугольника поиска.
anEnclosed
Только объекты, полностью лежащие в границе прямоугольника.

Возвращаемое значение

Список идентификаторов пространственных объектов.

См.также

IIngeoMapObjects, IIngeoMapObjectsQuery


Метод QueryByStyle (Объект IIngeoMapObjects)

Поиск пространственных объектов, содержащих формы с указанными стилями.

Синтаксис

Язык | Описание
VBScript, JavaScript | FunctionQueryByStyle(aStyleIDs, aFlags)
Visual Basic | Function QueryByStyle(ByVal aStyleIDs As Variant, ByVal aFlags As TIngeoQueryByStyleFlags) As IIngeoMapObjectsQuery
Delphi | function QueryByStyle(aStyleIDs: OleVariant; aFlags: TIngeoQueryByStyleFlags): IIngeoMapObjectsQuery;
C, C++ | HRESULT QueryByStyle(VARIANT aStyleIDs, TIngeoQueryByStyleFlags aFlags, IIngeoMapObjectsQuery** Value);

Параметры

aStyleIDs
Список стилей. Данный параметр может быть либо строкой либо масивом строк с идентификаторами стилей.
aFlags

Способ поиска объектов:

Значение | Описание
inqsOneOrMore | Объект попадет в результат поиска, если хотя бы одна форма объекта имеет стиль, содержащийся в списке aStyleIDs.
inqsAll | Объект попадет в результат поиска, если хотя все формы объекта имеет стили, содержащиеся в списке aStyleIDs.
inqsNone | Объект попадет в результат поиска, если все формы объекта имееют стили, не содержащиеся в списке aStyleIDs.

Возвращаемое значение

Объект для перебора результатов поиска.

Примечания

Список стилей может содержать идентификаторы стилей, принадлежащих разным слоям. В этом случае поиск будет производиться по нескольким слоям.


Метод QueryBySurfacePos (Объект IIngeoMapObjects)

Поиск объектов по координатам поверхности рисования.

В результаты поиска попадут объекты, соприкасающиеся с указанными координатами. Данная функция аналогична выбору объектов мышью в окне карты.

Синтаксис

Язык | Описание
VBScript, JavaScript | FunctionQueryBySurfacePos(aLayerIDs, aSurface, aDevX, aDevY)
Visual Basic | Function QueryBySurfacePos(ByVal aLayerIDs As Variant, ByVal aSurface As IIngeoPaintSurface, ByVal aDevX As Long, ByVal aDevY As Long) As IIngeoMapObjectsQuery
Delphi | function QueryBySurfacePos(aLayerIDs: OleVariant; aSurface: IIngeoPaintSurface; aDevX: Longint; aDevY: Longint): IIngeoMapObjectsQuery;
C, C++ | HRESULT QueryBySurfacePos(VARIANT aLayerIDs, IIngeoPaintSurface* aSurface, long aDevX, long aDevY, IIngeoMapObjectsQuery** Value);

Параметры

aLayerIDs
Список идентификаторов слоев, в которых следует производить поиск. Данный параметр может содержать строку или массив строк.
aSurface
Поверхность рисования.
aDevX
Координата по горизонтали.
aDevY
Координата по вертикали.

Возвращаемое значение

Объект для перебора результатов поиска.


Свойство EOF (Объект IIngeoMapObjectsQuery)

Признак того что достигнут конец списка объектов.

Синтаксис

Язык Описание
VBScript, JavaScript
EOF
Visual Basic
Property EOF As Boolean
Delphi
property EOF: WordBool
C, C++
HRESULT get_EOF(VARIANT_BOOL* Value);


Метод Fetch (Объект IIngeoMapObjectsQuery)

Получить текущий элемент списка и переместиться на следующую запись.

Синтаксис

Язык | Описание
VBScript, JavaScript | SubFetch(aLayerID, anObjectID, aShapeIndex)
Visual Basic | Sub Fetch(ByVal aLayerID As String, ByVal anObjectID As String, ByVal aShapeIndex As Long)
Delphi | procedure Fetch(const aLayerID: WideString; const anObjectID: WideString; aShapeIndex: Longint);
C, C++ | HRESULT Fetch(BSTR* aLayerID, BSTR* anObjectID, long* aShapeIndex);

Параметры

aLayerID
Идентификатор слоя объекта.
anObjectID
Идентификатор объекта.
aShapeIndex
Порядковый номер контура объекта.


Свойство LayerID (Объект IIngeoMapObjectsQuery)

Идентификатор слоя текущего объекта.

Синтаксис

Язык Описание
VBScript, JavaScript
LayerID
Visual Basic
Property LayerID As String
Delphi
property LayerID: WideString
C, C++
HRESULT get_LayerID(BSTR* Value);


Метод MoveNext (Объект IIngeoMapObjectsQuery)

Переместить указатель текущей записи на следующую.

Синтаксис

Язык | Описание
VBScript, JavaScript | SubMoveNext()
Visual Basic | Sub MoveNext()
Delphi | procedure MoveNext;
C, C++ | HRESULT MoveNext();


Свойство ObjectID (Объект IIngeoMapObjectsQuery)

Идентификатор текущего объекта.

Синтаксис

Язык Описание
VBScript, JavaScript
ObjectID
Visual Basic
Property ObjectID As String
Delphi
property ObjectID: WideString
C, C++
HRESULT get_ObjectID(BSTR* Value);


Метод Reset (Объект IIngeoMapObjectsQuery)

Переустановить указатель текущей записи на начало списка.

Синтаксис

Язык | Описание
VBScript, JavaScript | SubReset()
Visual Basic | Sub Reset()
Delphi | procedure Reset;
C, C++ | HRESULT Reset();


Метод sFetch (Объект IIngeoMapObjectsQuery)

Скриптовая версия метода Fetch.

Синтаксис

Язык | Описание
VBScript, JavaScript | SubsFetch(aLayerID, anObjectID, aShapeIndex)
Visual Basic | Sub sFetch(ByVal aLayerID As Variant, ByVal anObjectID As Variant, ByVal aShapeIndex As Variant)
Delphi | procedure sFetch(aLayerID: OleVariant; anObjectID: OleVariant; aShapeIndex: OleVariant);
C, C++ | HRESULT sFetch(VARIANT* aLayerID, VARIANT* anObjectID, VARIANT* aShapeIndex);

Параметры

aLayerID
Идентификатор слоя объекта.
anObjectID
Идентификатор объекта.
aShapeIndex
Порядковый номер контура объекта.


Свойство ShapeIndex (Объект IIngeoMapObjectsQuery)

Порядковый номер контура текущего объекта.

Синтаксис

Язык Описание
VBScript, JavaScript
ShapeIndex
Visual Basic
Property ShapeIndex As Long
Delphi
property ShapeIndex: Longint
C, C++
HRESULT get_ShapeIndex(long* Value);

Примечания

Данное свойство используется при пространственных запросах.


Свойство StoreUndo (Объект IIngeoMapObjects)

Определяет надо ли сохранять информацию о сделанных изменениях, чтобы потом можно было изменения отменить.

Синтаксис

Язык Описание
VBScript, JavaScript
StoreUndo
Visual Basic
Property StoreUndo As Boolean
Delphi
property StoreUndo: WordBool
C, C++
HRESULT get_StoreUndo(VARIANT_BOOL* Value);
HRESULT set_StoreUndo(VARIANT_BOOL Value);

См.также

IIngeoMapObjects


Свойство TransactionName (Объект IIngeoMapObjects)

Имя транзакции.

Синтаксис

Язык Описание
VBScript, JavaScript
TransactionName
Visual Basic
Property TransactionName As String
Delphi
property TransactionName: WideString
C, C++
HRESULT get_TransactionName(BSTR* Value);
HRESULT set_TransactionName(BSTR Value);

См.также

IIngeoMapObjects


Метод UpdateChanges (Объект IIngeoMapObjects)

Применяет сделанные изменения. Все изменения вносятся в базу данных. Предыдущая транзакция завершается и начинается новая транзакция.

Синтаксис

Язык | Описание
VBScript, JavaScript | SubUpdateChanges()
Visual Basic | Sub UpdateChanges()
Delphi | procedure UpdateChanges;
C, C++ | HRESULT UpdateChanges();

См.также

IIngeoMapObjects


Свойство TopoLinks (Объект IIngeoMapObject)

Коллекция топологических связей пространственного объекта.

Синтаксис

Язык Описание
VBScript, JavaScript
TopoLinks
Visual Basic
Property TopoLinks As IIngeoTopoLinks
Delphi
property TopoLinks: IIngeoTopoLinks
C, C++
HRESULT get_TopoLinks(IIngeoTopoLinks** Value);

См.также

IIngeoMapObject, IIngeoTopoLinks


Свойство X1 (Объект IIngeoMapObject)

Левая граница объекта.

Синтаксис

Язык Описание
VBScript, JavaScript
X1
Visual Basic
Property X1 As Double
Delphi
property X1: Double
C, C++
HRESULT get_X1(double* Value);

См.также

IIngeoMapObject


Свойство X2 (Объект IIngeoMapObject)

Правая граница объекта.

Синтаксис

Язык Описание
VBScript, JavaScript
X2
Visual Basic
Property X2 As Double
Delphi
property X2: Double
C, C++
HRESULT get_X2(double* Value);

См.также

IIngeoMapObject


Свойство Y1 (Объект IIngeoMapObject)

Верхняя граница объекта.

Синтаксис

Язык Описание
VBScript, JavaScript
Y1
Visual Basic
Property Y1 As Double
Delphi
property Y1: Double
C, C++
HRESULT get_Y1(double* Value);

См.также

IIngeoMapObject


Свойство Y2 (Объект IIngeoMapObject)

Нижняя граница объекта.

Синтаксис

Язык Описание
VBScript, JavaScript
Y2
Visual Basic
Property Y2 As Double
Delphi
property Y2: Double
C, C++
HRESULT get_Y2(double* Value);

См.также

IIngeoMapObject


Объект IIngeoMaps

Объект IIngeoMaps представляет собой список карт.

Свойства

Свойство | Описание
Count | Количество карт.
Item | Получение карты по индексу.
_NewEnum | Служебный метод: возвращает перечислитель коллекции списка.

Методы

Метод | Описание
AddRasterMap | Добавление растровой карты.
AddRasterMapWithID | Добавление растровой карты с указанным идентификатором.
AddVectorMap | Добавление векторной карты.
AddVectorMapWithID | Добавление векторной карты с указанным идентификатором.

См.также

IIngeoArea, IIngeoVectorMap, IIngeoRasterMap


Свойство _NewEnum (Объект IIngeoMaps)

Служебный метод: возвращает перечислитель коллекции списка.

Синтаксис

Язык Описание
VBScript, JavaScript
_NewEnum
Visual Basic
Property _NewEnum As Object
Delphi
property _NewEnum: IUnknown
C, C++
HRESULT get__NewEnum(IUnknown* Value);


Метод AddRasterMap (Объект IIngeoMaps)

Добавление растровой карты.

Синтаксис

Язык | Описание
VBScript, JavaScript | FunctionAddRasterMap()
Visual Basic | Function AddRasterMap() As IIngeoRasterMap
Delphi | function AddRasterMap: IIngeoRasterMap;
C, C++ | HRESULT AddRasterMap(IIngeoRasterMap** Value);

Примечания

Новая растровая карта будет добавлена в базу данных только после вызова метода Update IIngeoMap.


Метод AddRasterMapWithID (Объект IIngeoMaps)

Добавление растровой карты с указанным идентификатором.

Синтаксис

Язык | Описание
VBScript, JavaScript | FunctionAddRasterMapWithID(anID)
Visual Basic | Function AddRasterMapWithID(ByVal anID As String) As IIngeoRasterMap
Delphi | function AddRasterMapWithID(const anID: WideString): IIngeoRasterMap;
C, C++ | HRESULT AddRasterMapWithID(BSTR anID, IIngeoRasterMap** Value);

Параметры

anID
Идентификатор добавляемой карты.

Примечания

Новая растровая карта будет добавлена в базу данных только после вызова метода Update IIngeoMap.


Метод AddVectorMap (Объект IIngeoMaps)

Добавление векторной карты.

Синтаксис

Язык | Описание
VBScript, JavaScript | FunctionAddVectorMap()
Visual Basic | Function AddVectorMap() As IIngeoVectorMap
Delphi | function AddVectorMap: IIngeoVectorMap;
C, C++ | HRESULT AddVectorMap(IIngeoVectorMap** Value);

Примечания

Новая векторная карта будет добавлена в базу данных только после вызова метода Update IIngeoMap.


Метод AddVectorMapWithID (Объект IIngeoMaps)

Добавление векторной карты с указанным идентификатором.

Синтаксис

Язык | Описание
VBScript, JavaScript | FunctionAddVectorMapWithID(anID)
Visual Basic | Function AddVectorMapWithID(ByVal anID As String) As IIngeoVectorMap
Delphi | function AddVectorMapWithID(const anID: WideString): IIngeoVectorMap;
C, C++ | HRESULT AddVectorMapWithID(BSTR anID, IIngeoVectorMap** Value);

Параметры

anID
Идентификатор добавляемой карты.

Примечания

Новая векторная карта будет добавлена в базу данных только после вызова метода Update IIngeoMap.


Свойство Count (Объект IIngeoMaps)

Количество карт.

Синтаксис

Язык Описание
VBScript, JavaScript
Count
Visual Basic
Property Count As Long
Delphi
property Count: Longint
C, C++
HRESULT get_Count(long* Value);


Свойство Item (Объект IIngeoMaps)

Получение карты по индексу.

Синтаксис

Язык Описание
VBScript, JavaScript
Item(anIndex)
Visual Basic
Property Item(ByVal anIndex As Long) As IIngeoMap
Delphi
property Item[anIndex: Longint]: IIngeoMap
C, C++
HRESULT get_Item(long anIndex, IIngeoMap** Value);

Параметры

anIndex
Индекс карты (диапазон от 0 до Count-1).

Возвращаемое значение

Возвращает объект карты.

См.также

IIngeoMap


Метод Update (Объект IIngeoMap)

Сохранение внесенных изменений свойств карты в базу данных.

Синтаксис

Язык | Описание
VBScript, JavaScript | SubUpdate()
Visual Basic | Sub Update()
Delphi | procedure Update;
C, C++ | HRESULT Update();


Объект IIngeoMapView

Объект управления текущей карты.

Свойства

Свойство | Описание
Expanded | Состояние узла карты в дереве карт и слоев (раскрыт/скрыт).
Index | Индекс представленной карты.
LayerViews | Список представлений слоев, принадлежащих текущей карте.
Map | Карта.
Visible | Управление видимостью представления карты.

Методы

Метод | Описание
FindLayerView | Поиск объекта представления слоя.

См.также

IIngeoProjectView


Свойство Expanded (Объект IIngeoMapView)

Состояние узла карты в дереве карт и слоев (раскрыт/скрыт).

Синтаксис

Язык Описание
VBScript, JavaScript
Expanded
Visual Basic
Property Expanded As Boolean
Delphi
property Expanded: WordBool
C, C++
HRESULT get_Expanded(VARIANT_BOOL* Value);
HRESULT set_Expanded(VARIANT_BOOL Value);


Метод FindLayerView (Объект IIngeoMapView)

Поиск объекта представления слоя.

Синтаксис

Язык | Описание
VBScript, JavaScript | FunctionFindLayerView(aLayerID)
Visual Basic | Function FindLayerView(ByVal aLayerID As String) As IIngeoLayerView
Delphi | function FindLayerView(const aLayerID: WideString): IIngeoLayerView;
C, C++ | HRESULT FindLayerView(BSTR aLayerID, IIngeoLayerView** Value);

Параметры

aLayerID
Идентификатор объекта.


Свойство Index (Объект IIngeoMapView)

Индекс представленной карты.

Синтаксис

Язык Описание
VBScript, JavaScript
Index
Visual Basic
Property Index As Long
Delphi
property Index: Longint
C, C++
HRESULT get_Index(long* Value);
HRESULT set_Index(long Value);


Свойство LayerViews (Объект IIngeoMapView)

Список представлений слоев, принадлежащих текущей карте.

Синтаксис

Язык Описание
VBScript, JavaScript
LayerViews
Visual Basic
Property LayerViews As IIngeoLayerViews
Delphi
property LayerViews: IIngeoLayerViews
C, C++
HRESULT get_LayerViews(IIngeoLayerViews** Value);


Свойство Map (Объект IIngeoMapView)

Карта.

Синтаксис

Язык Описание
VBScript, JavaScript
Map
Visual Basic
Property Map As IIngeoMap
Delphi
property Map: IIngeoMap
C, C++
HRESULT get_Map(IIngeoMap** Value);


Объект IIngeoMapViews

Список объектов управления текущей карты. или Список представленных карт.

Свойства

Свойство | Описание
Count | Количество представленных карт.
Item | Получение представления карты по индексу.
_NewEnum | Служебный метод: возвращает перечислитель коллекции списка.


Свойство _NewEnum (Объект IIngeoMapViews)

Служебный метод: возвращает перечислитель коллекции списка.

Синтаксис

Язык Описание
VBScript, JavaScript
_NewEnum
Visual Basic
Property _NewEnum As Object
Delphi
property _NewEnum: IUnknown
C, C++
HRESULT get__NewEnum(IUnknown* Value);


Свойство Count (Объект IIngeoMapViews)

Количество представленных карт.

Синтаксис

Язык Описание
VBScript, JavaScript
Count
Visual Basic
Property Count As Long
Delphi
property Count: Longint
C, C++
HRESULT get_Count(long* Value);


Свойство Item (Объект IIngeoMapViews)

Получение представления карты по индексу.

Синтаксис

Язык Описание
VBScript, JavaScript
Item(anIndex)
Visual Basic
Property Item(ByVal anIndex As Long) As IIngeoMapView
Delphi
property Item[anIndex: Longint]: IIngeoMapView
C, C++
HRESULT get_Item(long anIndex, IIngeoMapView** Value);

Параметры

anIndex
Индекс объекта в списке.

Возвращаемое значение

Возвращает объект представленной карты.


Свойство Visible (Объект IIngeoMapView)

Управление видимостью представления карты.

Синтаксис

Язык Описание
VBScript, JavaScript
Visible
Visual Basic
Property Visible As Boolean
Delphi
property Visible: WordBool
C, C++
HRESULT get_Visible(VARIANT_BOOL* Value);
HRESULT set_Visible(VARIANT_BOOL Value);


Свойство VisibleMax (Объект IIngeoMap)

Максимальный диапазон видимости.

Синтаксис

Язык Описание
VBScript, JavaScript
VisibleMax
Visual Basic
Property VisibleMax As Double
Delphi
property VisibleMax: Double
C, C++
HRESULT get_VisibleMax(double* Value);
HRESULT set_VisibleMax(double Value);

См.также

Правила задания масштабов


Свойство VisibleMin (Объект IIngeoMap)

Минимальный диапазон видимости.

Синтаксис

Язык Описание
VBScript, JavaScript
VisibleMin
Visual Basic
Property VisibleMin As Double
Delphi
property VisibleMin: Double
C, C++
HRESULT get_VisibleMin(double* Value);
HRESULT set_VisibleMin(double Value);

См.также

Правила задания масштабов


Объект IIngeoMapWindow

Окно карты.

Свойства

Свойство | Описание
Cursor | Курсор.
Navigator | Навигатор окна карты.
Surface | Поверхность рисования окна карты.

Методы

Метод | Описание
Invalidate | Обновить окно карты.
InvalidateRect | Обновить часть окна карты, ограниченного заданным прямоугольником.
StartObjectCreation | Запустить редактор, для создания нового объекта.
StartShapeCreation | Запустить редактор, для пририсовки новой формы к уже существующему объекту.
StopHandler | Прекращение обработки текущего события объектами-подписчиками.


Свойство Cursor (Объект IIngeoMapWindow)

Курсор.

Синтаксис

Язык Описание
VBScript, JavaScript
Cursor
Visual Basic
Property Cursor As TIngeoCursor
Delphi
property Cursor: TIngeoCursor
C, C++
HRESULT get_Cursor(TIngeoCursor* Value);
HRESULT set_Cursor(TIngeoCursor Value);


Метод Invalidate (Объект IIngeoMapWindow)

Обновить окно карты.

Синтаксис

Язык | Описание
VBScript, JavaScript | SubInvalidate()
Visual Basic | Sub Invalidate()
Delphi | procedure Invalidate;
C, C++ | HRESULT Invalidate();


Метод InvalidateRect (Объект IIngeoMapWindow)

Обновить часть окна карты, ограниченного заданным прямоугольником.

Синтаксис

Язык | Описание
VBScript, JavaScript | SubInvalidateRect(X1, Y1, X2, Y2, CoordinateSpace)
Visual Basic | Sub InvalidateRect(ByVal X1 As Double, ByVal Y1 As Double, ByVal X2 As Double, ByVal Y2 As Double, ByVal CoordinateSpace As TCoordinateSpace)
Delphi | procedure InvalidateRect(X1: Double; Y1: Double; X2: Double; Y2: Double; CoordinateSpace: TCoordinateSpace);
C, C++ | HRESULT InvalidateRect(double X1, double Y1, double X2, double Y2, TCoordinateSpace CoordinateSpace);

Параметры

X1
X координата левого нижнего угла.
Y1
Y координата левого нижнего угла.
X2
X координата правого верхего угла.
Y2
Y координата правого верхего угла.
CoordinateSpace
Координатная система.

См.также

IIngeoMapWindow, TCoordinateSpace


Свойство Navigator (Объект IIngeoMapWindow)

Навигатор окна карты.

Синтаксис

Язык Описание
VBScript, JavaScript
Navigator
Visual Basic
Property Navigator As IIngeoNavigator
Delphi
property Navigator: IIngeoNavigator
C, C++
HRESULT get_Navigator(IIngeoNavigator** Value);


Объект IIngeoMapWindowSink

Объект-обработчик событий, связанных с рисованием содержимого окна карты.

Методы

Метод | Описание
PaintComplete | Вызывается после рисования окна карты.
ViewChangeComplete | Вызывается после изменения области просмотра карты.
WillPaint | Вызывается перед рисованием окна карты.

Примечания

Все события с префиксом Will вызываются только в том процессе ИнГео, в котором выполняется модуль расширения.

См.также

Порядок рисования карт


Метод PaintComplete (Объект IIngeoMapWindowSink)

Вызывается после рисования окна карты.

Синтаксис

Язык | Описание
VBScript, JavaScript | SubPaintComplete(aSurface)
Visual Basic | Sub PaintComplete(ByVal aSurface As IIngeoPaintSurface)
Delphi | procedure PaintComplete(aSurface: IIngeoPaintSurface);
C, C++ | HRESULT PaintComplete(IIngeoPaintSurface* aSurface);

Параметры

aSurface
Поверхность рисования.

Пример

sub MapWindow_PaintComplete(aSurface)
 MsgBox "Поверхность рисования имеет шрифт " & aSurface.Font.Name
end sub


Метод ViewChangeComplete (Объект IIngeoMapWindowSink)

Вызывается после изменения области просмотра карты.

Синтаксис

Язык | Описание
VBScript, JavaScript | SubViewChangeComplete()
Visual Basic | Sub ViewChangeComplete()
Delphi | procedure ViewChangeComplete;
C, C++ | HRESULT ViewChangeComplete();

Пример

sub MapWindow_ViewChangeComplete
 MsgBox "Область просмотра карты была изменена."
end sub


Метод WillPaint (Объект IIngeoMapWindowSink)

Вызывается перед рисованием окна карты.

Синтаксис

Язык | Описание
VBScript, JavaScript | SubWillPaint(aSurface)
Visual Basic | Sub WillPaint(ByVal aSurface As IIngeoPaintSurface)
Delphi | procedure WillPaint(aSurface: IIngeoPaintSurface);
C, C++ | HRESULT WillPaint(IIngeoPaintSurface* aSurface);

Параметры

aSurface
Поверхность рисования.

Пример

sub MapWindow_WillPaint(aSurface)
  MsgBox "Поверхность рисования имеет шрифт " & aSurface.Font.Name
end sub


Метод StartObjectCreation (Объект IIngeoMapWindow)

Запустить редактор, для создания нового объекта.

Синтаксис

Язык | Описание
VBScript, JavaScript | SubStartObjectCreation(StyleID, Flags)
Visual Basic | Sub StartObjectCreation(ByVal StyleID As String, ByVal Flags As TShapeCreationFlags)
Delphi | procedure StartObjectCreation(const StyleID: WideString; Flags: TShapeCreationFlags);
C, C++ | HRESULT StartObjectCreation(BSTR StyleID, TShapeCreationFlags Flags);

Параметры

StyleID
Идентификатор стиля создаваемого объекта.
Flags
Флаги определяющие поведение редактора.

См.также

IIngeoMapWindow, TShapeCreationFlags


Метод StartShapeCreation (Объект IIngeoMapWindow)

Запустить редактор, для пририсовки новой формы к уже существующему объекту.

Синтаксис

Язык | Описание
VBScript, JavaScript | SubStartShapeCreation(ObjectID, StyleID, Flags)
Visual Basic | Sub StartShapeCreation(ByVal ObjectID As String, ByVal StyleID As String, ByVal Flags As TShapeCreationFlags)
Delphi | procedure StartShapeCreation(const ObjectID: WideString; const StyleID: WideString; Flags: TShapeCreationFlags);
C, C++ | HRESULT StartShapeCreation(BSTR ObjectID, BSTR StyleID, TShapeCreationFlags Flags);

Параметры

ObjectID
Идентификатор существующего объекта.
StyleID
Идентификатор стиля создаваемой формы объекта.
Flags
Флаги определяющие поведение редактора.

См.также

IIngeoMapWindow, TShapeCreationFlags


Метод StopHandler (Объект IIngeoMapWindow)

Прекращение обработки текущего события объектами-подписчиками.

Синтаксис

Язык | Описание
VBScript, JavaScript | SubStopHandler()
Visual Basic | Sub StopHandler()
Delphi | procedure StopHandler;
C, C++ | HRESULT StopHandler();

Примечания

Окно карты является источником таких событий, как манипулирование мышью над окном карты и др. Каждое событие по очереди обрабатывается всеми объектами-подписчиками.

Если один из объектов-подписчиков отреагировал на некоторое событие и хочет остановить дальнейшую обработку этого события другими подписчиками, то он может вызвать данный метод.


Свойство Surface (Объект IIngeoMapWindow)

Поверхность рисования окна карты.

Синтаксис

Язык Описание
VBScript, JavaScript
Surface
Visual Basic
Property Surface As IIngeoPaintSurface
Delphi
property Surface: IIngeoPaintSurface
C, C++
HRESULT get_Surface(IIngeoPaintSurface** Value);


Объект IIngeoMatrixProjection

Объект IIngeoMatrixProjection(IIngeoProjection)

Проекция мировых координат в систему координат бумажной проекции с использованием линейных матричных (афинных) преобразований.

Свойства

Свойство | Наследуется от | Описание
YMirror | IIngeoProjection | Признак переворота оси Y относительно оси X при выполнении проекции.
ZoomScale | IIngeoProjection | Средний масштаб проекции.

Методы

Метод | Наследуется от | Описание
AddReflection | Добавить зеркальное отражение осей координат.
AddRotation | Добавить поворот координат относительно центра.
AddScaling | Добавить масштабирование координат.
AddShear | Добавить сдвиг координат.
AddTranslation | Добавить смещение координат.
Clear | Очистить матрицу преобразований.
ProjectBounds | IIngeoProjection | Преобразование ограничивающего прямоугольника из мировой системы координат в систему координат бумажной проекции.
ProjectContour | IIngeoProjection | Преобразование контура из мировой системы координат в систему координат бумажной проекции.
ProjectPoint | IIngeoProjection | Преобразование координат точки из мировых координат в координаты бумажной проекции.
sProjectBounds IIngeoProjection Преобразование ограничивающего прямоугольника из мировой системы координат в систему координат бумажной проекции.
Скриптовая версия.
sProjectPoint IIngeoProjection Преобразование координат точки из мировых координат в координаты бумажной проекции.
Скриптовая версия.
sUnprojectBounds IIngeoProjection Преобразование ограничивающего прямоугольника из системы координат бумажной проекции в мировую систему координат.
Скриптовая версия.
sUnprojectPoint IIngeoProjection Преобразование координат точки из бумажной проекции в мировые координаты.
Скриптовая версия.
UnprojectBounds | IIngeoProjection | Преобразование ограничивающего прямоугольника из системы координат бумажной проекции в мировую систему координат.
UnprojectContour | IIngeoProjection | Преобразование контура из системы координат бумажной проекции в мировую.
UnprojectPoint | IIngeoProjection | Преобразование координат точки из бумажной проекции в мировые координаты.

Примечания

Данный объект наследует свойства и методы объекта IIngeoProjection.

См.также

IIngeoProjection


Метод AddReflection (Объект IIngeoMatrixProjection)

Добавить зеркальное отражение осей координат.

Синтаксис

Язык | Описание
VBScript, JavaScript | SubAddReflection(aX, aY)
Visual Basic | Sub AddReflection(ByVal aX As Boolean, ByVal aY As Boolean)
Delphi | procedure AddReflection(aX: WordBool; aY: WordBool);
C, C++ | HRESULT AddReflection(VARIANT_BOOL aX, VARIANT_BOOL aY);

Параметры

aX
Признак отображения координат X относительно оси Y.
aY
Признак отображения координат Y относительно оси X.


Метод AddRotation (Объект IIngeoMatrixProjection)

Добавить поворот координат относительно центра.

Синтаксис

Язык | Описание
VBScript, JavaScript | SubAddRotation(anAngle)
Visual Basic | Sub AddRotation(ByVal anAngle As Double)
Delphi | procedure AddRotation(anAngle: Double);
C, C++ | HRESULT AddRotation(double anAngle);

Параметры

anAngle
Величина угла поворота в радианах. Положительное значение соответствует повороту против часовой стрелки.


Метод AddScaling (Объект IIngeoMatrixProjection)

Добавить масштабирование координат.

Синтаксис

Язык | Описание
VBScript, JavaScript | SubAddScaling(aX, aY)
Visual Basic | Sub AddScaling(ByVal aX As Double, ByVal aY As Double)
Delphi | procedure AddScaling(aX: Double; aY: Double);
C, C++ | HRESULT AddScaling(double aX, double aY);

Параметры

aX
Масштабирующий коэффициент по X
aY
Масштабирующий коэффициент по Y


Метод AddShear (Объект IIngeoMatrixProjection)

Добавить сдвиг координат.

Синтаксис

Язык | Описание
VBScript, JavaScript | SubAddShear(aX, aY)
Visual Basic | Sub AddShear(ByVal aX As Double, ByVal aY As Double)
Delphi | procedure AddShear(aX: Double; aY: Double);
C, C++ | HRESULT AddShear(double aX, double aY);

Параметры

aX
Величина сдвига по X.
aY
Величина сдвига по Y.


Метод AddTranslation (Объект IIngeoMatrixProjection)

Добавить смещение координат.

Синтаксис

Язык | Описание
VBScript, JavaScript | SubAddTranslation(aX, aY)
Visual Basic | Sub AddTranslation(ByVal aX As Double, ByVal aY As Double)
Delphi | procedure AddTranslation(aX: Double; aY: Double);
C, C++ | HRESULT AddTranslation(double aX, double aY);

Параметры

aX
Величина смещения по X
aY
Величина смещения по Y


Метод Clear (Объект IIngeoMatrixProjection)

Очистить матрицу преобразований.

Синтаксис

Язык | Описание
VBScript, JavaScript | SubClear()
Visual Basic | Sub Clear()
Delphi | procedure Clear;
C, C++ | HRESULT Clear();


Объект IIngeoMatrixProjectionNavigator

Объект IIngeoMatrixProjectionNavigator(IIngeoNavigator)

Навигатор окна карты, использующего матричную проекцию.

Свойства

Свойство | Описание
CenterX | X-координата точки, расположенной в центре области видимости.
CenterY | Y-координата точки, расположенной в центре области видимости.
XAngle | Угол поворота в радианах. Положительные значения соответствуют направлению против часовой стрелки.
YMirror | Признак зеркального отражения оси Y относительно оси X.
ZoomScale | Масштаб отображения мировых координат на бумажный лист.

Методы

Метод | Наследуется от | Описание
FitWorldBounds | IIngeoNavigator | Спозиционировать по указанным габаритам.
Navigate | IIngeoNavigator | Изменить область отображения.
ZoomToFitPaperRect | IIngeoNavigator | Вписать прямоугольник в видимую область.
ZoomToFitWorldRect | IIngeoNavigator | Вписать прямоугольник в видимую область.

Примечания

Данный объект наследует свойства и методы объекта IIngeoProjection.

См.также

IIngeoProjection


Свойство CenterX (Объект IIngeoMatrixProjectionNavigator)

X-координата точки, расположенной в центре области видимости.

Синтаксис

Язык Описание
VBScript, JavaScript
CenterX
Visual Basic
Property CenterX As Double
Delphi
property CenterX: Double
C, C++
HRESULT get_CenterX(double* Value);


Свойство CenterY (Объект IIngeoMatrixProjectionNavigator)

Y-координата точки, расположенной в центре области видимости.

Синтаксис

Язык Описание
VBScript, JavaScript
CenterY
Visual Basic
Property CenterY As Double
Delphi
property CenterY: Double
C, C++
HRESULT get_CenterY(double* Value);


Свойство XAngle (Объект IIngeoMatrixProjectionNavigator)

Угол поворота в радианах. Положительные значения соответствуют направлению против часовой стрелки.

Синтаксис

Язык Описание
VBScript, JavaScript
XAngle
Visual Basic
Property XAngle As Double
Delphi
property XAngle: Double
C, C++
HRESULT get_XAngle(double* Value);
HRESULT set_XAngle(double Value);


Свойство YMirror (Объект IIngeoMatrixProjectionNavigator)

Признак зеркального отражения оси Y относительно оси X.

Синтаксис

Язык Описание
VBScript, JavaScript
YMirror
Visual Basic
Property YMirror As Boolean
Delphi
property YMirror: WordBool
C, C++
HRESULT get_YMirror(VARIANT_BOOL* Value);
HRESULT set_YMirror(VARIANT_BOOL Value);


Свойство ZoomScale (Объект IIngeoMatrixProjectionNavigator)

Масштаб отображения мировых координат на бумажный лист.

Синтаксис

Язык Описание
VBScript, JavaScript
ZoomScale
Visual Basic
Property ZoomScale As Double
Delphi
property ZoomScale: Double
C, C++
HRESULT get_ZoomScale(double* Value);


Объект IIngeoModule

Не реализовано.

Свойства

Свойство Описание
Caption
Category
Name

Методы

Метод Описание
StartModule
StopModule


Свойство Caption (Объект IIngeoModule)

Синтаксис

Язык Описание
VBScript, JavaScript
Caption
Visual Basic
Property Caption As String
Delphi
property Caption: WideString
C, C++
HRESULT get_Caption(BSTR* Value);


Свойство Category (Объект IIngeoModule)

Синтаксис

Язык Описание
VBScript, JavaScript
Category
Visual Basic
Property Category As String
Delphi
property Category: WideString
C, C++
HRESULT get_Category(BSTR* Value);


Свойство Name (Объект IIngeoModule)

Синтаксис

Язык Описание
VBScript, JavaScript
Name
Visual Basic
Property Name As String
Delphi
property Name: WideString
C, C++
HRESULT get_Name(BSTR* Value);


Метод StartModule (Объект IIngeoModule)

Синтаксис

Язык | Описание
VBScript, JavaScript | SubStartModule(anIngeo)
Visual Basic | Sub StartModule(ByVal anIngeo As IIngeoApplication)
Delphi | procedure StartModule(anIngeo: IIngeoApplication);
C, C++ | HRESULT StartModule(IIngeoApplication* anIngeo);

Параметры

anIngeo


Метод StopModule (Объект IIngeoModule)

Синтаксис

Язык | Описание
VBScript, JavaScript | SubStopModule()
Visual Basic | Sub StopModule()
Delphi | procedure StopModule;
C, C++ | HRESULT StopModule();


Объект IIngeoNavigator

Навигатор окна карты.

Методы

Метод | Описание
FitWorldBounds | Спозиционировать по указанным габаритам.
Navigate | Изменить область отображения.
ZoomToFitPaperRect | Вписать прямоугольник в видимую область.
ZoomToFitWorldRect | Вписать прямоугольник в видимую область.


Метод FitWorldBounds (Объект IIngeoNavigator)

Данный метод изменяет параметры проекции таким образом, чтобы центр указанного прямоугольника совпадал с центром видимой области. Изменение масштаба происходит в зависимости от значения параметра aFitMode.

Синтаксис

Язык | Описание
VBScript, JavaScript | SubFitWorldBounds(aX1, aY1, aX2, aY2, aFitMode)
Visual Basic | Sub FitWorldBounds(ByVal aX1 As Double, ByVal aY1 As Double, ByVal aX2 As Double, ByVal aY2 As Double, ByVal aFitMode As TIngeoNavigatorFitMode)
Delphi | procedure FitWorldBounds(aX1: Double; aY1: Double; aX2: Double; aY2: Double; aFitMode: TIngeoNavigatorFitMode);
C, C++ | HRESULT FitWorldBounds(double aX1, double aY1, double aX2, double aY2, TIngeoNavigatorFitMode aFitMode);

Параметры

aX1
Минимальная координата прямоугольника по X
aY1
Минимальная координата прямоугольника по Y
aX2
Максимальная координата прямоугольника по X
aY2
Максимальная координата прямоугольника по Y
aFitMode

Способ изменения масштаба.

Может принимать следующие значения:

Значение | Описание
infitNoScale | Не изменять масштаб отображения
infitScaleIfNeed | Масштаб изменяется если указанные габариты превышают габариты области видимости или составляют менее одной восьмой от габаритов области видимости. Масштаб подбирается таким образом, чтобы указанный прямоугольник занимал семь восьмых области видимости.
infitAlwaysScale | Масштаб изменяется всегда и подбирается таким образом, чтобы указанный прямоугольник занимал семь восьмых области видимости.


Метод Navigate (Объект IIngeoNavigator)

Данный метод изменяет параметры проекции таким образом, чтобы указанная точка совпадала с центром области видимости, а масштаб отображения совпадал с указанным масштабом.

Синтаксис

Язык | Описание
VBScript, JavaScript | SubNavigate(aCenterX, aCenterY, aZoomScale)
Visual Basic | Sub Navigate(ByVal aCenterX As Double, ByVal aCenterY As Double, ByVal aZoomScale As Double)
Delphi | procedure Navigate(aCenterX: Double; aCenterY: Double; aZoomScale: Double);
C, C++ | HRESULT Navigate(double aCenterX, double aCenterY, double aZoomScale);

Параметры

aCenterX
X-координата точки, которая должна быть в центре видимой области.
aCenterY
Y-координата точки, которая должна быть в центре видимой области.
aZoomScale
Масштаб отображения.


Метод ZoomToFitPaperRect (Объект IIngeoNavigator)

Данный метод устанавливает такой масштаб и местоположение, чтобы указанный прямоугольник полностью вписывался в область отображения. Прямоугольник задан в системе координат бумажного листа.

Синтаксис

Язык | Описание
VBScript, JavaScript | SubZoomToFitPaperRect(aX1, aY1, aX2, aY2)
Visual Basic | Sub ZoomToFitPaperRect(ByVal aX1 As Double, ByVal aY1 As Double, ByVal aX2 As Double, ByVal aY2 As Double)
Delphi | procedure ZoomToFitPaperRect(aX1: Double; aY1: Double; aX2: Double; aY2: Double);
C, C++ | HRESULT ZoomToFitPaperRect(double aX1, double aY1, double aX2, double aY2);

Параметры

aX1
Левая граница прямоугольника.
aY1
Нижняя граница прямоугольника.
aX2
Правая граница прямоугольника.
aY2
Верхняя граница прямоугольника.


Метод ZoomToFitWorldRect (Объект IIngeoNavigator)

Данный метод устанавливает такой масштаб и местоположение, чтобы указанный прямоугольник полностью вписывался в область отображения. Прямоугольник задан в мировой системе координат.

Синтаксис

Язык | Описание
VBScript, JavaScript | SubZoomToFitWorldRect(aX1, aY1, aX2, aY2)
Visual Basic | Sub ZoomToFitWorldRect(ByVal aX1 As Double, ByVal aY1 As Double, ByVal aX2 As Double, ByVal aY2 As Double)
Delphi | procedure ZoomToFitWorldRect(aX1: Double; aY1: Double; aX2: Double; aY2: Double);
C, C++ | HRESULT ZoomToFitWorldRect(double aX1, double aY1, double aX2, double aY2);

Параметры

aX1
Минимальная координата по оси X
aY1
Минимальная координата по оси Y
aX2
Максимальная координата по оси X
aY2
Максимальная координата по оси Y


Объект IIngeoPainter

Базовый класс для всех методов отображения стиля.

Свойства

Свойство | Описание
Comment | Комментарий.
Index | Порядковый номер метода отображения в коллекции.
PainterType | Тип метода отображения.
VisibleMax | Верхняя граница диапазона видимости метода отображения.
VisibleMin | Нижняя граница диапазона видимости метода отображения.

Методы

Метод | Описание
Delete | Удаляет метод отображения из коллекции, которой он принадлежит.
PaintContour | Рисует заданный контур данным методом отображения на заданную поверхность рисования.

См.также

IIngeoPainters, IIngeoStyle, IIngeoStdPainter, IIngeoTextPainter, IIngeoSymbolPainter


Свойство Comment (Объект IIngeoPainter)

Комментарий.

Синтаксис

Язык Описание
VBScript, JavaScript
Comment
Visual Basic
Property Comment As String
Delphi
property Comment: WideString
C, C++
HRESULT get_Comment(BSTR* Value);
HRESULT set_Comment(BSTR Value);

См.также

IIngeoPainter


Метод Delete (Объект IIngeoPainter)

Удаляет метод отображения из коллекции, которой он принадлежит.

Синтаксис

Язык | Описание
VBScript, JavaScript | SubDelete()
Visual Basic | Sub Delete()
Delphi | procedure Delete;
C, C++ | HRESULT Delete();

См.также

IIngeoPainter


Свойство Index (Объект IIngeoPainter)

Порядковый номер метода отображения в коллекции. Этот порядок влияет на последовательность отрисовки методов отображения стиля.

Синтаксис

Язык Описание
VBScript, JavaScript
Index
Visual Basic
Property Index As Long
Delphi
property Index: Longint
C, C++
HRESULT get_Index(long* Value);
HRESULT set_Index(long Value);

См.также

IIngeoPainter


Метод PaintContour (Объект IIngeoPainter)

Рисует заданный контур данным методом отображения на заданную поверхность рисования.

Синтаксис

Язык | Описание
VBScript, JavaScript | SubPaintContour(aSurface, aContour, aData)
Visual Basic | Sub PaintContour(ByVal aSurface As IIngeoPaintSurface, ByVal aContour As IIngeoContour, ByVal aData As String)
Delphi | procedure PaintContour(aSurface: IIngeoPaintSurface; aContour: IIngeoContour; const aData: WideString);
C, C++ | HRESULT PaintContour(IIngeoPaintSurface* aSurface, IIngeoContour* aContour, BSTR aData);

Параметры

aSurface
Поверхность рисования.
aContour
Контур (определенный в мировой системе координат).
aData
Строка содержащая таблицу подстановок для текстов.
Смотрите пример для объекта IIngeoTextPainter.


Свойство PainterType (Объект IIngeoPainter)

Тип метода отображения.

Синтаксис

Язык Описание
VBScript, JavaScript
PainterType
Visual Basic
Property PainterType As TIngeoPainterType
Delphi
property PainterType: TIngeoPainterType
C, C++
HRESULT get_PainterType(TIngeoPainterType* Value);

См.также

IIngeoPainter, TIngeoPainterType


Объект IIngeoPainters

Коллекция методов отображения стиля.

Свойства

Свойство | Описание
Count | Количество методов отображения.
Item | Возвращает метод отображения.
_NewEnum | Возвращает перечислитель по элементам (методам отображения) коллекции.

Методы

Метод | Описание
Add | Добавляет в коллекцию новый метод отображения.

См.также

IIngeoStyle, IIngeoPainter, IIngeoStdPainter, IIngeoTextPainter, IIngeoSymbolPainter


Свойство _NewEnum (Объект IIngeoPainters)

Возвращает перечислитель по элементам (методам отображения) коллекции.

Синтаксис

Язык Описание
VBScript, JavaScript
_NewEnum
Visual Basic
Property _NewEnum As Object
Delphi
property _NewEnum: IUnknown
C, C++
HRESULT get__NewEnum(IUnknown* Value);

См.также

IIngeoPainters, IIngeoPainter


Метод Add (Объект IIngeoPainters)

Добавляет в коллекцию новый метод отображения. Метод добавляется в конец коллекции.

Синтаксис

Язык | Описание
VBScript, JavaScript | FunctionAdd(aPainterType)
Visual Basic | Function Add(ByVal aPainterType As TIngeoPainterType) As IIngeoPainter
Delphi | function Add(aPainterType: TIngeoPainterType): IIngeoPainter;
C, C++ | HRESULT Add(TIngeoPainterType aPainterType, IIngeoPainter** Value);

Параметры

aPainterType
Тип создаваемого метода отображения.

Возвращаемое значение

Добавленный метод отображения.

См.также

IIngeoPainters, IIngeoPainter


Свойство Count (Объект IIngeoPainters)

Количество методов отображения.

Синтаксис

Язык Описание
VBScript, JavaScript
Count
Visual Basic
Property Count As Long
Delphi
property Count: Longint
C, C++
HRESULT get_Count(long* Value);

См.также

IIngeoPainters


Свойство Item (Объект IIngeoPainters)

Возвращает метод отображения. Метод отображения задается по порядковому номеру.

Синтаксис

Язык Описание
VBScript, JavaScript
Item(anIndex)
Visual Basic
Property Item(ByVal anIndex As Long) As IIngeoPainter
Delphi
property Item[anIndex: Longint]: IIngeoPainter
C, C++
HRESULT get_Item(long anIndex, IIngeoPainter** Value);

Параметры

anIndex
Порядковый номер.

См.также

IIngeoPainters, IIngeoPainter


Свойство VisibleMax (Объект IIngeoPainter)

Верхняя граница диапазона видимости метода отображения. Если верхняя граница диапазона равна нулю, то это означает отсутствие ограничений сверху.

Синтаксис

Язык Описание
VBScript, JavaScript
VisibleMax
Visual Basic
Property VisibleMax As Double
Delphi
property VisibleMax: Double
C, C++
HRESULT get_VisibleMax(double* Value);
HRESULT set_VisibleMax(double Value);

См.также

IIngeoPainter, VisibleMin, Правила задания масштабов


Свойство VisibleMin (Объект IIngeoPainter)

Нижняя граница диапазона видимости метода отображения. Если нижняя граница диапазона равна нулю, то это означает отсутствие ограничения снизу.

Синтаксис

Язык Описание
VBScript, JavaScript
VisibleMin
Visual Basic
Property VisibleMin As Double
Delphi
property VisibleMin: Double
C, C++
HRESULT get_VisibleMin(double* Value);
HRESULT set_VisibleMin(double Value);

См.также

IIngeoPainter, VisibleMax, Правила задания масштабов


Объект IIngeoPaintSurface

Поверхность рисования.

При представлении координат на поверхности рисования используется идея бесконечного бумажного листа, на который проецируется некоторая мировая система координат.

Единицами измерения бумажного листа служат метры бумажного листа. Ось X всегда направлена вправо. Ось Y - вверх.

Некоторый прямоугольный участок поверхности рисования отображается на устройство вывода.

Свойства

Свойство | Описание
Brush | Текущие параметры закраски.
DC | Контекст устройства операционной системы Windows (Device Context).
DeviceBottom | Нижняя граница области отображения на устройстве вывода. Задается в точках устройства вывода.
DeviceLeft | Левая граница области отображения на устройстве вывода. Задается в точках устройства вывода.
DeviceRight | Правая граница области отображения на устройстве вывода. Задается в точках устройства вывода.
DeviceTop | Верхняя граница области отображения на устройстве вывода. Задается в точках устройства вывода.
DeviceType | Тип устройства вывода.
Font | Текущие параметры шрифта.
Navigator | Навигатор.
PaperX1 | Левая граница видимой части бумажного листа.
PaperX2 | Правая граница видимой части бумажного листа.
PaperY1 | Нижняя граница видимой части бумажного листа.
PaperY2 | Верхняя граница видимой части бумажного листа.
Pen | Текущие параметры окантовки.
Projection | Проекция, используемая для преобразования координат из мировой системы в систему координат бумажного листа.

Методы

Метод | Описание
GetContourTouchInfo

Получение информации о том, какая часть контура "задета" указанной точкой устройства.

PaintContour | Рисование контура, используя текщие параметры закраски и окантовки.
PointDeviceToPaper | Преобразование координат устройства в "бумажную" систему координат.
PointDeviceToWorld | Преобразование координат устройства в "мировую" систему координат.
PointPaperToDevice | Преобразование координат "бумажного" листа в координаты устройства.
PointWorldToDevice | Преобразование координат из "мировой" системы в координаты устройства.
RectDeviceToPaper | Преобразования координат прямоугольника из системы координат устройства в систему координат "бумажного" листа.
RectPaperToDevice | Преобразования координат прямоугольника из системы координат "бумажного" листа в систему координат устройства.
sGetContourTouchInfo | Скрипт версия метода GetContourTouchInfo.
SizeDeviceToPaper | Преобразование размера (расстояния) устройства в размер (расстояние) "бумажной" системы координат.
SizeDeviceToWorld | Преобразование размера (расстояния) устройства в размер (расстояние) "мировой" системы координат.
SizePaperToDevice | Преобразование размера (расстояния) "бумажной" системы координат в размер (расстояние) устройства.
SizeWorldToDevice | Преобразование размера (расстояния) "мировой" системы координат в размер (расстояние) устройства.
sPointDeviceToPaper | см. PointDeviceToPaper.
sPointDeviceToWorld | см. PointDeviceToWorld.
sPointPaperToDevice | см. PointPaperToDevice.
sPointWorldToDevice | см. PointWorldToDevice.
sRectDeviceToPaper | см. RectDeviceToPaper. Скриптовая версия.
sRectPaperToDevice | см. RectPaperToDevice.

См.также

IIngeoMapWindow, IInImage, IIngeoDbPaintXml, IIngeoMapObject.Paint, IIngeoPainter.PaintContour, IIngeoStyle.PaintContour


Свойство Brush (Объект IIngeoPaintSurface)

Текущие параметры закраски.

Синтаксис

Язык Описание
VBScript, JavaScript
Brush
Visual Basic
Property Brush As IInBrush
Delphi
property Brush: IInBrush
C, C++
HRESULT get_Brush(IInBrush** Value);

См.также

IInBrush


Свойство DC (Объект IIngeoPaintSurface)

Контекст устройства операционной системы Windows (Device Context).

Синтаксис

Язык Описание
VBScript, JavaScript
DC
Visual Basic
Property DC As Long
Delphi
property DC: Longint
C, C++
HRESULT get_DC(long* Value);


Свойство DeviceBottom (Объект IIngeoPaintSurface)

Нижняя граница области отображения на устройстве вывода. Задается в точках устройства вывода.

Синтаксис

Язык Описание
VBScript, JavaScript
DeviceBottom
Visual Basic
Property DeviceBottom As Long
Delphi
property DeviceBottom: Longint
C, C++
HRESULT get_DeviceBottom(long* Value);


Свойство DeviceLeft (Объект IIngeoPaintSurface)

Левая граница области отображения на устройстве вывода. Задается в точках устройства вывода.

Синтаксис

Язык Описание
VBScript, JavaScript
DeviceLeft
Visual Basic
Property DeviceLeft As Long
Delphi
property DeviceLeft: Longint
C, C++
HRESULT get_DeviceLeft(long* Value);


Свойство DeviceRight (Объект IIngeoPaintSurface)

Правая граница области отображения на устройстве вывода. Задается в точках устройства вывода.

Синтаксис

Язык Описание
VBScript, JavaScript
DeviceRight
Visual Basic
Property DeviceRight As Long
Delphi
property DeviceRight: Longint
C, C++
HRESULT get_DeviceRight(long* Value);


Свойство DeviceTop (Объект IIngeoPaintSurface)

Верхняя граница области отображения на устройстве вывода. Задается в точках устройства вывода.

Синтаксис

Язык Описание
VBScript, JavaScript
DeviceTop
Visual Basic
Property DeviceTop As Long
Delphi
property DeviceTop: Longint
C, C++
HRESULT get_DeviceTop(long* Value);


Свойство DeviceType (Объект IIngeoPaintSurface)

Тип устройства вывода.

Синтаксис

Язык Описание
VBScript, JavaScript
DeviceType
Visual Basic
Property DeviceType As TIngeoDeviceType
Delphi
property DeviceType: TIngeoDeviceType
C, C++
HRESULT get_DeviceType(TIngeoDeviceType* Value);

Возвращаемое значение

Может принимать одно из следующих значений:

Значение | Описание
indtScreen | Экран
indtPrinter | Печатающее устройство
indtRaster | Растр

См.также

TIngeoDeviceType


Свойство Font (Объект IIngeoPaintSurface)

Текущие параметры шрифта.

Синтаксис

Язык Описание
VBScript, JavaScript
Font
Visual Basic
Property Font As IInFont
Delphi
property Font: IInFont
C, C++
HRESULT get_Font(IInFont** Value);

См.также

IInFont


Метод GetContourTouchInfo (Объект IIngeoPaintSurface)

Получение информации о том, какая часть контура "задета" указанной точкой устройства.

Синтаксис

Язык | Описание
VBScript, JavaScript | FunctionGetContourTouchInfo(aContour, aDevX, aDevY, aX, aY, aPartIndex, aVertexIndex)
Visual Basic | Function GetContourTouchInfo(ByVal aContour As IIngeoContour, ByVal aDevX As Long, ByVal aDevY As Long, ByVal aX As Double, ByVal aY As Double, ByVal aPartIndex As Long, ByVal aVertexIndex As Long) As TIngeoTouchInfo
Delphi | function GetContourTouchInfo(aContour: IIngeoContour; aDevX: Longint; aDevY: Longint; aX: Double; aY: Double; aPartIndex: Longint; aVertexIndex: Longint): TIngeoTouchInfo;
C, C++ | HRESULT GetContourTouchInfo(IIngeoContour* aContour, long aDevX, long aDevY, double* aX, double* aY, long* aPartIndex, long* aVertexIndex, TIngeoTouchInfo* Value);

Параметры

aContour
Контур в мировой системе координат, по отношению к которому анализируется точка устройства.
aDevX
Координата устройства по горизонтали.
aDevY
Координата устройства по вертикали.
aX
Данный параметр возвращает координату X точки на контуре, ближайшую к заданной точке устройства.
aY
Данный параметр возвращает координату Y точки на контуре, ближайшую к заданной точке устройства.
aPartIndex
Данный параметр возвращает индекс части контура, ближайшей к заданной точке устройства.
aVertexIndex

Данный параметр возвращает индекс вершины, ближайшей к заданной точке устройства.

Возвращаемое значение

Может принимать одно из следующих значений:

Зачение | Описание
intiNone | Указанная точка устройства не "задевает" указанный контур. Параметры aX и aY содержат координаты точки устройства в "мировой" системе координат. Параметры aPartIndex и aVertexIndex не заполняются.
intiVertex | Указанная точка устройства "задевает" вершину контура. Параметры aX и aY содержат координаты вершины. Параметры aPartIndex и aVertexIndex содержат индекс части контура и вершины.
intiEdge | Указанная точка устройства "задевает" ребро контура. Параметры aX и aY содержат координаты ближайшей точки на ребре. Параметры aPartIndex и aVertexIndex содержат индекс части контура и конечной вершины ребра.
intiInside | Указанная точка попала внутрь полигональной части контура. Параметры aX и aY содержат координаты точки устройства в "мировой" системе координат. Параметры aPartIndex и aVertexIndex не заполняются.


Свойство Navigator (Объект IIngeoPaintSurface)

Навигатор.

Синтаксис

Язык Описание
VBScript, JavaScript
Navigator
Visual Basic
Property Navigator As IIngeoNavigator
Delphi
property Navigator: IIngeoNavigator
C, C++
HRESULT get_Navigator(IIngeoNavigator** Value);


Метод PaintContour (Объект IIngeoPaintSurface)

Рисование контура, используя текщие параметры закраски и окантовки.

Синтаксис

Язык | Описание
VBScript, JavaScript | SubPaintContour(aContour, aWorldSpace)
Visual Basic | Sub PaintContour(ByVal aContour As IIngeoContour, ByVal aWorldSpace As Boolean)
Delphi | procedure PaintContour(aContour: IIngeoContour; aWorldSpace: WordBool);
C, C++ | HRESULT PaintContour(IIngeoContour* aContour, VARIANT_BOOL aWorldSpace);

Параметры

aContour
Контур, который необходимо нарисовать.
aWorldSpace
Признак того, что данный контур задан в мировой системе координат. Если данный признак установлен, то перед рисованием контур будет преобразован в систему координат бумажного листа.


Свойство PaperX1 (Объект IIngeoPaintSurface)

Левая граница видимой части бумажного листа.

Синтаксис

Язык Описание
VBScript, JavaScript
PaperX1
Visual Basic
Property PaperX1 As Double
Delphi
property PaperX1: Double
C, C++
HRESULT get_PaperX1(double* Value);


Свойство PaperX2 (Объект IIngeoPaintSurface)

Правая граница видимой части бумажного листа.

Синтаксис

Язык Описание
VBScript, JavaScript
PaperX2
Visual Basic
Property PaperX2 As Double
Delphi
property PaperX2: Double
C, C++
HRESULT get_PaperX2(double* Value);


Свойство PaperY1 (Объект IIngeoPaintSurface)

Нижняя граница видимой части бумажного листа.

Синтаксис

Язык Описание
VBScript, JavaScript
PaperY1
Visual Basic
Property PaperY1 As Double
Delphi
property PaperY1: Double
C, C++
HRESULT get_PaperY1(double* Value);


Свойство PaperY2 (Объект IIngeoPaintSurface)

Верхняя граница видимой части бумажного листа.

Синтаксис

Язык Описание
VBScript, JavaScript
PaperY2
Visual Basic
Property PaperY2 As Double
Delphi
property PaperY2: Double
C, C++
HRESULT get_PaperY2(double* Value);


Свойство Pen (Объект IIngeoPaintSurface)

Текущие параметры окантовки.

Синтаксис

Язык Описание
VBScript, JavaScript
Pen
Visual Basic
Property Pen As IInPen
Delphi
property Pen: IInPen
C, C++
HRESULT get_Pen(IInPen** Value);

См.также

IInPen


Метод PointDeviceToPaper (Объект IIngeoPaintSurface)

Преобразование координат устройства в "бумажную" систему координат.

Синтаксис

Язык | Описание
VBScript, JavaScript | SubPointDeviceToPaper(aDevX, aDevY, aPaperX, aPaperY)
Visual Basic | Sub PointDeviceToPaper(ByVal aDevX As Long, ByVal aDevY As Long, ByVal aPaperX As Double, ByVal aPaperY As Double)
Delphi | procedure PointDeviceToPaper(aDevX: Longint; aDevY: Longint; aPaperX: Double; aPaperY: Double);
C, C++ | HRESULT PointDeviceToPaper(long aDevX, long aDevY, double* aPaperX, double* aPaperY);

Параметры

aDevX
Горизонтальная координата устройства.
aDevY
Вертикальная координата устройства.
aPaperX
"Бумажная" координата X.
aPaperY
"Бумажная" координата Y.


Метод PointDeviceToWorld (Объект IIngeoPaintSurface)

Преобразование координат устройства в "мировую" систему координат.

Синтаксис

Язык | Описание
VBScript, JavaScript | SubPointDeviceToWorld(aDevX, aDevY, aWorldX, aWorldY)
Visual Basic | Sub PointDeviceToWorld(ByVal aDevX As Long, ByVal aDevY As Long, ByVal aWorldX As Double, ByVal aWorldY As Double)
Delphi | procedure PointDeviceToWorld(aDevX: Longint; aDevY: Longint; aWorldX: Double; aWorldY: Double);
C, C++ | HRESULT PointDeviceToWorld(long aDevX, long aDevY, double* aWorldX, double* aWorldY);

Параметры

aDevX
Горизонтальная координата устройства.
aDevY
Вертикальная координата устройства.
aWorldX
"Мировая" координата X.
aWorldY
"Мировая" координата Y.


Метод PointPaperToDevice (Объект IIngeoPaintSurface)

Преобразование координат "бумажного" листа в координаты устройства.

Синтаксис

Язык | Описание
VBScript, JavaScript | FunctionPointPaperToDevice(aPaperX, aPaperY, aDevX, aDevY)
Visual Basic | Function PointPaperToDevice(ByVal aPaperX As Double, ByVal aPaperY As Double, ByVal aDevX As Long, ByVal aDevY As Long) As Boolean
Delphi | function PointPaperToDevice(aPaperX: Double; aPaperY: Double; aDevX: Longint; aDevY: Longint): WordBool;
C, C++ | HRESULT PointPaperToDevice(double aPaperX, double aPaperY, long* aDevX, long* aDevY, VARIANT_BOOL* Value);

Параметры

aPaperX
"Бумажная" координата X.
aPaperY
"Бумажная" координата X.
aDevX
Горизонтальная координата устройства.
aDevY
Вертикальная координата устройства.


Метод PointWorldToDevice (Объект IIngeoPaintSurface)

Преобразование координат из "мировой" системы в координаты устройства.

Синтаксис

Язык | Описание
VBScript, JavaScript | SubPointWorldToDevice(aWorldX, aWorldY, aDevX, aDevY)
Visual Basic | Sub PointWorldToDevice(ByVal aWorldX As Double, ByVal aWorldY As Double, ByVal aDevX As Long, ByVal aDevY As Long)
Delphi | procedure PointWorldToDevice(aWorldX: Double; aWorldY: Double; aDevX: Longint; aDevY: Longint);
C, C++ | HRESULT PointWorldToDevice(double aWorldX, double aWorldY, long* aDevX, long* aDevY);

Параметры

aWorldX
"Мировая" координата X.
aWorldY
"Мировая" координата Y.
aDevX
Горизонтальная координата устройства.
aDevY
Вертикальная координата устройства.


Свойство Projection (Объект IIngeoPaintSurface)

Проекция, используемая для преобразования координат из мировой системы в систему координат бумажного листа.

Синтаксис

Язык Описание
VBScript, JavaScript
Projection
Visual Basic
Property Projection As IIngeoProjection
Delphi
property Projection: IIngeoProjection
C, C++
HRESULT get_Projection(IIngeoProjection** Value);


Метод RectDeviceToPaper (Объект IIngeoPaintSurface)

Преобразования координат прямоугольника из системы координат устройства в систему координат "бумажного" листа.

Синтаксис

Язык | Описание
VBScript, JavaScript | SubRectDeviceToPaper(aDevLeft, aDevTop, aDevRight, aDevBottom, aPaperX1, aPaperY1, aPaperX2, aPaperY2)
Visual Basic | Sub RectDeviceToPaper(ByVal aDevLeft As Long, ByVal aDevTop As Long, ByVal aDevRight As Long, ByVal aDevBottom As Long, ByVal aPaperX1 As Double, ByVal aPaperY1 As Double, ByVal aPaperX2 As Double, ByVal aPaperY2 As Double)
Delphi | procedure RectDeviceToPaper(aDevLeft: Longint; aDevTop: Longint; aDevRight: Longint; aDevBottom: Longint; aPaperX1: Double; aPaperY1: Double; aPaperX2: Double; aPaperY2: Double);
C, C++ | HRESULT RectDeviceToPaper(long aDevLeft, long aDevTop, long aDevRight, long aDevBottom, double* aPaperX1, double* aPaperY1, double* aPaperX2, double* aPaperY2);

Параметры

aDevLeft
Левая координата устройства.
aDevTop
Верхняя координата устройства.
aDevRight
Правая координата устройства.
aDevBottom
Нижняя координата устройства.
aPaperX1
Левая "бумажная" координата.
aPaperY1
Нижняя "бумажная" координата.
aPaperX2
Правая "бумажная" координата.
aPaperY2
Верхняя "бумажная" координата.


Метод RectPaperToDevice (Объект IIngeoPaintSurface)

Преобразования координат прямоугольника из системы координат "бумажного" листа в систему координат устройства.

Синтаксис

Язык | Описание
VBScript, JavaScript | SubRectPaperToDevice(aPaperX1, aPaperY1, aPaperX2, aPaperY2, aDevLeft, aDevTop, aDevRight, aDevBottom)
Visual Basic | Sub RectPaperToDevice(ByVal aPaperX1 As Double, ByVal aPaperY1 As Double, ByVal aPaperX2 As Double, ByVal aPaperY2 As Double, ByVal aDevLeft As Long, ByVal aDevTop As Long, ByVal aDevRight As Long, ByVal aDevBottom As Long)
Delphi | procedure RectPaperToDevice(aPaperX1: Double; aPaperY1: Double; aPaperX2: Double; aPaperY2: Double; aDevLeft: Longint; aDevTop: Longint; aDevRight: Longint; aDevBottom: Longint);
C, C++ | HRESULT RectPaperToDevice(double aPaperX1, double aPaperY1, double aPaperX2, double aPaperY2, long* aDevLeft, long* aDevTop, long* aDevRight, long* aDevBottom);

Параметры

aPaperX1
Левая "бумажная" координата.
aPaperY1
Нижняя "бумажная" координата.
aPaperX2
Правая "бумажная" координата.
aPaperY2
Верхняя "бумажная" координата.
aDevLeft
Левая координата устройства.
aDevTop
Верхняя координата устройства.
aDevRight
Правая координата устройства.
aDevBottom
Нижняя координата устройства.


Метод sGetContourTouchInfo (Объект IIngeoPaintSurface)

Скрипт версия метода GetContourTouchInfo.

Синтаксис

Язык | Описание
VBScript, JavaScript | FunctionsGetContourTouchInfo(aContour, aDevX, aDevY, aX, aY, aPartIndex, aVertexIndex)
Visual Basic | Function sGetContourTouchInfo(ByVal aContour As IIngeoContour, ByVal aDevX As Long, ByVal aDevY As Long, ByVal aX As Variant, ByVal aY As Variant, ByVal aPartIndex As Variant, ByVal aVertexIndex As Variant) As TIngeoTouchInfo
Delphi | function sGetContourTouchInfo(aContour: IIngeoContour; aDevX: Longint; aDevY: Longint; aX: OleVariant; aY: OleVariant; aPartIndex: OleVariant; aVertexIndex: OleVariant): TIngeoTouchInfo;
C, C++ | HRESULT sGetContourTouchInfo(IIngeoContour* aContour, long aDevX, long aDevY, VARIANT* aX, VARIANT* aY, VARIANT* aPartIndex, VARIANT* aVertexIndex, TIngeoTouchInfo* Value);

Параметры

aContour
aDevX
aDevY
aX
aY
aPartIndex
aVertexIndex


Метод SizeDeviceToPaper (Объект IIngeoPaintSurface)

Преобразование размера (расстояния) устройства в размер (расстояние) "бумажной" системы координат.

Синтаксис

Язык | Описание
VBScript, JavaScript | FunctionSizeDeviceToPaper(aDevSize)
Visual Basic | Function SizeDeviceToPaper(ByVal aDevSize As Long) As Double
Delphi | function SizeDeviceToPaper(aDevSize: Longint): Double;
C, C++ | HRESULT SizeDeviceToPaper(long aDevSize, double* Value);

Параметры

aDevSize
Размер (расстояние) устройства.

Возвращаемое значение

Размер (расстояние) в "бумажной" системе координат.


Метод SizeDeviceToWorld (Объект IIngeoPaintSurface)

Преобразование размера (расстояния) устройства в размер (расстояние) "мировой" системы координат.

Синтаксис

Язык | Описание
VBScript, JavaScript | FunctionSizeDeviceToWorld(aDevSize)
Visual Basic | Function SizeDeviceToWorld(ByVal aDevSize As Long) As Double
Delphi | function SizeDeviceToWorld(aDevSize: Longint): Double;
C, C++ | HRESULT SizeDeviceToWorld(long aDevSize, double* Value);

Параметры

aDevSize
Размер (расстояние) устройства.

Возвращаемое значение

Размер (расстояние) в "мировой" системе координат.


Метод SizePaperToDevice (Объект IIngeoPaintSurface)

Преобразование размера (расстояния) "бумажной" системы координат в размер (расстояние) устройства.

Синтаксис

Язык | Описание
VBScript, JavaScript | FunctionSizePaperToDevice(aPaperSize)
Visual Basic | Function SizePaperToDevice(ByVal aPaperSize As Double) As Long
Delphi | function SizePaperToDevice(aPaperSize: Double): Longint;
C, C++ | HRESULT SizePaperToDevice(double aPaperSize, long* Value);

Параметры

aPaperSize
Размер (расстояние) в "бумажной" системе координат.

Возвращаемое значение

Размер (расстояние) устройства.


Метод SizeWorldToDevice (Объект IIngeoPaintSurface)

Преобразование размера (расстояния) "мировой" системы координат в размер (расстояние) устройства.

Синтаксис

Язык | Описание
VBScript, JavaScript | FunctionSizeWorldToDevice(aWorldSize)
Visual Basic | Function SizeWorldToDevice(ByVal aWorldSize As Double) As Long
Delphi | function SizeWorldToDevice(aWorldSize: Double): Longint;
C, C++ | HRESULT SizeWorldToDevice(double aWorldSize, long* Value);

Параметры

aWorldSize
Размер (расстояние) в "мировой" системе координат.

Возвращаемое значение

Размер (расстояние) устройства.


Метод sPointDeviceToPaper (Объект IIngeoPaintSurface)

см. PointDeviceToPaper.

Синтаксис

Язык | Описание
VBScript, JavaScript | SubsPointDeviceToPaper(aDevX, aDevY, aPaperX, aPaperY)
Visual Basic | Sub sPointDeviceToPaper(ByVal aDevX As Long, ByVal aDevY As Long, ByVal aPaperX As Variant, ByVal aPaperY As Variant)
Delphi | procedure sPointDeviceToPaper(aDevX: Longint; aDevY: Longint; aPaperX: OleVariant; aPaperY: OleVariant);
C, C++ | HRESULT sPointDeviceToPaper(long aDevX, long aDevY, VARIANT* aPaperX, VARIANT* aPaperY);

Параметры

aDevX
aDevY
aPaperX
aPaperY


Метод sPointDeviceToWorld (Объект IIngeoPaintSurface)

см. PointDeviceToWorld.

Синтаксис

Язык | Описание
VBScript, JavaScript | SubsPointDeviceToWorld(aDevX, aDevY, aWorldX, aWorldY)
Visual Basic | Sub sPointDeviceToWorld(ByVal aDevX As Long, ByVal aDevY As Long, ByVal aWorldX As Variant, ByVal aWorldY As Variant)
Delphi | procedure sPointDeviceToWorld(aDevX: Longint; aDevY: Longint; aWorldX: OleVariant; aWorldY: OleVariant);
C, C++ | HRESULT sPointDeviceToWorld(long aDevX, long aDevY, VARIANT* aWorldX, VARIANT* aWorldY);

Параметры

aDevX
aDevY
aWorldX
aWorldY


Метод sPointPaperToDevice (Объект IIngeoPaintSurface)

см. PointPaperToDevice.

Синтаксис

Язык | Описание
VBScript, JavaScript | FunctionsPointPaperToDevice(aPaperX, aPaperY, aDevX, aDevY)
Visual Basic | Function sPointPaperToDevice(ByVal aPaperX As Double, ByVal aPaperY As Double, ByVal aDevX As Variant, ByVal aDevY As Variant) As Boolean
Delphi | function sPointPaperToDevice(aPaperX: Double; aPaperY: Double; aDevX: OleVariant; aDevY: OleVariant): WordBool;
C, C++ | HRESULT sPointPaperToDevice(double aPaperX, double aPaperY, VARIANT* aDevX, VARIANT* aDevY, VARIANT_BOOL* Value);

Параметры

aPaperX
aPaperY
aDevX
aDevY


Метод sPointWorldToDevice (Объект IIngeoPaintSurface)

см. PointWorldToDevice.

Синтаксис

Язык | Описание
VBScript, JavaScript | SubsPointWorldToDevice(aWorldX, aWorldY, aDevX, aDevY)
Visual Basic | Sub sPointWorldToDevice(ByVal aWorldX As Double, ByVal aWorldY As Double, ByVal aDevX As Variant, ByVal aDevY As Variant)
Delphi | procedure sPointWorldToDevice(aWorldX: Double; aWorldY: Double; aDevX: OleVariant; aDevY: OleVariant);
C, C++ | HRESULT sPointWorldToDevice(double aWorldX, double aWorldY, VARIANT* aDevX, VARIANT* aDevY);

Параметры

aWorldX
aWorldY
aDevX
aDevY


Метод sRectDeviceToPaper (Объект IIngeoPaintSurface)

см. RectDeviceToPaper. Скриптовая версия.

Синтаксис

Язык | Описание
VBScript, JavaScript | SubsRectDeviceToPaper(aDevLeft, aDevTop, aDevRight, aDevBottom, aPaperX1, aPaperY1, aPaperX2, aPaperY2)
Visual Basic | Sub sRectDeviceToPaper(ByVal aDevLeft As Long, ByVal aDevTop As Long, ByVal aDevRight As Long, ByVal aDevBottom As Long, ByVal aPaperX1 As Variant, ByVal aPaperY1 As Variant, ByVal aPaperX2 As Variant, ByVal aPaperY2 As Variant)
Delphi | procedure sRectDeviceToPaper(aDevLeft: Longint; aDevTop: Longint; aDevRight: Longint; aDevBottom: Longint; aPaperX1: OleVariant; aPaperY1: OleVariant; aPaperX2: OleVariant; aPaperY2: OleVariant);
C, C++ | HRESULT sRectDeviceToPaper(long aDevLeft, long aDevTop, long aDevRight, long aDevBottom, VARIANT* aPaperX1, VARIANT* aPaperY1, VARIANT* aPaperX2, VARIANT* aPaperY2);

Параметры

aDevLeft
aDevTop
aDevRight
aDevBottom
aPaperX1
aPaperY1
aPaperX2
aPaperY2


Метод sRectPaperToDevice (Объект IIngeoPaintSurface)

см. RectPaperToDevice.

Синтаксис

Язык | Описание
VBScript, JavaScript | SubsRectPaperToDevice(aPaperX1, aPaperY1, aPaperX2, aPaperY2, aDevLeft, aDevTop, aDevRight, aDevBottom)
Visual Basic | Sub sRectPaperToDevice(ByVal aPaperX1 As Double, ByVal aPaperY1 As Double, ByVal aPaperX2 As Double, ByVal aPaperY2 As Double, ByVal aDevLeft As Variant, ByVal aDevTop As Variant, ByVal aDevRight As Variant, ByVal aDevBottom As Variant)
Delphi | procedure sRectPaperToDevice(aPaperX1: Double; aPaperY1: Double; aPaperX2: Double; aPaperY2: Double; aDevLeft: OleVariant; aDevTop: OleVariant; aDevRight: OleVariant; aDevBottom: OleVariant);
C, C++ | HRESULT sRectPaperToDevice(double aPaperX1, double aPaperY1, double aPaperX2, double aPaperY2, VARIANT* aDevLeft, VARIANT* aDevTop, VARIANT* aDevRight, VARIANT* aDevBottom);

Параметры

aPaperX1
aPaperY1
aPaperX2
aPaperY2
aDevLeft
aDevTop
aDevRight
aDevBottom


Объект IIngeoPicture

Описывает рисунок. Используется символьным методом отображения стиля.

Свойства

Свойство | Описание
Figures | Коллекция фигур рисунка.
X1 | Левая граница рисунка.
X2 | Правая граница рисунка.
Y1 | Верхняя граница рисунка.
Y2 | Нижняя граница рисунка.

Примечания

Границы рисунка задаются в метрах.

См.также

IIngeoSymbolPainter


Свойство Figures (Объект IIngeoPicture)

Коллекция фигур рисунка.

Синтаксис

Язык Описание
VBScript, JavaScript
Figures
Visual Basic
Property Figures As IInPictureFigures
Delphi
property Figures: IInPictureFigures
C, C++
HRESULT get_Figures(IInPictureFigures** Value);

См.также

IIngeoPicture, IInPictureFigures


Свойство X1 (Объект IIngeoPicture)

Левая граница рисунка.

Синтаксис

Язык Описание
VBScript, JavaScript
X1
Visual Basic
Property X1 As Double
Delphi
property X1: Double
C, C++
HRESULT get_X1(double* Value);
HRESULT set_X1(double Value);

См.также

IIngeoPicture


Свойство X2 (Объект IIngeoPicture)

Правая граница рисунка.

Синтаксис

Язык Описание
VBScript, JavaScript
X2
Visual Basic
Property X2 As Double
Delphi
property X2: Double
C, C++
HRESULT get_X2(double* Value);
HRESULT set_X2(double Value);

См.также

IIngeoPicture


Свойство Y1 (Объект IIngeoPicture)

Верхняя граница рисунка.

Синтаксис

Язык Описание
VBScript, JavaScript
Y1
Visual Basic
Property Y1 As Double
Delphi
property Y1: Double
C, C++
HRESULT get_Y1(double* Value);
HRESULT set_Y1(double Value);

См.также

IIngeoPicture


Свойство Y2 (Объект IIngeoPicture)

Нижняя граница рисунка.

Синтаксис

Язык Описание
VBScript, JavaScript
Y2
Visual Basic
Property Y2 As Double
Delphi
property Y2: Double
C, C++
HRESULT get_Y2(double* Value);
HRESULT set_Y2(double Value);

См.также

IIngeoPicture


Объект IIngeoPlugin

Не реализовано.

Свойства

Свойство Описание
ModuleCount
Modules


Свойство ModuleCount (Объект IIngeoPlugin)

Синтаксис

Язык Описание
VBScript, JavaScript
ModuleCount
Visual Basic
Property ModuleCount As Long
Delphi
property ModuleCount: Longint
C, C++
HRESULT get_ModuleCount(long* Value);


Свойство Modules (Объект IIngeoPlugin)

Синтаксис

Язык Описание
VBScript, JavaScript
Modules(anIndex)
Visual Basic
Property Modules(ByVal anIndex As Long) As IIngeoModule
Delphi
property Modules[anIndex: Longint]: IIngeoModule
C, C++
HRESULT get_Modules(long anIndex, IIngeoModule** Value);

Параметры

anIndex


Объект IIngeoProject

Объект IIngeoProject представляет собой проект.

Свойства

Свойство | Описание
AC | Права доступа.
Area | Территория, к которой принадлежит проект.
Contents | Список карт, включенных в проект.
ID | Внутренний идентификатор проекта.
Modified | Признак измения значений свойств проекта.
Name | Название проекта.

Методы

Метод | Описание
Delete | Удаление проекта.
DropChanges | Отмена внесенных изменений.
Update | Сохранение внесенных изменений свойств проекта в базу данных.


Свойство AC (Объект IIngeoProject)

Права доступа.

Синтаксис

Язык Описание
VBScript, JavaScript
AC
Visual Basic
Property AC As IIngeoAC
Delphi
property AC: IIngeoAC
C, C++
HRESULT get_AC(IIngeoAC** Value);

См.также

Список прав


Свойство Area (Объект IIngeoProject)

Территория, к которой принадлежит проект.

Синтаксис

Язык Описание
VBScript, JavaScript
Area
Visual Basic
Property Area As IIngeoArea
Delphi
property Area: IIngeoArea
C, C++
HRESULT get_Area(IIngeoArea** Value);


Объект IIngeoProjectContents

Объект ProjectContents представляет собой список идентификаторов карт, которые включены в проект.

Свойства

Свойство | Описание
Count | Количество карт, включенных в проект.
Item | Получение идентификатора карты по индексу.
_NewEnum | Служебный метод: возвращает перечислитель коллекции списка.

Методы

Метод | Описание
Add | Добавление карты.
Contains | Возвращает True, если карта с указанным идентификатором присутствует в списке, иначе возвращает False.
Remove


Свойство _NewEnum (Объект IIngeoProjectContents)

Служебный метод: возвращает перечислитель коллекции списка.

Синтаксис

Язык Описание
VBScript, JavaScript
_NewEnum
Visual Basic
Property _NewEnum As Object
Delphi
property _NewEnum: IUnknown
C, C++
HRESULT get__NewEnum(IUnknown* Value);


Метод Add (Объект IIngeoProjectContents)

Добавление карты.

Синтаксис

Язык | Описание
VBScript, JavaScript | SubAdd(aMapID)
Visual Basic | Sub Add(ByVal aMapID As String)
Delphi | procedure Add(const aMapID: WideString);
C, C++ | HRESULT Add(BSTR aMapID);

Параметры

aMapID
Идентификатор объекта карты.


Метод Contains (Объект IIngeoProjectContents)

Возвращает True, если карта с указанным идентификатором присутствует в списке, иначе возвращает False.

Синтаксис

Язык | Описание
VBScript, JavaScript | FunctionContains(aMapID)
Visual Basic | Function Contains(ByVal aMapID As String) As Boolean
Delphi | function Contains(const aMapID: WideString): WordBool;
C, C++ | HRESULT Contains(BSTR aMapID, VARIANT_BOOL* Value);

Параметры

aMapID
Идентификатор карты.

Пример

Dim ProjectContents

Dim MapCount, theMapID

Set ProjectContents = Application.ActiveDb.Areas.Item(0).Projects.Item(0).Contents

MapCount = ProjectContents.Count

theMapID = ProjectContents.Item(MapCount-1)

MsgBox "Сейчас карта " & theMapID & " будет удалена из территории."

ProjectContents.Remove theMapID

if   ProjectContents.Contains(theMapID)  then

   MsgBox "Карта " & theMapID & " прнадлежит территории."

else

   MsgBox "Карта " & theMapID & " не прнадлежит территории."

end if

MsgBox "Сейчас карта " & theMapID & " будет добавлена в территорию."

ProjectContents.Add theMapID

if  ProjectContents.Contains(theMapID)  then

   MsgBox "Карта " & theMapID & " прнадлежит территории."

else

   MsgBox "Карта " & theMapID & " не прнадлежит территории."

end if


Свойство Count (Объект IIngeoProjectContents)

Количество карт, включенных в проект.

Синтаксис

Язык Описание
VBScript, JavaScript
Count
Visual Basic
Property Count As Long
Delphi
property Count: Longint
C, C++
HRESULT get_Count(long* Value);


Свойство Item (Объект IIngeoProjectContents)

Получение идентификатора карты по индексу.

Синтаксис

Язык Описание
VBScript, JavaScript
Item(anIndex)
Visual Basic
Property Item(ByVal anIndex As Long) As String
Delphi
property Item[anIndex: Longint]: WideString
C, C++
HRESULT get_Item(long anIndex, BSTR* Value);

Параметры

anIndex
Индекс карты.

Возвращаемое значение

Возвращает идентификатор карты.


Метод Remove (Объект IIngeoProjectContents)

Синтаксис

Язык | Описание
VBScript, JavaScript | SubRemove(aMapID)
Visual Basic | Sub Remove(ByVal aMapID As String)
Delphi | procedure Remove(const aMapID: WideString);
C, C++ | HRESULT Remove(BSTR aMapID);

Параметры

aMapID
Идентификатор удаляемой карты.

Пример

Dim ProjectContents

Dim MapCount, theMapID

Set ProjectContents = Application.ActiveDb.Areas.Item(0).Projects.Item(0).Contents

MapCount = ProjectContents.Count

theMapID = ProjectContents.Item(MapCount-1)

MsgBox "Сейчас карта " & theMapID & " будет удалена из территории."

 ProjectContents.Remove theMapID

if ProjectContents.Contains(theMapID) then

   MsgBox "Карта " & theMapID & " прнадлежит территории."

else

   MsgBox "Карта " & theMapID & " не прнадлежит территории."

end if

MsgBox "Сейчас карта " & theMapID & " будет добавлена в территорию."

ProjectContents.Add theMapID

if ProjectContents.Contains(theMapID) then

   MsgBox "Карта " & theMapID & " прнадлежит территории."

else

   MsgBox "Карта " & theMapID & " не прнадлежит территории."

end if


Метод Delete (Объект IIngeoProject)

Удаление проекта.

Синтаксис

Язык | Описание
VBScript, JavaScript | SubDelete()
Visual Basic | Sub Delete()
Delphi | procedure Delete;
C, C++ | HRESULT Delete();


Метод DropChanges (Объект IIngeoProject)

Отмена внесенных изменений.

Синтаксис

Язык | Описание
VBScript, JavaScript | SubDropChanges()
Visual Basic | Sub DropChanges()
Delphi | procedure DropChanges;
C, C++ | HRESULT DropChanges();


Свойство ID (Объект IIngeoProject)

Внутренний идентификатор проекта.

Синтаксис

Язык Описание
VBScript, JavaScript
ID
Visual Basic
Property ID As String
Delphi
property ID: WideString
C, C++
HRESULT get_ID(BSTR* Value);


Объект IIngeoProjection

Проекция мировых координат в условные бумажные координаты.

Свойства

Свойство | Описание
YMirror | Признак переворота оси Y относительно оси X при выполнении проекции.
ZoomScale | Средний масштаб проекции.

Методы

Метод | Описание
ProjectBounds | Преобразование ограничивающего прямоугольника из мировой системы координат в систему координат бумажной проекции.
ProjectContour | Преобразование контура из мировой системы координат в систему координат бумажной проекции.
ProjectPoint | Преобразование координат точки из мировых координат в координаты бумажной проекции.
sProjectBounds Преобразование ограничивающего прямоугольника из мировой системы координат в систему координат бумажной проекции.
Скриптовая версия.
sProjectPoint Преобразование координат точки из мировых координат в координаты бумажной проекции.
Скриптовая версия.
sUnprojectBounds Преобразование ограничивающего прямоугольника из системы координат бумажной проекции в мировую систему координат.
Скриптовая версия.
sUnprojectPoint Преобразование координат точки из бумажной проекции в мировые координаты.
Скриптовая версия.
UnprojectBounds | Преобразование ограничивающего прямоугольника из системы координат бумажной проекции в мировую систему координат.
UnprojectContour | Преобразование контура из системы координат бумажной проекции в мировую.
UnprojectPoint | Преобразование координат точки из бумажной проекции в мировые координаты.


Метод ProjectBounds (Объект IIngeoProjection)

Преобразование ограничивающего прямоугольника из мировой системы координат в систему координат бумажной проекции.

Синтаксис

Язык | Описание
VBScript, JavaScript | SubProjectBounds(aWorldX1, aWorldY1, aWorldX2, aWorldY2, aPaperX1, aPaperY1, aPaperX2, aPaperY2)
Visual Basic | Sub ProjectBounds(ByVal aWorldX1 As Double, ByVal aWorldY1 As Double, ByVal aWorldX2 As Double, ByVal aWorldY2 As Double, ByVal aPaperX1 As Double, ByVal aPaperY1 As Double, ByVal aPaperX2 As Double, ByVal aPaperY2 As Double)
Delphi | procedure ProjectBounds(aWorldX1: Double; aWorldY1: Double; aWorldX2: Double; aWorldY2: Double; aPaperX1: Double; aPaperY1: Double; aPaperX2: Double; aPaperY2: Double);
C, C++ | HRESULT ProjectBounds(double aWorldX1, double aWorldY1, double aWorldX2, double aWorldY2, double* aPaperX1, double* aPaperY1, double* aPaperX2, double* aPaperY2);

Параметры

aWorldX1
Исходная минимальная координата по оси X
aWorldY1
Исходная минимальная координата по оси Y
aWorldX2
Исходная максимальная координата по оси X
aWorldY2
Исходная максимальная координата по оси Y
aPaperX1
Преобразованная минимальная координата по оси X
aPaperY1
Преобразованная минимальная координата по оси Y
aPaperX2
Преобразованная максимальная координата по оси X
aPaperY2
Преобразованная максимальная координата по оси Y


Метод ProjectContour (Объект IIngeoProjection)

Преобразование контура из мировой системы координат в систему координат бумажной проекции.

Синтаксис

Язык | Описание
VBScript, JavaScript | SubProjectContour(aWorld, aPaper)
Visual Basic | Sub ProjectContour(ByVal aWorld As IIngeoContour, ByVal aPaper As IIngeoContour)
Delphi | procedure ProjectContour(aWorld: IIngeoContour; aPaper: IIngeoContour);
C, C++ | HRESULT ProjectContour(IIngeoContour* aWorld, IIngeoContour* aPaper);

Параметры

aWorld
Исходный контур.
aPaper
Преобразованный контур.


Метод ProjectPoint (Объект IIngeoProjection)

Преобразование координат точки из мировых координат в координаты бумажной проекции.

Синтаксис

Язык | Описание
VBScript, JavaScript | SubProjectPoint(aWorldX, aWorldY, aPaperX, aPaperY)
Visual Basic | Sub ProjectPoint(ByVal aWorldX As Double, ByVal aWorldY As Double, ByVal aPaperX As Double, ByVal aPaperY As Double)
Delphi | procedure ProjectPoint(aWorldX: Double; aWorldY: Double; aPaperX: Double; aPaperY: Double);
C, C++ | HRESULT ProjectPoint(double aWorldX, double aWorldY, double* aPaperX, double* aPaperY);

Параметры

aWorldX
Исходная координата X.
aWorldY
Исходная координата Y.
aPaperX
Преобразованная координата X
aPaperY
Преобразованная координата Y.


Метод sProjectBounds (Объект IIngeoProjection)

Преобразование ограничивающего прямоугольника из мировой системы координат в систему координат бумажной проекции.
Скриптовая версия.

Синтаксис

Язык | Описание
VBScript, JavaScript | SubsProjectBounds(aWorldX1, aWorldY1, aWorldX2, aWorldY2, aPaperX1, aPaperY1, aPaperX2, aPaperY2)
Visual Basic | Sub sProjectBounds(ByVal aWorldX1 As Double, ByVal aWorldY1 As Double, ByVal aWorldX2 As Double, ByVal aWorldY2 As Double, ByVal aPaperX1 As Variant, ByVal aPaperY1 As Variant, ByVal aPaperX2 As Variant, ByVal aPaperY2 As Variant)
Delphi | procedure sProjectBounds(aWorldX1: Double; aWorldY1: Double; aWorldX2: Double; aWorldY2: Double; aPaperX1: OleVariant; aPaperY1: OleVariant; aPaperX2: OleVariant; aPaperY2: OleVariant);
C, C++ | HRESULT sProjectBounds(double aWorldX1, double aWorldY1, double aWorldX2, double aWorldY2, VARIANT* aPaperX1, VARIANT* aPaperY1, VARIANT* aPaperX2, VARIANT* aPaperY2);

Параметры

aWorldX1
aWorldY1
aWorldX2
aWorldY2
aPaperX1
aPaperY1
aPaperX2
aPaperY2


Метод sProjectPoint (Объект IIngeoProjection)

Преобразование координат точки из мировых координат в координаты бумажной проекции.
Скриптовая версия.

Синтаксис

Язык | Описание
VBScript, JavaScript | SubsProjectPoint(aWorldX, aWorldY, aPaperX, aPaperY)
Visual Basic | Sub sProjectPoint(ByVal aWorldX As Double, ByVal aWorldY As Double, ByVal aPaperX As Variant, ByVal aPaperY As Variant)
Delphi | procedure sProjectPoint(aWorldX: Double; aWorldY: Double; aPaperX: OleVariant; aPaperY: OleVariant);
C, C++ | HRESULT sProjectPoint(double aWorldX, double aWorldY, VARIANT* aPaperX, VARIANT* aPaperY);

Параметры

aWorldX
Исходная координата X
aWorldY
Исходная координата Y
aPaperX
Преобразованная координата X
aPaperY
Преобразованная координата Y.


Метод sUnprojectBounds (Объект IIngeoProjection)

Преобразование ограничивающего прямоугольника из системы координат бумажной проекции в мировую систему координат.
Скриптовая версия.

Синтаксис

Язык | Описание
VBScript, JavaScript | SubsUnprojectBounds(aPaperX1, aPaperY1, aPaperX2, aPaperY2, aWorldX1, aWorldY1, aWorldX2, aWorldY2)
Visual Basic | Sub sUnprojectBounds(ByVal aPaperX1 As Double, ByVal aPaperY1 As Double, ByVal aPaperX2 As Double, ByVal aPaperY2 As Double, ByVal aWorldX1 As Variant, ByVal aWorldY1 As Variant, ByVal aWorldX2 As Variant, ByVal aWorldY2 As Variant)
Delphi | procedure sUnprojectBounds(aPaperX1: Double; aPaperY1: Double; aPaperX2: Double; aPaperY2: Double; aWorldX1: OleVariant; aWorldY1: OleVariant; aWorldX2: OleVariant; aWorldY2: OleVariant);
C, C++ | HRESULT sUnprojectBounds(double aPaperX1, double aPaperY1, double aPaperX2, double aPaperY2, VARIANT* aWorldX1, VARIANT* aWorldY1, VARIANT* aWorldX2, VARIANT* aWorldY2);

Параметры

aPaperX1
aPaperY1
aPaperX2
aPaperY2
aWorldX1
aWorldY1
aWorldX2
aWorldY2


Метод sUnprojectPoint (Объект IIngeoProjection)

Преобразование координат точки из бумажной проекции в мировые координаты.
Скриптовая версия.

Синтаксис

Язык | Описание
VBScript, JavaScript | SubsUnprojectPoint(aPaperX, aPaperY, aWorldX, aWorldY)
Visual Basic | Sub sUnprojectPoint(ByVal aPaperX As Double, ByVal aPaperY As Double, ByVal aWorldX As Variant, ByVal aWorldY As Variant)
Delphi | procedure sUnprojectPoint(aPaperX: Double; aPaperY: Double; aWorldX: OleVariant; aWorldY: OleVariant);
C, C++ | HRESULT sUnprojectPoint(double aPaperX, double aPaperY, VARIANT* aWorldX, VARIANT* aWorldY);

Параметры

aPaperX
Исходная координата X
aPaperY
Исходная координата Y
aWorldX
Преобразованная координата X
aWorldY
Преобразованная координата Y.


Метод UnprojectBounds (Объект IIngeoProjection)

Преобразование ограничивающего прямоугольника из системы координат бумажной проекции в мировую систему координат.

Синтаксис

Язык | Описание
VBScript, JavaScript | SubUnprojectBounds(aPaperX1, aPaperY1, aPaperX2, aPaperY2, aWorldX1, aWorldY1, aWorldX2, aWorldY2)
Visual Basic | Sub UnprojectBounds(ByVal aPaperX1 As Double, ByVal aPaperY1 As Double, ByVal aPaperX2 As Double, ByVal aPaperY2 As Double, ByVal aWorldX1 As Double, ByVal aWorldY1 As Double, ByVal aWorldX2 As Double, ByVal aWorldY2 As Double)
Delphi | procedure UnprojectBounds(aPaperX1: Double; aPaperY1: Double; aPaperX2: Double; aPaperY2: Double; aWorldX1: Double; aWorldY1: Double; aWorldX2: Double; aWorldY2: Double);
C, C++ | HRESULT UnprojectBounds(double aPaperX1, double aPaperY1, double aPaperX2, double aPaperY2, double* aWorldX1, double* aWorldY1, double* aWorldX2, double* aWorldY2);

Параметры

aPaperX1
Исходная минимальная координата по оси X
aPaperY1
Исходная минимальная координата по оси Y
aPaperX2
Исходная максимальная координата по оси X
aPaperY2
Исходная максимальная координата по оси Y
aWorldX1
Преобразованная минимальная координата по оси X
aWorldY1
Преобразованная минимальная координата по оси Y
aWorldX2
Преобразованная максимальная координата по оси X
aWorldY2
Преобразованная максимальная координата по оси Y


Метод UnprojectContour (Объект IIngeoProjection)

Преобразование контура из системы координат бумажной проекции в мировую.

Синтаксис

Язык | Описание
VBScript, JavaScript | SubUnprojectContour(aPaper, aWorld)
Visual Basic | Sub UnprojectContour(ByVal aPaper As IIngeoContour, ByVal aWorld As IIngeoContour)
Delphi | procedure UnprojectContour(aPaper: IIngeoContour; aWorld: IIngeoContour);
C, C++ | HRESULT UnprojectContour(IIngeoContour* aPaper, IIngeoContour* aWorld);

Параметры

aPaper
Исходный контур.
aWorld
Преобразованный контур.


Метод UnprojectPoint (Объект IIngeoProjection)

Преобразование координат точки из бумажной проекции в мировые координаты.

Синтаксис

Язык | Описание
VBScript, JavaScript | SubUnprojectPoint(aPaperX, aPaperY, aWorldX, aWorldY)
Visual Basic | Sub UnprojectPoint(ByVal aPaperX As Double, ByVal aPaperY As Double, ByVal aWorldX As Double, ByVal aWorldY As Double)
Delphi | procedure UnprojectPoint(aPaperX: Double; aPaperY: Double; aWorldX: Double; aWorldY: Double);
C, C++ | HRESULT UnprojectPoint(double aPaperX, double aPaperY, double* aWorldX, double* aWorldY);

Параметры

aPaperX
Исходная координата X
aPaperY
Исходная координата Y
aWorldX
Преобразованная координата X
aWorldY
Преобразованная координата Y


Свойство YMirror (Объект IIngeoProjection)

Признак переворота оси Y относительно оси X при выполнении проекции.

Синтаксис

Язык Описание
VBScript, JavaScript
YMirror
Visual Basic
Property YMirror As Boolean
Delphi
property YMirror: WordBool
C, C++
HRESULT get_YMirror(VARIANT_BOOL* Value);


Свойство ZoomScale (Объект IIngeoProjection)

Средний масштаб проекции.

Синтаксис

Язык Описание
VBScript, JavaScript
ZoomScale
Visual Basic
Property ZoomScale As Double
Delphi
property ZoomScale: Double
C, C++
HRESULT get_ZoomScale(double* Value);


Свойство Modified (Объект IIngeoProject)

Признак измения значений свойств проекта.

Синтаксис

Язык Описание
VBScript, JavaScript
Modified
Visual Basic
Property Modified As Boolean
Delphi
property Modified: WordBool
C, C++
HRESULT get_Modified(VARIANT_BOOL* Value);

Примечания

Изменения свойств проекта будут внесены в базу данных только после вызова метода Update IIngeoProject.


Свойство Name (Объект IIngeoProject)

Название проекта.

Синтаксис

Язык Описание
VBScript, JavaScript
Name
Visual Basic
Property Name As String
Delphi
property Name: WideString
C, C++
HRESULT get_Name(BSTR* Value);
HRESULT set_Name(BSTR Value);


Объект IIngeoProjects

Объект IIngeoProjects представляет собой список проектов.

Свойства

Свойство | Описание
Count | Количество проектов.
Item | Получение проекта по индексу.
_NewEnum | Служебный метод: возвращает перечислитель коллекции списка.

Методы

Метод | Описание
Add | Добавление проекта.
AddWithID | Добавление проекта с указанным идентификатором.

См.также

IIngeoProject


Свойство _NewEnum (Объект IIngeoProjects)

Служебный метод: возвращает перечислитель коллекции списка.

Синтаксис

Язык Описание
VBScript, JavaScript
_NewEnum
Visual Basic
Property _NewEnum As Object
Delphi
property _NewEnum: IUnknown
C, C++
HRESULT get__NewEnum(IUnknown* Value);


Метод Add (Объект IIngeoProjects)

Добавление проекта.

Синтаксис

Язык | Описание
VBScript, JavaScript | FunctionAdd()
Visual Basic | Function Add() As IIngeoProject
Delphi | function Add: IIngeoProject;
C, C++ | HRESULT Add(IIngeoProject** Value);

Примечания

Новый проект будет добавлен в базу данных только после вызова метода Update IIngeoProject.


Метод AddWithID (Объект IIngeoProjects)

Добавление проекта с указанным идентификатором.

Синтаксис

Язык | Описание
VBScript, JavaScript | FunctionAddWithID(anID)
Visual Basic | Function AddWithID(ByVal anID As String) As IIngeoProject
Delphi | function AddWithID(const anID: WideString): IIngeoProject;
C, C++ | HRESULT AddWithID(BSTR anID, IIngeoProject** Value);

Параметры

anID
Идентификатор добавляемого проекта.

Примечания

Новый проект будет добавлен в базу данных только после вызова метода Update IIngeoProject.


Свойство Count (Объект IIngeoProjects)

Количество проектов.

Синтаксис

Язык Описание
VBScript, JavaScript
Count
Visual Basic
Property Count As Long
Delphi
property Count: Longint
C, C++
HRESULT get_Count(long* Value);


Свойство Item (Объект IIngeoProjects)

Получение проекта по индексу.

Синтаксис

Язык Описание
VBScript, JavaScript
Item(anIndex)
Visual Basic
Property Item(ByVal anIndex As Long) As IIngeoProject
Delphi
property Item[anIndex: Longint]: IIngeoProject
C, C++
HRESULT get_Item(long anIndex, IIngeoProject** Value);

Параметры

anIndex
Index проекта (диапазон от 0 до Count - 1)

Возвращаемое значение

Возвращает объект проекта.

См.также

IIngeoProject


Метод Update (Объект IIngeoProject)

Сохранение внесенных изменений свойств проекта в базу данных.

Синтаксис

Язык | Описание
VBScript, JavaScript | SubUpdate()
Visual Basic | Sub Update()
Delphi | procedure Update;
C, C++ | HRESULT Update();


Объект IIngeoProjectView

Объект для управления текущим проектом.

Свойства

Свойство | Описание
ActiveLayerView | Активное представление слоя в данный момент.
ActiveMapView | Активное представленние карты в данный момент.
MapViews | Список представлений карт, включенных в проект.
Project | Проект.
SelectedLayerView | Выделенное представление слоя в данный момент в окне карт и слоев.
SelectedMapView | Выделенное представление карты в данный момент в окне карт и слоев.
SelectedStyleView

Методы

Метод | Описание
FindLayerView | Поиск объекта представления слоя.
FindMapView | Поиск объекта представления карты.
FindStyleView
MakeImageFile | Формирование файла с изображением карты.


Свойство ActiveLayerView (Объект IIngeoProjectView)

Активное представление слоя в данный момент.

Синтаксис

Язык Описание
VBScript, JavaScript
ActiveLayerView
Visual Basic
Property ActiveLayerView As IIngeoLayerView
Delphi
property ActiveLayerView: IIngeoLayerView
C, C++
HRESULT get_ActiveLayerView(IIngeoLayerView** Value);
HRESULT set_ActiveLayerView(IIngeoLayerView* Value);


Свойство ActiveMapView (Объект IIngeoProjectView)

Активное представленние карты в данный момент.

Синтаксис

Язык Описание
VBScript, JavaScript
ActiveMapView
Visual Basic
Property ActiveMapView As IIngeoMapView
Delphi
property ActiveMapView: IIngeoMapView
C, C++
HRESULT get_ActiveMapView(IIngeoMapView** Value);
HRESULT set_ActiveMapView(IIngeoMapView* Value);


Метод FindLayerView (Объект IIngeoProjectView)

Поиск объекта представления слоя.

Синтаксис

Язык | Описание
VBScript, JavaScript | FunctionFindLayerView(aLayerID)
Visual Basic | Function FindLayerView(ByVal aLayerID As String) As IIngeoLayerView
Delphi | function FindLayerView(const aLayerID: WideString): IIngeoLayerView;
C, C++ | HRESULT FindLayerView(BSTR aLayerID, IIngeoLayerView** Value);

Параметры

aLayerID
Идентификатор объекта.


Метод FindMapView (Объект IIngeoProjectView)

Поиск объекта представления карты.

Синтаксис

Язык | Описание
VBScript, JavaScript | FunctionFindMapView(aMapID)
Visual Basic | Function FindMapView(ByVal aMapID As String) As IIngeoMapView
Delphi | function FindMapView(const aMapID: WideString): IIngeoMapView;
C, C++ | HRESULT FindMapView(BSTR aMapID, IIngeoMapView** Value);

Параметры

aMapID
Идентификатор объекта.


Метод FindStyleView (Объект IIngeoProjectView)

Синтаксис

Язык | Описание
VBScript, JavaScript | FunctionFindStyleView(StyleID)
Visual Basic | Function FindStyleView(ByVal StyleID As String) As IIngeoStyleView
Delphi | function FindStyleView(const StyleID: WideString): IIngeoStyleView;
C, C++ | HRESULT FindStyleView(BSTR StyleID, IIngeoStyleView** Value);

Параметры

StyleID


Метод MakeImageFile (Объект IIngeoProjectView)

Формирование файла с изображением карты.

Синтаксис

Язык | Описание
VBScript, JavaScript | SubMakeImageFile(aResX, aResY, aSizeX, aSizeY, aCenterX, aCenterY, aScale, aXAngle, aYMirror, aBkColor, aFileName)
Visual Basic | Sub MakeImageFile(ByVal aResX As Long, ByVal aResY As Long, ByVal aSizeX As Long, ByVal aSizeY As Long, ByVal aCenterX As Double, ByVal aCenterY As Double, ByVal aScale As Double, ByVal aXAngle As Double, ByVal aYMirror As Boolean, ByVal aBkColor As Long, ByVal aFileName As String)
Delphi | procedure MakeImageFile(aResX: Longint; aResY: Longint; aSizeX: Longint; aSizeY: Longint; aCenterX: Double; aCenterY: Double; aScale: Double; aXAngle: Double; aYMirror: WordBool; aBkColor: Longint; const aFileName: WideString);
C, C++ | HRESULT MakeImageFile(long aResX, long aResY, long aSizeX, long aSizeY, double aCenterX, double aCenterY, double aScale, double aXAngle, VARIANT_BOOL aYMirror, long aBkColor, BSTR aFileName);

Параметры

aResX
Разрешение растра в точках на дюйм по оси X.
aResY
Разрешение растра в точках на дюйм по оси Y.
aSizeX
Размер растра в точках по оси X.
aSizeY
Размер растра в точках по оси Y.
aCenterX
Координата точки по Х территории, которая будет располагаться в центре растра.
aCenterY
Координата точки по Y территории, которая будет располагаться в центре растра.
aScale
Масштаб, в котором должна быть нарисована карта. Н-р, если вы хотите нарисовать карту в масштабе 1:5000, то необходимо задавать 1/5000 =....
aXAngle
Угол поворота между горизонталью и осью Х в градусах.
aYMirror
Признак, что ось Y повернута относительно оси X.
aBkColor
Цвет фона растра.
aFileName
Название растрового файла. Файл может быть с расширением bmp, jpg, gif, emf.

Примечания

Установка разрешения в 0 приведет к тому, что будет использовано текущее экранное разрешение.
По умолчанию используется текущее экранное разрешение.

Для jpeg файлов в имени файла можно указать дополнительные параметры для управления качеством сжатия и используемой цветовой схемой.
Параметры передаются в формате, аналогичном формату HTTPRequest.

Допускаются следующие параметры:

Имя Описание
QUALITY Влияет на качество сжатия.
Задается целым числом, в диапазоне от 1 до 100 (100 - максимальное качество).
Значение по умолчанию равно 90.
GRAYSCALE Признак того, что изображение будет сохранено в оттенках серого.
Задается булевским значением (true или false).
Значение по умолчанию равно false.

Пример

Пример имени Jpeg файла с параметрами:

"FileName.jpg?QUALITY=50&GRAYSCALE=True"


Свойство MapViews (Объект IIngeoProjectView)

Список представлений карт, включенных в проект.

Синтаксис

Язык Описание
VBScript, JavaScript
MapViews
Visual Basic
Property MapViews As IIngeoMapViews
Delphi
property MapViews: IIngeoMapViews
C, C++
HRESULT get_MapViews(IIngeoMapViews** Value);


Свойство Project (Объект IIngeoProjectView)

Проект.

Синтаксис

Язык Описание
VBScript, JavaScript
Project
Visual Basic
Property Project As IIngeoProject
Delphi
property Project: IIngeoProject
C, C++
HRESULT get_Project(IIngeoProject** Value);


Свойство SelectedLayerView (Объект IIngeoProjectView)

Выделенное представление слоя в данный момент в окне карт и слоев.

Синтаксис

Язык Описание
VBScript, JavaScript
SelectedLayerView
Visual Basic
Property SelectedLayerView As IIngeoLayerView
Delphi
property SelectedLayerView: IIngeoLayerView
C, C++
HRESULT get_SelectedLayerView(IIngeoLayerView** Value);
HRESULT set_SelectedLayerView(IIngeoLayerView* Value);


Свойство SelectedMapView (Объект IIngeoProjectView)

Выделенное представление карты в данный момент в окне карт и слоев.

Синтаксис

Язык Описание
VBScript, JavaScript
SelectedMapView
Visual Basic
Property SelectedMapView As IIngeoMapView
Delphi
property SelectedMapView: IIngeoMapView
C, C++
HRESULT get_SelectedMapView(IIngeoMapView** Value);
HRESULT set_SelectedMapView(IIngeoMapView* Value);


Свойство SelectedStyleView (Объект IIngeoProjectView)

Синтаксис

Язык Описание
VBScript, JavaScript
SelectedStyleView
Visual Basic
Property SelectedStyleView As IIngeoStyleView
Delphi
property SelectedStyleView: IIngeoStyleView
C, C++
HRESULT get_SelectedStyleView(IIngeoStyleView** Value);
HRESULT set_SelectedStyleView(IIngeoStyleView* Value);


Объект IIngeoRasterMap

Объект IIngeoRasterMap(IIngeoMap)

Объект RasterMap представляет собой растровую карту.

Свойства

Свойство | Наследуется от | Описание
AC | IIngeoMap | Права доступа.
Area | IIngeoMap | Территория, к которй принадлежит карта.
CellDivX | Количество подпланшетов по оси X.
CellDivY | Количество подпланшетов по оси Y.
CellNumStartX | Начало нумерации по оси X.
CellNumStartY | Начало нумерации по оси Y.
CellNumStepX | Шаг нумерации по оси X.
CellNumStepY | Шаг нумерации по оси Y.
CellSizeX | Размеры планшета по оси X.
CellSizeY | Размеры планшета по оси Y.
Color | Цвет растровой карты.
ID | IIngeoMap | Внутренний идентификатор карты.
MapType | IIngeoMap | Тип карты (растровая или векторная).
Modified | IIngeoMap | Признак измения значений свойств карты.
Name | IIngeoMap | Название карты.
OffsetX | Смещение нулевого планшета по оси X.
OffsetY | Смещение нулевого планшета по оси Y.
VisibleMax | IIngeoMap | Максимальный диапазон видимости.
VisibleMin | IIngeoMap | Минимальный диапазон видимости.

Методы

Метод | Наследуется от | Описание
Delete | IIngeoMap | Удаление карты.
DropChanges | IIngeoMap | Отмена внесенных изменений.
Update | IIngeoMap | Сохранение внесенных изменений свойств карты в базу данных.

См.также

IIngeoArea, IIngeoMap


Свойство CellDivX (Объект IIngeoRasterMap)

Количество подпланшетов по оси X.

Синтаксис

Язык Описание
VBScript, JavaScript
CellDivX
Visual Basic
Property CellDivX As Long
Delphi
property CellDivX: Longint
C, C++
HRESULT get_CellDivX(long* Value);
HRESULT set_CellDivX(long Value);


Свойство CellDivY (Объект IIngeoRasterMap)

Количество подпланшетов по оси Y.

Синтаксис

Язык Описание
VBScript, JavaScript
CellDivY
Visual Basic
Property CellDivY As Long
Delphi
property CellDivY: Longint
C, C++
HRESULT get_CellDivY(long* Value);
HRESULT set_CellDivY(long Value);


Свойство CellNumStartX (Объект IIngeoRasterMap)

Начало нумерации по оси X.

Синтаксис

Язык Описание
VBScript, JavaScript
CellNumStartX
Visual Basic
Property CellNumStartX As Long
Delphi
property CellNumStartX: Longint
C, C++
HRESULT get_CellNumStartX(long* Value);
HRESULT set_CellNumStartX(long Value);


Свойство CellNumStartY (Объект IIngeoRasterMap)

Начало нумерации по оси Y.

Синтаксис

Язык Описание
VBScript, JavaScript
CellNumStartY
Visual Basic
Property CellNumStartY As Long
Delphi
property CellNumStartY: Longint
C, C++
HRESULT get_CellNumStartY(long* Value);
HRESULT set_CellNumStartY(long Value);


Свойство CellNumStepX (Объект IIngeoRasterMap)

Шаг нумерации по оси X.

Синтаксис

Язык Описание
VBScript, JavaScript
CellNumStepX
Visual Basic
Property CellNumStepX As Long
Delphi
property CellNumStepX: Longint
C, C++
HRESULT get_CellNumStepX(long* Value);
HRESULT set_CellNumStepX(long Value);


Свойство CellNumStepY (Объект IIngeoRasterMap)

Шаг нумерации по оси Y.

Синтаксис

Язык Описание
VBScript, JavaScript
CellNumStepY
Visual Basic
Property CellNumStepY As Long
Delphi
property CellNumStepY: Longint
C, C++
HRESULT get_CellNumStepY(long* Value);
HRESULT set_CellNumStepY(long Value);


Свойство CellSizeX (Объект IIngeoRasterMap)

Размеры планшета по оси X.

Синтаксис

Язык Описание
VBScript, JavaScript
CellSizeX
Visual Basic
Property CellSizeX As Double
Delphi
property CellSizeX: Double
C, C++
HRESULT get_CellSizeX(double* Value);
HRESULT set_CellSizeX(double Value);


Свойство CellSizeY (Объект IIngeoRasterMap)

Размеры планшета по оси Y.

Синтаксис

Язык Описание
VBScript, JavaScript
CellSizeY
Visual Basic
Property CellSizeY As Double
Delphi
property CellSizeY: Double
C, C++
HRESULT get_CellSizeY(double* Value);
HRESULT set_CellSizeY(double Value);


Свойство Color (Объект IIngeoRasterMap)

Цвет растровой карты.

Синтаксис

Язык Описание
VBScript, JavaScript
Color
Visual Basic
Property Color As Long
Delphi
property Color: Longint
C, C++
HRESULT get_Color(long* Value);
HRESULT set_Color(long Value);


Свойство OffsetX (Объект IIngeoRasterMap)

Смещение нулевого планшета по оси X.

Синтаксис

Язык Описание
VBScript, JavaScript
OffsetX
Visual Basic
Property OffsetX As Double
Delphi
property OffsetX: Double
C, C++
HRESULT get_OffsetX(double* Value);
HRESULT set_OffsetX(double Value);


Свойство OffsetY (Объект IIngeoRasterMap)

Смещение нулевого планшета по оси Y.

Синтаксис

Язык Описание
VBScript, JavaScript
OffsetY
Visual Basic
Property OffsetY As Double
Delphi
property OffsetY: Double
C, C++
HRESULT get_OffsetY(double* Value);
HRESULT set_OffsetY(double Value);


Объект IIngeoRefBook

Описывает справочник.

Изменения в структуре таблицы справочника применяются не сразу, а только после вызова метода Update.

Свойства

Свойство | Описание
AC | Права доступа к справочнику.
ID | Идентификатор справочника.
Modified | Указывает призводились ли изменения в структуре таблицы справочника.
Name | Логическое имя справочника.
SemDbTable | Через этот объект осуществляется работа с данными справочника.
SemDbTableName | Физическое имя таблицы справочника.

Методы

Метод | Описание
Delete | Удаляет справочник.
DropChanges | Отменяет изменения, сделанные в структуре таблицы справочника.
Update | Применяет изменения, сделанные в структуре таблицы справочника.

См.также

IIngeoRefBooks, IIngeoDb


Свойство AC (Объект IIngeoRefBook)

Права доступа к справочнику.

Синтаксис

Язык Описание
VBScript, JavaScript
AC
Visual Basic
Property AC As IIngeoAC
Delphi
property AC: IIngeoAC
C, C++
HRESULT get_AC(IIngeoAC** Value);

См.также

IIngeoAC, Список прав


Метод Delete (Объект IIngeoRefBook)

Удаляет справочник. Таблица справочника остается.

Синтаксис

Язык | Описание
VBScript, JavaScript | SubDelete()
Visual Basic | Sub Delete()
Delphi | procedure Delete;
C, C++ | HRESULT Delete();

См.также

IIngeoRefBook


Метод DropChanges (Объект IIngeoRefBook)

Отменяет изменения, сделанные в структуре таблицы справочника.

Синтаксис

Язык | Описание
VBScript, JavaScript | SubDropChanges()
Visual Basic | Sub DropChanges()
Delphi | procedure DropChanges;
C, C++ | HRESULT DropChanges();

См.также

IIngeoRefBook


Свойство ID (Объект IIngeoRefBook)

Идентификатор справочника.

Синтаксис

Язык Описание
VBScript, JavaScript
ID
Visual Basic
Property ID As String
Delphi
property ID: WideString
C, C++
HRESULT get_ID(BSTR* Value);

См.также

IIngeoRefBook


Свойство Modified (Объект IIngeoRefBook)

Указывает призводились ли изменения в структуре таблицы справочника.

Возвращает True, если структура таблицы была изменена. Иначе - False.

Синтаксис

Язык Описание
VBScript, JavaScript
Modified
Visual Basic
Property Modified As Boolean
Delphi
property Modified: WordBool
C, C++
HRESULT get_Modified(VARIANT_BOOL* Value);

См.также

IIngeoRefBook


Свойство Name (Объект IIngeoRefBook)

Логическое имя справочника. Используется для удобного именования справочника для пользователя.

Синтаксис

Язык Описание
VBScript, JavaScript
Name
Visual Basic
Property Name As String
Delphi
property Name: WideString
C, C++
HRESULT get_Name(BSTR* Value);
HRESULT set_Name(BSTR Value);

См.также

IIngeoRefBook


Объект IIngeoRefBooks

Коллекция описаний справочников.

Свойства

Свойство | Описание
Count | Количество описаний справочников.
Item | Возвращает описание справочника.
_NewEnum | Возвращает перечислитель по элементам (описаниям справочников) коллекции.

Методы

Метод | Описание
Add | Добавляет в коллекцию описание нового справочника.
AddWithID | Добавляет в коллекцию описание нового справочника с указанным идентификатором.

См.также

IIngeoDb, IIngeoRefBook


Свойство _NewEnum (Объект IIngeoRefBooks)

Возвращает перечислитель по элементам (описаниям справочников) коллекции.

Синтаксис

Язык Описание
VBScript, JavaScript
_NewEnum
Visual Basic
Property _NewEnum As Object
Delphi
property _NewEnum: IUnknown
C, C++
HRESULT get__NewEnum(IUnknown* Value);

См.также

IIngeoRefBooks, IIngeoRefBook


Метод Add (Объект IIngeoRefBooks)

Добавляет в коллекцию описание нового справочника. Описание добавляется в конец коллекции.

Синтаксис

Язык | Описание
VBScript, JavaScript | FunctionAdd()
Visual Basic | Function Add() As IIngeoRefBook
Delphi | function Add: IIngeoRefBook;
C, C++ | HRESULT Add(IIngeoRefBook** Value);

Возвращаемое значение

Добавленное описание справочника.

См.также

IIngeoRefBooks, IIngeoRefBook


Метод AddWithID (Объект IIngeoRefBooks)

Добавляет в коллекцию описание нового справочника с указанным идентификатором.

Синтаксис

Язык | Описание
VBScript, JavaScript | FunctionAddWithID(anID)
Visual Basic | Function AddWithID(ByVal anID As String) As IIngeoRefBook
Delphi | function AddWithID(const anID: WideString): IIngeoRefBook;
C, C++ | HRESULT AddWithID(BSTR anID, IIngeoRefBook** Value);

Параметры

anID
Идентификатор добавляемого справочника.

Возвращаемое значение

Добавленное описание справочника.

См.также

IIngeoRefBooks, IIngeoRefBook


Свойство Count (Объект IIngeoRefBooks)

Количество описаний справочников.

Синтаксис

Язык Описание
VBScript, JavaScript
Count
Visual Basic
Property Count As Long
Delphi
property Count: Longint
C, C++
HRESULT get_Count(long* Value);

См.также

IIngeoRefBooks


Свойство SemDbTable (Объект IIngeoRefBook)

Через этот объект осуществляется работа с данными справочника.

Синтаксис

Язык Описание
VBScript, JavaScript
SemDbTable
Visual Basic
Property SemDbTable As IIngeoSemDbTable
Delphi
property SemDbTable: IIngeoSemDbTable
C, C++
HRESULT get_SemDbTable(IIngeoSemDbTable** Value);

См.также

IIngeoRefBook, IIngeoSemDbTable


Свойство SemDbTableName (Объект IIngeoRefBook)

Физическое имя таблицы справочника. Под этим именем хранится таблица в базе данных.

Синтаксис

Язык Описание
VBScript, JavaScript
SemDbTableName
Visual Basic
Property SemDbTableName As String
Delphi
property SemDbTableName: WideString
C, C++
HRESULT get_SemDbTableName(BSTR* Value);
HRESULT set_SemDbTableName(BSTR Value);

См.также

IIngeoRefBook


Свойство Item (Объект IIngeoRefBooks)

Возвращает описание справочника. Описание справочника задается по порядковому номеру.

Синтаксис

Язык Описание
VBScript, JavaScript
Item(anIndex)
Visual Basic
Property Item(ByVal anIndex As Long) As IIngeoRefBook
Delphi
property Item[anIndex: Longint]: IIngeoRefBook
C, C++
HRESULT get_Item(long anIndex, IIngeoRefBook** Value);

Параметры

anIndex
Порядковый номер.

См.также

IIngeoRefBooks, IIngeoRefBook


Метод Update (Объект IIngeoRefBook)

Применяет изменения, сделанные в структуре таблицы справочника. Если таблица новая, то происходит ее физическое создание в базе данных.

Синтаксис

Язык | Описание
VBScript, JavaScript | SubUpdate()
Visual Basic | Sub Update()
Delphi | procedure Update;
C, C++ | HRESULT Update();

См.также

IIngeoRefBook


Объект IIngeoRole

Роль, которую могут играть пользователи.

Свойства

Свойство | Описание
Description | Описание роли.
ID | Идентификатор роли.
Modified | Характеристики роли были изменены.
Name | Имя роли.
UserIDs | Коллекция пользователей, которые играют эту роль.

Методы

Метод | Описание
Delete | Удаляет роль.
DropChanges | Отменяет сделанные изменения.
Update | Применяет сделанные изменения.

См.также

IIngeoRoles, IIngeoDb, IIngeoUser


Метод Delete (Объект IIngeoRole)

Удаляет роль.

Синтаксис

Язык | Описание
VBScript, JavaScript | SubDelete()
Visual Basic | Sub Delete()
Delphi | procedure Delete;
C, C++ | HRESULT Delete();

См.также

IIngeoRole


Свойство Description (Объект IIngeoRole)

Описание роли.

Синтаксис

Язык Описание
VBScript, JavaScript
Description
Visual Basic
Property Description As String
Delphi
property Description: WideString
C, C++
HRESULT get_Description(BSTR* Value);
HRESULT set_Description(BSTR Value);

См.также

IIngeoRole


Метод DropChanges (Объект IIngeoRole)

Отменяет сделанные изменения.

Синтаксис

Язык | Описание
VBScript, JavaScript | SubDropChanges()
Visual Basic | Sub DropChanges()
Delphi | procedure DropChanges;
C, C++ | HRESULT DropChanges();

См.также

IIngeoRole


Свойство ID (Объект IIngeoRole)

Идентификатор роли.

Синтаксис

Язык Описание
VBScript, JavaScript
ID
Visual Basic
Property ID As String
Delphi
property ID: WideString
C, C++
HRESULT get_ID(BSTR* Value);

См.также

IIngeoRole


Свойство Modified (Объект IIngeoRole)

Характеристики роли были изменены.

Возвращает True, если характеристики роли были изменены, иначе - False.

Синтаксис

Язык Описание
VBScript, JavaScript
Modified
Visual Basic
Property Modified As Boolean
Delphi
property Modified: WordBool
C, C++
HRESULT get_Modified(VARIANT_BOOL* Value);

См.также

IIngeoRole


Свойство Name (Объект IIngeoRole)

Имя роли.

Синтаксис

Язык Описание
VBScript, JavaScript
Name
Visual Basic
Property Name As String
Delphi
property Name: WideString
C, C++
HRESULT get_Name(BSTR* Value);
HRESULT set_Name(BSTR Value);

См.также

IIngeoRole


Объект IIngeoRoles

Коллекция ролей.

Свойства

Свойство | Описание
Count | Количество ролей.
Item | Возвращает роль.
_NewEnum | Возвращает перечислитель по элементам (ролям) коллекции.

Методы

Метод | Описание
Add | Добавляет роль.
AddWithID | Добавляет роль с указанным идентификатором.
RoleFromID | Возвращает роль с данным идентификатором.

См.также

IIngeoDb, IIngeoRole


Свойство _NewEnum (Объект IIngeoRoles)

Возвращает перечислитель по элементам (ролям) коллекции.

Синтаксис

Язык Описание
VBScript, JavaScript
_NewEnum
Visual Basic
Property _NewEnum As Object
Delphi
property _NewEnum: IUnknown
C, C++
HRESULT get__NewEnum(IUnknown* Value);

См.также

IIngeoRoles, IIngeoRole


Метод Add (Объект IIngeoRoles)

Добавляет роль.

Синтаксис

Язык | Описание
VBScript, JavaScript | FunctionAdd()
Visual Basic | Function Add() As IIngeoRole
Delphi | function Add: IIngeoRole;
C, C++ | HRESULT Add(IIngeoRole** Value);

Возвращаемое значение

Добавленная роль.

См.также

IIngeoRoles, IIngeoRole


Метод AddWithID (Объект IIngeoRoles)

Добавляет роль с указанным идентификатором.

Синтаксис

Язык | Описание
VBScript, JavaScript | FunctionAddWithID(anID)
Visual Basic | Function AddWithID(ByVal anID As String) As IIngeoRole
Delphi | function AddWithID(const anID: WideString): IIngeoRole;
C, C++ | HRESULT AddWithID(BSTR anID, IIngeoRole** Value);

Параметры

anID
Идентификатор добавляемой роли.


Свойство Count (Объект IIngeoRoles)

Количество ролей.

Синтаксис

Язык Описание
VBScript, JavaScript
Count
Visual Basic
Property Count As Long
Delphi
property Count: Longint
C, C++
HRESULT get_Count(long* Value);

См.также

IIngeoRoles


Свойство Item (Объект IIngeoRoles)

Возвращает роль. Роль задается по порядковому номеру.

Синтаксис

Язык Описание
VBScript, JavaScript
Item(anIndex)
Visual Basic
Property Item(ByVal anIndex As Long) As IIngeoRole
Delphi
property Item[anIndex: Longint]: IIngeoRole
C, C++
HRESULT get_Item(long anIndex, IIngeoRole** Value);

Параметры

anIndex
Порядковый номер.

См.также

IIngeoRoles, IIngeoRole


Метод RoleFromID (Объект IIngeoRoles)

Возвращает роль с данным идентификатором.

Синтаксис

Язык | Описание
VBScript, JavaScript | FunctionRoleFromID(aRoleID)
Visual Basic | Function RoleFromID(ByVal aRoleID As String) As IIngeoRole
Delphi | function RoleFromID(const aRoleID: WideString): IIngeoRole;
C, C++ | HRESULT RoleFromID(BSTR aRoleID, IIngeoRole** Value);

Параметры

aRoleID
Идентификатор роли.

Возвращаемое значение

Роль.

См.также

IIngeoRoles, IIngeoRole


Метод Update (Объект IIngeoRole)

Применяет сделанные изменения.

Синтаксис

Язык | Описание
VBScript, JavaScript | SubUpdate()
Visual Basic | Sub Update()
Delphi | procedure Update;
C, C++ | HRESULT Update();

См.также

IIngeoRole


Свойство UserIDs (Объект IIngeoRole)

Коллекция пользователей, которые играют эту роль.

Синтаксис

Язык Описание
VBScript, JavaScript
UserIDs
Visual Basic
Property UserIDs As Variant
Delphi
property UserIDs: OleVariant
C, C++
HRESULT get_UserIDs(VARIANT* Value);
HRESULT set_UserIDs(VARIANT Value);

См.также

IIngeoRole, IIngeoIDList, IIngeoUser


Объект IIngeoSelection

Объект Selection предоставляет доступ к списку пространственных объектов, выделенных в данный момент в окне карты.

Свойства

Свойство | Описание
Count | Количество выделенных объектов.
IDs | Идентификаторы выделенных объектов.
ShapeIndexes | Номера выделенных форм.

Методы

Метод | Описание
BeginUpdate | Начать обновление списка выделенных объектов.
Deselect | Исключить из списка выделенных объектов.
DeselectAll | Очистить список выделенных объектов.
EndUpdate | Закончить обновление списка выделенных объектов.
IsSelected | Проверка наличия объекта в списке выделенных объектов.
Select | Добавить объект в список выделенных объектов.
SelectAlone | Выделить объект.

Примечания

Объект Selection можно получить используя свойство Selection объекта Application.


Метод BeginUpdate (Объект IIngeoSelection)

Начать обновление списка выделенных объектов.

Синтаксис

Язык | Описание
VBScript, JavaScript | SubBeginUpdate()
Visual Basic | Sub BeginUpdate()
Delphi | procedure BeginUpdate;
C, C++ | HRESULT BeginUpdate();


Свойство Count (Объект IIngeoSelection)

Количество выделенных объектов.

Синтаксис

Язык Описание
VBScript, JavaScript
Count
Visual Basic
Property Count As Long
Delphi
property Count: Longint
C, C++
HRESULT get_Count(long* Value);


Метод Deselect (Объект IIngeoSelection)

Исключить из списка выделенных объектов.

Синтаксис

Язык | Описание
VBScript, JavaScript | SubDeselect(anObjectID)
Visual Basic | Sub Deselect(ByVal anObjectID As String)
Delphi | procedure Deselect(const anObjectID: WideString);
C, C++ | HRESULT Deselect(BSTR anObjectID);

Параметры

anObjectID
Идентификатор пространственного объекта.


Метод DeselectAll (Объект IIngeoSelection)

Очистить список выделенных объектов.

Синтаксис

Язык | Описание
VBScript, JavaScript | SubDeselectAll()
Visual Basic | Sub DeselectAll()
Delphi | procedure DeselectAll;
C, C++ | HRESULT DeselectAll();


Метод EndUpdate (Объект IIngeoSelection)

Закончить обновление списка выделенных объектов.

Синтаксис

Язык | Описание
VBScript, JavaScript | SubEndUpdate()
Visual Basic | Sub EndUpdate()
Delphi | procedure EndUpdate;
C, C++ | HRESULT EndUpdate();


Свойство IDs (Объект IIngeoSelection)

Получение идентификаторов выделенных объектов.

Синтаксис

Язык Описание
VBScript, JavaScript
IDs(anIndex)
Visual Basic
Property IDs(ByVal anIndex As Long) As String
Delphi
property IDs[anIndex: Longint]: WideString
C, C++
HRESULT get_IDs(long anIndex, BSTR* Value);

Параметры

anIndex
Индекс индентификатора выделенного объекта.

Возвращаемое значение

Возвращает идентификатор выделенного объекта.


Метод IsSelected (Объект IIngeoSelection)

Проверка наличия объекта в списке выделенных объектов.

Синтаксис

Язык | Описание
VBScript, JavaScript | FunctionIsSelected(anObjectID)
Visual Basic | Function IsSelected(ByVal anObjectID As String) As Boolean
Delphi | function IsSelected(const anObjectID: WideString): WordBool;
C, C++ | HRESULT IsSelected(BSTR anObjectID, VARIANT_BOOL* Value);

Параметры

anObjectID
Идентификатор пространственного объекта.


Метод Select (Объект IIngeoSelection)

Добавить объект в список выделенных объектов.

Синтаксис

Язык | Описание
VBScript, JavaScript | SubSelect(anObjectID, aShapeIndex)
Visual Basic | Sub Select(ByVal anObjectID As String, ByVal aShapeIndex As Long)
Delphi | procedure Select(const anObjectID: WideString; aShapeIndex: Longint);
C, C++ | HRESULT Select(BSTR anObjectID, long aShapeIndex);

Параметры

anObjectID
Идентификатор пространственного объекта.
aShapeIndex
Порядковый номер контура пространственного объекта.
Если значение данного параметра "-1", то выделяется вся форма.

Примечания

При выделении объекта указывается не только его идентификатор, но и порядковый номер контура.


Метод SelectAlone (Объект IIngeoSelection)

Выделить объект.

Синтаксис

Язык | Описание
VBScript, JavaScript | SubSelectAlone(anObjectID, aShapeIndex)
Visual Basic | Sub SelectAlone(ByVal anObjectID As String, ByVal aShapeIndex As Long)
Delphi | procedure SelectAlone(const anObjectID: WideString; aShapeIndex: Longint);
C, C++ | HRESULT SelectAlone(BSTR anObjectID, long aShapeIndex);

Параметры

anObjectID
Идентификатор пространственного объекта.
aShapeIndex
Порядковый номер контура пространственного объекта.

Примечания

Перед выделением объекта список очищается.


Свойство ShapeIndexes (Объект IIngeoSelection)

Номера выделенных форм.

Синтаксис

Язык Описание
VBScript, JavaScript
ShapeIndexes(anIndex)
Visual Basic
Property ShapeIndexes(ByVal anIndex As Long) As Long
Delphi
property ShapeIndexes[anIndex: Longint]: Longint
C, C++
HRESULT get_ShapeIndexes(long anIndex, long* Value);

Параметры

anIndex
Индекс индентификатора выделенной формы.


Объект IIngeoSemData

Обеспечивает доступ к семантическим данным пространственного объекта.

Методы

Метод | Описание
AddRec | Добавляет запись в таблицу.
AddRecWithID | Добавляет в таблицу запись c указанным идентификатором.
DeleteRec | Удаляет запись из таблицы.
GetDisplayText | Возвращает значение поля таблицы в формате для показа пользователю.
GetRecCount | Возвращает количество записей в таблице.
GetValue | Возвращает значение поля таблицы.
SetValue | Присваивает значение полю таблицы.

См.также

IIngeoMapObject


Метод AddRec (Объект IIngeoSemData)

Добавляет запись в таблицу.

Синтаксис

Язык | Описание
VBScript, JavaScript | FunctionAddRec(aTableName)
Visual Basic | Function AddRec(ByVal aTableName As String) As Long
Delphi | function AddRec(const aTableName: WideString): Longint;
C, C++ | HRESULT AddRec(BSTR aTableName, long* Value);

Параметры

aTableName
Имя таблицы, в которую добавляется запись.

Возвращаемое значение

Номер добавленной записи.

Примечания

Используется только для таблиц типа "Один ко многим".
Вызов метода для таблицы "Один к одному" вызовет исключительную ситуацию.

См.также

IIngeoSemData


Метод AddRecWithID (Объект IIngeoSemData)

Добавляет в таблицу запись c указанным идентификатором.

Синтаксис

Язык | Описание
VBScript, JavaScript | FunctionAddRecWithID(aTableName, aRecID)
Visual Basic | Function AddRecWithID(ByVal aTableName As String, ByVal aRecID As String) As Long
Delphi | function AddRecWithID(const aTableName: WideString; const aRecID: WideString): Longint;
C, C++ | HRESULT AddRecWithID(BSTR aTableName, BSTR aRecID, long* Value);

Параметры

aTableName
Имя таблицы.
aRecID
Идентификатор семантической таблицы (поле "SIMID").

Возвращаемое значение

Номер добавленной записи.

Примечания

Используется только для таблиц типа "Один ко многим".
Вызов метода для таблицы "Один к одному" вызовет исключительную ситуацию.

См.также

IIngeoSemData


Метод DeleteRec (Объект IIngeoSemData)

Удаляет запись из таблицы.

Синтаксис

Язык | Описание
VBScript, JavaScript | SubDeleteRec(aTableName, aRec)
Visual Basic | Sub DeleteRec(ByVal aTableName As String, ByVal aRec As Long)
Delphi | procedure DeleteRec(const aTableName: WideString; aRec: Longint);
C, C++ | HRESULT DeleteRec(BSTR aTableName, long aRec);

Параметры

aTableName
Имя таблицы.
aRec
Номер записи таблицы.

См.также

IIngeoSemData


Метод GetDisplayText (Объект IIngeoSemData)

Возвращает значение поля таблицы в формате для показа пользователю. Для справочного поля возвращаются значения отображаемых полей.

Синтаксис

Язык | Описание
VBScript, JavaScript | FunctionGetDisplayText(aTableName, aFieldName, aRec)
Visual Basic | Function GetDisplayText(ByVal aTableName As String, ByVal aFieldName As String, ByVal aRec As Long) As String
Delphi | const function GetDisplayText(const aTableName: WideString; const aFieldName: WideString; aRec: Longint): WideString;
C, C++ | HRESULT GetDisplayText(BSTR aTableName, BSTR aFieldName, long aRec, BSTR* Value);

Параметры

aTableName
Имя таблицы.
aFieldName
Имя поля.
aRec
Номер записи таблицы.

Возвращаемое значение

Значение поля таблицы.

См.также

IIngeoSemData


Метод GetRecCount (Объект IIngeoSemData)

Возвращает количество записей в таблице.

Синтаксис

Язык | Описание
VBScript, JavaScript | FunctionGetRecCount(aTableName)
Visual Basic | Function GetRecCount(ByVal aTableName As String) As Long
Delphi | function GetRecCount(const aTableName: WideString): Longint;
C, C++ | HRESULT GetRecCount(BSTR aTableName, long* Value);

Параметры

aTableName
Имя таблицы.

См.также

IIngeoSemData


Метод GetValue (Объект IIngeoSemData)

Возвращает значение поля таблицы. Для справочного поля возвращается значение ключевого поля.

Синтаксис

Язык | Описание
VBScript, JavaScript | FunctionGetValue(aTableName, aFieldName, aRec)
Visual Basic | Function GetValue(ByVal aTableName As String, ByVal aFieldName As String, ByVal aRec As Long) As Variant
Delphi | function GetValue(const aTableName: WideString; const aFieldName: WideString; aRec: Longint): OleVariant;
C, C++ | HRESULT GetValue(BSTR aTableName, BSTR aFieldName, long aRec, VARIANT* Value);

Параметры

aTableName
Имя таблицы.
aFieldName
Имя поля.
aRec
Номер записи таблицы.

Возвращаемое значение

Значение поля таблицы.

См.также

IIngeoSemData


Метод SetValue (Объект IIngeoSemData)

Присваивает значение полю таблицы.

Синтаксис

Язык | Описание
VBScript, JavaScript | SubSetValue(aTableName, aFieldName, aValue, aRec)
Visual Basic | Sub SetValue(ByVal aTableName As String, ByVal aFieldName As String, ByVal aValue As Variant, ByVal aRec As Long)
Delphi | procedure SetValue(const aTableName: WideString; const aFieldName: WideString; aValue: OleVariant; aRec: Longint);
C, C++ | HRESULT SetValue(BSTR aTableName, BSTR aFieldName, VARIANT aValue, long aRec);

Параметры

aTableName
Имя таблицы.
aFieldName
Имя поля.
aValue
Значение.
aRec
Номер записи таблицы.

См.также

IIngeoSemData


Объект IIngeoSemDbDataSet

Через этот объект передаются данные реляционных таблиц.

Данные хранятся в виде набора записей. Навигация по записям осуществляется с помощью соответствующих методов объекта.

Свойства

Свойство | Описание
BOF | Была ли попытка выйти за начало набора записей.
EOF | Была ли попытка выйти за конец набора записей.
Fields | Коллекция полей таблицы.

Методы

Метод | Описание
Close Закрывает набор и освобождаетиспользуемые ресурсы.
После вызова этого метода, вызов любого другого метода объекта, либо доступ к его полям приведет к исключительной ситуации.
MoveFirst | Осуществляет переход на первую запись.
MoveLast | Осуществляет переход на последнюю запись.
MoveNext | Осуществляет переход на следующую запись.
MovePrev | Осуществляет переход на предыдущую запись.

См.также

IIngeoSemDbTable


Свойство BOF (Объект IIngeoSemDbDataSet)

Была ли попытка выйти за начало набора записей.

Синтаксис

Язык Описание
VBScript, JavaScript
BOF
Visual Basic
Property BOF As Boolean
Delphi
property BOF: WordBool
C, C++
HRESULT get_BOF(VARIANT_BOOL* Value);

См.также

IIngeoSemDbDataSet, EOF


Метод Close (Объект IIngeoSemDbDataSet)

Закрывает набор и освобождаетиспользуемые ресурсы.
После вызова этого метода, вызов любого другого метода объекта, либо доступ к его полям приведет к исключительной ситуации.

Синтаксис

Язык | Описание
VBScript, JavaScript | SubClose()
Visual Basic | Sub Close()
Delphi | procedure Close;
C, C++ | HRESULT Close();


Свойство EOF (Объект IIngeoSemDbDataSet)

Была ли попытка выйти за конец набора записей.

Синтаксис

Язык Описание
VBScript, JavaScript
EOF
Visual Basic
Property EOF As Boolean
Delphi
property EOF: WordBool
C, C++
HRESULT get_EOF(VARIANT_BOOL* Value);

См.также

IIngeoSemDbDataSet, BOF


Свойство Fields (Объект IIngeoSemDbDataSet)

Коллекция полей таблицы. Через нее осуществляется доступ к данным полей.

Синтаксис

Язык Описание
VBScript, JavaScript
Fields
Visual Basic
Property Fields As IIngeoSemDbValues
Delphi
property Fields: IIngeoSemDbValues
C, C++
HRESULT get_Fields(IIngeoSemDbValues** Value);

См.также

IIngeoSemDbDataSet, IIngeoSemDbValues


Метод MoveFirst (Объект IIngeoSemDbDataSet)

Осуществляет переход на первую запись. Устанавливает признак BOF в True.

Синтаксис

Язык | Описание
VBScript, JavaScript | SubMoveFirst()
Visual Basic | Sub MoveFirst()
Delphi | procedure MoveFirst;
C, C++ | HRESULT MoveFirst();

См.также

IIngeoSemDbDataSet, MoveLast, MoveNext, MovePrev


Метод MoveLast (Объект IIngeoSemDbDataSet)

Осуществляет переход на последнюю запись. Устанавливает признак EOF в True.

Синтаксис

Язык | Описание
VBScript, JavaScript | SubMoveLast()
Visual Basic | Sub MoveLast()
Delphi | procedure MoveLast;
C, C++ | HRESULT MoveLast();

См.также

IIngeoSemDbDataSet, MoveFirst, MoveNext, MovePrev


Метод MoveNext (Объект IIngeoSemDbDataSet)

Осуществляет переход на следующую запись. Устанавливает признак EOF в True, если уже находимся на последней записи.

Синтаксис

Язык | Описание
VBScript, JavaScript | SubMoveNext()
Visual Basic | Sub MoveNext()
Delphi | procedure MoveNext;
C, C++ | HRESULT MoveNext();

См.также

IIngeoSemDbDataSet, MoveFirst, MoveLast, MovePrev


Метод MovePrev (Объект IIngeoSemDbDataSet)

Осуществляет переход на предыдущую запись. Устанавливает признак BOF в True, если уже находимся на первой записи.

Синтаксис

Язык | Описание
VBScript, JavaScript | SubMovePrev()
Visual Basic | Sub MovePrev()
Delphi | procedure MovePrev;
C, C++ | HRESULT MovePrev();

См.также

IIngeoSemDbDataSet, MoveFirst, MoveLast, MoveNext


Объект IIngeoSemDbField

Описывает поле таблицы.

Свойства

Свойство | Описание
DataSize | Для соответствующих типов полей задает размерность.
DataType | Тип поля.
Flags | Атрибуты поля.
Name | Имя поля.
Precision | Для соответствующих типов полей задает точность.

Методы

Метод | Описание
Delete | Удаляет поле из коллекции полей таблицы, которой оно принадлежит.

См.также

IIngeoSemDbFields, IIngeoSemDbTable


Свойство DataSize (Объект IIngeoSemDbField)

Для соответствующих типов полей задает размерность.

Синтаксис

Язык Описание
VBScript, JavaScript
DataSize
Visual Basic
Property DataSize As Long
Delphi
property DataSize: Longint
C, C++
HRESULT get_DataSize(long* Value);
HRESULT set_DataSize(long Value);

См.также

IIngeoSemDbField, TIngeoFieldDataType


Свойство DataType (Объект IIngeoSemDbField)

Тип поля.

Синтаксис

Язык Описание
VBScript, JavaScript
DataType
Visual Basic
Property DataType As TIngeoFieldDataType
Delphi
property DataType: TIngeoFieldDataType
C, C++
HRESULT get_DataType(TIngeoFieldDataType* Value);
HRESULT set_DataType(TIngeoFieldDataType Value);

См.также

IIngeoSemDbField, TIngeoFieldDataType


Метод Delete (Объект IIngeoSemDbField)

Удаляет поле из коллекции полей таблицы, которой оно принадлежит.

Синтаксис

Язык | Описание
VBScript, JavaScript | SubDelete()
Visual Basic | Sub Delete()
Delphi | procedure Delete;
C, C++ | HRESULT Delete();

См.также

IIngeoSemDbField


Свойство Flags (Объект IIngeoSemDbField)

Атрибуты поля.

Синтаксис

Язык Описание
VBScript, JavaScript
Flags
Visual Basic
Property Flags As TIngeoFieldFlags
Delphi
property Flags: TIngeoFieldFlags
C, C++
HRESULT get_Flags(TIngeoFieldFlags* Value);
HRESULT set_Flags(TIngeoFieldFlags Value);

См.также

IIngeoSemDbField, TIngeoFieldFlags


Свойство Name (Объект IIngeoSemDbField)

Имя поля.

Синтаксис

Язык Описание
VBScript, JavaScript
Name
Visual Basic
Property Name As String
Delphi
property Name: WideString
C, C++
HRESULT get_Name(BSTR* Value);
HRESULT set_Name(BSTR Value);

См.также

IIngeoSemDbField


Свойство Precision (Объект IIngeoSemDbField)

Для соответствующих типов полей задает точность.

Синтаксис

Язык Описание
VBScript, JavaScript
Precision
Visual Basic
Property Precision As Long
Delphi
property Precision: Longint
C, C++
HRESULT get_Precision(long* Value);
HRESULT set_Precision(long Value);

См.также

IIngeoSemDbField, TIngeoFieldDataType


Объект IIngeoSemDbFields

Коллекция полей таблицы.

Свойства

Свойство | Описание
Count | Количество полей в коллекции.
Item | Возвращает поле таблицы.
_NewEnum | Возвращает перечислитель по элементам (полям) коллекции.

Методы

Метод | Описание
Add | Добавляет в коллекцию новое поле.

См.также

IIngeoSemDbTable, IIngeoSemDbField


Свойство _NewEnum (Объект IIngeoSemDbFields)

Возвращает перечислитель по элементам (полям) коллекции.

Синтаксис

Язык Описание
VBScript, JavaScript
_NewEnum
Visual Basic
Property _NewEnum As Object
Delphi
property _NewEnum: IUnknown
C, C++
HRESULT get__NewEnum(IUnknown* Value);

См.также

IIngeoSemDbFields


Метод Add (Объект IIngeoSemDbFields)

Добавляет в коллекцию новое поле. Поле добавляется в конец коллекции.

Синтаксис

Язык | Описание
VBScript, JavaScript | FunctionAdd(aName, aDataType, aDataSize, aFlags, aPrecision)
Visual Basic | Function Add(ByVal aName As String, ByVal aDataType As TIngeoFieldDataType, ByVal aDataSize As Long, ByVal aFlags As TIngeoFieldFlags, ByVal aPrecision As Long) As IIngeoSemDbField
Delphi | function Add(const aName: WideString; aDataType: TIngeoFieldDataType; aDataSize: Longint; aFlags: TIngeoFieldFlags; aPrecision: Longint): IIngeoSemDbField;
C, C++ | HRESULT Add(BSTR aName, TIngeoFieldDataType aDataType, long aDataSize, TIngeoFieldFlags aFlags, long aPrecision, IIngeoSemDbField** Value);

Параметры

aName
Имя поля.
aDataType
Тип поля.
aDataSize
Размерность поля.
aFlags
Атрибуты поля.
aPrecision
Точность поля.

Возвращаемое значение

Добавленное поле таблицы.

См.также

IIngeoSemDbFields, IIngeoSemDbField


Свойство Count (Объект IIngeoSemDbFields)

Количество полей в коллекции.

Синтаксис

Язык Описание
VBScript, JavaScript
Count
Visual Basic
Property Count As Long
Delphi
property Count: Longint
C, C++
HRESULT get_Count(long* Value);

См.также

IIngeoSemDbFields


Свойство Item (Объект IIngeoSemDbFields)

Возвращает поле таблицы. Поле задается либо по порядковому номеру, либо по имени.

Синтаксис

Язык Описание
VBScript, JavaScript
Item(anIndex)
Visual Basic
Property Item(ByVal anIndex As Variant) As IIngeoSemDbField
Delphi
property Item[anIndex: OleVariant]: IIngeoSemDbField
C, C++
HRESULT get_Item(VARIANT anIndex, IIngeoSemDbField** Value);

Параметры

anIndex
Порядковый номер или имя поля.

См.также

IIngeoSemDbFields, IIngeoSemDbField


Объект IIngeoSemDbIndex

Описывает индекс таблицы.

Свойства

Свойство | Описание
Fields | Поля из которых состоит индекс.
Flags | Атрибуты индекса.
Name | Имя индекса.

Методы

Метод | Описание
Delete | Удаляет индекс из коллекции индексов таблицы, которой он принадлежит.

Примечания

Если в индекс входят несколько полей, то в поле Fields они представлены в виде строки состоящей из имен полей разделенных символом ';'.

См.также

IIngeoSemDbIndexes, IIngeoSemDbTable


Метод Delete (Объект IIngeoSemDbIndex)

Удаляет индекс из коллекции индексов таблицы, которой он принадлежит.

Синтаксис

Язык | Описание
VBScript, JavaScript | SubDelete()
Visual Basic | Sub Delete()
Delphi | procedure Delete;
C, C++ | HRESULT Delete();

См.также

IIngeoSemDbIndex


Объект IIngeoSemDbIndexes

Коллекция индексов таблицы.

Свойства

Свойство | Описание
Count | Количество индексов в коллекции.
Item | Возвращает индекс.
_NewEnum | Возвращает перечислитель по элементам (индексам) коллекции.

Методы

Метод | Описание
Add | Добавляет в коллекцию новый индекс.

См.также

IIngeoSemDbTable, IIngeoSemDbIndex


Свойство _NewEnum (Объект IIngeoSemDbIndexes)

Возвращает перечислитель по элементам (индексам) коллекции.

Синтаксис

Язык Описание
VBScript, JavaScript
_NewEnum
Visual Basic
Property _NewEnum As Object
Delphi
property _NewEnum: IUnknown
C, C++
HRESULT get__NewEnum(IUnknown* Value);

См.также

IIngeoSemDbIndexes


Метод Add (Объект IIngeoSemDbIndexes)

Добавляет в коллекцию новый индекс. Индекс добавляется в конец коллекции.

Синтаксис

Язык | Описание
VBScript, JavaScript | FunctionAdd(aName, aFields, aFlags)
Visual Basic | Function Add(ByVal aName As String, ByVal aFields As String, ByVal aFlags As TIngeoIndexFlags) As IIngeoSemDbIndex
Delphi | function Add(const aName: WideString; const aFields: WideString; aFlags: TIngeoIndexFlags): IIngeoSemDbIndex;
C, C++ | HRESULT Add(BSTR aName, BSTR aFields, TIngeoIndexFlags aFlags, IIngeoSemDbIndex** Value);

Параметры

aName
Имя индекса.
aFields
Поля, составляющие индекс. Перечислены через точку-запятую.
aFlags
Атрибуты индекса.

Возвращаемое значение

Добавленный индекс таблицы.

См.также

IIngeoSemDbIndexes, IIngeoSemDbIndex


Свойство Count (Объект IIngeoSemDbIndexes)

Количество индексов в коллекции.

Синтаксис

Язык Описание
VBScript, JavaScript
Count
Visual Basic
Property Count As Long
Delphi
property Count: Longint
C, C++
HRESULT get_Count(long* Value);

См.также

IIngeoSemDbIndexes


Свойство Item (Объект IIngeoSemDbIndexes)

Возвращает индекс. Индекс задается либо по порядковому номеру, либо по имени.

Синтаксис

Язык Описание
VBScript, JavaScript
Item(anIndex)
Visual Basic
Property Item(ByVal anIndex As Variant) As IIngeoSemDbIndex
Delphi
property Item[anIndex: OleVariant]: IIngeoSemDbIndex
C, C++
HRESULT get_Item(VARIANT anIndex, IIngeoSemDbIndex** Value);

Параметры

anIndex
Порядковый номер или имя индекса.

См.также

IIngeoSemDbIndexes, IIngeoSemDbIndex


Свойство Fields (Объект IIngeoSemDbIndex)

Поля из которых состоит индекс. Перечислены через точку-запятую.

Синтаксис

Язык Описание
VBScript, JavaScript
Fields
Visual Basic
Property Fields As String
Delphi
property Fields: WideString
C, C++
HRESULT get_Fields(BSTR* Value);
HRESULT set_Fields(BSTR Value);

См.также

IIngeoSemDbIndex


Свойство Flags (Объект IIngeoSemDbIndex)

Атрибуты индекса.

Синтаксис

Язык Описание
VBScript, JavaScript
Flags
Visual Basic
Property Flags As TIngeoIndexFlags
Delphi
property Flags: TIngeoIndexFlags
C, C++
HRESULT get_Flags(TIngeoIndexFlags* Value);
HRESULT set_Flags(TIngeoIndexFlags Value);

См.также

IIngeoSemDbIndex, TIngeoIndexFlags


Свойство Name (Объект IIngeoSemDbIndex)

Имя индекса.

Синтаксис

Язык Описание
VBScript, JavaScript
Name
Visual Basic
Property Name As String
Delphi
property Name: WideString
C, C++
HRESULT get_Name(BSTR* Value);
HRESULT set_Name(BSTR Value);

См.также

IIngeoSemDbIndex


Объект IIngeoSemDbTable

Предназначен для доступа к данным и структуре реляционной таблицы. Под структурой таблицы подразумеваются поля, индексы и физическое название таблицы. Через этот объект можно получать, изменять и удалять данные из таблицы.

С помощью этого объекта осуществляется доступ к любой таблице, находящейся в каталоге семантических таблиц базы данных. То есть работа производится напрямую с семантическими таблицами, справочниками и любыми другими таблицами.

Изменения в структуре таблицы применяются не сразу, а только после вызова метода Update.

Свойства

Свойство | Описание
Fields | Коллекция полей таблицы.
Indexes | Коллекция индексов таблицы.
Modified | Указывает призводились ли изменения в структуре таблицы.
TableName | Физическое название таблицы.

Методы

Метод | Описание
Delete | Удаляет таблицу.
DeleteData | Производит удаление данных из таблицы.
DropChanges | Отменяет изменения, сделанные в структуре таблицы.
InsertData | Добавляет данные (одну запись) в таблицу.
SelectData | Производит выборку данных из таблицы.
Update | Применяет изменения, сделанные в структуре таблицы.
UpdateData | Изменяет данные в таблице.

См.также

IIngeoSemDbTables, IIngeoDb, IIngeoSemTable, IIngeoRefBook


Метод Delete (Объект IIngeoSemDbTable)

Удаляет таблицу.

Синтаксис

Язык | Описание
VBScript, JavaScript | SubDelete()
Visual Basic | Sub Delete()
Delphi | procedure Delete;
C, C++ | HRESULT Delete();

См.также

IIngeoSemDbTable


Метод DeleteData (Объект IIngeoSemDbTable)

Производит удаление данных из таблицы.

Синтаксис

Язык | Описание
VBScript, JavaScript | SubDeleteData(aWhere, aParams)
Visual Basic | Sub DeleteData(ByVal aWhere As String, ByVal aParams As Variant)
Delphi | procedure DeleteData(const aWhere: WideString; aParams: OleVariant);
C, C++ | HRESULT DeleteData(BSTR aWhere, VARIANT aParams);

Параметры

aWhere
Задает условие отбора записей, которые будут удалены. Если необходимо удалить все записи, то надо передавать пустую строку. Если значение какого-либо параметра условия передается через aParams, то на его месте надо использовать символ ?.
aParams
Массив значений для aWhere. Порядок значений в массиве должен соответстовать порядку следования символов ? в aWhere.

Примечания

Будет выполнен следующий запрос следующего вида:
 'DELETE FROM ' + TableName + ' WHERE ' + aWhere,
  либо, если не задано условие отбора:
 'DELETE FROM ' + TableName

См.также

IIngeoSemDbTable


Метод DropChanges (Объект IIngeoSemDbTable)

Отменяет изменения, сделанные в структуре таблицы.

Синтаксис

Язык | Описание
VBScript, JavaScript | SubDropChanges()
Visual Basic | Sub DropChanges()
Delphi | procedure DropChanges;
C, C++ | HRESULT DropChanges();

См.также

IIngeoSemDbTable


Свойство Fields (Объект IIngeoSemDbTable)

Коллекция полей таблицы.

Синтаксис

Язык Описание
VBScript, JavaScript
Fields
Visual Basic
Property Fields As IIngeoSemDbFields
Delphi
property Fields: IIngeoSemDbFields
C, C++
HRESULT get_Fields(IIngeoSemDbFields** Value);

См.также

IIngeoSemDbTable, IIngeoSemDbFields


Свойство Indexes (Объект IIngeoSemDbTable)

Коллекция индексов таблицы.

Синтаксис

Язык Описание
VBScript, JavaScript
Indexes
Visual Basic
Property Indexes As IIngeoSemDbIndexes
Delphi
property Indexes: IIngeoSemDbIndexes
C, C++
HRESULT get_Indexes(IIngeoSemDbIndexes** Value);

См.также

IIngeoSemDbTable, IIngeoSemDbIndexes


Метод InsertData (Объект IIngeoSemDbTable)

Добавляет данные (одну запись) в таблицу.

Синтаксис

Язык | Описание
VBScript, JavaScript | SubInsertData(aFields, aValues, aParams)
Visual Basic | Sub InsertData(ByVal aFields As String, ByVal aValues As String, ByVal aParams As Variant)
Delphi | procedure InsertData(const aFields: WideString; const aValues: WideString; aParams: OleVariant);
C, C++ | HRESULT InsertData(BSTR aFields, BSTR aValues, VARIANT aParams);

Параметры

aFields
Задает поля, которым будут присвоены значения. Имена полей перечисляются через запятую и могут быть заключены в двойные кавычки.
aValues
Задает значения, которые присваиваются полям добавляемой записи. Количество значений должно соотвествовать количеству имен полей в параметре aFields. Если значение передается через aParams, то на его месте надо использовать символ ?.
aParams
Массив значений для aValues. Порядок значений в массиве должен соответстовать порядку следования символов ? в aValues.

Примечания

Будет выполнен следующий запрос следующего вида:
 'INSERT INTO ' + TableName + '( + aFields + ') VALUES (' + aValues +  ')'

См.также

IIngeoSemDbTable


Свойство Modified (Объект IIngeoSemDbTable)

Указывает призводились ли изменения в структуре таблицы.

Возвращает True, если структура таблицы была изменена. Иначе - False.

Синтаксис

Язык Описание
VBScript, JavaScript
Modified
Visual Basic
Property Modified As Boolean
Delphi
property Modified: WordBool
C, C++
HRESULT get_Modified(VARIANT_BOOL* Value);

См.также

IIngeoSemDbTable


Объект IIngeoSemDbTables

Коллекция таблиц, находящихся в семантическом каталоге базы данных ГИС.

С помощью этого объекта осуществляется доступ к любой таблице, находящейся в каталоге семантических таблиц базы данных. То есть работа производится напрямую с семантическими таблицами, справочниками и любыми другими таблицами.

Свойства

Свойство | Описание
Count | Количество таблиц.
Item | Возвращает таблицу.
_NewEnum | Возвращает перечислитель по элементам (таблицам) коллекции.

Методы

Метод | Описание
Add | Добавляет таблицу.
ExecSQL | Выполняет SQL запрос.
Exists | Определяет существует ли таблица с данным именем.

См.также

IIngeoDb, IIngeoSemDbTable


Свойство _NewEnum (Объект IIngeoSemDbTables)

Возвращает перечислитель по элементам (таблицам) коллекции.

Синтаксис

Язык Описание
VBScript, JavaScript
_NewEnum
Visual Basic
Property _NewEnum As Object
Delphi
property _NewEnum: IUnknown
C, C++
HRESULT get__NewEnum(IUnknown* Value);

См.также

IIngeoSemDbTables


Метод Add (Объект IIngeoSemDbTables)

Добавляет таблицу. Физически таблица сразу не создается. Сначала надо добавить поля и индексы в таблицу, а потом вызвать метод Update. В этот момент таблица будет создана физически.

Синтаксис

Язык | Описание
VBScript, JavaScript | FunctionAdd(aTableName)
Visual Basic | Function Add(ByVal aTableName As String) As IIngeoSemDbTable
Delphi | function Add(const aTableName: WideString): IIngeoSemDbTable;
C, C++ | HRESULT Add(BSTR aTableName, IIngeoSemDbTable** Value);

Параметры

aTableName
Имя таблицы.

См.также

IIngeoSemDbTables, IIngeoSemDbTable


Свойство Count (Объект IIngeoSemDbTables)

Количество таблиц.

Синтаксис

Язык Описание
VBScript, JavaScript
Count
Visual Basic
Property Count As Long
Delphi
property Count: Longint
C, C++
HRESULT get_Count(long* Value);

См.также

IIngeoSemDbTables


Метод SelectData (Объект IIngeoSemDbTable)

Производит выборку данных из таблицы.

Синтаксис

Язык | Описание
VBScript, JavaScript | FunctionSelectData(aFields, aWhere, aParams)
Visual Basic | Function SelectData(ByVal aFields As String, ByVal aWhere As String, ByVal aParams As Variant) As IIngeoSemDbDataSet
Delphi | function SelectData(const aFields: WideString; const aWhere: WideString; aParams: OleVariant): IIngeoSemDbDataSet;
C, C++ | HRESULT SelectData(BSTR aFields, BSTR aWhere, VARIANT aParams, IIngeoSemDbDataSet** Value);

Параметры

aFields
Задает поля, данные которых будут возвращены в результирующем наборе. Имена полей перечисляются через запятую и могут быть заключены в двойные кавычки. Если необходимо вернуть данные всех полей, то используется символ *.
aWhere
Задает условие отбора записей. Если необходимо вернуть все записи, то надо передавать пустую строку. Если значение какого-либо параметра условия передается через aParams, то на его месте надо использовать символ ?.
aParams
Массив значений для aWhere. Порядок значений в массиве должен соответстовать порядку следования символов ? в aWhere.

Возвращаемое значение

Набор из записей таблицы.

Примечания

Будет выполнен следующий запрос следующего вида:
 'SELECT ' + aFields + ' FROM ' + TableName + ' t WHERE ' + aWhere,
  либо, если не задано условие отбора:
 'SELECT ' + aFields + ' FROM ' + TableName + ' t'.

Пример

Задача 1:
В таблице с именем "Адрес_огнестойких", найти все дома с номером 10. Вернуть столбцы "Улица" и "Номер" таблицы.
option explicit

dim SemDbTable, QueryResults

set SemDbTable = ActiveDb.SemDbTables("Адрес_огнестойких")
set QueryResults = SemDbTable.SelectData("Улица, Номер", "Номер='10'", Null)
if QueryResults.EOF then
  msgbox "Не найдено ни одного дома с номером 10"
end if
Задача 2:
В таблице с именем "Дома_огнестойкие", найти все строки таблицы, поле "Подпись" которых начинается со строки заданной в некоторой переменной.
Вернуть все столбцы таблицы.
option explicit

function FindCaptionBeginFrom(Caption)
  dim SemDbTable
  set SemDbTable = ActiveDb.SemDbTables("Дома_огнестойкие")
  set FindCaptionBeginFrom = SemDbTable.SelectData("*", "Trim(Upper(Подпись)) like Upper(? + '%')", Array(Caption))
end function

dim QueryResults, Caption
Caption = "Маг"
set QueryResults = FindCaptionBeginFrom(Caption)
if QueryResults.EOF then
  msgbox "Не найдено ни одной строки поле 'Подпись' которых начинается со строки "  & Caption
end if

См.также

IIngeoSemDbTable, IIngeoSemDbDataSet


Метод ExecSQL (Объект IIngeoSemDbTables)

Выполняет SQL запрос.

Синтаксис

Язык | Описание
VBScript, JavaScript | FunctionExecSQL(aSQL, aParams, aParamTypes)
Visual Basic | Function ExecSQL(ByVal aSQL As String, ByVal aParams As Variant, ByVal aParamTypes As Variant) As IIngeoSemDbDataSet
Delphi | function ExecSQL(const aSQL: WideString; aParams: OleVariant; aParamTypes: OleVariant): IIngeoSemDbDataSet;
C, C++ | HRESULT ExecSQL(BSTR aSQL, VARIANT aParams, VARIANT aParamTypes, IIngeoSemDbDataSet** Value);

Параметры

aSQL
Текст SQL запроса.
aParams
Значения параметров, заданных в виде массива.
aParamTypes
Типы параметров.
Данный параметр может быть равен Null, в таком случае типы параметров определяются исходя из типов переменных переданных в aParams.

Возвращаемое значение

Набор из записей таблицы.

Примечания

В тексте SQL запроса рекомендуется, для большей совместимости с разными реляционными базами данных (РБД) , использовать полные имена полей, и заключать в кавычки имена таблиц и полей, используя в качестве "кавычек" квадратные скобки.
так запрос вида:

 SELECT Name, Date FROM MyTableName WHERE Number = 10
 лучше записать в виде:
 SELECT [Name], [Date] FROM [MyTableName] A WHERE A.[Number] = 10,
 либо:
 SELECT [MyTableName].[Name], [MyTableName].[Date] FROM [MyTableName] WHERE [MyTableName].[Number] = 10.
Перед выполнением запроса ГИС сама произведет необходимые подстановки, в соответствии с используемой РБД.


Метод Exists (Объект IIngeoSemDbTables)

Определяет существует ли таблица с данным именем.

Синтаксис

Язык | Описание
VBScript, JavaScript | FunctionExists(aTableName)
Visual Basic | Function Exists(ByVal aTableName As String) As Boolean
Delphi | function Exists(const aTableName: WideString): WordBool;
C, C++ | HRESULT Exists(BSTR aTableName, VARIANT_BOOL* Value);

Параметры

aTableName
Имя таблицы.

Возвращаемое значение

Возвращает True, если таблица существует, иначе - False.

См.также

IIngeoSemDbTables


Свойство Item (Объект IIngeoSemDbTables)

Возвращает таблицу. Таблица задается либо по порядковому номеру, либо по имени.

Синтаксис

Язык Описание
VBScript, JavaScript
Item(anIndex)
Visual Basic
Property Item(ByVal anIndex As Variant) As IIngeoSemDbTable
Delphi
property Item[anIndex: OleVariant]: IIngeoSemDbTable
C, C++
HRESULT get_Item(VARIANT anIndex, IIngeoSemDbTable** Value);

Параметры

anIndex
Порядковый номер или имя.

См.также

IIngeoSemDbTables, IIngeoSemDbTable


Свойство TableName (Объект IIngeoSemDbTable)

Физическое название таблицы.

Синтаксис

Язык Описание
VBScript, JavaScript
TableName
Visual Basic
Property TableName As String
Delphi
property TableName: WideString
C, C++
HRESULT get_TableName(BSTR* Value);
HRESULT set_TableName(BSTR Value);

См.также

IIngeoSemDbTable


Метод Update (Объект IIngeoSemDbTable)

Применяет изменения, сделанные в структуре таблицы. Если таблица новая, то происходит ее физическое создание в базе данных.

Синтаксис

Язык | Описание
VBScript, JavaScript | SubUpdate()
Visual Basic | Sub Update()
Delphi | procedure Update;
C, C++ | HRESULT Update();

См.также

IIngeoSemDbTable


Метод UpdateData (Объект IIngeoSemDbTable)

Изменяет данные в таблице.

Синтаксис

Язык | Описание
VBScript, JavaScript | SubUpdateData(aSet, aWhere, aParams)
Visual Basic | Sub UpdateData(ByVal aSet As String, ByVal aWhere As String, ByVal aParams As Variant)
Delphi | procedure UpdateData(const aSet: WideString; const aWhere: WideString; aParams: OleVariant);
C, C++ | HRESULT UpdateData(BSTR aSet, BSTR aWhere, VARIANT aParams);

Параметры

aSet
Через запятую перечисляются поля и их новые значения в формате: <имя поля> = <значение>. Имена полей могут быть заключены в двойные кавычки. Если какое-либо значение передается через aParams, то на его месте надо использовать символ ?.
aWhere
Задает условие отбора записей, которые будут изменяться. Если необходимо изменить все записи, то надо передавать пустую строку. Если значение какого-либо параметра условия передается через aParams, то на его месте надо использовать символ ?.
aParams
Массив значений для aSet и aWhere. Порядок значений в массиве должен соответстовать порядку следования символов ? сначала в aSet, потом в aWhere.

Примечания

Будет выполнен следующий запрос следующего вида:
 'UPDATE ' + TableName + ' SET ' + aSet + ' WHERE ' + aWhere,
  либо, если не задано условие отбора:
 'UPDATE ' + TableName + ' SET ' + aSet

Пример

Задача
Заполнить семантические данные из Excel-го файла
option explicit

const ExcelFileName = "C:\Test.xls"
const ExcelSheetName = "Лист1"
const ExcelRange = "A1:B10"

const SemTableID = "000100000438"
const SearchFieldName = "Кадастровый Номер"
const DataFieldName = "Владелец"

function GetExcelData
  dim  Excel, Wb, Sheet, Range

  set Excel = CreateObject("Excel.Application")
  set wb = Excel.Workbooks.Open(ExcelFileName)
  set sheet = Wb.sheets(ExcelSheetName)
  set range = Sheet.Range(ExcelRange)
  GetExcelData = Range.Value
  wb.close
  Excel.Quit
end function

sub FillDataFromExcel
  dim aTable, anExcelData, aSearchData, aData, aSetStr, aWhereStr, i

  set aTable = Application.ActiveDb.SemTableFromID(SemTableID).SemDbTable
  anExcelData = GetExcelData

  aSetStr = """" & aTable.TableName & """.""" & DataFieldName & """=?"
  aWhereStr = """" & aTable.TableName & """.""" & SearchFieldName & """=?"
  for i = LBound(anExcelData, 1) to UBound(anExcelData, 1)
    aSearchData = anExcelData(i, 1)
    aData = anExcelData(i, 2)
    aTable.UpdateData aSetStr, aWhereStr, Array(CStr(aData), CStr(aSearchData))
  next
  msgbox "Поля заполнены"
end sub

См.также

IIngeoSemDbTable


Объект IIngeoSemDbValue

Через этот объект осуществляется доступ к данным поля таблицы.

Свойства

Свойство | Описание
DisplayValue | Значение поля, отформатированное для показа пользователю.
Name | Имя поля.
Value | Значение поля.

См.также

IIngeoSemDbValues, IIngeoSemDbDataSet


Свойство DisplayValue (Объект IIngeoSemDbValue)

Значение поля, отформатированное для показа пользователю. У справочного поля возвращаются значения отображаемых полей справочника.

Синтаксис

Язык Описание
VBScript, JavaScript
DisplayValue
Visual Basic
Property DisplayValue As String
Delphi
property DisplayValue: WideString
C, C++
HRESULT get_DisplayValue(BSTR* Value);

См.также

IIngeoSemDbValue


Свойство Name (Объект IIngeoSemDbValue)

Имя поля.

Синтаксис

Язык Описание
VBScript, JavaScript
Name
Visual Basic
Property Name As String
Delphi
property Name: WideString
C, C++
HRESULT get_Name(BSTR* Value);

См.также

IIngeoSemDbValue


Объект IIngeoSemDbValues

Коллекция, предназначенная для доступа к значениям полей таблицы.

Свойства

Свойство | Описание
Count | Количество полей.
Item | Возвращает объект, через который осуществляется доступ к данных поля.
_NewEnum | Возвращает перечислитель по элементам (значениям полей) коллекции.

См.также

IIngeoSemDbDataSet, IIngeoSemDbValue


Свойство _NewEnum (Объект IIngeoSemDbValues)

Возвращает перечислитель по элементам (значениям полей) коллекции.

Синтаксис

Язык Описание
VBScript, JavaScript
_NewEnum
Visual Basic
Property _NewEnum As Object
Delphi
property _NewEnum: IUnknown
C, C++
HRESULT get__NewEnum(IUnknown* Value);

См.также

IIngeoSemDbValues


Свойство Count (Объект IIngeoSemDbValues)

Количество полей.

Синтаксис

Язык Описание
VBScript, JavaScript
Count
Visual Basic
Property Count As Long
Delphi
property Count: Longint
C, C++
HRESULT get_Count(long* Value);

См.также

IIngeoSemDbValues


Свойство Item (Объект IIngeoSemDbValues)

Возвращает объект, через который осуществляется доступ к данных поля. Поле задается либо по порядковому номеру, либо по имени.

Синтаксис

Язык Описание
VBScript, JavaScript
Item(anIndex)
Visual Basic
Property Item(ByVal anIndex As Variant) As IIngeoSemDbValue
Delphi
property Item[anIndex: OleVariant]: IIngeoSemDbValue
C, C++
HRESULT get_Item(VARIANT anIndex, IIngeoSemDbValue** Value);

Параметры

anIndex
Порядковый номер или имя.

См.также

IIngeoSemDbValues, IIngeoSemDbValue


Свойство Value (Объект IIngeoSemDbValue)

Значение поля. У справочного поля возвращается значение кодового поля справочника.

Синтаксис

Язык Описание
VBScript, JavaScript
Value
Visual Basic
Property Value As Variant
Delphi
property Value: OleVariant
C, C++
HRESULT get_Value(VARIANT* Value);

См.также

IIngeoSemDbValue


Объект IIngeoSemFieldInfo

Описывает поле семантической таблицы.

Свойства

Свойство | Описание
Caption | Заголовок поля.
FieldName | Имя поля.
RefBookDisplayFields | Для справочного поля. Содержит имена отображаемых полей справочника, разделенных символом ';'.
RefBookID | Если поле справочное, то здесь задается идентификатор используемого справочника.
RefBookKeyField | Для справочного поля. Содержит имя ключевого поля справочника.

Методы

Метод | Описание
Delete | Удаляет описание поля из коллекции, которой оно принадлежит.

См.также

IIngeoSemFieldInfos, IIngeoSemTable


Свойство Caption (Объект IIngeoSemFieldInfo)

Заголовок поля.

Синтаксис

Язык Описание
VBScript, JavaScript
Caption
Visual Basic
Property Caption As String
Delphi
property Caption: WideString
C, C++
HRESULT get_Caption(BSTR* Value);
HRESULT set_Caption(BSTR Value);

См.также

IIngeoSemFieldInfo


Метод Delete (Объект IIngeoSemFieldInfo)

Удаляет описание поля из коллекции, которой оно принадлежит.

Синтаксис

Язык | Описание
VBScript, JavaScript | SubDelete()
Visual Basic | Sub Delete()
Delphi | procedure Delete;
C, C++ | HRESULT Delete();

См.также

IIngeoSemFieldInfo


Свойство FieldName (Объект IIngeoSemFieldInfo)

Имя поля.

Синтаксис

Язык Описание
VBScript, JavaScript
FieldName
Visual Basic
Property FieldName As String
Delphi
property FieldName: WideString
C, C++
HRESULT get_FieldName(BSTR* Value);

См.также

IIngeoSemFieldInfo


Свойство RefBookDisplayFields (Объект IIngeoSemFieldInfo)

Для справочного поля. Содержит имена отображаемых полей справочника. Поля перечисляются через точку-запятую.

Синтаксис

Язык Описание
VBScript, JavaScript
RefBookDisplayFields
Visual Basic
Property RefBookDisplayFields As String
Delphi
property RefBookDisplayFields: WideString
C, C++
HRESULT get_RefBookDisplayFields(BSTR* Value);
HRESULT set_RefBookDisplayFields(BSTR Value);

См.также

IIngeoSemFieldInfo


Свойство RefBookID (Объект IIngeoSemFieldInfo)

Если поле справочное, то здесь задается идентификатор используемого справочника.

Синтаксис

Язык Описание
VBScript, JavaScript
RefBookID
Visual Basic
Property RefBookID As String
Delphi
property RefBookID: WideString
C, C++
HRESULT get_RefBookID(BSTR* Value);
HRESULT set_RefBookID(BSTR Value);

См.также

IIngeoSemFieldInfo


Свойство RefBookKeyField (Объект IIngeoSemFieldInfo)

Для справочного поля. Содержит имя ключевого поля справочника.

Синтаксис

Язык Описание
VBScript, JavaScript
RefBookKeyField
Visual Basic
Property RefBookKeyField As String
Delphi
property RefBookKeyField: WideString
C, C++
HRESULT get_RefBookKeyField(BSTR* Value);
HRESULT set_RefBookKeyField(BSTR Value);

См.также

IIngeoSemFieldInfo


Объект IIngeoSemFieldInfos

Коллекция описаний полей таблицы.

Свойства

Свойство | Описание
Count | Количество описаний полей.
Item | Возвращает описание поля.
_NewEnum | Возвращает перечислитель по элементам (описаниям полей) коллекции.

Методы

Метод | Описание
Add | Добавляет в коллекцию новое описание поля.

См.также

IIngeoSemTable, IIngeoSemFieldInfo


Свойство _NewEnum (Объект IIngeoSemFieldInfos)

Возвращает перечислитель по элементам (описаниям полей) коллекции.

Синтаксис

Язык Описание
VBScript, JavaScript
_NewEnum
Visual Basic
Property _NewEnum As Object
Delphi
property _NewEnum: IUnknown
C, C++
HRESULT get__NewEnum(IUnknown* Value);

См.также

IIngeoSemFieldInfos


Метод Add (Объект IIngeoSemFieldInfos)

Добавляет в коллекцию новое описание поля. Описание добавляется в конец коллекции.

Синтаксис

Язык | Описание
VBScript, JavaScript | FunctionAdd(aFieldName, aCaption, aRefBookID, aRefBookKeyField, aRefBookDisplayFields)
Visual Basic | Function Add(ByVal aFieldName As String, ByVal aCaption As String, ByVal aRefBookID As String, ByVal aRefBookKeyField As String, ByVal aRefBookDisplayFields As String) As IIngeoSemFieldInfo
Delphi | function Add(const aFieldName: WideString; const aCaption: WideString; const aRefBookID: WideString; const aRefBookKeyField: WideString; const aRefBookDisplayFields: WideString): IIngeoSemFieldInfo;
C, C++ | HRESULT Add(BSTR aFieldName, BSTR aCaption, BSTR aRefBookID, BSTR aRefBookKeyField, BSTR aRefBookDisplayFields, IIngeoSemFieldInfo** Value);

Параметры

aFieldName
Имя поля.
aCaption
Заголовок поля.
aRefBookID
Идентификатор справочника, если поле справочное.
aRefBookKeyField
Ключевое поле справочника, если поле справочное.
aRefBookDisplayFields
Отображаемые поля справочника, если поле справочное. Поля перечисляются через точку-запятую.

Возвращаемое значение

Добавленное описание поля.

См.также

IIngeoSemFieldInfos, IIngeoSemFieldInfo


Свойство Count (Объект IIngeoSemFieldInfos)

Количество описаний полей.

Синтаксис

Язык Описание
VBScript, JavaScript
Count
Visual Basic
Property Count As Long
Delphi
property Count: Longint
C, C++
HRESULT get_Count(long* Value);

См.также

IIngeoSemFieldInfos


Свойство Item (Объект IIngeoSemFieldInfos)

Возвращает описание поля. Описание поля задается либо по порядковому номеру, либо по имени.

Синтаксис

Язык Описание
VBScript, JavaScript
Item(anIndex)
Visual Basic
Property Item(ByVal anIndex As Variant) As IIngeoSemFieldInfo
Delphi
property Item[anIndex: OleVariant]: IIngeoSemFieldInfo
C, C++
HRESULT get_Item(VARIANT anIndex, IIngeoSemFieldInfo** Value);

Параметры

anIndex
Порядковый номер или имя.

См.также

IIngeoSemFieldInfos, IIngeoSemFieldInfo


Объект IIngeoSemTable

Описывает семантическую таблицу.

Семантические таблицы обязательно связаны с каким-либо слоем.

Изменения в структуре таблицы применяются не сразу, а только после вызова метода Update.

Свойства

Свойство | Описание
AC | Права доступа к семантической таблице.
FieldInfos | Коллекция описаний полей таблицы.
ID | Идентификатор таблицы.
LinkType | Тип связи между пространственным объектом слоя и соответствующим ему записям в семантической таблице.
Modified | Указывает призводились ли изменения в структуре таблицы.
Name | Логическое имя таблицы.
SemDbTable | Через этот объект осуществляется работа с данными семантической таблицы.
SemDbTableName | Физическое имя таблицы.

Методы

Метод | Описание
Delete | Удаляет таблицу.
DropCache | Сбрасывает кэш, используемый таблицей.
DropChanges | Отменяет изменения, сделанные в структуре таблицы.
Update | Применяет изменения, сделанные в структуре таблицы.

См.также

IIngeoSemTables, IIngeoLayer


Свойство AC (Объект IIngeoSemTable)

Права доступа к семантической таблице.

Синтаксис

Язык Описание
VBScript, JavaScript
AC
Visual Basic
Property AC As IIngeoAC
Delphi
property AC: IIngeoAC
C, C++
HRESULT get_AC(IIngeoAC** Value);

См.также

IIngeoAC, Список прав


Метод Delete (Объект IIngeoSemTable)

Удаляет таблицу.

Синтаксис

Язык | Описание
VBScript, JavaScript | SubDelete()
Visual Basic | Sub Delete()
Delphi | procedure Delete;
C, C++ | HRESULT Delete();

См.также

IIngeoSemTable


Метод DropCache (Объект IIngeoSemTable)

Сбрасывает кэш, используемый таблицей.

Синтаксис

Язык | Описание
VBScript, JavaScript | SubDropCache()
Visual Basic | Sub DropCache()
Delphi | procedure DropCache;
C, C++ | HRESULT DropCache();


Метод DropChanges (Объект IIngeoSemTable)

Отменяет изменения, сделанные в структуре таблицы.

Синтаксис

Язык | Описание
VBScript, JavaScript | SubDropChanges()
Visual Basic | Sub DropChanges()
Delphi | procedure DropChanges;
C, C++ | HRESULT DropChanges();

См.также

IIngeoSemTable


Свойство FieldInfos (Объект IIngeoSemTable)

Коллекция описаний полей таблицы.

Синтаксис

Язык Описание
VBScript, JavaScript
FieldInfos
Visual Basic
Property FieldInfos As IIngeoSemFieldInfos
Delphi
property FieldInfos: IIngeoSemFieldInfos
C, C++
HRESULT get_FieldInfos(IIngeoSemFieldInfos** Value);

См.также

IIngeoSemTable, IIngeoSemFieldInfos


Свойство ID (Объект IIngeoSemTable)

Идентификатор таблицы.

Синтаксис

Язык Описание
VBScript, JavaScript
ID
Visual Basic
Property ID As String
Delphi
property ID: WideString
C, C++
HRESULT get_ID(BSTR* Value);

См.также

IIngeoSemTable


Свойство LinkType (Объект IIngeoSemTable)

Тип связи между пространственным объектом слоя и соответствующим ему записям в семантической таблице. Возможные типы связи: 1) один к одному; 2) один ко многим.

Синтаксис

Язык Описание
VBScript, JavaScript
LinkType
Visual Basic
Property LinkType As Long
Delphi
property LinkType: Longint
C, C++
HRESULT get_LinkType(long* Value);
HRESULT set_LinkType(long Value);

См.также

IIngeoSemTable, TIngeoSemTableLinkType


Свойство Modified (Объект IIngeoSemTable)

Указывает призводились ли изменения в структуре таблицы.

Возвращает True, если структура таблицы была изменена. Иначе - False.

Синтаксис

Язык Описание
VBScript, JavaScript
Modified
Visual Basic
Property Modified As Boolean
Delphi
property Modified: WordBool
C, C++
HRESULT get_Modified(VARIANT_BOOL* Value);

См.также

IIngeoSemTable


Свойство Name (Объект IIngeoSemTable)

Логическое имя таблицы. Используется для удобного именования таблицы для пользователя.

Синтаксис

Язык Описание
VBScript, JavaScript
Name
Visual Basic
Property Name As String
Delphi
property Name: WideString
C, C++
HRESULT get_Name(BSTR* Value);
HRESULT set_Name(BSTR Value);

См.также

IIngeoSemTable


Объект IIngeoSemTables

Коллекция описаний семантических таблиц слоя.

Свойства

Свойство | Описание
Count | Количество описаний таблиц.
Item | Возвращает описание таблицы.
_NewEnum | Возвращает перечислитель по элементам (описаниям таблиц) коллекции.

Методы

Метод | Описание
Add | Добавляет в коллекцию описание новой таблицы.
AddWithID | Добавляет в коллекцию описание новой таблицы с указанным идентификатором.

См.также

IIngeoLayer, IIngeoSemTable


Свойство _NewEnum (Объект IIngeoSemTables)

Возвращает перечислитель по элементам (описаниям таблиц) коллекции.

Синтаксис

Язык Описание
VBScript, JavaScript
_NewEnum
Visual Basic
Property _NewEnum As Object
Delphi
property _NewEnum: IUnknown
C, C++
HRESULT get__NewEnum(IUnknown* Value);

См.также

IIngeoSemTables, IIngeoSemTable


Метод Add (Объект IIngeoSemTables)

Добавляет в коллекцию описание новой таблицы. Описание добавляется в конец коллекции.

Синтаксис

Язык | Описание
VBScript, JavaScript | FunctionAdd()
Visual Basic | Function Add() As IIngeoSemTable
Delphi | function Add: IIngeoSemTable;
C, C++ | HRESULT Add(IIngeoSemTable** Value);

Возвращаемое значение

Добавленное описание таблицы.

См.также

IIngeoSemTables, IIngeoSemTable


Метод AddWithID (Объект IIngeoSemTables)

Добавляет в коллекцию описание новой таблицы с указанным идентификатором.

Синтаксис

Язык | Описание
VBScript, JavaScript | FunctionAddWithID(anID)
Visual Basic | Function AddWithID(ByVal anID As String) As IIngeoSemTable
Delphi | function AddWithID(const anID: WideString): IIngeoSemTable;
C, C++ | HRESULT AddWithID(BSTR anID, IIngeoSemTable** Value);

Параметры

anID
Идентификатор добавляемой таблицы.

Возвращаемое значение

Добавленное описание таблицы.

См.также

IIngeoSemTables, IIngeoSemTable


Свойство Count (Объект IIngeoSemTables)

Количество описаний таблиц.

Синтаксис

Язык Описание
VBScript, JavaScript
Count
Visual Basic
Property Count As Long
Delphi
property Count: Longint
C, C++
HRESULT get_Count(long* Value);

См.также

IIngeoSemTables


Свойство SemDbTable (Объект IIngeoSemTable)

Через этот объект осуществляется работа с данными семантической таблицы.

Синтаксис

Язык Описание
VBScript, JavaScript
SemDbTable
Visual Basic
Property SemDbTable As IIngeoSemDbTable
Delphi
property SemDbTable: IIngeoSemDbTable
C, C++
HRESULT get_SemDbTable(IIngeoSemDbTable** Value);

См.также

IIngeoSemTable, IIngeoSemDbTable


Свойство SemDbTableName (Объект IIngeoSemTable)

Физическое имя таблицы. Под этим именем хранится таблица в базе данных.

Синтаксис

Язык Описание
VBScript, JavaScript
SemDbTableName
Visual Basic
Property SemDbTableName As String
Delphi
property SemDbTableName: WideString
C, C++
HRESULT get_SemDbTableName(BSTR* Value);
HRESULT set_SemDbTableName(BSTR Value);

См.также

IIngeoSemTable


Свойство Item (Объект IIngeoSemTables)

Возвращает описание таблицы. Описание таблицы задается по порядковому номеру.

Синтаксис

Язык Описание
VBScript, JavaScript
Item(anIndex)
Visual Basic
Property Item(ByVal anIndex As Long) As IIngeoSemTable
Delphi
property Item[anIndex: Longint]: IIngeoSemTable
C, C++
HRESULT get_Item(long anIndex, IIngeoSemTable** Value);

Параметры

anIndex
Порядковый номер.

См.также

IIngeoSemTables, IIngeoSemTable


Метод Update (Объект IIngeoSemTable)

Применяет изменения, сделанные в структуре таблицы. Если таблица новая, то происходит ее физическое создание в базе данных.

Синтаксис

Язык | Описание
VBScript, JavaScript | SubUpdate()
Visual Basic | Sub Update()
Delphi | procedure Update;
C, C++ | HRESULT Update();

См.также

IIngeoSemTable


Объект IIngeoShape

Фигура пространственного объекта.

Свойства

Свойство | Описание
Contour | Контур, описывающий пространственные координаты фигуры.
DefineGeometry | Определяет данная форма геометрию пространственного объекта или нет.
Index | Задает порядковый номер формы в пространственном объекте.
Style | Стиль, которым отображается данная форма.
StyleID | Идентификатор стиля, которым отображается данная форма.

Методы

Метод | Описание
Delete | Удаляет форму из коллекции форм, которой он принадлежит.
Paint | Рисует объект на заданной поверхности рисования.

См.также

IIngeoShapes


Свойство Contour (Объект IIngeoShape)

Контур, описывающий пространственные координаты фигуры.

Синтаксис

Язык Описание
VBScript, JavaScript
Contour
Visual Basic
Property Contour As IIngeoContour
Delphi
property Contour: IIngeoContour
C, C++
HRESULT get_Contour(IIngeoContour** Value);

См.также

IIngeoShape, IIngeoContour


Свойство DefineGeometry (Объект IIngeoShape)

Определяет данная форма геометрию пространственного объекта или нет. Данная информацию базируется на стиле формы.

Синтаксис

Язык Описание
VBScript, JavaScript
DefineGeometry
Visual Basic
Property DefineGeometry As Boolean
Delphi
property DefineGeometry: WordBool
C, C++
HRESULT get_DefineGeometry(VARIANT_BOOL* Value);

См.также

IIngeoShape, IIngeoStyle


Метод Delete (Объект IIngeoShape)

Удаляет форму из коллекции форм, которой он принадлежит.

Синтаксис

Язык | Описание
VBScript, JavaScript | SubDelete()
Visual Basic | Sub Delete()
Delphi | procedure Delete;
C, C++ | HRESULT Delete();

См.также

IIngeoShape


Свойство Index (Объект IIngeoShape)

Задает порядковый номер формы в пространственном объекте.

Синтаксис

Язык Описание
VBScript, JavaScript
Index
Visual Basic
Property Index As Long
Delphi
property Index: Longint
C, C++
HRESULT get_Index(long* Value);
HRESULT set_Index(long Value);

См.также

IIngeoShape


Метод Paint (Объект IIngeoShape)

Рисует объект на заданной поверхности рисования.

Синтаксис

Язык | Описание
VBScript, JavaScript | SubPaint(aSurface)
Visual Basic | Sub Paint(ByVal aSurface As IIngeoPaintSurface)
Delphi | procedure Paint(aSurface: IIngeoPaintSurface);
C, C++ | HRESULT Paint(IIngeoPaintSurface* aSurface);

Параметры

aSurface
Поверхность рисования.


Объект IIngeoShapes

Коллекция фигур пространственного объекта.

Свойства

Свойство | Описание
Count | Количество фигур.
Item | Возвращает фигуру.
MapObject | Возвращает пространственный объект, которому принадлежат фигуры.
_NewEnum | Возвращает перечислитель по элементам (фигурам) коллекции.

Методы

Метод | Описание
Clear | Удаляет все фигуры из коллекции.
Insert | Добавляет фигуру.

См.также

IIngeoMapObject, IIngeoShape


Свойство _NewEnum (Объект IIngeoShapes)

Возвращает перечислитель по элементам (фигурам) коллекции.

Синтаксис

Язык Описание
VBScript, JavaScript
_NewEnum
Visual Basic
Property _NewEnum As Object
Delphi
property _NewEnum: IUnknown
C, C++
HRESULT get__NewEnum(IUnknown* Value);

См.также

IIngeoShapes, IIngeoShape


Метод Clear (Объект IIngeoShapes)

Удаляет все фигуры из коллекции.

Синтаксис

Язык | Описание
VBScript, JavaScript | SubClear()
Visual Basic | Sub Clear()
Delphi | procedure Clear;
C, C++ | HRESULT Clear();

См.также

IIngeoShapes


Свойство Count (Объект IIngeoShapes)

Количество фигур.

Синтаксис

Язык Описание
VBScript, JavaScript
Count
Visual Basic
Property Count As Long
Delphi
property Count: Longint
C, C++
HRESULT get_Count(long* Value);

См.также

IIngeoShapes


Метод Insert (Объект IIngeoShapes)

Добавляет фигуру.

Синтаксис

Язык | Описание
VBScript, JavaScript | FunctionInsert(anIndex, aStyleID)
Visual Basic | Function Insert(ByVal anIndex As Long, ByVal aStyleID As String) As IIngeoShape
Delphi | function Insert(anIndex: Longint; const aStyleID: WideString): IIngeoShape;
C, C++ | HRESULT Insert(long anIndex, BSTR aStyleID, IIngeoShape** Value);

Параметры

anIndex
Позиция в которую добавляется фигура.
Если значение данного параметра равно "-1", то фигура добавится в конец списка.
aStyleID
Идентификатор стиля фигуры.

Возвращаемое значение

Добавленная фигура.

См.также

IIngeoShapes, IIngeoShape


Свойство Item (Объект IIngeoShapes)

Возвращает фигуру. Фигура задается по порядковому номеру.

Синтаксис

Язык Описание
VBScript, JavaScript
Item(anIndex)
Visual Basic
Property Item(ByVal anIndex As Long) As IIngeoShape
Delphi
property Item[anIndex: Longint]: IIngeoShape
C, C++
HRESULT get_Item(long anIndex, IIngeoShape** Value);

Параметры

anIndex
Порядковый номер.

См.также

IIngeoShapes, IIngeoShape


Свойство MapObject (Объект IIngeoShapes)

Возвращает пространственный объект, которому принадлежат фигуры.

Синтаксис

Язык Описание
VBScript, JavaScript
MapObject
Visual Basic
Property MapObject As IIngeoMapObject
Delphi
property MapObject: IIngeoMapObject
C, C++
HRESULT get_MapObject(IIngeoMapObject** Value);

См.также

IIngeoShapes, IIngeoMapObject


Свойство Style (Объект IIngeoShape)

Стиль, которым отображается данная форма.

Синтаксис

Язык Описание
VBScript, JavaScript
Style
Visual Basic
Property Style As IIngeoStyle
Delphi
property Style: IIngeoStyle
C, C++
HRESULT get_Style(IIngeoStyle** Value);

См.также

IIngeoShape, IIngeoStyle


Свойство StyleID (Объект IIngeoShape)

Идентификатор стиля, которым отображается данная форма.

Синтаксис

Язык Описание
VBScript, JavaScript
StyleID
Visual Basic
Property StyleID As String
Delphi
property StyleID: WideString
C, C++
HRESULT get_StyleID(BSTR* Value);
HRESULT set_StyleID(BSTR Value);

См.также

IIngeoShape, IIngeoStyle


Объект IIngeoStdPainter

Объект IIngeoStdPainter(IIngeoPainter)

Стандартный метод отображения.

Свойства

Свойство | Наследуется от | Описание
Brush | Кисть, которой производится закраска.
Comment | IIngeoPainter | Комментарий.
Index | IIngeoPainter | Порядковый номер метода отображения в коллекции.
PainterType | IIngeoPainter | Тип метода отображения.
Pen | Карандаш, которым рисуется окантовка.
VisibleMax | IIngeoPainter | Верхняя граница диапазона видимости метода отображения.
VisibleMin | IIngeoPainter | Нижняя граница диапазона видимости метода отображения.

Методы

Метод | Наследуется от | Описание
Delete | IIngeoPainter | Удаляет метод отображения из коллекции, которой он принадлежит.
PaintContour | IIngeoPainter | Рисует заданный контур данным методом отображения на заданную поверхность рисования.

См.также

IIngeoStyle, IIngeoPainter, IIngeoTextPainter, IIngeoSymbolPainter, Application.CreateObject, TIngeoPainterType


Свойство Brush (Объект IIngeoStdPainter)

Кисть, которой производится закраска.

Синтаксис

Язык Описание
VBScript, JavaScript
Brush
Visual Basic
Property Brush As IInBrush
Delphi
property Brush: IInBrush
C, C++
HRESULT get_Brush(IInBrush** Value);

См.также

IIngeoStdPainter, IInBrush


Свойство Pen (Объект IIngeoStdPainter)

Карандаш, которым рисуется окантовка.

Синтаксис

Язык Описание
VBScript, JavaScript
Pen
Visual Basic
Property Pen As IInPen
Delphi
property Pen: IInPen
C, C++
HRESULT get_Pen(IInPen** Value);

См.также

IIngeoStdPainter, IInPen


Объект IIngeoStyle

Объект Style представляет собой стиль.

Свойства

Свойство | Описание
AC | Права доступа.
CreationClosing | Тип замыкающей линии при создании новых объектов.
CreationClosingOrtho | Признак сохранения прямых углов при замыкании контура нового объекта.
CreationStart | Тип линии при создании новых объектов.
CreationStartOrtho | Сохранение прямых углов при создании новых объектов.
Flags | Различные параметры геометрических форм, использующих данный стиль. Подробное описание возможнх значений см. TIngeoStyleFlags
ID | Внутренний идентификатор стиля.
Layer | Слой, к которому принадлежит стиль.
MaxPoints | Максимальное количество точек в контуре, использующем этот стиль.
MinPoints | Минимальное количество точек в контуре, использующем этот стиль.
Modified | Признак измения значений свойств стиля.
Name | Название стиля.
Painters | Список методов отбражения.

Методы

Метод | Описание
Delete | Удаление стиля.
DropChanges | Отмена внесенных изменений.
PaintContour | Рисование контура данным стилем на указанную поверхность рисования.
Update | Сохранение внесенных изменений свойств стиля в базу данных.


Свойство AC (Объект IIngeoStyle)

Права доступа.

Синтаксис

Язык Описание
VBScript, JavaScript
AC
Visual Basic
Property AC As IIngeoAC
Delphi
property AC: IIngeoAC
C, C++
HRESULT get_AC(IIngeoAC** Value);

См.также

Список прав


Свойство CreationClosing (Объект IIngeoStyle)

Тип замыкающей линии при создании новых объектов.

Синтаксис

Язык Описание
VBScript, JavaScript
CreationClosing
Visual Basic
Property CreationClosing As TIngeoStyleClosing
Delphi
property CreationClosing: TIngeoStyleClosing
C, C++
HRESULT get_CreationClosing(TIngeoStyleClosing* Value);
HRESULT set_CreationClosing(TIngeoStyleClosing Value);


Свойство CreationClosingOrtho (Объект IIngeoStyle)

Признак сохранения прямых углов при замыкании контура нового объекта.

Синтаксис

Язык Описание
VBScript, JavaScript
CreationClosingOrtho
Visual Basic
Property CreationClosingOrtho As Boolean
Delphi
property CreationClosingOrtho: WordBool
C, C++
HRESULT get_CreationClosingOrtho(VARIANT_BOOL* Value);
HRESULT set_CreationClosingOrtho(VARIANT_BOOL Value);


Свойство CreationStart (Объект IIngeoStyle)

Тип линии при создании новых объектов.

Синтаксис

Язык Описание
VBScript, JavaScript
CreationStart
Visual Basic
Property CreationStart As TIngeoStyleCreation
Delphi
property CreationStart: TIngeoStyleCreation
C, C++
HRESULT get_CreationStart(TIngeoStyleCreation* Value);
HRESULT set_CreationStart(TIngeoStyleCreation Value);


Свойство CreationStartOrtho (Объект IIngeoStyle)

Сохранение прямых углов при создании новых объектов.

Синтаксис

Язык Описание
VBScript, JavaScript
CreationStartOrtho
Visual Basic
Property CreationStartOrtho As Boolean
Delphi
property CreationStartOrtho: WordBool
C, C++
HRESULT get_CreationStartOrtho(VARIANT_BOOL* Value);
HRESULT set_CreationStartOrtho(VARIANT_BOOL Value);


Метод Delete (Объект IIngeoStyle)

Удаление стиля.

Синтаксис

Язык | Описание
VBScript, JavaScript | SubDelete()
Visual Basic | Sub Delete()
Delphi | procedure Delete;
C, C++ | HRESULT Delete();


Метод DropChanges (Объект IIngeoStyle)

Отмена внесенных изменений.

Синтаксис

Язык | Описание
VBScript, JavaScript | SubDropChanges()
Visual Basic | Sub DropChanges()
Delphi | procedure DropChanges;
C, C++ | HRESULT DropChanges();


Свойство Flags (Объект IIngeoStyle)

Различные параметры геометрических форм, использующих данный стиль. Подробное описание возможнх значений см. TIngeoStyleFlags

Синтаксис

Язык Описание
VBScript, JavaScript
Flags
Visual Basic
Property Flags As TIngeoStyleFlags
Delphi
property Flags: TIngeoStyleFlags
C, C++
HRESULT get_Flags(TIngeoStyleFlags* Value);
HRESULT set_Flags(TIngeoStyleFlags Value);


Свойство ID (Объект IIngeoStyle)

Внутренний идентификатор стиля.

Синтаксис

Язык Описание
VBScript, JavaScript
ID
Visual Basic
Property ID As String
Delphi
property ID: WideString
C, C++
HRESULT get_ID(BSTR* Value);


Свойство Layer (Объект IIngeoStyle)

Слой, к которому принадлежит стиль.

Синтаксис

Язык Описание
VBScript, JavaScript
Layer
Visual Basic
Property Layer As IIngeoLayer
Delphi
property Layer: IIngeoLayer
C, C++
HRESULT get_Layer(IIngeoLayer** Value);


Свойство MaxPoints (Объект IIngeoStyle)

Максимальное количество точек в контуре, использующем этот стиль.

Синтаксис

Язык Описание
VBScript, JavaScript
MaxPoints
Visual Basic
Property MaxPoints As Long
Delphi
property MaxPoints: Longint
C, C++
HRESULT get_MaxPoints(long* Value);
HRESULT set_MaxPoints(long Value);


Свойство MinPoints (Объект IIngeoStyle)

Минимальное количество точек в контуре, использующем этот стиль.

Синтаксис

Язык Описание
VBScript, JavaScript
MinPoints
Visual Basic
Property MinPoints As Long
Delphi
property MinPoints: Longint
C, C++
HRESULT get_MinPoints(long* Value);
HRESULT set_MinPoints(long Value);


Свойство Modified (Объект IIngeoStyle)

Признак измения значений свойств стиля.

Синтаксис

Язык Описание
VBScript, JavaScript
Modified
Visual Basic
Property Modified As Boolean
Delphi
property Modified: WordBool
C, C++
HRESULT get_Modified(VARIANT_BOOL* Value);

Примечания

Изменения свойств стиля будут внесены в базу данных только после вызова метода Update IIngeoStyle.


Свойство Name (Объект IIngeoStyle)

Название стиля.

Синтаксис

Язык Описание
VBScript, JavaScript
Name
Visual Basic
Property Name As String
Delphi
property Name: WideString
C, C++
HRESULT get_Name(BSTR* Value);
HRESULT set_Name(BSTR Value);


Метод PaintContour (Объект IIngeoStyle)

Рисование контура данным стилем на указанную поверхность рисования.

Синтаксис

Язык | Описание
VBScript, JavaScript | SubPaintContour(aSurface, aContour, aData)
Visual Basic | Sub PaintContour(ByVal aSurface As IIngeoPaintSurface, ByVal aContour As IIngeoContour, ByVal aData As String)
Delphi | procedure PaintContour(aSurface: IIngeoPaintSurface; aContour: IIngeoContour; const aData: WideString);
C, C++ | HRESULT PaintContour(IIngeoPaintSurface* aSurface, IIngeoContour* aContour, BSTR aData);

Параметры

aSurface
Поверхность рисования.
aContour
Контур.
aData
Строка содержащая таблицу подстановок для текстов.
Смотрите пример для объекта IIngeoTextPainter.


Свойство Painters (Объект IIngeoStyle)

Список методов отбражения.

Синтаксис

Язык Описание
VBScript, JavaScript
Painters
Visual Basic
Property Painters As IIngeoPainters
Delphi
property Painters: IIngeoPainters
C, C++
HRESULT get_Painters(IIngeoPainters** Value);


Объект IIngeoStyles

Объект IIngeoStyles представляет собой список стилей.

Свойства

Свойство | Описание
Count | Количество стилей.
Item | Получение стиля по индексу.
_NewEnum | Служебный метод: возвращает перечислитель коллекции списка.

Методы

Метод | Описание
Add | Добавление стиля.
AddWithID | Добавление стиля с указанным идентификатором.

См.также

IIngeoLayer, IIngeoStyle


Свойство _NewEnum (Объект IIngeoStyles)

Служебный метод: возвращает перечислитель коллекции списка.

Синтаксис

Язык Описание
VBScript, JavaScript
_NewEnum
Visual Basic
Property _NewEnum As Object
Delphi
property _NewEnum: IUnknown
C, C++
HRESULT get__NewEnum(IUnknown* Value);


Метод Add (Объект IIngeoStyles)

Добавление стиля.

Синтаксис

Язык | Описание
VBScript, JavaScript | FunctionAdd()
Visual Basic | Function Add() As IIngeoStyle
Delphi | function Add: IIngeoStyle;
C, C++ | HRESULT Add(IIngeoStyle** Value);

Примечания

Новый стиль будет добавлен в базу данных только после вызова метода Update IIngeoStyle.


Метод AddWithID (Объект IIngeoStyles)

Добавление стиля с указанным идентификатором.

Синтаксис

Язык | Описание
VBScript, JavaScript | FunctionAddWithID(anID)
Visual Basic | Function AddWithID(ByVal anID As String) As IIngeoStyle
Delphi | function AddWithID(const anID: WideString): IIngeoStyle;
C, C++ | HRESULT AddWithID(BSTR anID, IIngeoStyle** Value);

Параметры

anID
Идентификатор добавляемого стиля.

Примечания

Новый стиль будет добавлен в базу данных только после вызова метода Update IIngeoStyle.


Свойство Count (Объект IIngeoStyles)

Количество стилей.

Синтаксис

Язык Описание
VBScript, JavaScript
Count
Visual Basic
Property Count As Long
Delphi
property Count: Longint
C, C++
HRESULT get_Count(long* Value);


Свойство Item (Объект IIngeoStyles)

Получение стиля по индексу.

Синтаксис

Язык Описание
VBScript, JavaScript
Item(anIndex)
Visual Basic
Property Item(ByVal anIndex As Long) As IIngeoStyle
Delphi
property Item[anIndex: Longint]: IIngeoStyle
C, C++
HRESULT get_Item(long anIndex, IIngeoStyle** Value);

Параметры

anIndex
Индекс стиля (диапазон от 0 до Count - 1).

Возвращаемое значение

Возвращает объект стилей.

См.также

IIngeoStyle


Метод Update (Объект IIngeoStyle)

Сохранение внесенных изменений свойств стиля в базу данных.

Синтаксис

Язык | Описание
VBScript, JavaScript | SubUpdate()
Visual Basic | Sub Update()
Delphi | procedure Update;
C, C++ | HRESULT Update();


Объект IIngeoStyleView

Объект управления стилем.

Свойства

Свойство | Описание
LayerView | Представленный слой.
Style | Представленный стиль.
Visible | Управление видимостью стиля.

См.также

IIngeoLayerView


Свойство LayerView (Объект IIngeoStyleView)

Представленный слой.

Синтаксис

Язык Описание
VBScript, JavaScript
LayerView
Visual Basic
Property LayerView As IIngeoLayerView
Delphi
property LayerView: IIngeoLayerView
C, C++
HRESULT get_LayerView(IIngeoLayerView** Value);

См.также

IIngeoLayerView


Объект IIngeoStyleViews

Список объектов для управления стилями.

Свойства

Свойство | Описание
Count | Количество элементов в списке.
Item | Получение представления стиля по индексу.
_NewEnum | Служебный метод: возвращает перечислитель коллекции списка.


Свойство _NewEnum (Объект IIngeoStyleViews)

Служебный метод: возвращает перечислитель коллекции списка.

Синтаксис

Язык Описание
VBScript, JavaScript
_NewEnum
Visual Basic
Property _NewEnum As Object
Delphi
property _NewEnum: IUnknown
C, C++
HRESULT get__NewEnum(IUnknown* Value);


Свойство Count (Объект IIngeoStyleViews)

Количество элементов в списке.

Синтаксис

Язык Описание
VBScript, JavaScript
Count
Visual Basic
Property Count As Long
Delphi
property Count: Longint
C, C++
HRESULT get_Count(long* Value);


Свойство Item (Объект IIngeoStyleViews)

Получение представления стиля по индексу.

Синтаксис

Язык Описание
VBScript, JavaScript
Item(Index)
Visual Basic
Property Item(ByVal Index As Long) As IIngeoStyleView
Delphi
property Item[Index: Longint]: IIngeoStyleView
C, C++
HRESULT get_Item(long Index, IIngeoStyleView** Value);

Параметры

Index
Индекс объекта в списке.


Свойство Style (Объект IIngeoStyleView)

Представленный стиль.

Синтаксис

Язык Описание
VBScript, JavaScript
Style
Visual Basic
Property Style As IIngeoStyle
Delphi
property Style: IIngeoStyle
C, C++
HRESULT get_Style(IIngeoStyle** Value);

См.также

IIngeoStyle


Свойство Visible (Объект IIngeoStyleView)

Управление видимостью стиля.

Синтаксис

Язык Описание
VBScript, JavaScript
Visible
Visual Basic
Property Visible As Boolean
Delphi
property Visible: WordBool
C, C++
HRESULT get_Visible(VARIANT_BOOL* Value);
HRESULT set_Visible(VARIANT_BOOL Value);


Объект IIngeoSymbolPainter

Объект IIngeoSymbolPainter(IIngeoPainter)

Символьный метод отображения стиля.

Свойства

Свойство | Наследуется от | Описание
Comment | IIngeoPainter | Комментарий.
Index | IIngeoPainter | Порядковый номер метода отображения в коллекции.
PainterType | IIngeoPainter | Тип метода отображения.
PaintMethod | Способ рисования символа.
Picture | Объект, содержащий описание символа.
PictureZoomScale | Задает для какого масштаба определен символ.
VisibleMax | IIngeoPainter | Верхняя граница диапазона видимости метода отображения.
VisibleMin | IIngeoPainter | Нижняя граница диапазона видимости метода отображения.

Методы

Метод | Наследуется от | Описание
Delete | IIngeoPainter | Удаляет метод отображения из коллекции, которой он принадлежит.
PaintContour | IIngeoPainter | Рисует заданный контур данным методом отображения на заданную поверхность рисования.

См.также

IIngeoStyle, IIngeoPainter, IIngeoStdPainter, IIngeoTextPainter, Application.CreateObject, TIngeoPainterType


Свойство PaintMethod (Объект IIngeoSymbolPainter)

Способ рисования символа.

Синтаксис

Язык Описание
VBScript, JavaScript
PaintMethod
Visual Basic
Property PaintMethod As TIngeoPicturePaintMethod
Delphi
property PaintMethod: TIngeoPicturePaintMethod
C, C++
HRESULT get_PaintMethod(TIngeoPicturePaintMethod* Value);
HRESULT set_PaintMethod(TIngeoPicturePaintMethod Value);

См.также

IIngeoSymbolPainter, TIngeoPicturePaintMethod


Свойство Picture (Объект IIngeoSymbolPainter)

Объект, содержащий описание символа.

Синтаксис

Язык Описание
VBScript, JavaScript
Picture
Visual Basic
Property Picture As IIngeoPicture
Delphi
property Picture: IIngeoPicture
C, C++
HRESULT get_Picture(IIngeoPicture** Value);

См.также

IIngeoSymbolPainter, IIngeoPicture


Свойство PictureZoomScale (Объект IIngeoSymbolPainter)

Задает для какого масштаба определен символ.

Синтаксис

Язык Описание
VBScript, JavaScript
PictureZoomScale
Visual Basic
Property PictureZoomScale As Double
Delphi
property PictureZoomScale: Double
C, C++
HRESULT get_PictureZoomScale(double* Value);
HRESULT set_PictureZoomScale(double Value);

См.также

IIngeoSymbolPainter


Объект IIngeoTaskPanel

Панель задач.

Свойства

Свойство | Описание
Active | Признак активности.
Caption | Заголовок.
Name | Имя панели.
Visible
WindowHandle | Идентификатор окна панели задач.

Методы

Метод | Описание
Activate | Активизировать панель задач.


Метод Activate (Объект IIngeoTaskPanel)

Активизировать панель задач.

Синтаксис

Язык | Описание
VBScript, JavaScript | SubActivate()
Visual Basic | Sub Activate()
Delphi | procedure Activate;
C, C++ | HRESULT Activate();


Свойство Active (Объект IIngeoTaskPanel)

Признак активности.

Синтаксис

Язык Описание
VBScript, JavaScript
Active
Visual Basic
Property Active As Boolean
Delphi
property Active: WordBool
C, C++
HRESULT get_Active(VARIANT_BOOL* Value);


Свойство Caption (Объект IIngeoTaskPanel)

Заголовок.

Синтаксис

Язык Описание
VBScript, JavaScript
Caption
Visual Basic
Property Caption As String
Delphi
property Caption: WideString
C, C++
HRESULT get_Caption(BSTR* Value);
HRESULT set_Caption(BSTR Value);


Свойство Name (Объект IIngeoTaskPanel)

Имя панели.

Синтаксис

Язык Описание
VBScript, JavaScript
Name
Visual Basic
Property Name As String
Delphi
property Name: WideString
C, C++
HRESULT get_Name(BSTR* Value);


Свойство Visible (Объект IIngeoTaskPanel)

Синтаксис

Язык Описание
VBScript, JavaScript
Visible
Visual Basic
Property Visible As Boolean
Delphi
property Visible: WordBool
C, C++
HRESULT get_Visible(VARIANT_BOOL* Value);
HRESULT set_Visible(VARIANT_BOOL Value);


Свойство WindowHandle (Объект IIngeoTaskPanel)

Идентификатор окна панели задач.

Синтаксис

Язык Описание
VBScript, JavaScript
WindowHandle
Visual Basic
Property WindowHandle As Long
Delphi
property WindowHandle: Longint
C, C++
HRESULT get_WindowHandle(long* Value);


Объект IIngeoTextPainter

Объект IIngeoTextPainter(IIngeoPainter)

Текстовый метод отображения стиля.

Свойства

Свойство | Наследуется от | Описание
BackColor | Цвет фоновой закраски под выводимым текстом.
Comment | IIngeoPainter | Комментарий.
Flags | Атрибуты текстового метода отображения.
Font | Шрифт, которым выводятся надписи.
Index | IIngeoPainter | Порядковый номер метода отображения в коллекции.
PainterType | IIngeoPainter | Тип метода отображения.
Text | Выводимый текст.
VisibleMax | IIngeoPainter | Верхняя граница диапазона видимости метода отображения.
VisibleMin | IIngeoPainter | Нижняя граница диапазона видимости метода отображения.

Методы

Метод | Наследуется от | Описание
Delete | IIngeoPainter | Удаляет метод отображения из коллекции, которой он принадлежит.
PaintContour | IIngeoPainter | Рисует заданный контур данным методом отображения на заданную поверхность рисования.

Пример

Вывод текстовой подписи
Пример объекта предоставляющего метод для вывода текста на Surface, по заданным координатам вектора (Delphi).

...
type
  TPaintText = class
   private
      FTextData: TStringList;
      FTextPainter: IIngeoTextPainter;
      FEdge: IIngeoContour;

  public
     constructor Create(App: IIngeoApplication);
     destructor Destroy; override;

     procedure PaintText(aSurface:IIngeoPaintSurface; aX1, Y1, aX2, aY2: Double; const aText: string);
  end ;
...

implementation

....
{TPaintText}

constructor TPaintText.Create(App: IIngeoApplication);
begin
  FTextData := TStringList.Create;
  FTextPainter := App.CreateObject(inocPainter, inptText) as IIngeoTextPainter;
  FTextPainter.Font.Name = 'Arial';
  FTextPainter.Font.Style := 0;
  FTextPainter.Font.Color := ColorToRgb(clGreen);
  FTextPainter.Font.ForZoomScale := 1/500;
  FTextPainter.Font.Size := 12;
  FTextPainter.Text := '{text}';
  FEdge := App.CreateObject(inocContour, EmptyParam) as IIngeoContour;
  with FEdge.Insert(-1) do begin
    InsertVertex(-1, 0, 0, 0);
    InsertVertex(-1, 0, 0, 0);
  end;
end;

destructor Destroy;
begin
  FTextData.Free;
end;

procedure PaintText(aSurface:IIngeoPaintSurface; aX1, Y1, aX2, aY2: Double; const aText: string);
begin
  FEdge[0].SetVertex(0, aX1, aY1, 0);
  FEdge[0].SetVertex(1, aX2, aY2, 0);
  FTextData.Values['text'] := aText;
  FTextPainter.PaintContour(aSurface, FEdge, FTextData.Text);
end;
...

См.также

IIngeoStyle, IIngeoPainter, IIngeoStdPainter, IIngeoSymbolPainter, Application.CreateObject, TIngeoPainterType


Свойство BackColor (Объект IIngeoTextPainter)

Цвет фоновой закраски под выводимым текстом.

Синтаксис

Язык Описание
VBScript, JavaScript
BackColor
Visual Basic
Property BackColor As Long
Delphi
property BackColor: Longint
C, C++
HRESULT get_BackColor(long* Value);
HRESULT set_BackColor(long Value);

См.также

IIngeoTextPainter


Свойство Flags (Объект IIngeoTextPainter)

Атрибуты текстового метода отображения.

Синтаксис

Язык Описание
VBScript, JavaScript
Flags
Visual Basic
Property Flags As TIngeoTextPainterFlags
Delphi
property Flags: TIngeoTextPainterFlags
C, C++
HRESULT get_Flags(TIngeoTextPainterFlags* Value);
HRESULT set_Flags(TIngeoTextPainterFlags Value);

См.также

IIngeoTextPainter, TIngeoTextPainterFlags


Свойство Font (Объект IIngeoTextPainter)

Шрифт, которым выводятся надписи.

Синтаксис

Язык Описание
VBScript, JavaScript
Font
Visual Basic
Property Font As IInFont
Delphi
property Font: IInFont
C, C++
HRESULT get_Font(IInFont** Value);

См.также

IIngeoTextPainter, IInFont


Свойство Text (Объект IIngeoTextPainter)

Выводимый текст. Текст обычно содержит ссылки на поля семантических таблиц.

Синтаксис

Язык Описание
VBScript, JavaScript
Text
Visual Basic
Property Text As String
Delphi
property Text: WideString
C, C++
HRESULT get_Text(BSTR* Value);
HRESULT set_Text(BSTR Value);

См.также

IIngeoTextPainter


Объект IIngeoTopoLinks

Коллекция топологических связей пространственного объекта.

Свойства

Свойство | Описание
Count | Количество топологических связей.
Item | Возвращает идентификатор пространственного объекта с которым установлена топологическая связь.
_NewEnum | Возвращает перечислитель по элементам (идентификаторам связанных объектов) коллекции.

Методы

Метод | Описание
Add | Добавляет топологическую связь.
Clear | Удаляет все топологические связи из коллекции.
Delete | Удаляет топологическую связь.
DeleteID | Удаляет топологическую связь.

См.также

IIngeoMapObject


Свойство _NewEnum (Объект IIngeoTopoLinks)

Возвращает перечислитель по элементам (идентификаторам связанных объектов) коллекции.

Синтаксис

Язык Описание
VBScript, JavaScript
_NewEnum
Visual Basic
Property _NewEnum As Object
Delphi
property _NewEnum: IUnknown
C, C++
HRESULT get__NewEnum(IUnknown* Value);

См.также

IIngeoTopoLinks


Метод Add (Объект IIngeoTopoLinks)

Добавляет топологическую связь.

Синтаксис

Язык | Описание
VBScript, JavaScript | SubAdd(anObjectID)
Visual Basic | Sub Add(ByVal anObjectID As String)
Delphi | procedure Add(const anObjectID: WideString);
C, C++ | HRESULT Add(BSTR anObjectID);

Параметры

anObjectID
Идентификатор объекта с которым устанавливается топологическая связь.

См.также

IIngeoTopoLinks


Метод Clear (Объект IIngeoTopoLinks)

Удаляет все топологические связи из коллекции.

Синтаксис

Язык | Описание
VBScript, JavaScript | SubClear()
Visual Basic | Sub Clear()
Delphi | procedure Clear;
C, C++ | HRESULT Clear();

См.также

IIngeoTopoLinks


Свойство Count (Объект IIngeoTopoLinks)

Количество топологических связей.

Синтаксис

Язык Описание
VBScript, JavaScript
Count
Visual Basic
Property Count As Long
Delphi
property Count: Longint
C, C++
HRESULT get_Count(long* Value);

См.также

IIngeoTopoLinks


Метод Delete (Объект IIngeoTopoLinks)

Удаляет топологическую связь.

Синтаксис

Язык | Описание
VBScript, JavaScript | SubDelete(anIndex)
Visual Basic | Sub Delete(ByVal anIndex As Long)
Delphi | procedure Delete(anIndex: Longint);
C, C++ | HRESULT Delete(long anIndex);

Параметры

anIndex
Индекс удаляемой топологической связи.

См.также

IIngeoTopoLinks


Метод DeleteID (Объект IIngeoTopoLinks)

Удаляет топологическую связь.

Синтаксис

Язык | Описание
VBScript, JavaScript | SubDeleteID(anObjectID)
Visual Basic | Sub DeleteID(ByVal anObjectID As String)
Delphi | procedure DeleteID(const anObjectID: WideString);
C, C++ | HRESULT DeleteID(BSTR anObjectID);

Параметры

anObjectID
Идентификатор объекта, топологическая связь с которым удаляется.

См.также

IIngeoTopoLinks


Свойство Item (Объект IIngeoTopoLinks)

Возвращает идентификатор пространственного объекта с которым установлена топологическая связь. Идентификатор задается по порядковому номеру.

Синтаксис

Язык Описание
VBScript, JavaScript
Item(anIndex)
Visual Basic
Property Item(ByVal anIndex As Long) As String
Delphi
property Item[anIndex: Longint]: WideString
C, C++
HRESULT get_Item(long anIndex, BSTR* Value);

Параметры

anIndex
Порядковый номер.

См.также

IIngeoTopoLinks


Объект IIngeoUser

Описывает пользователя.

Свойства

Свойство | Описание
Description | Описание пользователя.
FullName | Полное имя пользователя.
ID | Идентификатор пользователя.
Modified | Характеристики пользователя были изменены.
Name | Краткое имя пользователя.
Password | Пароль пользователя.
RoleIDs | Список ролей, которые играет пользователь.

Методы

Метод | Описание
Delete | Удаляет пользователя.
DropChanges | Отменяет сделанные изменения.
Update | Применяет сделанные изменения.

См.также

IIngeoUsers, IIngeoDb, IIngeoRole


Метод Delete (Объект IIngeoUser)

Удаляет пользователя.

Синтаксис

Язык | Описание
VBScript, JavaScript | SubDelete()
Visual Basic | Sub Delete()
Delphi | procedure Delete;
C, C++ | HRESULT Delete();

См.также

IIngeoUser


Свойство Description (Объект IIngeoUser)

Описание пользователя.

Синтаксис

Язык Описание
VBScript, JavaScript
Description
Visual Basic
Property Description As String
Delphi
property Description: WideString
C, C++
HRESULT get_Description(BSTR* Value);
HRESULT set_Description(BSTR Value);

См.также

IIngeoUser


Метод DropChanges (Объект IIngeoUser)

Отменяет сделанные изменения.

Синтаксис

Язык | Описание
VBScript, JavaScript | SubDropChanges()
Visual Basic | Sub DropChanges()
Delphi | procedure DropChanges;
C, C++ | HRESULT DropChanges();

См.также

IIngeoUser


Свойство FullName (Объект IIngeoUser)

Полное имя пользователя.

Синтаксис

Язык Описание
VBScript, JavaScript
FullName
Visual Basic
Property FullName As String
Delphi
property FullName: WideString
C, C++
HRESULT get_FullName(BSTR* Value);
HRESULT set_FullName(BSTR Value);

См.также

IIngeoUser


Свойство ID (Объект IIngeoUser)

Идентификатор пользователя.

Синтаксис

Язык Описание
VBScript, JavaScript
ID
Visual Basic
Property ID As String
Delphi
property ID: WideString
C, C++
HRESULT get_ID(BSTR* Value);

См.также

IIngeoUser


Свойство Modified (Объект IIngeoUser)

Характеристики пользователя были изменены.

Возвращает True если характеристики пользователя были изменены, иначе - False.

Синтаксис

Язык Описание
VBScript, JavaScript
Modified
Visual Basic
Property Modified As Boolean
Delphi
property Modified: WordBool
C, C++
HRESULT get_Modified(VARIANT_BOOL* Value);

См.также

IIngeoUser


Свойство Name (Объект IIngeoUser)

Краткое имя пользователя.

Синтаксис

Язык Описание
VBScript, JavaScript
Name
Visual Basic
Property Name As String
Delphi
property Name: WideString
C, C++
HRESULT get_Name(BSTR* Value);
HRESULT set_Name(BSTR Value);

См.также

IIngeoUser


Свойство Password (Объект IIngeoUser)

Пароль пользователя.

Синтаксис

Язык Описание
VBScript, JavaScript
Password
Visual Basic
Property Password As String
Delphi
property Password: WideString
C, C++
HRESULT get_Password(BSTR* Value);
HRESULT set_Password(BSTR Value);

Возвращаемое значение

Всегда возвращает пустую строку.

См.также

IIngeoUser


Объект IIngeoUserProfile

Используется для сохранения произвольных данных. Обычно это какие-либо настройки.

Методы

Метод | Описание
Delete | Удаляет данные с заданным ключом.
Exists | Признак наличия данных.
Get | Считывает данные.
Put | Сохраняет данные.

См.также

IIngeoApplication


Метод Delete (Объект IIngeoUserProfile)

Удаляет данные с заданным ключом.

Синтаксис

Язык | Описание
VBScript, JavaScript | SubDelete(Scope, ObjectID, Key)
Visual Basic | Sub Delete(ByVal Scope As TIngeoUserProfileScope, ByVal ObjectID As String, ByVal Key As String)
Delphi | procedure Delete(Scope: TIngeoUserProfileScope; const ObjectID: WideString; const Key: WideString);
C, C++ | HRESULT Delete(TIngeoUserProfileScope Scope, BSTR ObjectID, BSTR Key);

Параметры

Scope
Контекст данных.
ObjectID
Идентификатор объект, с которым ассоциируются данные. Может быть пустая строка.
Key
Идентификатор данных.

См.также

IIngeoUserProfile, TIngeoUserProfileScope


Метод Exists (Объект IIngeoUserProfile)

Признак наличия данных.

Синтаксис

Язык | Описание
VBScript, JavaScript | FunctionExists(Scope, ObjectID, Key)
Visual Basic | Function Exists(ByVal Scope As TIngeoUserProfileScope, ByVal ObjectID As String, ByVal Key As String) As Boolean
Delphi | function Exists(Scope: TIngeoUserProfileScope; const ObjectID: WideString; const Key: WideString): WordBool;
C, C++ | HRESULT Exists(TIngeoUserProfileScope Scope, BSTR ObjectID, BSTR Key, VARIANT_BOOL* Value);

Параметры

Scope
Контекст данных.
ObjectID
Идентификатор объект, с которым ассоциируются данные. Может быть пустая строка.
Key
Идентификатор данных.

Возвращаемое значение

Возвращает True если данные по заданному ключу существуют, иначе возвращает False.

См.также

IIngeoUserProfile, TIngeoUserProfileScope


Метод Get (Объект IIngeoUserProfile)

Считывает данные.

Синтаксис

Язык | Описание
VBScript, JavaScript | FunctionGet(aScope, anObjectID, aKey, aDefault)
Visual Basic | Function Get(ByVal aScope As TIngeoUserProfileScope, ByVal anObjectID As String, ByVal aKey As String, ByVal aDefault As String) As String
Delphi | const function Get(aScope: TIngeoUserProfileScope; const anObjectID: WideString; const aKey: WideString; const aDefault: WideString): WideString;
C, C++ | HRESULT Get(TIngeoUserProfileScope aScope, BSTR anObjectID, BSTR aKey, BSTR aDefault, BSTR* Value);

Параметры

aScope
Контекст данных.
anObjectID
Идентификатор объект, с которым ассоциируются данные. Может быть пустая строка.
aKey
Идентификатор данных.
aDefault
Значение по умолчанию. Возвращается, если запрашиваемых данных нет.

Возвращаемое значение

Данные в виде строки.

См.также

IIngeoUserProfile, TIngeoUserProfileScope


Метод Put (Объект IIngeoUserProfile)

Сохраняет данные.

Синтаксис

Язык | Описание
VBScript, JavaScript | SubPut(aScope, anObjectID, aKey, aValue)
Visual Basic | Sub Put(ByVal aScope As TIngeoUserProfileScope, ByVal anObjectID As String, ByVal aKey As String, ByVal aValue As String)
Delphi | procedure Put(aScope: TIngeoUserProfileScope; const anObjectID: WideString; const aKey: WideString; const aValue: WideString);
C, C++ | HRESULT Put(TIngeoUserProfileScope aScope, BSTR anObjectID, BSTR aKey, BSTR aValue);

Параметры

aScope
Контекст данных.
anObjectID
Идентификатор объект, с которым ассоциируются данные. Может быть пустая строка.
aKey
Идентификатор данных.
aValue
Данные.

См.также

IIngeoUserProfile, TIngeoUserProfileScope


Свойство RoleIDs (Объект IIngeoUser)

Список ролей, которые играет пользователь.

Синтаксис

Язык Описание
VBScript, JavaScript
RoleIDs
Visual Basic
Property RoleIDs As Variant
Delphi
property RoleIDs: OleVariant
C, C++
HRESULT get_RoleIDs(VARIANT* Value);
HRESULT set_RoleIDs(VARIANT Value);

Примечания

Список задается в виде одномерного массива идентификаторов ролей.

См.также

IIngeoUser, IIngeoIDList, IIngeoRole


Объект IIngeoUsers

Коллекция пользователей.

Свойства

Свойство | Описание
Count | Количество пользователей.
Item | Возвращает пользователя.
_NewEnum | Возвращает перечислитель по элементам (пользователям) коллекции.

Методы

Метод | Описание
Add | Добавляет пользователя.
AddWithID | Добавляет пользователя с указанным идентификатором.
UserFromID | Возвращает пользователя с данным идентификатором.

См.также

IIngeoDb, IIngeoUser


Свойство _NewEnum (Объект IIngeoUsers)

Возвращает перечислитель по элементам (пользователям) коллекции.

Синтаксис

Язык Описание
VBScript, JavaScript
_NewEnum
Visual Basic
Property _NewEnum As Object
Delphi
property _NewEnum: IUnknown
C, C++
HRESULT get__NewEnum(IUnknown* Value);

См.также

IIngeoUsers, IIngeoUser


Метод Add (Объект IIngeoUsers)

Добавляет пользователя.

Синтаксис

Язык | Описание
VBScript, JavaScript | FunctionAdd()
Visual Basic | Function Add() As IIngeoUser
Delphi | function Add: IIngeoUser;
C, C++ | HRESULT Add(IIngeoUser** Value);

Возвращаемое значение

Добавленный пользователь.

См.также

IIngeoUsers, IIngeoUser


Метод AddWithID (Объект IIngeoUsers)

Добавляет пользователя с указанным идентификатором.

Синтаксис

Язык | Описание
VBScript, JavaScript | FunctionAddWithID(anID)
Visual Basic | Function AddWithID(ByVal anID As String) As IIngeoUser
Delphi | function AddWithID(const anID: WideString): IIngeoUser;
C, C++ | HRESULT AddWithID(BSTR anID, IIngeoUser** Value);

Параметры

anID
Идентификатор добавляемого пользователя.

Возвращаемое значение

Добавленный пользователь.

См.также

IIngeoUsers, IIngeoUser


Свойство Count (Объект IIngeoUsers)

Количество пользователей.

Синтаксис

Язык Описание
VBScript, JavaScript
Count
Visual Basic
Property Count As Long
Delphi
property Count: Longint
C, C++
HRESULT get_Count(long* Value);

См.также

IIngeoUsers


Свойство Item (Объект IIngeoUsers)

Возвращает пользователя. Пользователь задается по порядковому номеру.

Синтаксис

Язык Описание
VBScript, JavaScript
Item(anIndex)
Visual Basic
Property Item(ByVal anIndex As Long) As IIngeoUser
Delphi
property Item[anIndex: Longint]: IIngeoUser
C, C++
HRESULT get_Item(long anIndex, IIngeoUser** Value);

Параметры

anIndex
Порядковый номер.

См.также

IIngeoUsers, IIngeoUser


Метод UserFromID (Объект IIngeoUsers)

Возвращает пользователя с данным идентификатором.

Синтаксис

Язык | Описание
VBScript, JavaScript | FunctionUserFromID(anUserID)
Visual Basic | Function UserFromID(ByVal anUserID As String) As IIngeoUser
Delphi | function UserFromID(const anUserID: WideString): IIngeoUser;
C, C++ | HRESULT UserFromID(BSTR anUserID, IIngeoUser** Value);

Параметры

anUserID
Идентификатор пользователя.

Возвращаемое значение

Пользователь.

См.также

IIngeoUsers, IIngeoUser


Метод Update (Объект IIngeoUser)

Применяет сделанные изменения.

Синтаксис

Язык | Описание
VBScript, JavaScript | SubUpdate()
Visual Basic | Sub Update()
Delphi | procedure Update;
C, C++ | HRESULT Update();

См.также

IIngeoUser


Объект IIngeoVectorMap

Объект IIngeoVectorMap(IIngeoMap)

Объект VektorMap представляет собой векторную карту.

Свойства

Свойство | Наследуется от | Описание
AC | IIngeoMap | Права доступа.
Area | IIngeoMap | Территория, к которй принадлежит карта.
ID | IIngeoMap | Внутренний идентификатор карты.
Layers | Список слоев принадлежащих векторной карте.
MapType | IIngeoMap | Тип карты (растровая или векторная).
Modified | IIngeoMap | Признак измения значений свойств карты.
Name | IIngeoMap | Название карты.
VisibleMax | IIngeoMap | Максимальный диапазон видимости.
VisibleMin | IIngeoMap | Минимальный диапазон видимости.

Методы

Метод | Наследуется от | Описание
Delete | IIngeoMap | Удаление карты.
DropChanges | IIngeoMap | Отмена внесенных изменений.
Update | IIngeoMap | Сохранение внесенных изменений свойств карты в базу данных.

См.также

IIngeoArea, IIngeoMap


Свойство Layers (Объект IIngeoVectorMap)

Список слоев принадлежащих векторной карте.

Синтаксис

Язык Описание
VBScript, JavaScript
Layers
Visual Basic
Property Layers As IIngeoLayers
Delphi
property Layers: IIngeoLayers
C, C++
HRESULT get_Layers(IIngeoLayers** Value);


Объект IIngeoXmlResponse

Свойства

Свойство Описание
EOF

Методы

Метод Описание
Read


Свойство EOF (Объект IIngeoXmlResponse)

Синтаксис

Язык Описание
VBScript, JavaScript
EOF
Visual Basic
Property EOF As Boolean
Delphi
property EOF: WordBool
C, C++
HRESULT get_EOF(VARIANT_BOOL* Value);


Метод Read (Объект IIngeoXmlResponse)

Синтаксис

Язык | Описание
VBScript, JavaScript | FunctionRead(aCount, aFlags)
Visual Basic | Function Read(ByVal aCount As Long, ByVal aFlags As TIngeoXmlRequestFlags) As Variant
Delphi | function Read(aCount: Longint; aFlags: TIngeoXmlRequestFlags): OleVariant;
C, C++ | HRESULT Read(long aCount, TIngeoXmlRequestFlags aFlags, VARIANT* Value);

Параметры

aCount
aFlags


Объект IInGridFormat

Набор элементов формата.

Свойства

Свойство | Описание
Brush | Получение элемента набора, представляемого в виде закраски.
Font | Получение элемента набора, представляемого в виде шрифта.
Pen | Получение элемента набора, представляемого в виде окантовки.
Size | Получение элемента набора, представляемого в виде размера.
TextFormat | Получение элемента набора, представляемого в виде формата отображения текста.

Методы

Метод | Описание
ContainsKinds | Проверить переопределение указанных элементов набора форматов.
DropKinds | Удалить переопределение указанных элементов набора форматов.
Update | Обновить изменения, сделанные в наборе форматов.


Свойство Brush (Объект IInGridFormat)

Получение элемента набора, представляемого в виде закраски.

Синтаксис

Язык Описание
VBScript, JavaScript
Brush(aKind)
Visual Basic
Property Brush(ByVal aKind As TInGridFormatKind) As IInBrush
Delphi
property Brush[aKind: TInGridFormatKind]: IInBrush
C, C++
HRESULT get_Brush(TInGridFormatKind aKind, IInBrush** Value);

Параметры

aKind
Тип элемента набора. Допускаемые типы: ingfBrush.


Метод ContainsKinds (Объект IInGridFormat)

Проверить переопределение указанных элементов набора форматов.

Синтаксис

Язык | Описание
VBScript, JavaScript | FunctionContainsKinds(aKinds)
Visual Basic | Function ContainsKinds(ByVal aKinds As TInGridFormatKind) As Boolean
Delphi | function ContainsKinds(aKinds: TInGridFormatKind): WordBool;
C, C++ | HRESULT ContainsKinds(TInGridFormatKind aKinds, VARIANT_BOOL* Value);

Параметры

aKinds
Комбинация типов элементов набора формата, которые нужно проверить.


Метод DropKinds (Объект IInGridFormat)

Удалить переопределение указанных элементов набора форматов.

Синтаксис

Язык | Описание
VBScript, JavaScript | SubDropKinds(aKinds)
Visual Basic | Sub DropKinds(ByVal aKinds As TInGridFormatKind)
Delphi | procedure DropKinds(aKinds: TInGridFormatKind);
C, C++ | HRESULT DropKinds(TInGridFormatKind aKinds);

Параметры

aKinds
Комбинация типов элементов набора формата, которые нужно удалить.


Свойство Font (Объект IInGridFormat)

Получение элемента набора, представляемого в виде шрифта.

Синтаксис

Язык Описание
VBScript, JavaScript
Font(aKind)
Visual Basic
Property Font(ByVal aKind As TInGridFormatKind) As IInFont
Delphi
property Font[aKind: TInGridFormatKind]: IInFont
C, C++
HRESULT get_Font(TInGridFormatKind aKind, IInFont** Value);

Параметры

aKind
Тип элемента набора. Допускаемые типы: ingfFont.


Свойство Pen (Объект IInGridFormat)

Получение элемента набора, представляемого в виде окантовки.

Синтаксис

Язык Описание
VBScript, JavaScript
Pen(aKind)
Visual Basic
Property Pen(ByVal aKind As TInGridFormatKind) As IInPen
Delphi
property Pen[aKind: TInGridFormatKind]: IInPen
C, C++
HRESULT get_Pen(TInGridFormatKind aKind, IInPen** Value);

Параметры

aKind
Тип элемента набора. Допускаемые типы: ingfLeftPen, ingfTopPen, ingfRightPen. ingfBottomPen.


Свойство Size (Объект IInGridFormat)

Получение элемента набора, представляемого в виде размера.

Синтаксис

Язык Описание
VBScript, JavaScript
Size(aKind)
Visual Basic
Property Size(ByVal aKind As TInGridFormatKind) As Double
Delphi
property Size[aKind: TInGridFormatKind]: Double
C, C++
HRESULT get_Size(TInGridFormatKind aKind, double* Value);
HRESULT set_Size(TInGridFormatKind aKind, double Value);

Параметры

aKind
Тип элемента набора. Допускаемые типы: ingfColWidth, ingfRowHeight, ingfLeftIndent, ingfTopIndent, ingfRightIndent. ingfBottomIndent.


Свойство TextFormat (Объект IInGridFormat)

Получение элемента набора, представляемого в виде формата отображения текста.

Синтаксис

Язык Описание
VBScript, JavaScript
TextFormat(aKind)
Visual Basic
Property TextFormat(ByVal aKind As TInGridFormatKind) As TInGridTextFormat
Delphi
property TextFormat[aKind: TInGridFormatKind]: TInGridTextFormat
C, C++
HRESULT get_TextFormat(TInGridFormatKind aKind, TInGridTextFormat* Value);
HRESULT set_TextFormat(TInGridFormatKind aKind, TInGridTextFormat Value);

Параметры

aKind
Тип элемента набора. Допускаемые типы: ingfTextFormat.


Метод Update (Объект IInGridFormat)

Обновить изменения, сделанные в наборе форматов.

Синтаксис

Язык | Описание
VBScript, JavaScript | SubUpdate()
Visual Basic | Sub Update()
Delphi | procedure Update;
C, C++ | HRESULT Update();


Объект IInHTMLWindow

Объект IInHTMLWindow(IInWindow)

HTML окно.

Свойства

Свойство | Наследуется от | Описание
Browser | Объект управления HTML страницей (интерфейс IWebBrowser2).
Caption | IInWindow | Заголовок окна.
External Объект, предоставляемый скриптам HTML страницы, для связи с внешней средой.
Данный объект устанавливается программой создавшей HTML окно.
Для доступа к данному объекту из HTML-скриптов следует использовать window.external.
Height | IInWindow | Высота окна в пикселях.
Left | IInWindow | X координата левого верхнего угла окна.
Name | IInWindow | Имя окна.
ToolbarVisible | Признак видимости панели инструментов.
Top | IInWindow | Y координата верхнего левого угла окна.
Visible | IInWindow | Признак видимости.
Width | IInWindow | Ширина окна в пикселях.
WindowState | IInWindow | Текущее состояние окна.

Методы

Метод | Наследуется от | Описание
Close | IInWindow | Скрывает окно.
ShowModal | Открыть окно в модальном режиме.

Примечания

Данный объект наследует свойства и методы объекта IInWindow.


Свойство Browser (Объект IInHTMLWindow)

Объект управления HTML страницей (интерфейс IWebBrowser2).

Синтаксис

Язык Описание
VBScript, JavaScript
Browser
Visual Basic
Property Browser As Object
Delphi
property Browser: IDispatch
C, C++
HRESULT get_Browser(IDispatch* Value);


Свойство External (Объект IInHTMLWindow)

Объект, предоставляемый скриптам HTML страницы, для связи с внешней средой.
Данный объект устанавливается программой создавшей HTML окно.
Для доступа к данному объекту из HTML-скриптов следует использовать window.external.

Синтаксис

Язык Описание
VBScript, JavaScript
External
Visual Basic
Property External As Object
Delphi
property External: IDispatch
C, C++
HRESULT get_External(IDispatch* Value);
HRESULT set_External(IDispatch Value);


Метод ShowModal (Объект IInHTMLWindow)

Открыть окно в модальном режиме.

Синтаксис

Язык | Описание
VBScript, JavaScript | SubShowModal()
Visual Basic | Sub ShowModal()
Delphi | procedure ShowModal;
C, C++ | HRESULT ShowModal();


Свойство ToolbarVisible (Объект IInHTMLWindow)

Признак видимости панели инструментов.

Синтаксис

Язык Описание
VBScript, JavaScript
ToolbarVisible
Visual Basic
Property ToolbarVisible As Boolean
Delphi
property ToolbarVisible: WordBool
C, C++
HRESULT get_ToolbarVisible(VARIANT_BOOL* Value);
HRESULT set_ToolbarVisible(VARIANT_BOOL Value);

Примечания

Панель инструментов содержит кнопки навигации "назад" и "вперед".


Объект IInImage

Растровый рисунок.

Свойства

Свойство | Описание
Data | Данные в бинарном формате.
Height | Высота (в пикселях).
ResolutionX | Разрешение растра в точках на дюйм по оси X.
ResolutionY | Разрешение растра в точках на дюйм по оси Y.
Surface | Поверхность рисования.
Transparent | Зарезервировано.
TransparentColor | Определяет какой из цветов изображения не будет выводится при выводе изображения.
Width | Ширина (в пикселях).

Методы

Метод | Описание
LoadFromFile | Загрузить изображение из файла.
SaveToFile | Сохранить изображение в файл.

Пример

sub Rectangle(theSurface, x1, y1, x2, y2)
  Dim theContour, theContourPart
  Dim theParam

  theSurface.Pen.Color = 1
  Set theContour = Application.CreateObject(0, theParam)
  Set theContourPart = theContour.Insert(0)
  theContourPart.InsertVertex 0, x1, y1, 0
  theContourPart.InsertVertex -1, x1, y2, 0
  theContourPart.InsertVertex -1, x2, y2, 0
  theContourPart.InsertVertex -1, x2, y1, 0
  theContourPart.InsertVertex -1, x1, y1, 0

  theSurface.PaintContour theContour, true
end sub

' Вызывается при отпускании клавиши мыши над окном карты
sub MapEditors_MouseUp(aButton, aShift, aX, aY)
  Dim theImage, theParam
  Dim theContour, theContourPart

  Set theImage = Application.CreateObject(2, theParam)
  theImage.Width = 800
  theImage.Height = 600
  theImage.ResolutionX = 400
  theImage.ResolutionY = 400
  Dim x1, y1, x2, y2

  theImage.Surface.sPointDeviceToWorld 100, 100, x1, y1
  theImage.Surface.sPointDeviceToWorld 200, 200, x2, y2

  Rectangle theImage.Surface, x1, y1, x2, y2

  theImage.SaveToFile "c:\tmp\image1.jpg"
end sub

См.также

IIngeoApplication, CreateObject


Свойство Data (Объект IInImage)

Данные в бинарном формате.

Синтаксис

Язык Описание
VBScript, JavaScript
Data(aType)
Visual Basic
Property Data(ByVal aType As TInImageDataType) As Variant
Delphi
property Data[aType: TInImageDataType]: OleVariant
C, C++
HRESULT get_Data(TInImageDataType aType, VARIANT* Value);
HRESULT set_Data(TInImageDataType aType, VARIANT Value);

Параметры

aType
Тип файла изображения.


Свойство Height (Объект IInImage)

Высота (в пикселях).

Синтаксис

Язык Описание
VBScript, JavaScript
Height
Visual Basic
Property Height As Long
Delphi
property Height: Longint
C, C++
HRESULT get_Height(long* Value);
HRESULT set_Height(long Value);


Метод LoadFromFile (Объект IInImage)

Загрузить изображение из файла.

Синтаксис

Язык | Описание
VBScript, JavaScript | SubLoadFromFile(aFileName)
Visual Basic | Sub LoadFromFile(ByVal aFileName As String)
Delphi | procedure LoadFromFile(const aFileName: WideString);
C, C++ | HRESULT LoadFromFile(BSTR aFileName);

Параметры

aFileName
Имя файла.

Примечания

Поддерживаются следующие форматы файлов: BMP, JPG


Свойство ResolutionX (Объект IInImage)

Разрешение растра в точках на дюйм по оси X.
По умолчанию используется текущее экранное разрешение.

Синтаксис

Язык Описание
VBScript, JavaScript
ResolutionX
Visual Basic
Property ResolutionX As Long
Delphi
property ResolutionX: Longint
C, C++
HRESULT get_ResolutionX(long* Value);
HRESULT set_ResolutionX(long Value);

Примечания

Установка разрешения в 0 приведет к тому, что будет использовано текущее экранное разрешение.


Свойство ResolutionY (Объект IInImage)

Разрешение растра в точках на дюйм по оси Y.

Синтаксис

Язык Описание
VBScript, JavaScript
ResolutionY
Visual Basic
Property ResolutionY As Long
Delphi
property ResolutionY: Longint
C, C++
HRESULT get_ResolutionY(long* Value);
HRESULT set_ResolutionY(long Value);

Примечания

Установка разрешения в 0 приведет к тому, что будет использовано текущее экранное разрешение.


Метод SaveToFile (Объект IInImage)

Сохранить изображение в файл.

Синтаксис

Язык | Описание
VBScript, JavaScript | SubSaveToFile(aFileName)
Visual Basic | Sub SaveToFile(ByVal aFileName As String)
Delphi | procedure SaveToFile(const aFileName: WideString);
C, C++ | HRESULT SaveToFile(BSTR aFileName);

Параметры

aFileName
Имя файла.

Примечания

Тип сохраняемого файла определяется по его расширению.
При сохранении Jpeg файла в имени можно указать параметры сжатия см. метод MakeImageFile


Свойство Surface (Объект IInImage)

Поверхность рисования.
Используется для вывода изображения на растровый рисунок.

Синтаксис

Язык Описание
VBScript, JavaScript
Surface
Visual Basic
Property Surface As IIngeoPaintSurface
Delphi
property Surface: IIngeoPaintSurface
C, C++
HRESULT get_Surface(IIngeoPaintSurface** Value);

См.также

IIngeoDbPaintXml, IIngeoMapObject.Paint, IIngeoPainter.PaintContour, IIngeoStyle.PaintContour


Свойство Transparent (Объект IInImage)

Зарезервировано.

Синтаксис

Язык Описание
VBScript, JavaScript
Transparent
Visual Basic
Property Transparent As Boolean
Delphi
property Transparent: WordBool
C, C++
HRESULT get_Transparent(VARIANT_BOOL* Value);
HRESULT set_Transparent(VARIANT_BOOL Value);


Свойство TransparentColor (Объект IInImage)

Определяет какой из цветов изображения не будет выводится при выводе изображения.

Синтаксис

Язык Описание
VBScript, JavaScript
TransparentColor
Visual Basic
Property TransparentColor As Long
Delphi
property TransparentColor: Longint
C, C++
HRESULT get_TransparentColor(long* Value);
HRESULT set_TransparentColor(long Value);


Свойство Width (Объект IInImage)

Ширина (в пикселях).

Синтаксис

Язык Описание
VBScript, JavaScript
Width
Visual Basic
Property Width As Long
Delphi
property Width: Longint
C, C++
HRESULT get_Width(long* Value);
HRESULT set_Width(long Value);


Объект IInLayoutSelection

Содержит список элементов, выделенных в макете печати.

Свойства

Свойство | Описание
Count | Количество выделенных элементов.
Item | Получение элемента по индексу.

Методы

Метод | Описание
BeginUpdate | Начать обновление списка выделенных элементов.
Deselect | Снимает выделение с указанного объекта.
DeselectAll | Очищает список выделенных объектов.
EndUpdate | Закончить обновление списка выделенных элементов.
IsSelected | Возвращает True, если элемент выделен, иначе возвращает False.
Select | Выделяет указанный объект.
SelectAll | Выделяет все элементы макета печати.

См.также

IInLayoutWindow


Метод BeginUpdate (Объект IInLayoutSelection)

Начать обновление списка выделенных элементов.

Синтаксис

Язык | Описание
VBScript, JavaScript | SubBeginUpdate()
Visual Basic | Sub BeginUpdate()
Delphi | procedure BeginUpdate;
C, C++ | HRESULT BeginUpdate();


Свойство Count (Объект IInLayoutSelection)

Количество выделенных элементов.

Синтаксис

Язык Описание
VBScript, JavaScript
Count
Visual Basic
Property Count As Long
Delphi
property Count: Longint
C, C++
HRESULT get_Count(long* Value);


Метод Deselect (Объект IInLayoutSelection)

Снимает выделение с указанного объекта.

Синтаксис

Язык | Описание
VBScript, JavaScript | SubDeselect(aFigure)
Visual Basic | Sub Deselect(ByVal aFigure As IInPictureFigure)
Delphi | procedure Deselect(aFigure: IInPictureFigure);
C, C++ | HRESULT Deselect(IInPictureFigure* aFigure);

Параметры

aFigure
Элемент макета печати.


Метод DeselectAll (Объект IInLayoutSelection)

Очищает список выделенных объектов.

Синтаксис

Язык | Описание
VBScript, JavaScript | SubDeselectAll()
Visual Basic | Sub DeselectAll()
Delphi | procedure DeselectAll;
C, C++ | HRESULT DeselectAll();


Метод EndUpdate (Объект IInLayoutSelection)

Закончить обновление списка выделенных элементов.

Синтаксис

Язык | Описание
VBScript, JavaScript | SubEndUpdate()
Visual Basic | Sub EndUpdate()
Delphi | procedure EndUpdate;
C, C++ | HRESULT EndUpdate();


Метод IsSelected (Объект IInLayoutSelection)

Возвращает True, если элемент выделен, иначе возвращает False.

Синтаксис

Язык | Описание
VBScript, JavaScript | FunctionIsSelected(aFigure)
Visual Basic | Function IsSelected(ByVal aFigure As IInPictureFigure) As Boolean
Delphi | function IsSelected(aFigure: IInPictureFigure): WordBool;
C, C++ | HRESULT IsSelected(IInPictureFigure* aFigure, VARIANT_BOOL* Value);

Параметры

aFigure
Элемент макета печати.


Свойство Item (Объект IInLayoutSelection)

Получение элемента по индексу.

Синтаксис

Язык Описание
VBScript, JavaScript
Item(anIndex)
Visual Basic
Property Item(ByVal anIndex As Long) As IInPictureFigure
Delphi
property Item[anIndex: Longint]: IInPictureFigure
C, C++
HRESULT get_Item(long anIndex, IInPictureFigure** Value);

Параметры

anIndex
Индекс элемента в списке.


Метод Select (Объект IInLayoutSelection)

Выделяет указанный объект.

Синтаксис

Язык | Описание
VBScript, JavaScript | SubSelect(aFigure)
Visual Basic | Sub Select(ByVal aFigure As IInPictureFigure)
Delphi | procedure Select(aFigure: IInPictureFigure);
C, C++ | HRESULT Select(IInPictureFigure* aFigure);

Параметры

aFigure
Элемент макета печати.


Метод SelectAll (Объект IInLayoutSelection)

Выделяет все элементы макета печати.

Синтаксис

Язык | Описание
VBScript, JavaScript | SubSelectAll()
Visual Basic | Sub SelectAll()
Delphi | procedure SelectAll;
C, C++ | HRESULT SelectAll();


Объект IInLayoutWindow

Объект IInLayoutWindow(IInWindow)

Окно макета печати.

Свойства

Свойство | Наследуется от | Описание
Actions | Список команд окна макета печати.
Caption | IInWindow | Заголовок окна.
DesignMode | Режим конструктора.
Figures | Список элементов рисунка макета печати.
Height | IInWindow | Высота окна в пикселях.
Left | IInWindow | X координата левого верхнего угла окна.
Menu | Главное меню окна макета печати.
Modified | Признак внесения изменений в макет печати.
Name | IInWindow | Имя окна.
PrintParams | Параметры печати.
Selection | Список отмеченных элементов в макете печати.
Top | IInWindow | Y координата верхнего левого угла окна.
Visible | IInWindow | Признак видимости.
Width | IInWindow | Ширина окна в пикселях.
WindowState | IInWindow | Текущее состояние окна.

Методы

Метод | Наследуется от | Описание
Close | IInWindow | Скрывает окно.
NewLayout | Очищает список элементов и сбрасывает признак модификации.
OpenLayout | Открывает макет печати из указанного файла.
PrintPage | Выводит заданную страницу на печать.
SaveLayout | Сохраняет макет печати в файл.
SaveLayoutAs | Сохраняет макет печати в файл с заданным именем

Примечания

Этот объект наследует свойства и методы объекта IInWindow.
В скриптовых модулях макета печати, доступ к свойствам текущего макета можно получить через переменную с именем LayoutWindow типа IInLayoutWindow.

См.также

IInWindow, IInPictureFigures, IInUIActions, IInUIMenu, IInPrintParams, IInLayoutSelection


Свойство Actions (Объект IInLayoutWindow)

Список команд окна макета печати.

Синтаксис

Язык Описание
VBScript, JavaScript
Actions
Visual Basic
Property Actions As IInUIActions
Delphi
property Actions: IInUIActions
C, C++
HRESULT get_Actions(IInUIActions** Value);

См.также

IInUIActions


Свойство DesignMode (Объект IInLayoutWindow)

Режим конструктора.

Синтаксис

Язык Описание
VBScript, JavaScript
DesignMode
Visual Basic
Property DesignMode As Boolean
Delphi
property DesignMode: WordBool
C, C++
HRESULT get_DesignMode(VARIANT_BOOL* Value);
HRESULT set_DesignMode(VARIANT_BOOL Value);


Свойство Figures (Объект IInLayoutWindow)

Список элементов рисунка макета печати.

Синтаксис

Язык Описание
VBScript, JavaScript
Figures
Visual Basic
Property Figures As IInPictureFigures
Delphi
property Figures: IInPictureFigures
C, C++
HRESULT get_Figures(IInPictureFigures** Value);

См.также

IInPictureFigures


Свойство Menu (Объект IInLayoutWindow)

Главное меню окна макета печати.

Синтаксис

Язык Описание
VBScript, JavaScript
Menu
Visual Basic
Property Menu As IInUIMenu
Delphi
property Menu: IInUIMenu
C, C++
HRESULT get_Menu(IInUIMenu** Value);

См.также

IInUIMenu


Свойство Modified (Объект IInLayoutWindow)

Признак внесения изменений в макет печати.

Синтаксис

Язык Описание
VBScript, JavaScript
Modified
Visual Basic
Property Modified As Boolean
Delphi
property Modified: WordBool
C, C++
HRESULT get_Modified(VARIANT_BOOL* Value);
HRESULT set_Modified(VARIANT_BOOL Value);


Метод NewLayout (Объект IInLayoutWindow)

Очищает список элементов и сбрасывает признак модификации.

Синтаксис

Язык | Описание
VBScript, JavaScript | SubNewLayout()
Visual Basic | Sub NewLayout()
Delphi | procedure NewLayout;
C, C++ | HRESULT NewLayout();


Метод OpenLayout (Объект IInLayoutWindow)

Открывает макет печати из указанного файла.

Синтаксис

Язык | Описание
VBScript, JavaScript | SubOpenLayout(aFileName)
Visual Basic | Sub OpenLayout(ByVal aFileName As String)
Delphi | procedure OpenLayout(const aFileName: WideString);
C, C++ | HRESULT OpenLayout(BSTR aFileName);

Параметры

aFileName
Имя файла макета печати.


Метод PrintPage (Объект IInLayoutWindow)

Выводит заданную страницу на печать.

Синтаксис

Язык | Описание
VBScript, JavaScript | SubPrintPage(aPageNumX, aPageNumY, aCopies, aJobTitle, aFileName)
Visual Basic | Sub PrintPage(ByVal aPageNumX As Long, ByVal aPageNumY As Long, ByVal aCopies As Long, ByVal aJobTitle As String, ByVal aFileName As String)
Delphi | procedure PrintPage(aPageNumX: Longint; aPageNumY: Longint; aCopies: Longint; const aJobTitle: WideString; const aFileName: WideString);
C, C++ | HRESULT PrintPage(long aPageNumX, long aPageNumY, long aCopies, BSTR aJobTitle, BSTR aFileName);

Параметры

aPageNumX
Порядковый номер страницы по горизонтали.
aPageNumY
Порядковый номер страницы по вертикали.
aCopies
Количество копий.
aJobTitle
Имя документа.
aFileName
Если задано имя файла, то печать будет производится в заданный файл.

Примечания

В связи с тем, что размер страницы принтера может быть меньше размера страницы макета печати, печать всего макета может быть произведена только постранично.
Страница с номером (0,0) располагается в нижнем левом угле макета печати .


Свойство PrintParams (Объект IInLayoutWindow)

Параметры печати.

Синтаксис

Язык Описание
VBScript, JavaScript
PrintParams
Visual Basic
Property PrintParams As IInPrintParams
Delphi
property PrintParams: IInPrintParams
C, C++
HRESULT get_PrintParams(IInPrintParams** Value);


Метод SaveLayout (Объект IInLayoutWindow)

Сохраняет макет печати в файл.

Синтаксис

Язык | Описание
VBScript, JavaScript | SubSaveLayout()
Visual Basic | Sub SaveLayout()
Delphi | procedure SaveLayout;
C, C++ | HRESULT SaveLayout();


Метод SaveLayoutAs (Объект IInLayoutWindow)

Сохраняет макет печати в файл с заданным именем

Синтаксис

Язык | Описание
VBScript, JavaScript | SubSaveLayoutAs(aFileName)
Visual Basic | Sub SaveLayoutAs(ByVal aFileName As String)
Delphi | procedure SaveLayoutAs(const aFileName: WideString);
C, C++ | HRESULT SaveLayoutAs(BSTR aFileName);

Параметры

aFileName
Имя файла макета печати.


Свойство Selection (Объект IInLayoutWindow)

Список отмеченных элементов в макете печати.

Синтаксис

Язык Описание
VBScript, JavaScript
Selection
Visual Basic
Property Selection As IInLayoutSelection
Delphi
property Selection: IInLayoutSelection
C, C++
HRESULT get_Selection(IInLayoutSelection** Value);


Объект IInModuleSink

События уровня модуля.

Методы

Метод | Описание
StartComplete | Вызывается при старте модуля.
WillStop | Вызывается при остановке модуля.


Метод StartComplete (Объект IInModuleSink)

Вызывается при старте модуля.

Синтаксис

Язык | Описание
VBScript, JavaScript | SubStartComplete()
Visual Basic | Sub StartComplete()
Delphi | procedure StartComplete;
C, C++ | HRESULT StartComplete();


Метод WillStop (Объект IInModuleSink)

Вызывается при остановке модуля.

Синтаксис

Язык | Описание
VBScript, JavaScript | SubWillStop()
Visual Basic | Sub WillStop()
Delphi | procedure WillStop;
C, C++ | HRESULT WillStop();


Объект IInPen

Окантовка.

Свойства

Свойство | Описание
Color | Цвет линии.
ForZoomScale | Для масштаба.
Mode | Режим отрисовки.
Style | Стиль окантовки.
WidthInMM | Ширина линии окантовки в мм.

См.также

IInBrush, IInFont, TInPenStyle, TInPenMode


Свойство Color (Объект IInPen)

Цвет линии.

Синтаксис

Язык Описание
VBScript, JavaScript
Color
Visual Basic
Property Color As Long
Delphi
property Color: Longint
C, C++
HRESULT get_Color(long* Value);
HRESULT set_Color(long Value);


Свойство ForZoomScale (Объект IInPen)

Значение масштаба, для которого определяется ширина линии окантовки.

Синтаксис

Язык Описание
VBScript, JavaScript
ForZoomScale
Visual Basic
Property ForZoomScale As Double
Delphi
property ForZoomScale: Double
C, C++
HRESULT get_ForZoomScale(double* Value);
HRESULT set_ForZoomScale(double Value);

См.также

IInPenWidthInMM


Свойство Mode (Объект IInPen)

Режим отрисовки.

Синтаксис

Язык Описание
VBScript, JavaScript
Mode
Visual Basic
Property Mode As TInPenMode
Delphi
property Mode: TInPenMode
C, C++
HRESULT get_Mode(TInPenMode* Value);
HRESULT set_Mode(TInPenMode Value);


Свойство Style (Объект IInPen)

Стиль окантовки.

Синтаксис

Язык Описание
VBScript, JavaScript
Style
Visual Basic
Property Style As TInPenStyle
Delphi
property Style: TInPenStyle
C, C++
HRESULT get_Style(TInPenStyle* Value);
HRESULT set_Style(TInPenStyle Value);

См.также

TInPenStyle


Свойство WidthInMM (Объект IInPen)

Ширина линии окантовки в мм.

Синтаксис

Язык Описание
VBScript, JavaScript
WidthInMM
Visual Basic
Property WidthInMM As Double
Delphi
property WidthInMM: Double
C, C++
HRESULT get_WidthInMM(double* Value);
HRESULT set_WidthInMM(double Value);

Примечания

Влияет только на ширину линии сплошной окантовки.

См.также

TInPenStyle


Объект IInPictureEllipseFigure

Объект IInPictureEllipseFigure(IInPictureFigure)

Элемент рисунка - круг.

Свойства

Свойство | Наследуется от | Описание
Bottom | IInPictureFigure | Нижняя граница элемента.
Brush | Закраска.
FigureType | IInPictureFigure | Тип элемента рисунка.
Height | IInPictureFigure | Высота элемента.
Left | IInPictureFigure | Левая граница элемента.
Name | IInPictureFigure | Имя (название) элемента рисунка.
Pen | Окантовка.
Visible | IInPictureFigure | Признак видимости элемента.
Width | IInPictureFigure | Ширина элемента.

Примечания

Этот объект наследует свойства и методы объекта IInPictureFigure.

См.также

IInPictureFigures, IInPictureFigure, IInPen, IInBrush


Свойство Brush (Объект IInPictureEllipseFigure)

Закраска.

Синтаксис

Язык Описание
VBScript, JavaScript
Brush
Visual Basic
Property Brush As IInBrush
Delphi
property Brush: IInBrush
C, C++
HRESULT get_Brush(IInBrush** Value);

См.также

IInBrush


Свойство Pen (Объект IInPictureEllipseFigure)

Окантовка.

Синтаксис

Язык Описание
VBScript, JavaScript
Pen
Visual Basic
Property Pen As IInPen
Delphi
property Pen: IInPen
C, C++
HRESULT get_Pen(IInPen** Value);

См.также

IInPen


Объект IInPictureFigure

Элемент рисунка.

Свойства

Свойство | Описание
Bottom | Нижняя граница элемента.
FigureType | Тип элемента рисунка.
Height | Высота элемента.
Left | Левая граница элемента.
Name | Имя (название) элемента рисунка.
Visible | Признак видимости элемента.
Width | Ширина элемента.

Примечания

Координаты границ элемента, а также его габариты задаются в метрах.
Точка с координатами (0,0) располагается в левом нижнем углу.
Ось OX горизонтальна и направлена вправо, ось OY перпендикулярна ей и направлена вверх.

См.также

IInPictureFigures, TInPictureFigureType


Свойство Bottom (Объект IInPictureFigure)

Нижняя граница элемента.

Синтаксис

Язык Описание
VBScript, JavaScript
Bottom
Visual Basic
Property Bottom As Double
Delphi
property Bottom: Double
C, C++
HRESULT get_Bottom(double* Value);
HRESULT set_Bottom(double Value);


Свойство FigureType (Объект IInPictureFigure)

Тип элемента рисунка.

Синтаксис

Язык Описание
VBScript, JavaScript
FigureType
Visual Basic
Property FigureType As TInPictureFigureType
Delphi
property FigureType: TInPictureFigureType
C, C++
HRESULT get_FigureType(TInPictureFigureType* Value);


Свойство Height (Объект IInPictureFigure)

Высота элемента.

Синтаксис

Язык Описание
VBScript, JavaScript
Height
Visual Basic
Property Height As Double
Delphi
property Height: Double
C, C++
HRESULT get_Height(double* Value);
HRESULT set_Height(double Value);


Свойство Left (Объект IInPictureFigure)

Левая граница элемента.

Синтаксис

Язык Описание
VBScript, JavaScript
Left
Visual Basic
Property Left As Double
Delphi
property Left: Double
C, C++
HRESULT get_Left(double* Value);
HRESULT set_Left(double Value);


Свойство Name (Объект IInPictureFigure)

Имя (название) элемента рисунка.

Синтаксис

Язык Описание
VBScript, JavaScript
Name
Visual Basic
Property Name As String
Delphi
property Name: WideString
C, C++
HRESULT get_Name(BSTR* Value);


Объект IInPictureFigures

Список элементов рисунка.

Свойства

Свойство | Описание
Count | Количество элементов рисунка.
Item | Получение элемента рисунка по индексу или имени.
_NewEnum | Служебный объект для перебора элементов списка.

Методы

Метод | Описание
Add | Добавляет новый элемент в рисунок.
Delete | Удаляет элемент с заданным индексом из списка.
Find | Возвращает элемент рисунка по его имени, если он присутствует в списке, иначе возвращает Null.
IndexOf | Возвращает индекс рисунка в списке по его ссылке.
IsExists | Возвращает true, если элемент с именем aName присутствует в списке, иначе возвращает false.


Свойство _NewEnum (Объект IInPictureFigures)

Служебный объект для перебора элементов списка.

Синтаксис

Язык Описание
VBScript, JavaScript
_NewEnum
Visual Basic
Property _NewEnum As Object
Delphi
property _NewEnum: IUnknown
C, C++
HRESULT get__NewEnum(IUnknown* Value);


Метод Add (Объект IInPictureFigures)

Добавляет новый элемент в рисунок.

Синтаксис

Язык | Описание
VBScript, JavaScript | FunctionAdd(aFigureType)
Visual Basic | Function Add(ByVal aFigureType As TInPictureFigureType) As IInPictureFigure
Delphi | function Add(aFigureType: TInPictureFigureType): IInPictureFigure;
C, C++ | HRESULT Add(TInPictureFigureType aFigureType, IInPictureFigure** Value);

Параметры

aFigureType
Тип добавляемого элемента.

См.также

TInPictureFigureType


Свойство Count (Объект IInPictureFigures)

Количество элементов рисунка.

Синтаксис

Язык Описание
VBScript, JavaScript
Count
Visual Basic
Property Count As Long
Delphi
property Count: Longint
C, C++
HRESULT get_Count(long* Value);


Метод Delete (Объект IInPictureFigures)

Удаляет элемент с заданным индексом из списка.

Синтаксис

Язык | Описание
VBScript, JavaScript | SubDelete(anIndex)
Visual Basic | Sub Delete(ByVal anIndex As Long)
Delphi | procedure Delete(anIndex: Longint);
C, C++ | HRESULT Delete(long anIndex);

Параметры

anIndex
Индекс элемента.


Метод Find (Объект IInPictureFigures)

Возвращает элемент рисунка по его имени, если он присутствует в списке, иначе возвращает Null.

Синтаксис

Язык | Описание
VBScript, JavaScript | FunctionFind(aName)
Visual Basic | Function Find(ByVal aName As String) As IInPictureFigure
Delphi | function Find(const aName: WideString): IInPictureFigure;
C, C++ | HRESULT Find(BSTR aName, IInPictureFigure** Value);

Параметры

aName
Имя элемента рисунка.


Метод IndexOf (Объект IInPictureFigures)

Возвращает индекс рисунка в списке по его ссылке.

Синтаксис

Язык | Описание
VBScript, JavaScript | FunctionIndexOf(aFigure)
Visual Basic | Function IndexOf(ByVal aFigure As IInPictureFigure) As Long
Delphi | function IndexOf(aFigure: IInPictureFigure): Longint;
C, C++ | HRESULT IndexOf(IInPictureFigure* aFigure, long* Value);

Параметры

aFigure
Элемент рисунка


Метод IsExists (Объект IInPictureFigures)

Возвращает true, если элемент с именем aName присутствует в списке, иначе возвращает false.

Синтаксис

Язык | Описание
VBScript, JavaScript | FunctionIsExists(aName)
Visual Basic | Function IsExists(ByVal aName As String) As Boolean
Delphi | function IsExists(const aName: WideString): WordBool;
C, C++ | HRESULT IsExists(BSTR aName, VARIANT_BOOL* Value);

Параметры

aName
Имя элемента рисунка.


Свойство Item (Объект IInPictureFigures)

Получение элемента рисунка по индексу или имени.

Синтаксис

Язык Описание
VBScript, JavaScript
Item(anIndex)
Visual Basic
Property Item(ByVal anIndex As Variant) As IInPictureFigure
Delphi
property Item[anIndex: OleVariant]: IInPictureFigure
C, C++
HRESULT get_Item(VARIANT anIndex, IInPictureFigure** Value);

Параметры

anIndex
Индекс или имя элемента рисунка.

См.также

TInPictureFigureType


Свойство Visible (Объект IInPictureFigure)

Признак видимости элемента.

Синтаксис

Язык Описание
VBScript, JavaScript
Visible
Visual Basic
Property Visible As Boolean
Delphi
property Visible: WordBool
C, C++
HRESULT get_Visible(VARIANT_BOOL* Value);
HRESULT set_Visible(VARIANT_BOOL Value);


Свойство Width (Объект IInPictureFigure)

Ширина элемента.

Синтаксис

Язык Описание
VBScript, JavaScript
Width
Visual Basic
Property Width As Double
Delphi
property Width: Double
C, C++
HRESULT get_Width(double* Value);
HRESULT set_Width(double Value);


Объект IInPictureGridFigure

Объект IInPictureGridFigure(IInPictureFigure)

Элемент рисунка - таблица.

Свойства

Свойство | Наследуется от | Описание
Bottom | IInPictureFigure | Нижняя граница элемента.
CellFormat | Формат ячеек по умолчанию.
ColCount | Количество столбцов.
ColFormat | Формат столбцов по умолчанию.
FigureType | IInPictureFigure | Тип элемента рисунка.
GridFormat | Формат окантовки таблицы.
Height | IInPictureFigure | Высота элемента.
Left | IInPictureFigure | Левая граница элемента.
LeftCol | Левый столбец, начиная с которого отображаются ячейки.
Name | IInPictureFigure | Имя (название) элемента рисунка.
RowCount | Количество строк.
RowFormat | Формат строк по умолчанию.
Text | Содержимое ячейки таблицы.
TopRow | Верхняя строка, начиная с которой отображаются ячейки.
Visible | IInPictureFigure | Признак видимости элемента.
Width | IInPictureFigure | Ширина элемента.

Методы

Метод | Описание
ContainsFormat | Проверка - переопределен-ли формат ячейки, строки или столбца.
DropFormat | Удалить переопределение формата ячейки, строки или столбца (если таковое имело место).
GetFormat | Получить или создать переопределения формата ячейки, строки или столбца.

Примечания

Этот объект наследует свойства и методы объекта IInPictureFigure.

См.также

IInPictureFigures, IInPictureFigure, IInGridFormat


Свойство CellFormat (Объект IInPictureGridFigure)

Формат ячеек по умолчанию.

Синтаксис

Язык Описание
VBScript, JavaScript
CellFormat
Visual Basic
Property CellFormat As IInGridFormat
Delphi
property CellFormat: IInGridFormat
C, C++
HRESULT get_CellFormat(IInGridFormat** Value);

Примечания

Доступные элементы формата: ingfFont, ingfTextFormat, ingfLeftIndent, ingfTopIndent, ingfRightIndent, ingfBottomIndent, ingfBrush.


Свойство ColCount (Объект IInPictureGridFigure)

Количество столбцов.

Синтаксис

Язык Описание
VBScript, JavaScript
ColCount
Visual Basic
Property ColCount As Long
Delphi
property ColCount: Longint
C, C++
HRESULT get_ColCount(long* Value);
HRESULT set_ColCount(long Value);


Свойство ColFormat (Объект IInPictureGridFigure)

Формат столбцов по умолчанию.

Синтаксис

Язык Описание
VBScript, JavaScript
ColFormat
Visual Basic
Property ColFormat As IInGridFormat
Delphi
property ColFormat: IInGridFormat
C, C++
HRESULT get_ColFormat(IInGridFormat** Value);

Примечания

Доступные элементы формата: ingfLeftPen, ingfTopPen, ingfRightPen, ingfBottomPen, ingfColWidth.


Метод ContainsFormat (Объект IInPictureGridFigure)

Проверка - переопределен-ли формат ячейки, строки или столбца.

Синтаксис

Язык | Описание
VBScript, JavaScript | FunctionContainsFormat(aCol, aRow)
Visual Basic | Function ContainsFormat(ByVal aCol As Long, ByVal aRow As Long) As Boolean
Delphi | function ContainsFormat(aCol: Longint; aRow: Longint): WordBool;
C, C++ | HRESULT ContainsFormat(long aCol, long aRow, VARIANT_BOOL* Value);

Параметры

aCol
Номер столбца. Если "-1", то проверяется переопределение формата строки.
aRow
Номер строки. Если "-1", то проверяется переопределение формата столбца.


Метод DropFormat (Объект IInPictureGridFigure)

Удалить переопределение формата ячейки, строки или столбца (если таковое имело место).

Синтаксис

Язык | Описание
VBScript, JavaScript | SubDropFormat(aCol, aRow)
Visual Basic | Sub DropFormat(ByVal aCol As Long, ByVal aRow As Long)
Delphi | procedure DropFormat(aCol: Longint; aRow: Longint);
C, C++ | HRESULT DropFormat(long aCol, long aRow);

Параметры

aCol
Номер столбца. Если "-1", то удаляется переопределение формата строки.
aRow
Номер строки. Если "-1", то удаляется переопределение формата столбца.


Метод GetFormat (Объект IInPictureGridFigure)

Получить или создать переопределения формата ячейки, строки или столбца.

Синтаксис

Язык | Описание
VBScript, JavaScript | FunctionGetFormat(aCol, aRow)
Visual Basic | Function GetFormat(ByVal aCol As Long, ByVal aRow As Long) As IInGridFormat
Delphi | function GetFormat(aCol: Longint; aRow: Longint): IInGridFormat;
C, C++ | HRESULT GetFormat(long aCol, long aRow, IInGridFormat** Value);

Параметры

aCol
Номер столбца. Если "-1", то переопределяется формат строки.
aRow
Номер строки. Если "-1", то переопределяется формат столбца.

Примечания

Набор доступных элементов формата зависит от того какой формат переопределяется: ячейки, строки или столбца.

Для ячеек доступны:

ingfFont, ingfTextFormat, ingfLeftIndent, ingfTopIndent, ingfRightIndent, ingfBottomIndent, ingfBrush, ingfLeftPen, ingfTopPen, ingfRightPen, ingfBottomPen.

Для строк доступны:

ingfFont, ingfTextFormat, ingfLeftIndent, ingfTopIndent, ingfRightIndent, ingfBottomIndent, ingfBrush, ingfLeftPen, ingfTopPen, ingfRightPen, ingfBottomPen, ingfRowHeight.

Для столбцов доступны: ingfFont, ingfTextFormat, ingfLeftIndent, ingfTopIndent, ingfRightIndent, ingfBottomIndent, ingfBrush, ingfLeftPen, ingfTopPen, ingfRightPen, ingfBottomPen, ingfColWidth.


Свойство GridFormat (Объект IInPictureGridFigure)

Формат окантовки таблицы.

Синтаксис

Язык Описание
VBScript, JavaScript
GridFormat
Visual Basic
Property GridFormat As IInGridFormat
Delphi
property GridFormat: IInGridFormat
C, C++
HRESULT get_GridFormat(IInGridFormat** Value);

Примечания

Доступные элементы формата: ingfLeftPen, ingfTopPen, ingfRightPen, ingfBottomPen.


Свойство LeftCol (Объект IInPictureGridFigure)

Левый столбец, начиная с которого отображаются ячейки.

Синтаксис

Язык Описание
VBScript, JavaScript
LeftCol
Visual Basic
Property LeftCol As Long
Delphi
property LeftCol: Longint
C, C++
HRESULT get_LeftCol(long* Value);
HRESULT set_LeftCol(long Value);


Свойство RowCount (Объект IInPictureGridFigure)

Количество строк.

Синтаксис

Язык Описание
VBScript, JavaScript
RowCount
Visual Basic
Property RowCount As Long
Delphi
property RowCount: Longint
C, C++
HRESULT get_RowCount(long* Value);
HRESULT set_RowCount(long Value);


Свойство RowFormat (Объект IInPictureGridFigure)

Формат строк по умолчанию.

Синтаксис

Язык Описание
VBScript, JavaScript
RowFormat
Visual Basic
Property RowFormat As IInGridFormat
Delphi
property RowFormat: IInGridFormat
C, C++
HRESULT get_RowFormat(IInGridFormat** Value);

Примечания

Доступные элементы формата: ingfLeftPen, ingfTopPen, ingfRightPen, ingfBottomPen, ingfRowHeight.


Свойство Text (Объект IInPictureGridFigure)

Содержимое ячейки таблицы.

Синтаксис

Язык Описание
VBScript, JavaScript
Text(aCol, aRow)
Visual Basic
Property Text(ByVal aCol As Long, ByVal aRow As Long) As String
Delphi
property Text[aCol: Longint; aRow: Longint]: WideString
C, C++
HRESULT get_Text(long aCol, long aRow, BSTR* Value);
HRESULT set_Text(long aCol, long aRow, BSTR Value);

Параметры

aCol
Номер столбца (начиная с нуля).
aRow
Номер строки (начиная с нуля).


Свойство TopRow (Объект IInPictureGridFigure)

Верхняя строка, начиная с которой отображаются ячейки.

Синтаксис

Язык Описание
VBScript, JavaScript
TopRow
Visual Basic
Property TopRow As Long
Delphi
property TopRow: Longint
C, C++
HRESULT get_TopRow(long* Value);
HRESULT set_TopRow(long Value);


Объект IInPictureLineFigure

Объект IInPictureLineFigure(IInPictureFigure)

Элемент рисунка - линия.

Свойства

Свойство | Наследуется от | Описание
Bottom | IInPictureFigure | Нижняя граница элемента.
FigureType | IInPictureFigure | Тип элемента рисунка.
Height | IInPictureFigure | Высота элемента.
Left | IInPictureFigure | Левая граница элемента.
Name | IInPictureFigure | Имя (название) элемента рисунка.
Pen | Окантовка.
Visible | IInPictureFigure | Признак видимости элемента.
Width | IInPictureFigure | Ширина элемента.
X1 | Координата Х начальной точки.
X2 | Координата Х конечной точки.
Y1 | Координата Y начальной точки.
Y2 | Координата Y конечной точки.

Примечания

Этот объект наследует свойства и методы объекта IInPictureFigure.

См.также

IInPictureFigures, IInPictureFigure, IInPen


Свойство Pen (Объект IInPictureLineFigure)

Окантовка.

Синтаксис

Язык Описание
VBScript, JavaScript
Pen
Visual Basic
Property Pen As IInPen
Delphi
property Pen: IInPen
C, C++
HRESULT get_Pen(IInPen** Value);

См.также

IInPen


Свойство X1 (Объект IInPictureLineFigure)

Координата Х начальной точки.

Синтаксис

Язык Описание
VBScript, JavaScript
X1
Visual Basic
Property X1 As Double
Delphi
property X1: Double
C, C++
HRESULT get_X1(double* Value);
HRESULT set_X1(double Value);


Свойство X2 (Объект IInPictureLineFigure)

Координата Х конечной точки.

Синтаксис

Язык Описание
VBScript, JavaScript
X2
Visual Basic
Property X2 As Double
Delphi
property X2: Double
C, C++
HRESULT get_X2(double* Value);
HRESULT set_X2(double Value);


Свойство Y1 (Объект IInPictureLineFigure)

Координата Y начальной точки.

Синтаксис

Язык Описание
VBScript, JavaScript
Y1
Visual Basic
Property Y1 As Double
Delphi
property Y1: Double
C, C++
HRESULT get_Y1(double* Value);
HRESULT set_Y1(double Value);


Свойство Y2 (Объект IInPictureLineFigure)

Координата Y конечной точки.

Синтаксис

Язык Описание
VBScript, JavaScript
Y2
Visual Basic
Property Y2 As Double
Delphi
property Y2: Double
C, C++
HRESULT get_Y2(double* Value);
HRESULT set_Y2(double Value);


Объект IInPictureMapFigure

Объект IInPictureMapFigure(IInPictureFigure)

Элемент рисунка - Карта.

Свойства

Свойство | Наследуется от | Описание
Bottom | IInPictureFigure | Нижняя граница элемента.
Brush | Закраска.
CenterX | X координаты центра карты.
CenterY | Y координаты центра карты.
FigureType | IInPictureFigure | Тип элемента рисунка.
Height | IInPictureFigure | Высота элемента.
Left | IInPictureFigure | Левая граница элемента.
MapVisible | Признак видимости.
Name | IInPictureFigure | Имя (название) элемента рисунка.
Pen | Окантовка.
Visible | IInPictureFigure | Признак видимости элемента.
Width | IInPictureFigure | Ширина элемента.
XAngle | Угол между горизонталью и осью OX (в радианах).
YMirror | Признак, того что ось Y перевернута относительно оси OX.
ZoomScale | Масштаб.

Примечания

Этот объект наследует свойства и методы объекта IInPictureFigure.

См.также

IInPictureFigures, IInPictureFigure, IInPen, IInBrush


Свойство Brush (Объект IInPictureMapFigure)

Закраска.

Синтаксис

Язык Описание
VBScript, JavaScript
Brush
Visual Basic
Property Brush As IInBrush
Delphi
property Brush: IInBrush
C, C++
HRESULT get_Brush(IInBrush** Value);


Свойство CenterX (Объект IInPictureMapFigure)

X координаты центра карты (в мировой системе координат).

Синтаксис

Язык Описание
VBScript, JavaScript
CenterX
Visual Basic
Property CenterX As Double
Delphi
property CenterX: Double
C, C++
HRESULT get_CenterX(double* Value);
HRESULT set_CenterX(double Value);


Свойство CenterY (Объект IInPictureMapFigure)

Y координаты центра карты (в мировой системе координат).

Синтаксис

Язык Описание
VBScript, JavaScript
CenterY
Visual Basic
Property CenterY As Double
Delphi
property CenterY: Double
C, C++
HRESULT get_CenterY(double* Value);
HRESULT set_CenterY(double Value);


Свойство MapVisible (Объект IInPictureMapFigure)

Признак видимости.

Синтаксис

Язык Описание
VBScript, JavaScript
MapVisible
Visual Basic
Property MapVisible As Boolean
Delphi
property MapVisible: WordBool
C, C++
HRESULT get_MapVisible(VARIANT_BOOL* Value);
HRESULT set_MapVisible(VARIANT_BOOL Value);


Свойство Pen (Объект IInPictureMapFigure)

Окантовка.

Синтаксис

Язык Описание
VBScript, JavaScript
Pen
Visual Basic
Property Pen As IInPen
Delphi
property Pen: IInPen
C, C++
HRESULT get_Pen(IInPen** Value);


Свойство XAngle (Объект IInPictureMapFigure)

Угол между горизонталью и осью OX (в радианах).

Синтаксис

Язык Описание
VBScript, JavaScript
XAngle
Visual Basic
Property XAngle As Double
Delphi
property XAngle: Double
C, C++
HRESULT get_XAngle(double* Value);
HRESULT set_XAngle(double Value);


Свойство YMirror (Объект IInPictureMapFigure)

Признак, того что ось Y перевернута относительно оси OX.

Синтаксис

Язык Описание
VBScript, JavaScript
YMirror
Visual Basic
Property YMirror As Boolean
Delphi
property YMirror: WordBool
C, C++
HRESULT get_YMirror(VARIANT_BOOL* Value);
HRESULT set_YMirror(VARIANT_BOOL Value);


Свойство ZoomScale (Объект IInPictureMapFigure)

Масштаб в котором отображается карта.

Синтаксис

Язык Описание
VBScript, JavaScript
ZoomScale
Visual Basic
Property ZoomScale As Double
Delphi
property ZoomScale: Double
C, C++
HRESULT get_ZoomScale(double* Value);
HRESULT set_ZoomScale(double Value);


Объект IInPicturePictureFigure

Объект IInPicturePictureFigure(IInPictureFigure)

Элемент рисунка - рисунок.

Свойства

Свойство | Наследуется от | Описание
Bottom | IInPictureFigure | Нижняя граница элемента.
Brush | Закраска.
FigureType | IInPictureFigure | Тип элемента рисунка.
Height | IInPictureFigure | Высота элемента.
HorAlign | Выравнивание по горизонтали.
Left | IInPictureFigure | Левая граница элемента.
Name | IInPictureFigure | Имя (название) элемента рисунка.
Pen | Окантовка.
Picture | Содержимое рисунка.
Stretch | Вписать рисунок.
TransparentBack | Признак прозрачности фона растрового рисунка.
VerAlign | Выравнивание по вертикали.
Visible | IInPictureFigure | Признак видимости элемента.
Width | IInPictureFigure | Ширина элемента.

Примечания

Этот объект наследует свойства и методы объекта IInPictureFigure.

См.также

IInPictureFigures, IInPictureFigure, IInPen, IInBrush, TInPictureHorAlign, TInPictureVerAlign, TInPictureStretch


Свойство Brush (Объект IInPicturePictureFigure)

Закраска.

Синтаксис

Язык Описание
VBScript, JavaScript
Brush
Visual Basic
Property Brush As IInBrush
Delphi
property Brush: IInBrush
C, C++
HRESULT get_Brush(IInBrush** Value);

См.также

IInBrush


Свойство HorAlign (Объект IInPicturePictureFigure)

Выравнивание рисунка по горизонтали.

Синтаксис

Язык Описание
VBScript, JavaScript
HorAlign
Visual Basic
Property HorAlign As TInPictureHorAlign
Delphi
property HorAlign: TInPictureHorAlign
C, C++
HRESULT get_HorAlign(TInPictureHorAlign* Value);
HRESULT set_HorAlign(TInPictureHorAlign Value);

См.также

TInPictureHorAlign


Свойство Pen (Объект IInPicturePictureFigure)

Окантовка.

Синтаксис

Язык Описание
VBScript, JavaScript
Pen
Visual Basic
Property Pen As IInPen
Delphi
property Pen: IInPen
C, C++
HRESULT get_Pen(IInPen** Value);

См.также

IInPen


Свойство Picture (Объект IInPicturePictureFigure)

Содержимое рисунка в двоичном формате.

Синтаксис

Язык Описание
VBScript, JavaScript
Picture
Visual Basic
Property Picture As Variant
Delphi
property Picture: OleVariant
C, C++
HRESULT get_Picture(VARIANT* Value);
HRESULT set_Picture(VARIANT Value);


Свойство Stretch (Объект IInPicturePictureFigure)

Вписать рисунок в границы элемента.

Синтаксис

Язык Описание
VBScript, JavaScript
Stretch
Visual Basic
Property Stretch As TInPictureStretch
Delphi
property Stretch: TInPictureStretch
C, C++
HRESULT get_Stretch(TInPictureStretch* Value);
HRESULT set_Stretch(TInPictureStretch Value);

См.также

TInPictureStretch


Свойство TransparentBack (Объект IInPicturePictureFigure)

Признак прозрачности фона растрового рисунка.

Синтаксис

Язык Описание
VBScript, JavaScript
TransparentBack
Visual Basic
Property TransparentBack As Boolean
Delphi
property TransparentBack: WordBool
C, C++
HRESULT get_TransparentBack(VARIANT_BOOL* Value);
HRESULT set_TransparentBack(VARIANT_BOOL Value);

Примечания

За цвет фона принимается цвет левого нижнего пиксела рисунка.


Свойство VerAlign (Объект IInPicturePictureFigure)

Выравнивание рисунка по вертикали.

Синтаксис

Язык Описание
VBScript, JavaScript
VerAlign
Visual Basic
Property VerAlign As TInPictureVerAlign
Delphi
property VerAlign: TInPictureVerAlign
C, C++
HRESULT get_VerAlign(TInPictureVerAlign* Value);
HRESULT set_VerAlign(TInPictureVerAlign Value);

См.также

TInPictureVerAlign


Объект IInPicturePolygonFigure

Объект IInPicturePolygonFigure(IInPictureFigure)

Элемент рисунка - многоугольник или ломаная линия.

Свойства

Свойство | Наследуется от | Описание
Bottom | IInPictureFigure | Нижняя граница элемента.
Brush | Закраска.
Closed | Признак замкнутости.
FigureType | IInPictureFigure | Тип элемента рисунка.
Height | IInPictureFigure | Высота элемента.
Left | IInPictureFigure | Левая граница элемента.
Name | IInPictureFigure | Имя (название) элемента рисунка.
Pen | Окантовка.
Points | Координаты вершин многоугольника или ломаной линии.
Visible | IInPictureFigure | Признак видимости элемента.
Width | IInPictureFigure | Ширина элемента.

Примечания

Этот объект наследует свойства и методы объекта IInPictureFigure.

См.также

IInPictureFigures, IInPictureFigure, IInPen


Свойство Brush (Объект IInPicturePolygonFigure)

Закраска.

Синтаксис

Язык Описание
VBScript, JavaScript
Brush
Visual Basic
Property Brush As IInBrush
Delphi
property Brush: IInBrush
C, C++
HRESULT get_Brush(IInBrush** Value);

См.также

IInBrush


Свойство Closed (Объект IInPicturePolygonFigure)

Признак замкнутости.

Синтаксис

Язык Описание
VBScript, JavaScript
Closed
Visual Basic
Property Closed As Boolean
Delphi
property Closed: WordBool
C, C++
HRESULT get_Closed(VARIANT_BOOL* Value);
HRESULT set_Closed(VARIANT_BOOL Value);

Примечания

True - многоугольник (замкнут)
False - ломаная линия (не замкнута)


Свойство Pen (Объект IInPicturePolygonFigure)

Окантовка.

Синтаксис

Язык Описание
VBScript, JavaScript
Pen
Visual Basic
Property Pen As IInPen
Delphi
property Pen: IInPen
C, C++
HRESULT get_Pen(IInPen** Value);

См.также

IInPen


Свойство Points (Объект IInPicturePolygonFigure)

Координаты вершин многоугольника или ломаной линии.

Синтаксис

Язык Описание
VBScript, JavaScript
Points
Visual Basic
Property Points As Variant
Delphi
property Points: OleVariant
C, C++
HRESULT get_Points(VARIANT* Value);
HRESULT set_Points(VARIANT Value);

Примечания

Список координат вершин задается в виде двумерного массива, состоящего из N строк и двух столбцов, где N количество вершин.
1-й столбец - координата X,
2-й столбец - координата Y.

Также список координат можно задать в виде одномерного массива, состоящего из 2*N элементов.
В четных позициях располагаются координаты по X, а в нечетных координаты по Y.

Пример

Вариант 1
' Получение координат вершин
aPoints = aPolygon.Points
For i = LBound(aPoints) to UBound
    aX = aPoints(i, 0)
    aY = aPoints(i, 1)
Next

' Задание координат вершин
Dim aPoints(3, 2)
aPoints(0, 0) = aX1
aPoints(0, 1) = aY1
aPoints(1, 0) = aX2
aPoints(1, 1) = aY2
aPoints(2, 0) = aX3
aPoints(2, 1) = aY3
aPolygon.Points = aPoints
Вариант 2
' Получение координат вершин
aPoints = aPolygon.Points
For i = LBound(aPoints) to UBound step 2
    aX = aPoints(i)
    aY = aPoints(i + 1)
Next

' Задание координат вершин
Dim aPoints(3)
aPoints(0) = aX1
aPoints(1) = aY1
aPoints(2) = aX2
aPoints(3) = aY2
aPolygon.Points = aPoints


Объект IInPictureRectFigure

Объект IInPictureRectFigure(IInPictureFigure)

Элемент рисунка - прямоугольник.

Свойства

Свойство | Наследуется от | Описание
Bottom | IInPictureFigure | Нижняя граница элемента.
Brush | Закраска.
FigureType | IInPictureFigure | Тип элемента рисунка.
Height | IInPictureFigure | Высота элемента.
Left | IInPictureFigure | Левая граница элемента.
Name | IInPictureFigure | Имя (название) элемента рисунка.
Pen | Окантовка.
Visible | IInPictureFigure | Признак видимости элемента.
Width | IInPictureFigure | Ширина элемента.

Примечания

Этот объект наследует свойства и методы объекта IInPictureFigure

См.также

IInPictureFigures, IInPictureFigure, IInPen, IInBrush


Свойство Brush (Объект IInPictureRectFigure)

Закраска.

Синтаксис

Язык Описание
VBScript, JavaScript
Brush
Visual Basic
Property Brush As IInBrush
Delphi
property Brush: IInBrush
C, C++
HRESULT get_Brush(IInBrush** Value);

См.также

IInBrush


Свойство Pen (Объект IInPictureRectFigure)

Окантовка.

Синтаксис

Язык Описание
VBScript, JavaScript
Pen
Visual Basic
Property Pen As IInPen
Delphi
property Pen: IInPen
C, C++
HRESULT get_Pen(IInPen** Value);

См.также

IInPen


Объект IInPictureTextFigure

Объект IInPictureTextFigure(IInPictureFigure)

Элемент рисунка - текст.

Свойства

Свойство | Наследуется от | Описание
Alignment | Выравнивание.
Bottom | IInPictureFigure | Нижняя граница элемента.
Brush | Закраска.
FigureType | IInPictureFigure | Тип элемента рисунка.
Font | Шрифт.
Height | IInPictureFigure | Высота элемента.
Indent | Отступ от границ элемента.
Left | IInPictureFigure | Левая граница элемента.
Name | IInPictureFigure | Имя (название) элемента рисунка.
Orientation | Ориентация.
Pen | Окантовка.
Text | Содержание.
Visible | IInPictureFigure | Признак видимости элемента.
Width | IInPictureFigure | Ширина элемента.

Примечания

Этот объект наследует свойства и методы объекта IInPictureFigure.

См.также

IInPictureFigures, IInPictureFigure, IInPen, IInBrush, IInFont, TInTextAlignment, TInTextOrientation


Свойство Alignment (Объект IInPictureTextFigure)

Выравнивание текста.

Синтаксис

Язык Описание
VBScript, JavaScript
Alignment
Visual Basic
Property Alignment As TInTextAlignment
Delphi
property Alignment: TInTextAlignment
C, C++
HRESULT get_Alignment(TInTextAlignment* Value);
HRESULT set_Alignment(TInTextAlignment Value);

См.также

TInTextAlignment


Свойство Brush (Объект IInPictureTextFigure)

Закраска.

Синтаксис

Язык Описание
VBScript, JavaScript
Brush
Visual Basic
Property Brush As IInBrush
Delphi
property Brush: IInBrush
C, C++
HRESULT get_Brush(IInBrush** Value);

См.также

IInBrush


Свойство Font (Объект IInPictureTextFigure)

Шрифт.

Синтаксис

Язык Описание
VBScript, JavaScript
Font
Visual Basic
Property Font As IInFont
Delphi
property Font: IInFont
C, C++
HRESULT get_Font(IInFont** Value);

См.также

IInFont


Свойство Indent (Объект IInPictureTextFigure)

Отступ текста от границ элемента.

Синтаксис

Язык Описание
VBScript, JavaScript
Indent
Visual Basic
Property Indent As Double
Delphi
property Indent: Double
C, C++
HRESULT get_Indent(double* Value);
HRESULT set_Indent(double Value);


Свойство Orientation (Объект IInPictureTextFigure)

Ориентация текста.

Синтаксис

Язык Описание
VBScript, JavaScript
Orientation
Visual Basic
Property Orientation As TInTextOrientation
Delphi
property Orientation: TInTextOrientation
C, C++
HRESULT get_Orientation(TInTextOrientation* Value);
HRESULT set_Orientation(TInTextOrientation Value);

См.также

TInTextOrientation


Свойство Pen (Объект IInPictureTextFigure)

Окантовка.

Синтаксис

Язык Описание
VBScript, JavaScript
Pen
Visual Basic
Property Pen As IInPen
Delphi
property Pen: IInPen
C, C++
HRESULT get_Pen(IInPen** Value);

См.также

IInPen


Свойство Text (Объект IInPictureTextFigure)

Содержание текста.

Синтаксис

Язык Описание
VBScript, JavaScript
Text
Visual Basic
Property Text As String
Delphi
property Text: WideString
C, C++
HRESULT get_Text(BSTR* Value);
HRESULT set_Text(BSTR Value);


Объект IInPrinter

Объект описывающий характеристики принтера установленного в системе.

Свойства

Свойство | Описание
Comment
DriverName | Имя драйвера принтера.
Name | Имя принтера
PortName | Порт используемый принтером.
Selected | Признак того, что принтер выбран как принтер используемый по умолчанию.

См.также

IInLayoutWindow, IInPrinters


Свойство Comment (Объект IInPrinter)

Синтаксис

Язык Описание
VBScript, JavaScript
Comment
Visual Basic
Property Comment As String
Delphi
property Comment: WideString
C, C++
HRESULT get_Comment(BSTR* Value);


Свойство DriverName (Объект IInPrinter)

Имя драйвера принтера.

Синтаксис

Язык Описание
VBScript, JavaScript
DriverName
Visual Basic
Property DriverName As String
Delphi
property DriverName: WideString
C, C++
HRESULT get_DriverName(BSTR* Value);


Свойство Name (Объект IInPrinter)

Имя принтера

Синтаксис

Язык Описание
VBScript, JavaScript
Name
Visual Basic
Property Name As String
Delphi
property Name: WideString
C, C++
HRESULT get_Name(BSTR* Value);


Свойство PortName (Объект IInPrinter)

Порт используемый принтером.

Синтаксис

Язык Описание
VBScript, JavaScript
PortName
Visual Basic
Property PortName As String
Delphi
property PortName: WideString
C, C++
HRESULT get_PortName(BSTR* Value);


Объект IInPrinters

IInPrintParams

Свойства

Свойство | Описание
Count | Количество элементов в списке.
DefaultPrinterName | Имя принтера используемого по умолчанию.
Item | Получение элемента списка по индексу либо по имени принтера.
_NewEnum | Служебный объект для перебора элементов списка.

Методы

Метод Описание
Refresh

См.также

IIngeoApplication, IInLayoutWindow, IInPrinter


Свойство _NewEnum (Объект IInPrinters)

Служебный объект для перебора элементов списка.

Синтаксис

Язык Описание
VBScript, JavaScript
_NewEnum
Visual Basic
Property _NewEnum As Object
Delphi
property _NewEnum: IUnknown
C, C++
HRESULT get__NewEnum(IUnknown* Value);


Свойство Count (Объект IInPrinters)

Количество элементов в списке.

Синтаксис

Язык Описание
VBScript, JavaScript
Count
Visual Basic
Property Count As Long
Delphi
property Count: Longint
C, C++
HRESULT get_Count(long* Value);


Свойство DefaultPrinterName (Объект IInPrinters)

Имя принтера используемого по умолчанию.

Синтаксис

Язык Описание
VBScript, JavaScript
DefaultPrinterName
Visual Basic
Property DefaultPrinterName As String
Delphi
property DefaultPrinterName: WideString
C, C++
HRESULT get_DefaultPrinterName(BSTR* Value);


Свойство Selected (Объект IInPrinter)

Признак того, что принтер выбран как принтер используемый по умолчанию.

Синтаксис

Язык Описание
VBScript, JavaScript
Selected
Visual Basic
Property Selected As Boolean
Delphi
property Selected: WordBool
C, C++
HRESULT get_Selected(VARIANT_BOOL* Value);
HRESULT set_Selected(VARIANT_BOOL Value);


Свойство Item (Объект IInPrinters)

Получение элемента списка по индексу либо по имени принтера.

Синтаксис

Язык Описание
VBScript, JavaScript
Item(anIndex)
Visual Basic
Property Item(ByVal anIndex As Variant) As IInPrinter
Delphi
property Item[anIndex: OleVariant]: IInPrinter
C, C++
HRESULT get_Item(VARIANT anIndex, IInPrinter** Value);

Параметры

anIndex


Метод Refresh (Объект IInPrinters)

Синтаксис

Язык | Описание
VBScript, JavaScript | SubRefresh()
Visual Basic | Sub Refresh()
Delphi | procedure Refresh;
C, C++ | HRESULT Refresh();


Объект IInPrintParams

Параметры печати.

Свойства

Свойство | Описание
MarginX1 | Левый отступ от края страницы.
MarginX2 | Правый отступ от края страницы.
MarginY1 | Нижний отступ от края страницы.
MarginY2 | Верхний отступ от края страницы.
PageCountX | Количество страниц по горизонтали.
PageCountY | Количество страниц по вертикали.
PageFormat | Формат страницы.
PageFormatIndex | Размер страницы.
PageOrientation | Ориентация страницы.
PageSizeX | Ширина страницы (в метрах).
PageSizeY | Высота страницы (в метрах).
PrinterPaperSizeX | Ширина бумажного листа (в метрах).
PrinterPaperSizeY | Высота бумажного листа (в метрах).
PrintMargins | Печатать поля.
Rasterize | Если признак установлен, то будет использоваться растровая печать.
RasterizeBitCount | Параметр не используется.
RasterizeBufSize | Размер буфера растра (в килобайтах).
ScaleX | Множитель размера по ширине.
ScaleY | Множитель размера по высоте.

Примечания

Поля страницы задаются в метрах.

См.также

IInLayoutWindow, IInPrinter, IInPrinters


Свойство MarginX1 (Объект IInPrintParams)

Левый отступ от края страницы.

Синтаксис

Язык Описание
VBScript, JavaScript
MarginX1
Visual Basic
Property MarginX1 As Double
Delphi
property MarginX1: Double
C, C++
HRESULT get_MarginX1(double* Value);
HRESULT set_MarginX1(double Value);


Свойство MarginX2 (Объект IInPrintParams)

Правый отступ от края страницы.

Синтаксис

Язык Описание
VBScript, JavaScript
MarginX2
Visual Basic
Property MarginX2 As Double
Delphi
property MarginX2: Double
C, C++
HRESULT get_MarginX2(double* Value);
HRESULT set_MarginX2(double Value);


Свойство MarginY1 (Объект IInPrintParams)

Нижний отступ от края страницы.

Синтаксис

Язык Описание
VBScript, JavaScript
MarginY1
Visual Basic
Property MarginY1 As Double
Delphi
property MarginY1: Double
C, C++
HRESULT get_MarginY1(double* Value);
HRESULT set_MarginY1(double Value);


Свойство MarginY2 (Объект IInPrintParams)

Верхний отступ от края страницы.

Синтаксис

Язык Описание
VBScript, JavaScript
MarginY2
Visual Basic
Property MarginY2 As Double
Delphi
property MarginY2: Double
C, C++
HRESULT get_MarginY2(double* Value);
HRESULT set_MarginY2(double Value);


Свойство PageCountX (Объект IInPrintParams)

Количество страниц по горизонтали.

Синтаксис

Язык Описание
VBScript, JavaScript
PageCountX
Visual Basic
Property PageCountX As Long
Delphi
property PageCountX: Longint
C, C++
HRESULT get_PageCountX(long* Value);


Свойство PageCountY (Объект IInPrintParams)

Количество страниц по вертикали.

Синтаксис

Язык Описание
VBScript, JavaScript
PageCountY
Visual Basic
Property PageCountY As Long
Delphi
property PageCountY: Longint
C, C++
HRESULT get_PageCountY(long* Value);


Свойство PageFormat (Объект IInPrintParams)

Формат страницы.

Синтаксис

Язык Описание
VBScript, JavaScript
PageFormat
Visual Basic
Property PageFormat As TInPageFormat
Delphi
property PageFormat: TInPageFormat
C, C++
HRESULT get_PageFormat(TInPageFormat* Value);
HRESULT set_PageFormat(TInPageFormat Value);


Свойство PageFormatIndex (Объект IInPrintParams)

Размер страницы.

Синтаксис

Язык Описание
VBScript, JavaScript
PageFormatIndex
Visual Basic
Property PageFormatIndex As TInPageFormatIndex
Delphi
property PageFormatIndex: TInPageFormatIndex
C, C++
HRESULT get_PageFormatIndex(TInPageFormatIndex* Value);
HRESULT set_PageFormatIndex(TInPageFormatIndex Value);


Свойство PageOrientation (Объект IInPrintParams)

Ориентация страницы.

Синтаксис

Язык Описание
VBScript, JavaScript
PageOrientation
Visual Basic
Property PageOrientation As TInPageOrientation
Delphi
property PageOrientation: TInPageOrientation
C, C++
HRESULT get_PageOrientation(TInPageOrientation* Value);
HRESULT set_PageOrientation(TInPageOrientation Value);


Свойство PageSizeX (Объект IInPrintParams)

Ширина страницы (в метрах).

Синтаксис

Язык Описание
VBScript, JavaScript
PageSizeX
Visual Basic
Property PageSizeX As Double
Delphi
property PageSizeX: Double
C, C++
HRESULT get_PageSizeX(double* Value);
HRESULT set_PageSizeX(double Value);


Свойство PageSizeY (Объект IInPrintParams)

Высота страницы (в метрах).

Синтаксис

Язык Описание
VBScript, JavaScript
PageSizeY
Visual Basic
Property PageSizeY As Double
Delphi
property PageSizeY: Double
C, C++
HRESULT get_PageSizeY(double* Value);
HRESULT set_PageSizeY(double Value);


Свойство PrinterPaperSizeX (Объект IInPrintParams)

Ширина бумажного листа (в метрах).

Синтаксис

Язык Описание
VBScript, JavaScript
PrinterPaperSizeX
Visual Basic
Property PrinterPaperSizeX As Double
Delphi
property PrinterPaperSizeX: Double
C, C++
HRESULT get_PrinterPaperSizeX(double* Value);


Свойство PrinterPaperSizeY (Объект IInPrintParams)

Высота бумажного листа (в метрах).

Синтаксис

Язык Описание
VBScript, JavaScript
PrinterPaperSizeY
Visual Basic
Property PrinterPaperSizeY As Double
Delphi
property PrinterPaperSizeY: Double
C, C++
HRESULT get_PrinterPaperSizeY(double* Value);


Свойство PrintMargins (Объект IInPrintParams)

Печатать поля.

Синтаксис

Язык Описание
VBScript, JavaScript
PrintMargins
Visual Basic
Property PrintMargins As Boolean
Delphi
property PrintMargins: WordBool
C, C++
HRESULT get_PrintMargins(VARIANT_BOOL* Value);
HRESULT set_PrintMargins(VARIANT_BOOL Value);


Свойство Rasterize (Объект IInPrintParams)

Если признак установлен, то будет использоваться растровая печать.

Синтаксис

Язык Описание
VBScript, JavaScript
Rasterize
Visual Basic
Property Rasterize As Boolean
Delphi
property Rasterize: WordBool
C, C++
HRESULT get_Rasterize(VARIANT_BOOL* Value);
HRESULT set_Rasterize(VARIANT_BOOL Value);


Свойство RasterizeBitCount (Объект IInPrintParams)

Параметр не используется.

Синтаксис

Язык Описание
VBScript, JavaScript
RasterizeBitCount
Visual Basic
Property RasterizeBitCount As Long
Delphi
property RasterizeBitCount: Longint
C, C++
HRESULT get_RasterizeBitCount(long* Value);
HRESULT set_RasterizeBitCount(long Value);


Свойство RasterizeBufSize (Объект IInPrintParams)

Размер буфера растра (в килобайтах).

Синтаксис

Язык Описание
VBScript, JavaScript
RasterizeBufSize
Visual Basic
Property RasterizeBufSize As Long
Delphi
property RasterizeBufSize: Longint
C, C++
HRESULT get_RasterizeBufSize(long* Value);
HRESULT set_RasterizeBufSize(long Value);


Свойство ScaleX (Объект IInPrintParams)

Множитель размера по ширине.

Синтаксис

Язык Описание
VBScript, JavaScript
ScaleX
Visual Basic
Property ScaleX As Double
Delphi
property ScaleX: Double
C, C++
HRESULT get_ScaleX(double* Value);
HRESULT set_ScaleX(double Value);


Свойство ScaleY (Объект IInPrintParams)

Множитель размера по высоте.

Синтаксис

Язык Описание
VBScript, JavaScript
ScaleY
Visual Basic
Property ScaleY As Double
Delphi
property ScaleY: Double
C, C++
HRESULT get_ScaleY(double* Value);
HRESULT set_ScaleY(double Value);


Объект IInScript

Объект, предоставляющий информации о выполняемой в данный момент программе.

Свойства

Свойство | Описание
ContextCard | Карточка контекста, автоматически создаваемая для каждой запущенной программы.
Disp | Ссылка на объект программы.


Свойство ContextCard (Объект IInScript)

Карточка контекста, автоматически создаваемая для каждой запущенной программы.

Синтаксис

Язык Описание
VBScript, JavaScript
ContextCard
Visual Basic
Property ContextCard As IInContextCard
Delphi
property ContextCard: IInContextCard
C, C++
HRESULT get_ContextCard(IInContextCard** Value);


Свойство Disp (Объект IInScript)

Ссылка на объект программы.

Синтаксис

Язык Описание
VBScript, JavaScript
Disp
Visual Basic
Property Disp As Object
Delphi
property Disp: IDispatch
C, C++
HRESULT get_Disp(IDispatch* Value);


Объект IInScriptScope

Программный модуль, в среде которого выполняется программа.

Методы

Метод | Описание
LoadActions | Создать и добавить команды в указанный список команд на основе информации о списке команд, содержащейся ресурсе программного модуля.
LoadMenu | Создать и добавить элементы меню в указанный список на основе информации о меню, содержащейся ресурсе программного модуля.


Метод LoadActions (Объект IInScriptScope)

Создать и добавить команды в указанный список команд на основе информации о списке команд, содержащейся ресурсе программного модуля.

Синтаксис

Язык | Описание
VBScript, JavaScript | SubLoadActions(aContextCard, aResName, anActions)
Visual Basic | Sub LoadActions(ByVal aContextCard As IInContextCard, ByVal aResName As String, ByVal anActions As IInUIActions)
Delphi | procedure LoadActions(aContextCard: IInContextCard; const aResName: WideString; anActions: IInUIActions);
C, C++ | HRESULT LoadActions(IInContextCard* aContextCard, BSTR aResName, IInUIActions* anActions);

Параметры

aContextCard
Карточка контекста, к которой будут приписаны все созданные команды.
aResName
Имя ресурса описания списка команд.
anActions
Список команд в который будут добавлены новые команды.


Метод LoadMenu (Объект IInScriptScope)

Создать и добавить элементы меню в указанный список на основе информации о меню, содержащейся ресурсе программного модуля.

Синтаксис

Язык | Описание
VBScript, JavaScript | SubLoadMenu(aContextCard, aResName, aParentItems, aBefore)
Visual Basic | Sub LoadMenu(ByVal aContextCard As IInContextCard, ByVal aResName As String, ByVal aParentItems As IInUIMenuItems, ByVal aBefore As Variant)
Delphi | procedure LoadMenu(aContextCard: IInContextCard; const aResName: WideString; aParentItems: IInUIMenuItems; aBefore: OleVariant);
C, C++ | HRESULT LoadMenu(IInContextCard* aContextCard, BSTR aResName, IInUIMenuItems* aParentItems, VARIANT aBefore);

Параметры

aContextCard
Карточка контекста, к которой будут приписаны все созданные элементы меню.
aResName
Имя ресурса описания меню.
aParentItems
Списо, в который будут добавлены элементы меню.
aBefore
Ссыдка на объект или имя существующего элемента меню из списка, перед которым необходимо вставить новые элементы. Если не задан, то новые элементы будут добавлены в конец списка.


Объект IInUIAction

Команда, с которой могут ассоциироваться элементы интерфейса пользователя.

Свойства

Свойство | Описание
Caption | Загловок команды. Данный заголовок будет использоваться при формировании заголовков связанных с командой пунктов меню.
Category | Название категории, к которой относится команда (например "Импорт").
Checked | Признак того, что команда отмечена. Пункты меню, связанные с командой, будут визуально отмечены галочкой, а кнопки на панелях инструментов бутуд вдавлены и иметь светло-серый фон.
Enabled Признак того, что команда в данный момент разрешена.
Пункты меню и кнопки на панелях инструментов визуально засерены и не реагируют на действия пользователя.
Handler | Объект, содержащий метод обработки команды.
HandlerMethod | Название метода-обработчика команды.
HandlerOptions | Флаги влияющие на способ обработки команды.
Hint | Строка оперативной подсказки. Всплывает над кнопками панелей инструментов, привязанных к команде.
Name | Имя команды.
Shortcut | Горячая клавиша или комбинация клавиш. При нажатии этой клавиши или комбинации команда срабатывает.
Visible | Признак видимости элементов интерфейса пользователя, привязанных к команде.

Методы

Метод | Описание
Execute | Явное выполнение команды.

Примечания

Если в HandlerOptions установлен флаг inhoSenderAsParam, то при выполнении команды в метод обработки первым параметром передается ссылка на экземпляр IInUIAction.
В противном случае считается, что у метода обработки команды нет параметров.

См.также

IInUIActions, IInUIMenu


Свойство Caption (Объект IInUIAction)

Загловок команды. Данный заголовок будет использоваться при формировании заголовков связанных с командой пунктов меню.

Синтаксис

Язык Описание
VBScript, JavaScript
Caption
Visual Basic
Property Caption As String
Delphi
property Caption: WideString
C, C++
HRESULT get_Caption(BSTR* Value);
HRESULT set_Caption(BSTR Value);


Свойство Category (Объект IInUIAction)

Название категории, к которой относится команда (например "Импорт").

Синтаксис

Язык Описание
VBScript, JavaScript
Category
Visual Basic
Property Category As String
Delphi
property Category: WideString
C, C++
HRESULT get_Category(BSTR* Value);
HRESULT set_Category(BSTR Value);


Свойство Checked (Объект IInUIAction)

Признак того, что команда отмечена. Пункты меню, связанные с командой, будут визуально отмечены галочкой, а кнопки на панелях инструментов бутуд вдавлены и иметь светло-серый фон.

Синтаксис

Язык Описание
VBScript, JavaScript
Checked
Visual Basic
Property Checked As Boolean
Delphi
property Checked: WordBool
C, C++
HRESULT get_Checked(VARIANT_BOOL* Value);
HRESULT set_Checked(VARIANT_BOOL Value);


Свойство Enabled (Объект IInUIAction)

Признак того, что команда в данный момент разрешена.
Пункты меню и кнопки на панелях инструментов визуально засерены и не реагируют на действия пользователя.

Синтаксис

Язык Описание
VBScript, JavaScript
Enabled
Visual Basic
Property Enabled As Boolean
Delphi
property Enabled: WordBool
C, C++
HRESULT get_Enabled(VARIANT_BOOL* Value);
HRESULT set_Enabled(VARIANT_BOOL Value);


Метод Execute (Объект IInUIAction)

Явное выполнение команды.

Синтаксис

Язык | Описание
VBScript, JavaScript | SubExecute()
Visual Basic | Sub Execute()
Delphi | procedure Execute;
C, C++ | HRESULT Execute();


Свойство Handler (Объект IInUIAction)

Объект, содержащий метод обработки команды.

Синтаксис

Язык Описание
VBScript, JavaScript
Handler
Visual Basic
Property Handler As Object
Delphi
property Handler: IDispatch
C, C++
HRESULT get_Handler(IDispatch* Value);
HRESULT set_Handler(IDispatch Value);


Свойство HandlerMethod (Объект IInUIAction)

Название метода-обработчика команды.

Синтаксис

Язык Описание
VBScript, JavaScript
HandlerMethod
Visual Basic
Property HandlerMethod As String
Delphi
property HandlerMethod: WideString
C, C++
HRESULT get_HandlerMethod(BSTR* Value);
HRESULT set_HandlerMethod(BSTR Value);


Свойство HandlerOptions (Объект IInUIAction)

Флаги влияющие на способ обработки команды.

Синтаксис

Язык Описание
VBScript, JavaScript
HandlerOptions
Visual Basic
Property HandlerOptions As TInUIHandlerOptions
Delphi
property HandlerOptions: TInUIHandlerOptions
C, C++
HRESULT get_HandlerOptions(TInUIHandlerOptions* Value);
HRESULT set_HandlerOptions(TInUIHandlerOptions Value);


Свойство Hint (Объект IInUIAction)

Строка оперативной подсказки. Всплывает над кнопками панелей инструментов, привязанных к команде.

Синтаксис

Язык Описание
VBScript, JavaScript
Hint
Visual Basic
Property Hint As String
Delphi
property Hint: WideString
C, C++
HRESULT get_Hint(BSTR* Value);
HRESULT set_Hint(BSTR Value);


Свойство Name (Объект IInUIAction)

Имя команды.

Синтаксис

Язык Описание
VBScript, JavaScript
Name
Visual Basic
Property Name As String
Delphi
property Name: WideString
C, C++
HRESULT get_Name(BSTR* Value);
HRESULT set_Name(BSTR Value);


Объект IInUIActions

Список команд.

Свойства

Свойство | Описание
Count | Количество команд в списке.
Item | Получение команды по индексу или имени.
_NewEnum | Создание служебного объекта для перебора элементов списка.

Методы

Метод | Описание
Add | Добавление команды в список.
Remove | Удалить указанную команду.


Свойство _NewEnum (Объект IInUIActions)

Создание служебного объекта для перебора элементов списка.

Синтаксис

Язык Описание
VBScript, JavaScript
_NewEnum
Visual Basic
Property _NewEnum As Object
Delphi
property _NewEnum: IUnknown
C, C++
HRESULT get__NewEnum(IUnknown* Value);


Метод Add (Объект IInUIActions)

Добавление команды в список.

Синтаксис

Язык | Описание
VBScript, JavaScript | FunctionAdd(aContextCard, aCategory, aName, aCaption, aHandler, aHandlerMethod)
Visual Basic | Function Add(ByVal aContextCard As IInContextCard, ByVal aCategory As String, ByVal aName As String, ByVal aCaption As String, ByVal aHandler As Object, ByVal aHandlerMethod As String) As IInUIAction
Delphi | function Add(aContextCard: IInContextCard; const aCategory: WideString; const aName: WideString; const aCaption: WideString; aHandler: IDispatch; const aHandlerMethod: WideString): IInUIAction;
C, C++ | HRESULT Add(IInContextCard* aContextCard, BSTR aCategory, BSTR aName, BSTR aCaption, IDispatch aHandler, BSTR aHandlerMethod, IInUIAction** Value);

Параметры

aContextCard
Карточка контекста, к которой приписывается добавляемая команда. При уничтожении карточки контекста автоматически уничтожаются все приписанные к ней команды.
aCategory
Название категории, к которой относится добавляемая команда.
aName
Имя команды.
aCaption
Заголовок команды. Данный параметр команды определяет названия пунктов меню.
aHandler
Объект, содержащий метод обработки команды.
aHandlerMethod
Название метода обработки команды.


Свойство Count (Объект IInUIActions)

Количество команд в списке.

Синтаксис

Язык Описание
VBScript, JavaScript
Count
Visual Basic
Property Count As Long
Delphi
property Count: Longint
C, C++
HRESULT get_Count(long* Value);


Свойство Shortcut (Объект IInUIAction)

Горячая клавиша или комбинация клавиш. При нажатии этой клавиши или комбинации команда срабатывает.

Синтаксис

Язык Описание
VBScript, JavaScript
Shortcut
Visual Basic
Property Shortcut As Long
Delphi
property Shortcut: Longint
C, C++
HRESULT get_Shortcut(long* Value);
HRESULT set_Shortcut(long Value);


Свойство Item (Объект IInUIActions)

Получение команды по индексу или имени.

Синтаксис

Язык Описание
VBScript, JavaScript
Item(anIndex)
Visual Basic
Property Item(ByVal anIndex As Variant) As IInUIAction
Delphi
property Item[anIndex: OleVariant]: IInUIAction
C, C++
HRESULT get_Item(VARIANT anIndex, IInUIAction** Value);

Параметры

anIndex
Индекс или имя команды.


Метод Remove (Объект IInUIActions)

Удалить указанную команду.

Синтаксис

Язык | Описание
VBScript, JavaScript | SubRemove(anItem)
Visual Basic | Sub Remove(ByVal anItem As IInUIAction)
Delphi | procedure Remove(anItem: IInUIAction);
C, C++ | HRESULT Remove(IInUIAction* anItem);

Параметры

anItem
Удаляемая команда.


Свойство Visible (Объект IInUIAction)

Признак видимости элементов интерфейса пользователя, привязанных к команде.

Синтаксис

Язык Описание
VBScript, JavaScript
Visible
Visual Basic
Property Visible As Boolean
Delphi
property Visible: WordBool
C, C++
HRESULT get_Visible(VARIANT_BOOL* Value);
HRESULT set_Visible(VARIANT_BOOL Value);


Объект IInUIMenu

Меню

Свойства

Свойство | Описание
Items | Список элементов меню.


Объект IInUIMenuItem

Элемент меню.

Свойства

Свойство | Описание
Action Команда, к которой привязан данный элемент меню.
Если значение этого поля пустой указатель, то элемент меню является разделителем или подменю.
Caption | Заголовок элемента меню.
GroupIndex | Если элемент меню является членом зависимой группы переключателей, то данное свойство содержит номер группы переключателей.
Items | Список элементов подменю.
Name | Имя элемента меню.
RadioItem | Признак того, что элемент меню является членом зависимой группы переключателей.
Visible | Признак видимости элемента меню.


Свойство Action (Объект IInUIMenuItem)

Команда, к которой привязан данный элемент меню.
Если значение этого поля пустой указатель, то элемент меню является разделителем или подменю.

Синтаксис

Язык Описание
VBScript, JavaScript
Action
Visual Basic
Property Action As IInUIAction
Delphi
property Action: IInUIAction
C, C++
HRESULT get_Action(IInUIAction** Value);
HRESULT set_Action(IInUIAction* Value);


Свойство Caption (Объект IInUIMenuItem)

Заголовок элемента меню.

Синтаксис

Язык Описание
VBScript, JavaScript
Caption
Visual Basic
Property Caption As String
Delphi
property Caption: WideString
C, C++
HRESULT get_Caption(BSTR* Value);
HRESULT set_Caption(BSTR Value);

Примечания

Для элементов меню, привязанных к командам, заголовок всегда совпадает с заголовком команды и попытка изменить заголовок приведет к исключению.


Свойство GroupIndex (Объект IInUIMenuItem)

Если элемент меню является членом зависимой группы переключателей, то данное свойство содержит номер группы переключателей.

Синтаксис

Язык Описание
VBScript, JavaScript
GroupIndex
Visual Basic
Property GroupIndex As Long
Delphi
property GroupIndex: Longint
C, C++
HRESULT get_GroupIndex(long* Value);
HRESULT set_GroupIndex(long Value);


Свойство Items (Объект IInUIMenuItem)

Список элементов подменю.

Синтаксис

Язык Описание
VBScript, JavaScript
Items
Visual Basic
Property Items As IInUIMenuItems
Delphi
property Items: IInUIMenuItems
C, C++
HRESULT get_Items(IInUIMenuItems** Value);


Свойство Name (Объект IInUIMenuItem)

Имя элемента меню.

Синтаксис

Язык Описание
VBScript, JavaScript
Name
Visual Basic
Property Name As String
Delphi
property Name: WideString
C, C++
HRESULT get_Name(BSTR* Value);
HRESULT set_Name(BSTR Value);


Свойство RadioItem (Объект IInUIMenuItem)

Признак того, что элемент меню является членом зависимой группы переключателей.

Синтаксис

Язык Описание
VBScript, JavaScript
RadioItem
Visual Basic
Property RadioItem As Boolean
Delphi
property RadioItem: WordBool
C, C++
HRESULT get_RadioItem(VARIANT_BOOL* Value);
HRESULT set_RadioItem(VARIANT_BOOL Value);


Объект IInUIMenuItems

Список элементов меню.

Свойства

Свойство | Описание
Count | Количество элементов в списке.
Item | Получение элемента по индексу в списке или по имени.
_NewEnum | Получение служебного объекта для перебора элементов списка.

Методы

Метод | Описание
Insert | Вставка нового элемента в список.
Remove | Удалить элемент меню из списка.


Свойство _NewEnum (Объект IInUIMenuItems)

Получение служебного объекта для перебора элементов списка.

Синтаксис

Язык Описание
VBScript, JavaScript
_NewEnum
Visual Basic
Property _NewEnum As Object
Delphi
property _NewEnum: IUnknown
C, C++
HRESULT get__NewEnum(IUnknown* Value);


Свойство Count (Объект IInUIMenuItems)

Количество элементов в списке.

Синтаксис

Язык Описание
VBScript, JavaScript
Count
Visual Basic
Property Count As Long
Delphi
property Count: Longint
C, C++
HRESULT get_Count(long* Value);


Метод Insert (Объект IInUIMenuItems)

Вставка нового элемента в список.

Синтаксис

Язык | Описание
VBScript, JavaScript | FunctionInsert(aContextCard, aName, aCaption, anAction, aBefore)
Visual Basic | Function Insert(ByVal aContextCard As IInContextCard, ByVal aName As String, ByVal aCaption As String, ByVal anAction As Variant, ByVal aBefore As Variant) As IInUIMenuItem
Delphi | function Insert(aContextCard: IInContextCard; const aName: WideString; const aCaption: WideString; anAction: OleVariant; aBefore: OleVariant): IInUIMenuItem;
C, C++ | HRESULT Insert(IInContextCard* aContextCard, BSTR aName, BSTR aCaption, VARIANT anAction, VARIANT aBefore, IInUIMenuItem** Value);

Параметры

aContextCard
Карточка контекста, к которому приписывается создаваемый элемент меню.
При уничтожении карточки контекста автоматически уничтожаются все приписанные к нему элементы меню.
aName
Имя элемента меню.
aCaption
Заголовок элемента меню. Значение данного параметра игнорируется, если задан параметр anAction.
anAction
Команда, к которой привязывается элемент меню. Можно указать как ссылку на объект команды, так и имя команды.
aBefore
Ссылка на объект или имя элемента меню, перед которым необходимо вставить новый пункт.
Если данный параметр не задан, то новый пункт вставляется в конец списка.


Свойство Item (Объект IInUIMenuItems)

Получение элемента по индексу в списке или по имени.

Синтаксис

Язык Описание
VBScript, JavaScript
Item(anIndex)
Visual Basic
Property Item(ByVal anIndex As Variant) As IInUIMenuItem
Delphi
property Item[anIndex: OleVariant]: IInUIMenuItem
C, C++
HRESULT get_Item(VARIANT anIndex, IInUIMenuItem** Value);

Параметры

anIndex
Индекс элемента в списке или имя элемента.


Метод Remove (Объект IInUIMenuItems)

Удалить элемент меню из списка.

Синтаксис

Язык | Описание
VBScript, JavaScript | SubRemove(anItem)
Visual Basic | Sub Remove(ByVal anItem As IInUIMenuItem)
Delphi | procedure Remove(anItem: IInUIMenuItem);
C, C++ | HRESULT Remove(IInUIMenuItem* anItem);

Параметры

anItem
Ссылка на объект или имя удаляемого элемента меню.


Свойство Visible (Объект IInUIMenuItem)

Признак видимости элемента меню.

Синтаксис

Язык Описание
VBScript, JavaScript
Visible
Visual Basic
Property Visible As Boolean
Delphi
property Visible: WordBool
C, C++
HRESULT get_Visible(VARIANT_BOOL* Value);
HRESULT set_Visible(VARIANT_BOOL Value);

Примечания

Для элементов меню, привязанных к командам, признак видимости всегда совпадает с признаком видимости команды и попытка изменить его приведет к исключению.


Объект IInWindow

Базовый интерфейс для объектов типа "Окно".

Свойства

Свойство | Описание
Caption | Заголовок окна.
Height | Высота окна в пикселях.
Left | X координата левого верхнего угла окна.
Name | Имя окна.
Top | Y координата верхнего левого угла окна.
Visible | Признак видимости.
Width | Ширина окна в пикселях.
WindowState | Текущее состояние окна.

Методы

Метод | Описание
Close | Скрывает окно.

См.также

IInWindows, IInLayoutWindow


Свойство Caption (Объект IInWindow)

Заголовок окна.

Синтаксис

Язык Описание
VBScript, JavaScript
Caption
Visual Basic
Property Caption As String
Delphi
property Caption: WideString
C, C++
HRESULT get_Caption(BSTR* Value);
HRESULT set_Caption(BSTR Value);


Метод Close (Объект IInWindow)

Скрывает окно.

Синтаксис

Язык | Описание
VBScript, JavaScript | SubClose()
Visual Basic | Sub Close()
Delphi | procedure Close;
C, C++ | HRESULT Close();


Свойство Height (Объект IInWindow)

Высота окна в пикселях.

Синтаксис

Язык Описание
VBScript, JavaScript
Height
Visual Basic
Property Height As Long
Delphi
property Height: Longint
C, C++
HRESULT get_Height(long* Value);
HRESULT set_Height(long Value);


Свойство Left (Объект IInWindow)

X координата левого верхнего угла окна.

Синтаксис

Язык Описание
VBScript, JavaScript
Left
Visual Basic
Property Left As Long
Delphi
property Left: Longint
C, C++
HRESULT get_Left(long* Value);
HRESULT set_Left(long Value);


Свойство Name (Объект IInWindow)

Имя окна.

Синтаксис

Язык Описание
VBScript, JavaScript
Name
Visual Basic
Property Name As String
Delphi
property Name: WideString
C, C++
HRESULT get_Name(BSTR* Value);


Объект IInWindows

Список открытых окон

Свойства

Свойство | Описание
Count | Количество элементов в списке
Item | Получение окна из списка по его имени или индексу
_NewEnum | Служебный объект для перебора элементов списка.

Примечания

В текущей версии методы данного интерфейса не реализованы

См.также

IInWindow


Свойство _NewEnum (Объект IInWindows)

Служебный объект для перебора элементов списка.

Синтаксис

Язык Описание
VBScript, JavaScript
_NewEnum
Visual Basic
Property _NewEnum As Object
Delphi
property _NewEnum: IUnknown
C, C++
HRESULT get__NewEnum(IUnknown* Value);


Свойство Count (Объект IInWindows)

Количество элементов в списке

Синтаксис

Язык Описание
VBScript, JavaScript
Count
Visual Basic
Property Count As Long
Delphi
property Count: Longint
C, C++
HRESULT get_Count(long* Value);


Свойство Item (Объект IInWindows)

Получение окна из списка по его имени или индексу

Синтаксис

Язык Описание
VBScript, JavaScript
Item(anIndex)
Visual Basic
Property Item(ByVal anIndex As Variant) As IInWindow
Delphi
property Item[anIndex: OleVariant]: IInWindow
C, C++
HRESULT get_Item(VARIANT anIndex, IInWindow** Value);

Параметры

anIndex


Свойство Top (Объект IInWindow)

Y координата верхнего левого угла окна.

Синтаксис

Язык Описание
VBScript, JavaScript
Top
Visual Basic
Property Top As Long
Delphi
property Top: Longint
C, C++
HRESULT get_Top(long* Value);
HRESULT set_Top(long Value);


Свойство Visible (Объект IInWindow)

Признак видимости.

Синтаксис

Язык Описание
VBScript, JavaScript
Visible
Visual Basic
Property Visible As Boolean
Delphi
property Visible: WordBool
C, C++
HRESULT get_Visible(VARIANT_BOOL* Value);
HRESULT set_Visible(VARIANT_BOOL Value);


Свойство Width (Объект IInWindow)

Ширина окна в пикселях.

Синтаксис

Язык Описание
VBScript, JavaScript
Width
Visual Basic
Property Width As Long
Delphi
property Width: Longint
C, C++
HRESULT get_Width(long* Value);
HRESULT set_Width(long Value);


Свойство WindowState (Объект IInWindow)

Текущее состояние окна.

Синтаксис

Язык Описание
VBScript, JavaScript
WindowState
Visual Basic
Property WindowState As TInWindowState
Delphi
property WindowState: TInWindowState
C, C++
HRESULT get_WindowState(TInWindowState* Value);
HRESULT set_WindowState(TInWindowState Value);


Тип TCoordinateSpace

Координатная система.
Константа | Значение | Описание
incsWorld | 0 | Мировая система координат.
incsPaper | 1 | Бумажная система координат.


Тип TInBrushStyle

Стиль закраски.
Константа | Значение | Описание
inbsSolid | 0 | Сплошная.
inbsClear | 1 | Нет заливки.
inbsHotizontal | 2 | Горизонтальная заливка.
inbsVertical | 3 | Вертикальная штриховка.
inbsFDiagonal | 4 | Штриховка диагональная, наклон штрихов вправо.
inbsBDiagonal | 5 | Штриховка диагональная, наклон штрихов влево.
inbsCross | 6 | Штриховка крест на крест вертикально-горизонтальная.
inbsDiagCross | 7 | Штриховка крест на крест диагональная.


Тип TInFontPitch

Шаг шрифта.
Константа | Значение | Описание
infpDefault | 0 | По умолчанию.
infpVariable | 1 | Переменный.
infpFixed | 2 | Фиксированный.


Тип TInFontStyle

Начертание шрифта.
Константа | Значение | Описание
infsBold | 1 | Жирный.
infsItalic | 2 | Курсив.
infsUnderline | 4 | Подчеркнутый.
infsStrikeOut | 8 | Перечеркнутый.


Тип TIngeoContourCombineOperation

Тип пространственной операции.
Константа | Значение | Описание
inccOr | 0 | Объединение.
inccSub | 1 | Вычитание.
inccAnd | 2 | Пересечение.
inccXor | 3 | Исключение.

См.также

IIngeoContour


Тип TIngeoContourRelation

Относительное пространственное расположение контуров.
Константа | Значение | Описание
incrIntersected | 1 | Два контура имеют пересечения.
incrContained | 2 | Первый контур лежит внутри второго.
incrContains | 4 | Второй контур лежит внутри первого.
incrTouched | 8 | Контуры имеют точки соприкосновения.

См.также

IIngeoContour


Тип TIngeoCursor

Вид курсора.

Константа | Значение | Описание
incrDefault | 0 | Default.
incrNone | -1 | None.
incrArrow | -2 | Arrow.
incrCross | -3 | Cross.
incrIBeam | -4 | Beam.
incrSize | -22 | Size.
incrSizeNESW | -6 | SizeNESW.
incrSizeNS | -7 | SizeNS.
incrSizeNWSE | -8 | SizeNWSE.
incrSizeWE | -9 | SizeWE.
incrUpArrow | -10 | UpArrow.
incrHourGlass | -11 | HourGlass.
incrDrag | -12 | Drag.
incrNoDrop | -13 | NoDrop.
incrHSplit | -14 | HSplit.
incrVSplit | -15 | VSplit.
incrMultiDrag | -16 | MultiDrag.
incrSQLWait | -17 | SQLWait.
incrNo | -18 | No.
incrAppStart | -19 | AppStart.
incrHelp | -20 | Help.
incrHandPoint | -21 | HandPoint.
incrSizeAll | -22 | SizeAll.


Тип TIngeoDeviceType

Тип устройства отображения.
Константа | Значение | Описание
indtScreen | 0 | Экран.
indtPrinter | 1 | Принтер.
indtRaster | 2 | Растр.


Тип TIngeoFieldDataType

Типы полей таблицы.

Для соответствующих типов необходимо задавать размерность и точность. Если не надо задавать, то размерность и точность задают равными нулю.

Константа | Значение | Описание
inftUnknown | 0 | Неопределенный.
inftString | 10 | Строковый. Необходимо задать размер.
inftWideString | 11 | Строковый (Unicode). Необходимо задать размер.
inftText | 12 | Текст.
inftFmtText | 13 | Многострочный. Необходимо задать размер.
inftSmallInt | 20 | Короткий целый (2 байта).
inftUnsignedSmallInt | 21 | Короткий целый беззнаковый (2 байта).
inftInteger | 22 | Целый (4 байта).
inftLargeInt | 23 | Длинный целый (8 байт).
inftFloat | 30 | Вещественный (8 байт).
inftCurrency | 31 | Денежный.
inftDecimal | 32 | Вещественный с фиксированной точкой. Необходимо задать размер и точность.
inftDate | 40 | Дата.
inftTime | 41 | Время.
inftDateTime | 42 | Дата и время.
inftBoolean | 50 | Логический.
inftVariant | 51 | Любой.
inftGUID | 52 | GUID
inftBinary | 60 | Двоичный.
inftGraphic | 61 | Двоичный-графический.

См.также

IIngeoSemDbField


Тип TIngeoFieldFlags

Атрибуты поля таблицы.

Константа | Значение | Описание
inffRequired | 1 | Поле всегда должно содержать данные. То есть не быть пустым.

См.также

IIngeoSemDbField


Тип TIngeoIndexFlags

Атрибуты индекса таблицы.

Константа | Значение | Описание
inixPrimary | 1 | Первичный индекс.
inixUnique | 2 | Уникальный индекс.
inixDescending | 4 | Индекс отсортирован по убыванию.
inixCaseInsensitive | 8 | Индекс не различает регистр символов.

См.также

IIngeoSemDbIndex


Тип TIngeoMapObjectPart

Константа | Значение | Описание
inmpShapes | 1 |
inmpSemData | 2 |
inmpTopoLinks | 4 |


Тип TIngeoMapType

Данный тип описывает все возможные типы карт в ГИС ИнГео

Константа | Значение | Описание
inmtRaster | 1 | Растровая карта.
inmtVector | 2 | Векторная карта.

См.также

Свойство MapType (объект IIngeoMap), IIngeoMap, IIngeoRasterMap, IIngeoVectorMap


Тип TIngeoMouseButton

Кнопка мыши.
Константа | Значение | Описание
inmbLeft | 0 | Левая кнопка мыши.
inmbRight | 1 | Правая кнопка мыши.
inmbMiddle | 2 | Средняя кнопка мыши.

См.также

IIngeoMapEditorsSink


Тип TIngeoNavigatorFitMode

Данный тип описывает способ подбора масштаба при вписывании прямоугольника в область видимости.
Константа | Значение | Описание
infitNoScale | 0 | Не изменять масштаб отображения
infitScaleIfNeed | 1 | Масштаб изменяется если указанные габариты превышают габариты области видимости или составляют менее одной восьмой от габаритов области видимости. Масштаб подбирается таким образом, чтобы указанный прямоугольник занимал семь восьмых области видимости.
infitAlwaysScale | 2 | Масштаб изменяется всегда и подбирается таким образом, чтобы указанный прямоугольник занимал семь восьмых области видимости.


Тип TIngeoObjectClass

Класс объектов.
Константа | Значение | Описание
inocContour | 0 | Контур.
inocContextCard | 1 | Карточка контекста.
inocImage | 2 | Растровый рисунок.
inocPainter | 3 | Метод отображения.

См.также

IIngeoApplication, IIngeoContour, IInContextCard, IInImage, IIngeoPainter, Application.CreateObject


Тип TIngeoOp

Операция над объектом БД.

Константа | Значение | Описание
inaoViewAttrs | 1 | Просмотр атрибутов системного объекта.
inaoEditAttrs | 2 | Изменение атрибутов системного объекта.
inaoDelete | 4 | Удаление системного объекта.
inaoAdmin | 8 | Администрирование системного объекта.
inaoViewImage | 16 | Отображение содержимого карты или слоя.
inaoDbExplore | 1 | Использование проводника БД.
inaoDbAdmin | 2 | Администрирование БД.
inaoDbCreateAreas | 4 | Создание территорий.
inaoDbCreateRefBooks | 8 | Создание справочников.
inaoDbExportData | 16 | Экспортирование данных.
inaoDbPrint | 32 | Печать карты.
inaoDbAllowMultipleLogins | 64 | Многократный вход в систему.
inaoAreaCreateRastMaps | 16 | Создание растровых карт.
inaoAreaCreateVectMaps | 32 | Создание векторных карт.
inaoAreaCreateProjects | 64 | Создание проектов.
inaoProjectIncludeMaps | 16 | Включение карт в проект.
inaoProjectExcludeMaps | 32 | Исключение карт из проекта.
inaoRastMapLinkRasters | 32 | Привязка растровых файлов к ячейкам растровой карты.
inaoRastMapAdjustRasters | 64 | Выравнивание привязанных растров.
inaoVectMapCreateLayers | 32 | Создание слоев.
inaoMapsExportImage | 128 | Печать/создание растра.
inaoLayerEditRelations | 32 | Редактирование топологических отношений слоя.
inaoLayerCreateStyles | 64 | Создание стилей.
inaoLayerCreateTables | 128 | Создание семантических таблиц.
inaoLayersExportImage | 256 | Печать/создание растра.
inaoStyleCreateShape | 16 | Создание контуров с указанным стилем.
inaoStyleDeleteShape | 32 | Удаление контуров указанного стиля.
inaoStyleEditShape | 64 | Изменение контуров указанного стиля.
inaoStyleChangeStyle | 128 | Замена стиля контура с указанного на другой.
inaoSemTableRestructure | 16 | Изменение структуры семантической таблицы.
inaoSemTableEditRecords | 32 | Изменение содержимого семантической таблицы (редактирование записей).
inaoSemTableViewRecords | 128 | Просмотр содержимого семантической таблицы (просмотр записей).
inaoRefBookRestructure | 16 | Изменение структуры справочника.
inaoRefBookEditContents | 32 | Редактирование содержимого справочника.


Тип TIngeoPainterType

Тип метода отображения стиля.

Константа | Значение | Описание
inptStd | 0 | Стандартный.
inptText | 1 | Текстовый.
inptSymbol | 2 | Символьный.

См.также

IIngeoPainter, IIngeoStdPainter, IIngeoTextPainter, IIngeoSymbolPainter


Тип TIngeoPicturePaintMethod

Способ рисования рисунка.

Константа | Значение | Описание
inppmSingle | 0 | В вершинах контура.
inppmOutline | 1 | Вдоль окантовки контура.
inppmFill | 2 | Заливка площадных частей.
inppmVertexIn | 3 | На входах в вершины.
inppmVertexOut | 4 | На выходах из вершин.
inppmVertexFirst | 5 | На выходе из первой вершины.
inppmVertexLast | 6 | На входе в последнюю вершину.
inppmRect | 7 | Вписать в прямоугольник.
inppmArrow | 8 | Вдоль ребер с сохранением пропорций.

См.также

IIngeoSymbolPainter


Тип TIngeoQueryByStyleFlags

Флаги используются при вызове метода QueryByStyle объекта IIngeoMapObjects и влияют на результаты его работы.

Константа | Значение | Описание
inqsOneOrMore | 0 | Объект попадет в результат поиска, если хотя бы одна из форм объекта имеет стиль, содержащийся в списке.
inqsAll | 1 | Объект попадет в результат поиска, если все формы объекта имееют стили содержащиеся в списке запрашиваемых стилей.
inqsNone | 2 | Объект попадет в результат поиска, если все формы объекта имееют стили, не содержащиеся в списке.

См.также

IIngeoMapObjects, QueryByStyle


Тип TIngeoSemTableLinkType

Тип связи семантической таблицы.

Константа | Значение | Описание
inltOneToOne | 0 | Один к одному.
inltOneToMany | 1 | Один ко многим.

См.также

IIngeoSemTable


Тип TIngeoShiftState

Флаги состояния клавиш <Alt>, <Shift>, <Ctrl> клавиатуры и кнопок мыши.

Константа | Значение | Описание
inssShift | 1 | Нажата клавиша Shift.
inssAlt | 2 | Нажата клавиша Alt.
inssCtrl | 4 | Нажата клавиша Ctrl.
inssLeft | 8 | Нажата левая клавиша мыши.
inssRight | 16 | Нажата правая клавиша мыши.
inssMiddle | 32 | Нажата средняя клавиша мыши.
inssDouble | 64 | Выполнен двойной щелчок мышью.

См.также

IIngeoMapEditorsSink


Тип TIngeoStyleClosing

Тип StyleClosing определяет вспомогательные правила, определяющие тип замыкающего ребра при создании нового контура..
Константа | Значение | Описание
instCloseNone | 0 | Не замыкать новый контур.
instCloseByLine | 1 | Замыкать новый контур прямой линией.
instCloseByArc | 2 | Замыкать новый контур дугой.

См.также

IIngeoStyle


Тип TIngeoStyleCreation

Тип StyleCreation определяет вспомогательные правила, которые будут использоваться при создании контура..
Константа | Значение | Описание
instStartWithMove | 0 | Начинать создание контура, состоящего из точечных частей, не соединенных ребрами.
instStartWithLine | 1 | Начинать новый контур с прямой линии.
instStartWithArc | 2 | Начинать новый контур с дуги.

См.также

IIngeoStyle


Тип TIngeoStyleFlags

Тип StyleFlags представляет собой описание праметров стиля.
Константа | Значение | Описание
instDefineGeometry | 1 | Определяет геометрию объекта.
instDisableObjectCreation | 2 | Не включать в меню создания объекта.
instDisableContourCreation | 4 | Не включать в меню пририсовки формы.
instDisableStyleChanging | 8 | Не включать в меню замены стиля.
instPaintOrderMask | 240 | Последовательность рисования объектов слоя.
instPaintOrderNormal | 0 | Обычная последовательность рисования.
instPaintOrderAfterLayer | 16 | Последовательность рисования после всех объектов слоя.
instPaintOrderAfterMap | 32 | Последовательность рисования после всех объектов карты.
instPaintOrderAfterAll | 48 | Последовательность рисования после всех объектов.

См.также

IIngeoStyle


Тип TIngeoSysObjectType

Тип системного объекта (объекта структуры базы данных).
Константа | Значение | Описание
insoArea | 0 | Территория.
insoRefBook | 1 | Справочник.
insoRastMap | 2 | Растровая карта.
insoVectMap | 3 | Векторная карта.
insoLayer | 4 | Слой.
insoStyle | 5 | Стиль.
insoSemTable | 6 | Семантическая таблица.


Тип TIngeoTextPainterFlags

Атрибуты текстового метода отображения стиля.

Константа | Значение | Описание
intpfOpaque | 1 | Закрашивать фон под текстом.
intpfHorLeft | 0 | Горизонтальное выравнивание по левому краю.
intpfHorCenter | 16 | Горизонтальное центрирование.
intpfHorRight | 32 | Горизонтальное выравнивание по правому краю.
intpfHorMask | 240 | Маска горизонтальных флагов.
intpfVerBottom | 0 | Вертикальное выравнивание по нижнему краю.
intpfVerCenter | 256 | Вертикальное центрирование.
intpfVerTop | 512 | Вертикальное выравнивание по верхнему краю.
intpfVerMask | 3840 | Маска вертикальных флагов.

См.также

IIngeoTextPainter


Тип TIngeoTouchInfo

Результат выполнения функции GetContourTouchInfo.

Константа | Значение | Описание
intiNone | 0 | Указанная точка устройства не "задевает" указанный контур.
intiVertex | 1 | Указанная точка устройства "задевает" вершину контура.
intiEdge | 2 | Указанная точка устройства "задевает" ребро контура.
intiInside | 3 | Указанная точка попала внутрь полигональной части контура.

См.также

IIngeoPaintSurface, GetContourTouchInfo


Тип TIngeoUserProfileScope

Контекст сохраняемых данных.
Константа | Значение | Описание
inupGlobal | 0 | Глобальный контекст. Данные доступны всем пользователям во всех проектах базы данных ГИС.
inupUser | 1 | Контекст пользователя. Данные доступны только одному пользователю во всех проектах базы данных ГИС.
inupProject | 2 | Контекст проекта. Данные доступны всем пользователям в одном проекте базы данных ГИС.
inupUserAndProject | 3 | Контекст пользователя и проекта. Данные доступны одному пользователю в одном проекте базы данных ГИС.

См.также

IIngeoUserProfile


Тип TIngeoXmlRequestFlags

Константа | Значение | Описание
inxrReturnString | 0 |
inxrReturnBinary | 1 |
inxrReturnMSXML | 2 |
inxrReturnResponse | 3 |


Тип TInGridFormatKind

Тип элемента формата ячейки, строки, столбца или таблицы.
Константа | Значение | Описание
ingfFont | 1 | Формат шрифта.
ingfTextFormat | 2 | Формат отображения текста.
ingfLeftIndent | 4 | Левый отступ от границы ячейки до области вывода текста (задается в мм).
ingfTopIndent | 8 | Верхний отступ от границы ячейки до области вывода текста (задается в мм).
ingfRightIndent | 16 | Правый отступ от границы ячейки до области вывода текста (задается в мм).
ingfBottomIndent | 32 | Нижний отступ от границы ячейки до области вывода текста (задается в мм).
ingfBrush | 64 | Формат закраски.
ingfLeftPen | 128 | Формат окантовки слева.
ingfTopPen | 256 | Формат окантовки сверху.
ingfRightPen | 512 | Формат окантовки справа.
ingfBottomPen | 1024 | Формат окантовки снизу.
ingfColWidth | 2048 | Ширина столбца.
ingfRowHeight | 4096 | Высота строки.


Тип TInGridTextFormat

Формат отображения текста.
Константа | Значение | Описание
intfHorAlignLeft | 0 | Горизонтальное выравнивание - влево.
intfHorAlignCenter | 1 | Горизонтальное выравнивание - по центру.
intfHorAlignRight | 2 | Горизонтальное выравнивание - вправо.
intfVerAlignTop | 0 | Вертикальное выравнивание - сверху.
intfVerAlignCenter | 16 | Вертикальное выравнивание - по центру.
intfVerAlignBottom | 32 | Вертикальное выравнивание - снизу.
intfWordBreak | 256 | Перенос слов.


Тип TInImageDataType

Тип файла изображения.

Константа | Значение | Описание
inidBMP | 0 | BMP
inidJPEG | 1 | JPEG
inidGIF | 2 | GIF
inidEMF | 3 | EMF
inidPNG | 4 |


Тип TInPageFormat

Формат страницы.
Константа | Значение | Описание
inpfCustom | 0 | Определяется пользователем.
inpfFromPrinter | 1 | По принтеру (используется размеры страницы доступные принтеру).
inpfArchitectural | 2 | Архитектурные (ANSI).
inpfEngineering | 3 | Инженерные (ANSI).
inpfMetric | 4 | Метрические (ISO).
inpfStandard | 5 | Стандартные.

См.также

IInPrintParams


Тип TInPageFormatIndex

Предопределенные форматы страниц,
Константа | Значение | Описание
inpfsLetter | 0 | Letter (8.5'' x 11'').
inpfsFolio | 1 | Folio (8.5'' x 13'').
inpfsLegal | 2 | Legal (8.5'' x 14'').
inpfsTabloid | 3 | Tabloid (11'' x 17'').
inpfmA5 | 0 | A5 (148 x 210 мм).
inpfmA4 | 1 | A4 (210 x 297 мм).
inpfmA3 | 2 | A3 (297 x 420 мм).
inpfmA2 | 3 | A2 (420 x 594 мм).
inpfmA1 | 4 | A1 (594 x 841 мм).
inpfmA0 | 5 | A0 (841x 1189 мм).
inpfeA | 0 | A (8.5'' x 11'').
inpfeB | 1 | B (11'' x 17'').
inpfeC | 2 | C (17'' x 22'').
inpfeD | 3 | D (22'' x 34'').
inpfeE | 4 | E (34'' x 44'').
inpfa9x12 | 0 | 9'' x 12''.
inpfa12x18 | 1 | 12'' x 18''.
inpfa18x24 | 2 | 18'' x 24''.
inpfa24x36 | 3 | 24'' x 36''.
inpfa30x42 | 4 | 30'' x 42''.

См.также

IInLayoutWindow, IInPrintParams


Тип TInPageOrientation

Ориентация страницы.
Константа | Значение | Описание
inpoPortrait | 0 | Книжная.
inpoLandscape | 1 | Альбомная.

См.также

IInPrintParams


Тип TInPenMode

Режим отрисовки.
Константа | Значение | Описание
inpmBlack | 0 |
inpmWhite | 1 |
inpmNop | 2 |
inpmNot | 3 |
inpmCopy | 4 |
inpmNotCopy | 5 |
inpmMergePenNot | 6 |
inpmMaskPenNot | 7 |
inpmMergeNotPen | 8 |
inpmMaskNotPen | 9 |
inpmMerge | 10 |
inpmNotMerge | 11 |
inpmMask | 12 |
inpmNotMask | 13 |
inpmXor | 14 |
inpmNotXor | 15 |


Тип TInPenStyle

Стиль окантовки.
Константа | Значение | Описание
inpsSolid | 0 | Сплошная _____________
inpsDash | 1 | Штриховая __ __ __ __ __
inpsDot | 2 | Пунктирная _ _ _ _ _ _ _ _
inpsDashDot | 3 | Штрих - пунктирная __ _ __ _ __ _ __
inpsDashDotDot | 4 | Штрих - пунктирная __ _ _ __ _ _ __
inpsClear | 5 | Нет окантовки
inpsInsideFrame | 6 | Зарезервировано


Тип TInPictureFigureType

Тип элемента рисунка.
Константа | Значение | Описание
inftRect | 1 | Прямоугольник.
inftEllipse | 2 | Круг.
inftLine | 3 | Линия.
inftPolygon | 4 | Многоугольник или ломаная линия.
inftText | 5 | Текст.
inftPicture | 6 | Рисунок.
inftGrid | 7 | Таблица.
inftMap | 100 | Карта


Тип TInPictureHorAlign

Выравнивание рисунка по горизонтали.
Константа | Значение | Описание
inpaLeft | 0 | Влево.
inpaHorCenter | 1 | По центру.
inpaRight | 2 | Вправо.


Тип TInPictureStretch

Вписать рисунок в границы элемента.
Константа | Значение | Описание
inpsNone | 0 | Не вписывать.
inpsFitToBounds | 1 | По границам.
inpsProportional | 2 | Соблюдая пропорции.


Тип TInPictureVerAlign

Выравнивание рисунка по вертикали.
Константа | Значение | Описание
inpaTop | 0 | Вверх.
inpaVerCenter | 1 | По центру.
inpaBottom | 2 | Вниз.


Тип TInTextAlignment

Выравнивание текста.
Константа | Значение | Описание
intaLeftJustify | 0 | Влево.
intaRightJustify | 1 | Вправо.
intaCenter | 2 | По центру.


Тип TInTextOrientation

Ориентация текста.
Константа | Значение | Описание
intoLeftToRight | 0 | Слева направо.
intoRightToLeft | 1 | Справа налево.
intoTopToBottom | 2 | Сверху вниз.
intoBottomToTop | 3 | Снизу вверх.


Тип TInUIHandlerOptions

Флаги влияющие на способ обработки команды.
Константа | Значение | Описание
inhoSenderAsParam | 1 | Если установлен данный флаг, то считается что метод обработки содержит один параметр типа IInUIAction, в противном случае считается, что у метода обработки команды нет параметров.

См.также

IInUIAction, IInUIActions


Тип TInWindowState

Состояние окна.
Константа | Значение | Описание
inwsNormal | 0 | Окно в нормальном состоянии (не свернуто и не распахнуто).
inwsMinimized | 1 | Окно свернуто.
inwsMaximized | 2 | Окно распахнуто на весь экран.


Тип TShapeCreationFlags

Флаги используемые методами StartObjectCreation и StartShapeCreation.

Константа | Значение | Описание
inscSingleShapeCreation | 1 | При установленном флаге, после создания объекта (формы) редактор прекращает свою работу, в противном случае переходит к созданию нового объекта (формы).
inscSuppressNewObjectSelection | 2 | При установленном флаге, после создания объекта (формы) не происходит его выделения.

См.также

IIngeoMapWindow